new release
rebased tuned to latest upstream related: rhbz#1643654 used dmidecode only on x86 architectures resolves: rhbz#1688371 recommend: fixed to work without tuned daemon running resolves: rhbz#1687397 powertop2tuned: added support for wakeup tuning (powertop-2.10) resolves: rhbz#1690354
This commit is contained in:
parent
0f8bd5f424
commit
3389e183b6
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (tuned-2.11.0-rc.1.tar.gz) = 95fba1698bb4b4d938e113f3c78413253aa2c4580c8794f860e8d6efabe83f3e8905c36603910ec8af95880f128f7cabe4a01127392920078dcb2a4206b01f42
|
SHA512 (tuned-2.11.0.tar.gz) = d3ce400f73bc868bafe34433c9b7c1c425e744e70559b86808b59c7820c6baefc41b435eeeb5e6fdbcc28731cee079e6adeb709615cb9c778dc316d69527b0a9
|
||||||
|
13
tuned-2.11.0-powertop2tuned-add-wakeup-support.patch
Normal file
13
tuned-2.11.0-powertop2tuned-add-wakeup-support.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/experiments/powertop2tuned.py b/experiments/powertop2tuned.py
|
||||||
|
index ec69d97..76d048a 100755
|
||||||
|
--- a/experiments/powertop2tuned.py
|
||||||
|
+++ b/experiments/powertop2tuned.py
|
||||||
|
@@ -96,7 +96,7 @@ class PowertopHTMLParser(HTMLParser):
|
||||||
|
|
||||||
|
def handle_starttag(self, tag, attrs):
|
||||||
|
self.lastStartTag = tag
|
||||||
|
- if self.lastStartTag == "div" and dict(attrs).get("id") == "tuning":
|
||||||
|
+ if self.lastStartTag == "div" and dict(attrs).get("id") in ["tuning", "wakeup"]:
|
||||||
|
self.inProperTable = True
|
||||||
|
if self.inProperTable and tag == "td":
|
||||||
|
self.tdCounter += 1
|
37
tuned.spec
37
tuned.spec
@ -14,8 +14,10 @@
|
|||||||
|
|
||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
%global _py python3
|
%global _py python3
|
||||||
|
%global make_python_arg PYTHON=%{__python3}
|
||||||
%else
|
%else
|
||||||
%{!?python2_sitelib:%global python2_sitelib %{python_sitelib}}
|
%{!?python2_sitelib:%global python2_sitelib %{python_sitelib}}
|
||||||
|
%global make_python_arg PYTHON=%{__python2}
|
||||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||||
%global _py python
|
%global _py python
|
||||||
%else
|
%else
|
||||||
@ -23,8 +25,8 @@
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global prerelease rc
|
#%%global prerelease rc
|
||||||
%global prereleasenum 1
|
#%%global prereleasenum 1
|
||||||
|
|
||||||
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
||||||
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
||||||
@ -32,12 +34,17 @@
|
|||||||
Summary: A dynamic adaptive system tuning daemon
|
Summary: A dynamic adaptive system tuning daemon
|
||||||
Name: tuned
|
Name: tuned
|
||||||
Version: 2.11.0
|
Version: 2.11.0
|
||||||
Release: 0.1%{?prerel1}%{?dist}
|
Release: 1%{?prerel1}%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||||
URL: http://www.tuned-project.org/
|
URL: http://www.tuned-project.org/
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: systemd, desktop-file-utils
|
BuildRequires: systemd, desktop-file-utils
|
||||||
|
%if 0%{?rhel}
|
||||||
|
BuildRequires: asciidoc
|
||||||
|
%else
|
||||||
|
BuildRequires: asciidoctor
|
||||||
|
%endif
|
||||||
Requires(post): systemd, virt-what
|
Requires(post): systemd, virt-what
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
@ -64,6 +71,7 @@ Recommends: kernel-tools
|
|||||||
%if 0%{?rhel} > 7
|
%if 0%{?rhel} > 7
|
||||||
Requires: python3-syspurpose
|
Requires: python3-syspurpose
|
||||||
%endif
|
%endif
|
||||||
|
Patch0: tuned-2.11.0-powertop2tuned-add-wakeup-support.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The tuned package contains a daemon that tunes system settings dynamically.
|
The tuned package contains a daemon that tunes system settings dynamically.
|
||||||
@ -208,20 +216,20 @@ It can be also used to fine tune your system for specific scenarios.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?prerel2}
|
%setup -q -n %{name}-%{version}%{?prerel2}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
make html %{make_python_arg}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=%{buildroot} DOCDIR=%{docdir} \
|
make install DESTDIR=%{buildroot} DOCDIR=%{docdir} %{make_python_arg}
|
||||||
%if %{with python3}
|
|
||||||
PYTHON=%{__python3}
|
|
||||||
%else
|
|
||||||
PYTHON=%{__python2}
|
|
||||||
%endif
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
sed -i 's/\(dynamic_tuning[ \t]*=[ \t]*\).*/\10/' %{buildroot}%{_sysconfdir}/tuned/tuned-main.conf
|
sed -i 's/\(dynamic_tuning[ \t]*=[ \t]*\).*/\10/' %{buildroot}%{_sysconfdir}/tuned/tuned-main.conf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# manual
|
||||||
|
make install-html DESTDIR=%{buildroot} DOCDIR=%{docdir}
|
||||||
|
|
||||||
# conditional support for grub2, grub2 is not available on all architectures
|
# conditional support for grub2, grub2 is not available on all architectures
|
||||||
# and tuned is noarch package, thus the following hack is needed
|
# and tuned is noarch package, thus the following hack is needed
|
||||||
mkdir -p %{buildroot}%{_datadir}/tuned/grub2
|
mkdir -p %{buildroot}%{_datadir}/tuned/grub2
|
||||||
@ -458,6 +466,17 @@ fi
|
|||||||
%{_mandir}/man7/tuned-profiles-compat.7*
|
%{_mandir}/man7/tuned-profiles-compat.7*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 21 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 2.11.0-1
|
||||||
|
- new release
|
||||||
|
- rebased tuned to latest upstream
|
||||||
|
related: rhbz#1643654
|
||||||
|
- used dmidecode only on x86 architectures
|
||||||
|
resolves: rhbz#1688371
|
||||||
|
- recommend: fixed to work without tuned daemon running
|
||||||
|
resolves: rhbz#1687397
|
||||||
|
- powertop2tuned: added support for wakeup tuning (powertop-2.10)
|
||||||
|
resolves: rhbz#1690354
|
||||||
|
|
||||||
* Sun Mar 10 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 2.11.0-0.1.rc1
|
* Sun Mar 10 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 2.11.0-0.1.rc1
|
||||||
- new release
|
- new release
|
||||||
- rebased tuned to latest upstream
|
- rebased tuned to latest upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user