New release
Resolves: rhbz#1362481 - Dropped tuned-gui-traceback-fix and tuned-adm-list-no-dbus-traceback-fix patches (both upstreamed)
This commit is contained in:
parent
c3104a467e
commit
0725332c68
2
sources
2
sources
@ -1 +1 @@
|
||||
5afcb636743cb10c370ba77a04c874ce tuned-2.7.0.tar.bz2
|
||||
a1d91a4ed1d3827f48d2184aa6f90585 tuned-2.7.1.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
From e6b647641bbb17f36f804ba22dda198478d8533b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jaroslav=20=C5=A0karvada?= <jskarvad@redhat.com>
|
||||
Date: Thu, 21 Jul 2016 16:34:29 +0200
|
||||
Subject: [PATCH 2/2] tuned-adm: fixed traceback of 'tuned-adm list' if daemon
|
||||
is not running
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
|
||||
---
|
||||
tuned/admin/admin.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tuned/admin/admin.py b/tuned/admin/admin.py
|
||||
index ad501c0..cbdd1be 100644
|
||||
--- a/tuned/admin/admin.py
|
||||
+++ b/tuned/admin/admin.py
|
||||
@@ -98,7 +98,7 @@ class Admin(object):
|
||||
|
||||
def _action_list(self):
|
||||
self._print_profiles(self._profiles_locator.get_known_names_summary())
|
||||
- self._action_dbus_active()
|
||||
+ self._action_active()
|
||||
return True
|
||||
|
||||
def _dbus_get_active_profile(self):
|
||||
--
|
||||
2.5.5
|
||||
|
@ -1,32 +0,0 @@
|
||||
From e6c6e157336acd08e40c817d4e7ee7bf1a1f5a04 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jaroslav=20=C5=A0karvada?= <jskarvad@redhat.com>
|
||||
Date: Thu, 21 Jul 2016 11:08:20 +0200
|
||||
Subject: [PATCH 1/2] gui: fixed traceback caused by DBus paths copy&paste
|
||||
error
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Related: rhbz#1356369
|
||||
|
||||
Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
|
||||
---
|
||||
tuned-gui.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tuned-gui.py b/tuned-gui.py
|
||||
index 0555404..b169dec 100755
|
||||
--- a/tuned-gui.py
|
||||
+++ b/tuned-gui.py
|
||||
@@ -89,7 +89,7 @@ class Base(object):
|
||||
try:
|
||||
self.controller = \
|
||||
tuned.admin.DBusController(consts.DBUS_BUS,
|
||||
- consts.DBUS_OBJECT, consts.DBUS_INTERFACE)
|
||||
+ consts.DBUS_INTERFACE, consts.DBUS_OBJECT)
|
||||
self.controller.is_running()
|
||||
except tuned.admin.exceptions.TunedAdminDBusException, ex:
|
||||
response = self.tuned_daemon_exception_dialog.run()
|
||||
--
|
||||
2.5.5
|
||||
|
14
tuned.spec
14
tuned.spec
@ -1,7 +1,7 @@
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.7.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.7.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Source: https://fedorahosted.org/releases/t/u/tuned/tuned-%{version}.tar.bz2
|
||||
URL: https://fedorahosted.org/tuned/
|
||||
@ -13,8 +13,6 @@ Requires(postun): systemd
|
||||
Requires: python-decorator, dbus-python, pygobject3-base, python-pyudev
|
||||
Requires: virt-what, python-configobj, ethtool, gawk, kernel-tools, hdparm
|
||||
Requires: util-linux, python-perf, dbus, polkit
|
||||
Patch0: tuned-2.7.0-tuned-gui-traceback-fix.patch
|
||||
Patch1: tuned-2.7.0-tuned-adm-list-no-dbus-traceback-fix.patch
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
@ -115,8 +113,6 @@ It can be also used to fine tune your system for specific scenarios.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -325,6 +321,12 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-compat.7*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 2 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7.1-1
|
||||
- New release
|
||||
Resolves: rhbz#1362481
|
||||
- Dropped tuned-gui-traceback-fix and tuned-adm-list-no-dbus-traceback-fix
|
||||
patches (both upstreamed)
|
||||
|
||||
* Thu Jul 21 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7.0-2
|
||||
- Fixed tuned-gui traceback (by tuned-gui-traceback-fix patch)
|
||||
Resolves: rhbz#1358846
|
||||
|
Loading…
Reference in New Issue
Block a user