tuna/tuna-Add-cleanlogs-rule-to-...

32 lines
832 B
Diff

From 681304a9a57a9c2b05fcc2cc372e3d921b5ff415 Mon Sep 17 00:00:00 2001
From: Leah Leshchinsky <lleshchi@redhat.com>
Date: Tue, 10 May 2022 11:59:08 -0400
Subject: [PATCH 2/2] tuna: Add cleanlogs rule to Makefile
The logging infrastructure creates directories that contain log files.
It may be tedious for users to manually remove these directories and
files.
Add a Makefile rule that allows for easy removal of multiple logging
directories. The rule can be called via 'make cleanlogs'.
Signed-off-by: Leah Leshchinsky <lleshchi@redhat.com>
Signed-off-by: John Kacur <jkacur@redhat.com>
diff --git a/Makefile b/Makefile
index 2c72feaa398c..50ded3985743 100644
--- a/Makefile
+++ b/Makefile
@@ -45,4 +45,8 @@ tags:
cleantags:
rm -f tags
+.PHONY: cleanlogs
+cleanlogs:
+ rm -rf tuna-20*
+
clean: pyclean rpmclean
--
2.27.0