import tuna-0.16-1.el8
This commit is contained in:
parent
68d63d52a4
commit
ff8181090b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/tuna-0.15.tar.xz
|
||||
SOURCES/tuna-0.16.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
67fb3ea8815809203ca5f37941a03bee3dc1422f SOURCES/tuna-0.15.tar.xz
|
||||
634c59ed06f7e638412e0e4832cf811c432a767b SOURCES/tuna-0.16.tar.xz
|
||||
|
@ -1,51 +0,0 @@
|
||||
From cd9e707b23980ed568aeddac6eaa2125b651c6cc Mon Sep 17 00:00:00 2001
|
||||
From: John Kacur <jkacur@redhat.com>
|
||||
Date: Wed, 3 Mar 2021 10:45:28 -0500
|
||||
Subject: [PATCH] tuna: Fix tuna --include option breakage
|
||||
|
||||
The change to remove the dependency on python-schedutils
|
||||
broke the --include function.
|
||||
|
||||
get_affinity(pid) from python-schedutils returned a list
|
||||
os.sched_getaffinity(pid) returns a set
|
||||
|
||||
In many cases they can be interchanged, but not with the '+' operation
|
||||
Fix this by changing affinity to a list before concatenation
|
||||
|
||||
Reported-by: Mark Simmons <msimmons@redhat.com>
|
||||
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||
---
|
||||
tuna/tuna.py | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tuna/tuna.py b/tuna/tuna.py
|
||||
index e5122dac1081..614a8250b054 100755
|
||||
--- a/tuna/tuna.py
|
||||
+++ b/tuna/tuna.py
|
||||
@@ -431,9 +431,9 @@ def include_cpus(cpus, nr_cpus):
|
||||
if err.args[0] == errno.ESRCH:
|
||||
continue
|
||||
raise err
|
||||
- if set(affinity).intersection(set(cpus)) != set(cpus):
|
||||
+ if affinity.intersection(set(cpus)) != set(cpus):
|
||||
previous_pid_affinities[pid] = copy.copy(affinity)
|
||||
- affinity = list(set(affinity + cpus))
|
||||
+ affinity = list(affinity) + cpus
|
||||
try:
|
||||
os.sched_setaffinity(pid, affinity)
|
||||
except OSError as err:
|
||||
@@ -453,9 +453,9 @@ def include_cpus(cpus, nr_cpus):
|
||||
if err.args[0] == errno.ESRCH:
|
||||
continue
|
||||
raise err
|
||||
- if set(affinity).intersection(set(cpus)) != set(cpus):
|
||||
+ if affinity.intersection(set(cpus)) != set(cpus):
|
||||
previous_pid_affinities[tid] = copy.copy(affinity)
|
||||
- affinity = list(set(affinity + cpus))
|
||||
+ affinity = list(affinity) + cpus
|
||||
try:
|
||||
os.sched_setaffinity(tid, affinity)
|
||||
except OSError as err:
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: tuna
|
||||
Version: 0.15
|
||||
Release: 2%{?dist}
|
||||
Version: 0.16
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Summary: Application tuning GUI & command line utility
|
||||
Group: Applications/System
|
||||
@ -16,7 +16,6 @@ Requires: python3-linux-procfs >= 0.6
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
# PATCHES
|
||||
Patch1: tuna-Fix-tuna-include-option-breakage.patch
|
||||
|
||||
%description
|
||||
Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
|
||||
@ -29,7 +28,6 @@ installed.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -76,9 +74,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/polkit-1/actions/org.tuna.policy
|
||||
|
||||
%changelog
|
||||
* Thu Mar 04 2021 John Kacur <jkacur@redhat.com> - 0.15-2
|
||||
- Fix tuna's include option
|
||||
Resolves: rhbz#1934594
|
||||
* Wed Jun 30 2021 John Kacur <jkacur@redhat.com> - 0.16-1
|
||||
- Upgrade to latest upstream
|
||||
Resolves: rhbz#1947069
|
||||
|
||||
* Thu Jan 21 2021 John Kacur <jkacur@redhat.com> - 0.15-1
|
||||
- Upgrade to latest upstream code
|
||||
|
Loading…
Reference in New Issue
Block a user