import tuna-0.17-1.el8
This commit is contained in:
parent
6784e6b581
commit
87358df6ab
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/tuna-0.16.tar.xz
|
||||
SOURCES/tuna-0.17.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
634c59ed06f7e638412e0e4832cf811c432a767b SOURCES/tuna-0.16.tar.xz
|
||||
9bde1e92e09277efcb13ee5808baa1632ae815cb SOURCES/tuna-0.17.tar.xz
|
||||
|
35
SOURCES/tuna-Fix-ModuleNotFoundError.patch
Normal file
35
SOURCES/tuna-Fix-ModuleNotFoundError.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 7684169d22af5379d2f466730c450afc92e80da8 Mon Sep 17 00:00:00 2001
|
||||
From: John Kacur <jkacur@redhat.com>
|
||||
Date: Tue, 11 Jan 2022 16:58:58 -0500
|
||||
Subject: [PATCH] tuna: Fix ModuleNotFoundError
|
||||
|
||||
commit 43b434867514934593ada5aa8ea448ef6a1778f9 fixed the problem with
|
||||
relative imports but unfortunately created a new problem with installed
|
||||
tuna
|
||||
|
||||
This fixes the original problem and also fixes the ModuleNotFoundError
|
||||
in an installed (not running from git) version of tuna.
|
||||
|
||||
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||
---
|
||||
tuna/tuna.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tuna/tuna.py b/tuna/tuna.py
|
||||
index 98a1725598dd..8fb42121e2e4 100755
|
||||
--- a/tuna/tuna.py
|
||||
+++ b/tuna/tuna.py
|
||||
@@ -12,8 +12,8 @@ import platform
|
||||
import ethtool
|
||||
import procfs
|
||||
from procfs import utilist
|
||||
-import help
|
||||
-import tuna_sched
|
||||
+from tuna import help
|
||||
+from tuna import tuna_sched
|
||||
|
||||
try:
|
||||
fntable
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: tuna
|
||||
Version: 0.16
|
||||
Version: 0.17
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Summary: Application tuning GUI & command line utility
|
||||
@ -16,6 +16,7 @@ Requires: python3-linux-procfs >= 0.6
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
# PATCHES
|
||||
Patch1: tuna-Fix-ModuleNotFoundError.patch
|
||||
|
||||
%description
|
||||
Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
|
||||
@ -28,6 +29,7 @@ installed.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -74,6 +76,28 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/polkit-1/actions/org.tuna.policy
|
||||
|
||||
%changelog
|
||||
* Thu Jan 13 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.17-1
|
||||
- Rebase to upstream version 0.17
|
||||
- Fix ModuleNotFoundError
|
||||
Resolves: rhbz#2012306
|
||||
|
||||
* Tue Dec 14 2021 John Kacur <jkacur@redhat.com> - 0.16-5
|
||||
- Display correct cpu-affinity when a cpu is disabled
|
||||
Resolves: rhbz#2032614
|
||||
|
||||
* Wed Nov 10 2021 John Kacur <jkacur@redhat.com> - 0.16-4
|
||||
- Make it clear in online help and man pages that --include and --isolate
|
||||
affect IRQs as well as threads
|
||||
Resolves: rhbz#1886804
|
||||
|
||||
* Thu Oct 28 2021 John Kacur <jkacur@redhat.com> - 0.16-3
|
||||
- Print warning if setaffinity causes EBUSY and continue
|
||||
Resolves: rhbz#2018285
|
||||
|
||||
* Tue Oct 26 2021 Leah Leshchinsky <lleshchi@redhat.com> - 0.16-2
|
||||
- Add distinction between --spread and --move to error message
|
||||
Resolves: rhbz#2012241
|
||||
|
||||
* Wed Jun 30 2021 John Kacur <jkacur@redhat.com> - 0.16-1
|
||||
- Upgrade to latest upstream
|
||||
Resolves: rhbz#1947069
|
||||
|
Loading…
Reference in New Issue
Block a user