import tuna-0.18-1.el8

This commit is contained in:
CentOS Sources 2022-11-08 01:54:38 -05:00 committed by Stepan Oksanichenko
parent 551033afa2
commit 86ef4a5ef2
4 changed files with 18 additions and 40 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/tuna-0.17.tar.xz
SOURCES/tuna-0.18.tar.xz

View File

@ -1 +1 @@
9bde1e92e09277efcb13ee5808baa1632ae815cb SOURCES/tuna-0.17.tar.xz
70666ad7164e0b80d63c11afc9888af273966896 SOURCES/tuna-0.18.tar.xz

View File

@ -1,35 +0,0 @@
From 7684169d22af5379d2f466730c450afc92e80da8 Mon Sep 17 00:00:00 2001
From: John Kacur <jkacur@redhat.com>
Date: Tue, 11 Jan 2022 16:58:58 -0500
Subject: [PATCH] tuna: Fix ModuleNotFoundError
commit 43b434867514934593ada5aa8ea448ef6a1778f9 fixed the problem with
relative imports but unfortunately created a new problem with installed
tuna
This fixes the original problem and also fixes the ModuleNotFoundError
in an installed (not running from git) version of tuna.
Signed-off-by: John Kacur <jkacur@redhat.com>
---
tuna/tuna.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tuna/tuna.py b/tuna/tuna.py
index 98a1725598dd..8fb42121e2e4 100755
--- a/tuna/tuna.py
+++ b/tuna/tuna.py
@@ -12,8 +12,8 @@ import platform
import ethtool
import procfs
from procfs import utilist
-import help
-import tuna_sched
+from tuna import help
+from tuna import tuna_sched
try:
fntable
--
2.27.0

View File

@ -1,5 +1,5 @@
Name: tuna
Version: 0.17
Version: 0.18
Release: 1%{?dist}
License: GPLv2
Summary: Application tuning GUI & command line utility
@ -16,7 +16,6 @@ Requires: python3-linux-procfs >= 0.6
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
# PATCHES
Patch1: tuna-Fix-ModuleNotFoundError.patch
%description
Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
@ -29,7 +28,6 @@ installed.
%prep
%setup -q
%patch1 -p1
%build
%{__python3} setup.py build
@ -76,6 +74,21 @@ rm -rf %{buildroot}
%{_datadir}/polkit-1/actions/org.tuna.policy
%changelog
* Wed Jun 29 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.18-1
- Rebase to upstream version 0.18
Resolves: rhbz#2073555
* Thu May 19 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.17-3
- Add logging infrastructure to tuna
- Add cleanlogs rule to Makefile
Resolves: rhbz#2062882
* Mon Apr 11 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.17-2
- Fix typo for variable parm
- Handle get_policy_and_rtprio exceptions
- Remove finally block in get_policy_and_rtprio
Resolves: rhbz#2049746
* Thu Jan 13 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.17-1
- Rebase to upstream version 0.17
- Fix ModuleNotFoundError