Import from AlmaLinux stable repository
This commit is contained in:
parent
f3a74fa370
commit
6d69359c07
@ -1 +0,0 @@
|
|||||||
70666ad7164e0b80d63c11afc9888af273966896 SOURCES/tuna-0.18.tar.xz
|
|
357
SOURCES/Add-SPDX-license-identifiers.patch
Normal file
357
SOURCES/Add-SPDX-license-identifiers.patch
Normal file
@ -0,0 +1,357 @@
|
|||||||
|
From 8c9b74f89c616a7aebbbd159e71aeb3c49979472 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Clark Williams <clrkwllms@kernel.org>
|
||||||
|
Date: Thu, 17 Aug 2023 08:12:38 -0500
|
||||||
|
Subject: [PATCH 1/2] Add SPDX license identifiers
|
||||||
|
|
||||||
|
use SPDX license identifiers to clarify the licences under which
|
||||||
|
tuna is released.
|
||||||
|
|
||||||
|
Signed-off-by: Clark Williams <williams@redhat.com>
|
||||||
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 3 +++
|
||||||
|
org.tuna.policy | 1 +
|
||||||
|
oscilloscope-cmd.py | 15 +--------------
|
||||||
|
setup.py | 1 +
|
||||||
|
testuna | 10 +++++-----
|
||||||
|
tuna-cmd.py | 9 +--------
|
||||||
|
tuna.desktop | 1 +
|
||||||
|
tuna/__init__.py | 2 +-
|
||||||
|
tuna/config.py | 2 ++
|
||||||
|
tuna/gui/__init__.py | 2 ++
|
||||||
|
tuna/gui/commonview.py | 2 ++
|
||||||
|
tuna/gui/cpuview.py | 1 +
|
||||||
|
tuna/gui/irqview.py | 1 +
|
||||||
|
tuna/gui/procview.py | 1 +
|
||||||
|
tuna/gui/profileview.py | 1 +
|
||||||
|
tuna/gui/util.py | 1 +
|
||||||
|
tuna/new_eth.py | 1 +
|
||||||
|
tuna/oscilloscope.py | 15 +--------------
|
||||||
|
tuna/sysfs.py | 2 ++
|
||||||
|
tuna/tuna.py | 7 ++++---
|
||||||
|
tuna/tuna_gui.py | 1 +
|
||||||
|
tuna/tuna_sched.py | 1 +
|
||||||
|
22 files changed, 35 insertions(+), 45 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 50ded3985743..a3d71d2de896 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -1,3 +1,6 @@
|
||||||
|
+#
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
+#
|
||||||
|
PACKAGE := tuna
|
||||||
|
VERSION := $(shell rpm -q --qf '%{VERSION} ' --specfile rpm/SPECS/$(PACKAGE).spec | cut -d' ' -f1)
|
||||||
|
|
||||||
|
diff --git a/org.tuna.policy b/org.tuna.policy
|
||||||
|
index 4f71d4ad65f4..b3b3900a4d76 100644
|
||||||
|
--- a/org.tuna.policy
|
||||||
|
+++ b/org.tuna.policy
|
||||||
|
@@ -1,4 +1,5 @@
|
||||||
|
<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
+<!-- SPDX-License-Identifier: GPL-2.0-only -->
|
||||||
|
<!DOCTYPE policyconfig PUBLIC "-//freedesktop//DTD polkit Policy Configuration 1.0//EN"
|
||||||
|
"http://www.freedesktop.org/software/polkit/policyconfig-1.dtd">
|
||||||
|
<policyconfig>
|
||||||
|
diff --git a/oscilloscope-cmd.py b/oscilloscope-cmd.py
|
||||||
|
index 2ca87e9edc62..a65117637160 100755
|
||||||
|
--- a/oscilloscope-cmd.py
|
||||||
|
+++ b/oscilloscope-cmd.py
|
||||||
|
@@ -5,20 +5,7 @@
|
||||||
|
# http://git.kernel.org/?p=linux/kernel/git/acme/tuna.git;a=tree
|
||||||
|
# For newer versions and to see it integrated with tuna
|
||||||
|
#
|
||||||
|
-# This library is free software; you can redistribute it and/or
|
||||||
|
-# modify it under the terms of the GNU Lesser General Public
|
||||||
|
-# License as published by the Free Software Foundation;
|
||||||
|
-# version 2.1 of the License.
|
||||||
|
-#
|
||||||
|
-# This library is distributed in the hope that it will be useful,
|
||||||
|
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||||
|
-# Lesser General Public License for more details.
|
||||||
|
-#
|
||||||
|
-# You should have received a copy of the GNU Lesser General Public
|
||||||
|
-# License along with this library; if not, write to the Free Software
|
||||||
|
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
|
||||||
|
-# USA
|
||||||
|
+# SPDX-License-Identifier: LGPL-2.1-only
|
||||||
|
|
||||||
|
import getopt
|
||||||
|
import sys
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index f3e36529fefb..a00adb9721a8 100755
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -1,4 +1,5 @@
|
||||||
|
#!/usr/bin/python3
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
from distutils.sysconfig import get_python_lib
|
||||||
|
from distutils.core import setup
|
||||||
|
from os.path import isfile, join
|
||||||
|
diff --git a/testuna b/testuna
|
||||||
|
index 4bf91ebdb76f..cb98640c0167 100755
|
||||||
|
--- a/testuna
|
||||||
|
+++ b/testuna
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
# Regression tests for tuna
|
||||||
|
# (c) 2008 Red Hat Inc.
|
||||||
|
# Arnaldo Carvalho de Melo <acme@redhat.com>
|
||||||
|
-# Released under the GPLv2
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
|
||||||
|
dprint() {
|
||||||
|
[ -n "$VERBOSE" ] && echo $1
|
||||||
|
@@ -111,21 +111,21 @@ PID=$(ktpidof "watchdog")
|
||||||
|
RTPRIO=$(get_rtprio $PID)
|
||||||
|
POLICY=$(get_policy $PID)
|
||||||
|
POLICY=$(echo ${POLICY:6:1} | tr 'A-Z' 'a-z')
|
||||||
|
-chrt -$POLICY -p $((RTPRIO - 1)) $PID
|
||||||
|
+chrt -$POLICY -p $((RTPRIO - 1)) $PID
|
||||||
|
|
||||||
|
die_if_not_saved 1 'Saving changes to a kernel thread priority'
|
||||||
|
|
||||||
|
-chrt -$POLICY -p $RTPRIO $PID
|
||||||
|
+chrt -$POLICY -p $RTPRIO $PID
|
||||||
|
|
||||||
|
die_if_conf_changed 'Restoring kernel thread priority'
|
||||||
|
|
||||||
|
new_policy=$(echo $POLICY | tr fr rf)
|
||||||
|
|
||||||
|
-chrt -$new_policy -p $RTPRIO $PID
|
||||||
|
+chrt -$new_policy -p $RTPRIO $PID
|
||||||
|
|
||||||
|
die_if_not_saved 1 'Changing kernel thread sched policy'
|
||||||
|
|
||||||
|
-chrt -$POLICY -p $RTPRIO $PID
|
||||||
|
+chrt -$POLICY -p $RTPRIO $PID
|
||||||
|
|
||||||
|
die_if_conf_changed 'Restoring kernel thread sched policy'
|
||||||
|
|
||||||
|
diff --git a/tuna-cmd.py b/tuna-cmd.py
|
||||||
|
index f5dafa739da2..38e7017336a5 100755
|
||||||
|
--- a/tuna-cmd.py
|
||||||
|
+++ b/tuna-cmd.py
|
||||||
|
@@ -5,14 +5,7 @@
|
||||||
|
# Copyright (C) 2008, 2009, 2010, 2011 Red Hat Inc.
|
||||||
|
# Arnaldo Carvalho de Melo <acme@redhat.com>
|
||||||
|
#
|
||||||
|
-# This application is free software; you can redistribute it and/or
|
||||||
|
-# modify it under the terms of the GNU General Public License
|
||||||
|
-# as published by the Free Software Foundation; version 2.
|
||||||
|
-#
|
||||||
|
-# This application is distributed in the hope that it will be useful,
|
||||||
|
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||||
|
-# General Public License for more details.
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
|
||||||
|
""" tuna - Application Tuning GUI """
|
||||||
|
|
||||||
|
diff --git a/tuna.desktop b/tuna.desktop
|
||||||
|
index 603011f79467..87ca3a35ce63 100644
|
||||||
|
--- a/tuna.desktop
|
||||||
|
+++ b/tuna.desktop
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
[Desktop Entry]
|
||||||
|
Name=tuna
|
||||||
|
GenericName=Application Tuner
|
||||||
|
diff --git a/tuna/__init__.py b/tuna/__init__.py
|
||||||
|
index 30924a00cf96..614e3e4c7ed8 100755
|
||||||
|
--- a/tuna/__init__.py
|
||||||
|
+++ b/tuna/__init__.py
|
||||||
|
@@ -4,4 +4,4 @@ Copyright (c) 2008, 2009 Red Hat Inc.
|
||||||
|
Application Tuning GUI
|
||||||
|
"""
|
||||||
|
__author__ = "Arnaldo Carvalho de Melo <acme@redhat.com>"
|
||||||
|
-__license__ = "GPLv2 License"
|
||||||
|
+__license__ = "SPDX-License-Identifier: GPL-2.0-only"
|
||||||
|
diff --git a/tuna/config.py b/tuna/config.py
|
||||||
|
index 09d26dd87029..63c9f23bb09b 100644
|
||||||
|
--- a/tuna/config.py
|
||||||
|
+++ b/tuna/config.py
|
||||||
|
@@ -1,3 +1,5 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
+
|
||||||
|
import io
|
||||||
|
import os
|
||||||
|
import re
|
||||||
|
diff --git a/tuna/gui/__init__.py b/tuna/gui/__init__.py
|
||||||
|
index ad1191c13d8d..a40f86292e6f 100755
|
||||||
|
--- a/tuna/gui/__init__.py
|
||||||
|
+++ b/tuna/gui/__init__.py
|
||||||
|
@@ -1,3 +1,5 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
+
|
||||||
|
"""
|
||||||
|
Copyright (c) 2009 Red Hat Inc.
|
||||||
|
|
||||||
|
diff --git a/tuna/gui/commonview.py b/tuna/gui/commonview.py
|
||||||
|
index cc8f913819a2..8089ed154dae 100644
|
||||||
|
--- a/tuna/gui/commonview.py
|
||||||
|
+++ b/tuna/gui/commonview.py
|
||||||
|
@@ -1,3 +1,5 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
+
|
||||||
|
from gi.repository import Gtk
|
||||||
|
from tuna import tuna
|
||||||
|
|
||||||
|
diff --git a/tuna/gui/cpuview.py b/tuna/gui/cpuview.py
|
||||||
|
index cc3f0f905ae7..844705a4bb21 100755
|
||||||
|
--- a/tuna/gui/cpuview.py
|
||||||
|
+++ b/tuna/gui/cpuview.py
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
# -*- python -*-
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
|
||||||
|
from functools import reduce
|
||||||
|
|
||||||
|
diff --git a/tuna/gui/irqview.py b/tuna/gui/irqview.py
|
||||||
|
index 5143d6dc0df5..e89fb70197fc 100755
|
||||||
|
--- a/tuna/gui/irqview.py
|
||||||
|
+++ b/tuna/gui/irqview.py
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
# -*- python -*-
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
from tuna import tuna, gui
|
||||||
|
import procfs
|
||||||
|
from gi.repository import Gdk
|
||||||
|
diff --git a/tuna/gui/procview.py b/tuna/gui/procview.py
|
||||||
|
index 440a289a1b29..78d5f573dd49 100755
|
||||||
|
--- a/tuna/gui/procview.py
|
||||||
|
+++ b/tuna/gui/procview.py
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
import re
|
||||||
|
import os
|
||||||
|
import tuna.tuna_sched as tuna_sched
|
||||||
|
diff --git a/tuna/gui/profileview.py b/tuna/gui/profileview.py
|
||||||
|
index 26f58cbc8f4f..7570bc0e57ce 100644
|
||||||
|
--- a/tuna/gui/profileview.py
|
||||||
|
+++ b/tuna/gui/profileview.py
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
import os
|
||||||
|
import shutil
|
||||||
|
import gi
|
||||||
|
diff --git a/tuna/gui/util.py b/tuna/gui/util.py
|
||||||
|
index ec368ae4b2c9..92bd368179cc 100644
|
||||||
|
--- a/tuna/gui/util.py
|
||||||
|
+++ b/tuna/gui/util.py
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
import errno
|
||||||
|
import os
|
||||||
|
import gi
|
||||||
|
diff --git a/tuna/new_eth.py b/tuna/new_eth.py
|
||||||
|
index 98f9179d5695..e2888d4cef36 100755
|
||||||
|
--- a/tuna/new_eth.py
|
||||||
|
+++ b/tuna/new_eth.py
|
||||||
|
@@ -1,4 +1,5 @@
|
||||||
|
# Copyright (C) 2022 John Kacur
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
""" A few functions similar to ethtool """
|
||||||
|
import os
|
||||||
|
import socket
|
||||||
|
diff --git a/tuna/oscilloscope.py b/tuna/oscilloscope.py
|
||||||
|
index 317fe4554c60..a44ace53ec27 100755
|
||||||
|
--- a/tuna/oscilloscope.py
|
||||||
|
+++ b/tuna/oscilloscope.py
|
||||||
|
@@ -8,20 +8,7 @@
|
||||||
|
# http://git.kernel.org/?p=linux/kernel/git/acme/tuna.git;a=tree
|
||||||
|
# For newer versions and to see it integrated with tuna
|
||||||
|
#
|
||||||
|
-# This library is free software; you can redistribute it and/or
|
||||||
|
-# modify it under the terms of the GNU Lesser General Public
|
||||||
|
-# License as published by the Free Software Foundation;
|
||||||
|
-# version 2.1 of the License.
|
||||||
|
-#
|
||||||
|
-# This library is distributed in the hope that it will be useful,
|
||||||
|
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||||
|
-# Lesser General Public License for more details.
|
||||||
|
-#
|
||||||
|
-# You should have received a copy of the GNU Lesser General Public
|
||||||
|
-# License along with this library; if not, write to the Free Software
|
||||||
|
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
|
||||||
|
-# USA
|
||||||
|
+# SPDX-License-Identifier: LGPL-2.1-only
|
||||||
|
|
||||||
|
import os
|
||||||
|
import sys
|
||||||
|
diff --git a/tuna/sysfs.py b/tuna/sysfs.py
|
||||||
|
index 1c903e106a44..cd2377a8df26 100755
|
||||||
|
--- a/tuna/sysfs.py
|
||||||
|
+++ b/tuna/sysfs.py
|
||||||
|
@@ -1,5 +1,7 @@
|
||||||
|
# -*- python -*-
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
+
|
||||||
|
"""
|
||||||
|
classes for /sys/devices/system/cpu/
|
||||||
|
so we can get topology information and do CPU hotplug operations
|
||||||
|
diff --git a/tuna/tuna.py b/tuna/tuna.py
|
||||||
|
index e64211b88fc3..464d7f73212e 100755
|
||||||
|
--- a/tuna/tuna.py
|
||||||
|
+++ b/tuna/tuna.py
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
# -*- python -*-
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
|
||||||
|
import copy
|
||||||
|
import errno
|
||||||
|
@@ -649,12 +650,12 @@ def generate_rtgroups(filename, kthreads, nr_cpus):
|
||||||
|
f.write('''# Generated by tuna
|
||||||
|
#
|
||||||
|
# Use it with rtctl:
|
||||||
|
-#
|
||||||
|
+#
|
||||||
|
# rtctl --file %s reset
|
||||||
|
#
|
||||||
|
# Please use 'man rtctl' for more operations
|
||||||
|
#
|
||||||
|
-# Associate processes into named groups with default priority and
|
||||||
|
+# Associate processes into named groups with default priority and
|
||||||
|
# scheduling policy.
|
||||||
|
#
|
||||||
|
# Format is: <groupname>:<sched>:<prio>:<regex>
|
||||||
|
@@ -663,7 +664,7 @@ def generate_rtgroups(filename, kthreads, nr_cpus):
|
||||||
|
# sched must be one of: 'f' (fifo)
|
||||||
|
# 'b' (batch)
|
||||||
|
# 'r' (round-robin)
|
||||||
|
-# 'o' (other)
|
||||||
|
+# 'o' (other)
|
||||||
|
# '*' (leave alone)
|
||||||
|
# regex is an awk regex
|
||||||
|
#
|
||||||
|
diff --git a/tuna/tuna_gui.py b/tuna/tuna_gui.py
|
||||||
|
index 459f90303ed5..cefee4a57697 100755
|
||||||
|
--- a/tuna/tuna_gui.py
|
||||||
|
+++ b/tuna/tuna_gui.py
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
# -*- python -*-
|
||||||
|
# -*- coding: utf-8 -*-
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
|
||||||
|
import sys
|
||||||
|
import os
|
||||||
|
diff --git a/tuna/tuna_sched.py b/tuna/tuna_sched.py
|
||||||
|
index de9846bb5fae..1051983e53f9 100644
|
||||||
|
--- a/tuna/tuna_sched.py
|
||||||
|
+++ b/tuna/tuna_sched.py
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
#!/usr/bin/python3
|
||||||
|
# Copyright (C) 2022 John Kacur
|
||||||
|
+# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
"""
|
||||||
|
Functions to translate a scheduling policy into either a string name or an
|
||||||
|
equivalent integer
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,34 @@
|
|||||||
|
From f2763aaed8f421bcf266a3122a84c41a7441a5d9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: John Kacur <jkacur@redhat.com>
|
||||||
|
Date: Mon, 11 Dec 2023 16:29:02 -0500
|
||||||
|
Subject: [PATCH] tuna: Don't start the gui if a display is not available
|
||||||
|
|
||||||
|
This is intended for the getopt branch of tuna
|
||||||
|
|
||||||
|
Don't start the gui if a display is not available.
|
||||||
|
|
||||||
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||||
|
---
|
||||||
|
tuna-cmd.py | 6 ++++++
|
||||||
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/tuna-cmd.py b/tuna-cmd.py
|
||||||
|
index 38e7017336a5..ff2920f06d6f 100755
|
||||||
|
--- a/tuna-cmd.py
|
||||||
|
+++ b/tuna-cmd.py
|
||||||
|
@@ -821,6 +821,12 @@ def main():
|
||||||
|
sys.exit(2)
|
||||||
|
|
||||||
|
if run_gui:
|
||||||
|
+ # Don't try to start the gui if no display is available
|
||||||
|
+ display = os.getenv("DISPLAY")
|
||||||
|
+ if not display:
|
||||||
|
+ usage()
|
||||||
|
+ return
|
||||||
|
+
|
||||||
|
try:
|
||||||
|
from tuna import tuna_gui
|
||||||
|
except ImportError:
|
||||||
|
--
|
||||||
|
2.42.0
|
||||||
|
|
220
SOURCES/tuna-Remove-spec-file-from-git.patch
Normal file
220
SOURCES/tuna-Remove-spec-file-from-git.patch
Normal file
@ -0,0 +1,220 @@
|
|||||||
|
From 2d0f78751760bcc737bc4b3530d77b05aaa1c286 Mon Sep 17 00:00:00 2001
|
||||||
|
From: John Kacur <jkacur@redhat.com>
|
||||||
|
Date: Wed, 18 Oct 2023 10:54:49 -0400
|
||||||
|
Subject: [PATCH 2/2] tuna: Remove spec file from git
|
||||||
|
|
||||||
|
The specfile should be maintained in the distribution and not upstream
|
||||||
|
The specfile that is upstream is largely unmaintained anyway.
|
||||||
|
This change also guts the Makefile which uses the specfile.
|
||||||
|
Most of the functionality in the Makefile is available through tools
|
||||||
|
such as rpmbuild anyway. Leaving the Makefile in place for a few
|
||||||
|
minor things like makeing tagfiles
|
||||||
|
|
||||||
|
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 39 +------------
|
||||||
|
rpm/SPECS/tuna.spec | 137 --------------------------------------------
|
||||||
|
2 files changed, 3 insertions(+), 173 deletions(-)
|
||||||
|
delete mode 100644 rpm/SPECS/tuna.spec
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index a3d71d2de896..a55821a8f908 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -1,42 +1,8 @@
|
||||||
|
#
|
||||||
|
# SPDX-License-Identifier: GPL-2.0-only
|
||||||
|
#
|
||||||
|
-PACKAGE := tuna
|
||||||
|
-VERSION := $(shell rpm -q --qf '%{VERSION} ' --specfile rpm/SPECS/$(PACKAGE).spec | cut -d' ' -f1)
|
||||||
|
-
|
||||||
|
-rpmdirs:
|
||||||
|
- @[ -d rpm/BUILD ] || mkdir rpm/BUILD
|
||||||
|
- @[ -d rpm/RPMS ] || mkdir rpm/RPMS
|
||||||
|
- @[ -d rpm/SRPMS ] || mkdir rpm/SRPMS
|
||||||
|
- @[ -d rpm/SOURCES ] || mkdir rpm/SOURCES
|
||||||
|
-
|
||||||
|
-bz2: rpmdirs
|
||||||
|
- git archive --format=tar --prefix=$(PACKAGE)-$(VERSION)/ HEAD | \
|
||||||
|
- bzip2 -9 > rpm/SOURCES/$(PACKAGE)-$(VERSION).tar.bz2
|
||||||
|
-
|
||||||
|
-rpm: bz2 rpmdirs
|
||||||
|
- rpmbuild -ba --define "_topdir $(PWD)/rpm" rpm/SPECS/$(PACKAGE).spec
|
||||||
|
-
|
||||||
|
-bz2dev: rpmdirs
|
||||||
|
- @mkdir -p /tmp/$(PACKAGE)-$(VERSION)
|
||||||
|
- @tar cf - `cat MANIFEST` | (cd /tmp/$(PACKAGE)-$(VERSION) ; tar xf -)
|
||||||
|
- @(cd /tmp; tar cf - $(PACKAGE)-$(VERSION)) | bzip2 -9 > rpm/SOURCES/$(PACKAGE)-$(VERSION).tar.bz2
|
||||||
|
-
|
||||||
|
-rpmdev: bz2dev rpmdirs
|
||||||
|
- rpmbuild -ba --define "_topdir $(PWD)/rpm" rpm/SPECS/$(PACKAGE).spec
|
||||||
|
-
|
||||||
|
-po/$(PACKAGE).pot:
|
||||||
|
- xgettext -k_ -kN_ -f po/POTFILES.in -o $@
|
||||||
|
-
|
||||||
|
-po/%.po: po/$(PACKAGE).pot
|
||||||
|
- msgmerge --suffix=.old -U $@ $< && rm -f $@.old
|
||||||
|
-
|
||||||
|
-rpmclean:
|
||||||
|
- @rm -f rpm/RPMS/*/$(PACKAGE)-$(VERSION)-*.rpm
|
||||||
|
- @rm -f rpm/SRPMS/$(PACKAGE)-$(VERSION)-*.src.rpm
|
||||||
|
- @rm -f rpm/SOURCES/$(PACKAGE)-$(VERSION).tar.bz2
|
||||||
|
- @rm -rf rpm/BUILD/$(PACKAGE)-$(VERSION)*
|
||||||
|
|
||||||
|
+.PHONY: pyclean
|
||||||
|
pyclean:
|
||||||
|
@find . -type f \( -name \*~ -o -name \*.pyc \) -delete
|
||||||
|
|
||||||
|
@@ -52,4 +18,5 @@ cleantags:
|
||||||
|
cleanlogs:
|
||||||
|
rm -rf tuna-20*
|
||||||
|
|
||||||
|
-clean: pyclean rpmclean
|
||||||
|
+.PHONY: clean
|
||||||
|
+clean: pyclean
|
||||||
|
diff --git a/rpm/SPECS/tuna.spec b/rpm/SPECS/tuna.spec
|
||||||
|
deleted file mode 100644
|
||||||
|
index eca96c833265..000000000000
|
||||||
|
--- a/rpm/SPECS/tuna.spec
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,137 +0,0 @@
|
||||||
|
-Name: tuna
|
||||||
|
-Version: 0.15
|
||||||
|
-Release: 1%{?dist}
|
||||||
|
-License: GPLv2
|
||||||
|
-Summary: Application tuning GUI & command line utility
|
||||||
|
-Group: Applications/System
|
||||||
|
-Source: http://userweb.kernel.org/~acme/tuna/%{name}-%{version}.tar.bz2
|
||||||
|
-URL: http://userweb.kernel.org/~acme/tuna/
|
||||||
|
-BuildArch: noarch
|
||||||
|
-BuildRequires: python-devel, gettext, desktop-file-utils
|
||||||
|
-Requires: python-ethtool
|
||||||
|
-Requires: python-linux-procfs >= 0.6
|
||||||
|
-# This really should be a Suggests...
|
||||||
|
-# Requires: python-inet_diag
|
||||||
|
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
-
|
||||||
|
-%description
|
||||||
|
-Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
|
||||||
|
-per thread/IRQ level. Allows isolating CPUs for use by a specific application
|
||||||
|
-and moving threads and interrupts to a CPU by just dragging and dropping them.
|
||||||
|
-Operations can be done on CPU sockets, understanding CPU topology.
|
||||||
|
-
|
||||||
|
-Can be used as a command line utility without requiring the GUI libraries to be
|
||||||
|
-installed.
|
||||||
|
-
|
||||||
|
-%package -n oscilloscope
|
||||||
|
-Summary: Generic graphical signal plotting tool
|
||||||
|
-Group: Applications/System
|
||||||
|
-Requires: python-matplotlib
|
||||||
|
-Requires: numpy
|
||||||
|
-Requires: pygtk2
|
||||||
|
-Requires: tuna = %{version}-%{release}
|
||||||
|
-
|
||||||
|
-%description -n oscilloscope
|
||||||
|
-Plots stream of values read from standard input on the screen together with
|
||||||
|
-statistics and a histogram.
|
||||||
|
-
|
||||||
|
-Allows to instantly see how a signal generator, such as cyclictest, signaltest
|
||||||
|
-or even ping, reacts when, for instance, its scheduling policy or real time
|
||||||
|
-priority is changed, be it using tuna or plain chrt & taskset.
|
||||||
|
-
|
||||||
|
-%prep
|
||||||
|
-%setup -q
|
||||||
|
-
|
||||||
|
-%build
|
||||||
|
-%{python3} setup.py build
|
||||||
|
-
|
||||||
|
-%install
|
||||||
|
-rm -rf %{buildroot}
|
||||||
|
-%{python3} setup.py install --skip-build --root %{buildroot}
|
||||||
|
-mkdir -p %{buildroot}/%{_sysconfdir}/tuna/
|
||||||
|
-mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/tuna/help/kthreads,%{_mandir}/man8}
|
||||||
|
-mkdir -p %{buildroot}/%{_datadir}/polkit-1/actions/
|
||||||
|
-install -p -m644 tuna/tuna_gui.glade %{buildroot}/%{_datadir}/tuna/
|
||||||
|
-install -p -m755 tuna-cmd.py %{buildroot}/%{_bindir}/tuna
|
||||||
|
-install -p -m755 oscilloscope-cmd.py %{buildroot}/%{_bindir}/oscilloscope
|
||||||
|
-install -p -m644 help/kthreads/* %{buildroot}/%{_datadir}/tuna/help/kthreads/
|
||||||
|
-install -p -m644 docs/tuna.8 %{buildroot}/%{_mandir}/man8/
|
||||||
|
-install -p -m644 etc/tuna/example.conf %{buildroot}/%{_sysconfdir}/tuna/
|
||||||
|
-install -p -m644 etc/tuna.conf %{buildroot}/%{_sysconfdir}/
|
||||||
|
-install -p -m644 org.tuna.policy %{buildroot}/%{_datadir}/polkit-1/actions/
|
||||||
|
-desktop-file-install --dir=%{buildroot}/%{_datadir}/applications tuna.desktop
|
||||||
|
-
|
||||||
|
-# l10n-ed message catalogues
|
||||||
|
-for lng in `cat po/LINGUAS`; do
|
||||||
|
- po=po/"$lng.po"
|
||||||
|
- mkdir -p %{buildroot}/%{_datadir}/locale/${lng}/LC_MESSAGES
|
||||||
|
- msgfmt $po -o %{buildroot}/%{_datadir}/locale/${lng}/LC_MESSAGES/%{name}.mo
|
||||||
|
-done
|
||||||
|
-
|
||||||
|
-%find_lang %name
|
||||||
|
-
|
||||||
|
-%clean
|
||||||
|
-rm -rf %{buildroot}
|
||||||
|
-
|
||||||
|
-%files -f %{name}.lang
|
||||||
|
-%defattr(-,root,root,-)
|
||||||
|
-%doc ChangeLog
|
||||||
|
-%if "%{python_ver}" >= "2.5"
|
||||||
|
-%{python2_sitelib}/*.egg-info
|
||||||
|
-%endif
|
||||||
|
-%{_bindir}/tuna
|
||||||
|
-%{_datadir}/tuna/
|
||||||
|
-%{python3_sitelib}/tuna/
|
||||||
|
-%{_mandir}/man8/tuna.8*
|
||||||
|
-%{_sysconfdir}/tuna.conf
|
||||||
|
-%{_sysconfdir}/tuna/*
|
||||||
|
-%{_datadir}/polkit-1/actions/org.tuna.policy
|
||||||
|
-%{_datadir}/applications/tuna.desktop
|
||||||
|
-
|
||||||
|
-%files -n oscilloscope
|
||||||
|
-%defattr(-,root,root,-)
|
||||||
|
-%{_bindir}/oscilloscope
|
||||||
|
-%doc docs/oscilloscope+tuna.html
|
||||||
|
-%doc docs/oscilloscope+tuna.pdf
|
||||||
|
-
|
||||||
|
-%changelog
|
||||||
|
-* Fri Feb 1 2013 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.10.4-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Fri Aug 24 2012 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.10.3-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Thu Jul 28 2011 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.10.2-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Wed Feb 23 2011 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.10.1-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Wed Feb 23 2011 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.10-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Mon May 17 2010 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9.3-1
|
||||||
|
-- New upstream release
|
||||||
|
-- Fixes the folowing bugzilla.redhat.com tickets:
|
||||||
|
-- 563355 error in tuna --help output
|
||||||
|
-- 574950 cannot use cpu ranges in the tuna GUI
|
||||||
|
-- 559770 tuna backtrace when moving threads
|
||||||
|
-- 563352 tuna backtrace when no thread list is given for --priority
|
||||||
|
-- 563350 tuna backtrace when scheduler is mis-typed.
|
||||||
|
-
|
||||||
|
-* Thu Nov 12 2009 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9.2-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Thu Sep 03 2009 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9.1-1
|
||||||
|
-- New upstream release
|
||||||
|
-
|
||||||
|
-* Wed Aug 26 2009 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9-3
|
||||||
|
-- Rewrite the oscilloscope package summary
|
||||||
|
-- Remove the shebang in tuna/oscilloscope.py
|
||||||
|
-
|
||||||
|
-* Mon Aug 17 2009 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9-2
|
||||||
|
-- Use install -p
|
||||||
|
-- Add BuildRequires for gettext
|
||||||
|
-
|
||||||
|
-* Fri Jul 10 2009 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.9-1
|
||||||
|
-- Fedora package reviewing changes: introduce ChangeLog file
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Name: tuna
|
Name: tuna
|
||||||
Version: 0.18
|
Version: 0.18
|
||||||
Release: 6%{?dist}
|
Release: 9%{?dist}
|
||||||
License: GPLv2
|
License: GPL-2.0-only AND LGPL-2.1-only
|
||||||
Summary: Application tuning GUI & command line utility
|
Summary: Application tuning GUI & command line utility
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: https://www.kernel.org/pub/software/utils/tuna/%{name}-%{version}.tar.xz
|
Source: https://www.kernel.org/pub/software/utils/tuna/%{name}-%{version}.tar.xz
|
||||||
@ -22,6 +22,9 @@ Patch4: tuna-tuna_gui.py-use-fstrings.patch
|
|||||||
Patch5: tuna-tuna-cmd.py-use-fstrings.patch
|
Patch5: tuna-tuna-cmd.py-use-fstrings.patch
|
||||||
Patch6: tuna-Adapt-show_threads-cgroup-output-to-terminal-si.patch
|
Patch6: tuna-Adapt-show_threads-cgroup-output-to-terminal-si.patch
|
||||||
Patch7: tuna-Fix-show_threads-cgroup-without-a-term.patch
|
Patch7: tuna-Fix-show_threads-cgroup-without-a-term.patch
|
||||||
|
Patch8: Add-SPDX-license-identifiers.patch
|
||||||
|
Patch9: tuna-Remove-spec-file-from-git.patch
|
||||||
|
Patch10: tuna-Don-t-start-the-gui-if-a-display-is-not-availab.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
|
Provides interface for changing scheduler and IRQ tunables, at whole CPU and at
|
||||||
@ -80,6 +83,21 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/polkit-1/actions/org.tuna.policy
|
%{_datadir}/polkit-1/actions/org.tuna.policy
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 13 2023 John Kacur <jkacur@redhat.com> - 0.18-9
|
||||||
|
- Don't start the gui if a display is not available
|
||||||
|
- Revert removing distutils for rhel8
|
||||||
|
- Update the License tag in the specfile to the spdx version
|
||||||
|
Resolves: RHEL-19179
|
||||||
|
|
||||||
|
* Mon Dec 11 2023 John Kacur <jkacur@redhat.com> - 0.18-8
|
||||||
|
- Remove deprecated distutils from setup
|
||||||
|
- Adjust SPDX patch to accomdate the removed distutils
|
||||||
|
Resolves: RHEL-19037
|
||||||
|
|
||||||
|
* Wed Nov 01 2023 John Kacur <jkacur@redhat.com> - 0.18-7
|
||||||
|
- Remove specfile from upstream source
|
||||||
|
Resolves: RHEL-9197
|
||||||
|
|
||||||
* Wed Nov 23 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.18-6
|
* Wed Nov 23 2022 Leah Leshchinsky <lleshchi@redhat.com> - 0.18-6
|
||||||
- Fix show_threads --cgroups without a term
|
- Fix show_threads --cgroups without a term
|
||||||
Resolves: rhbz#2121518
|
Resolves: rhbz#2121518
|
||||||
|
Loading…
Reference in New Issue
Block a user