Add --tag=CC to libtool invocations
Otherwise the build fails with clang
This commit is contained in:
parent
1b8a7090fa
commit
5db028aee0
15
ttmkfdir-3.0.9-tag.patch
Normal file
15
ttmkfdir-3.0.9-tag.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- ttmkfdir-3.0.9.old/Makefile 2020-03-25 16:06:55.999792212 +0100
|
||||
+++ ttmkfdir-3.0.9/Makefile 2020-03-25 17:04:16.179479496 +0100
|
||||
@@ -40,10 +40,10 @@
|
||||
all: ttmkfdir
|
||||
|
||||
.cpp.o:
|
||||
- libtool --mode=compile $(CXX) $(CXXFLAGS) -o $@ -c $^
|
||||
+ libtool --tag=CC --mode=compile $(CXX) $(CXXFLAGS) -o $@ -c $^
|
||||
|
||||
ttmkfdir: ttmkfdir.o directory.o commandline.o ttf.o encoding.o parser.o builtin.o
|
||||
- libtool --mode=link $(CXX) -o $@ $^ $(LDFLAGS)
|
||||
+ libtool --tag=CC --mode=link $(CXX) -o $@ $^ $(LDFLAGS)
|
||||
|
||||
parser.cpp: encoding.l
|
||||
flex -i -8 -o$@ $<
|
@ -1,7 +1,7 @@
|
||||
Summary: Utility to create fonts.scale files for truetype fonts
|
||||
Name: ttmkfdir
|
||||
Version: 3.0.9
|
||||
Release: 60%{?dist}
|
||||
Release: 61%{?dist}
|
||||
# Only licensing attribution is in README, no version.
|
||||
License: LGPLv2+
|
||||
# This is a Red Hat maintained package which is specific to
|
||||
@ -20,6 +20,7 @@ Patch8: ttmkfdir-3.0.9-font-scale.patch
|
||||
Patch9: ttmkfdir-3.0.9-bug434301.patch
|
||||
Patch10:ttmkfdir-3.0.9-freetype-header-fix2.patch
|
||||
Patch11:ttmkfdir-3.0.9-fedora-ldflags.patch
|
||||
Patch12:ttmkfdir-3.0.9-tag.patch
|
||||
Source10: ttmkfdir.1
|
||||
|
||||
BuildRequires: freetype-devel >= 2.0
|
||||
@ -52,6 +53,7 @@ cp -p %{SOURCE10} %{buildroot}%{_mandir}/man1/
|
||||
%changelog
|
||||
* Mon Mar 30 2020 Timm Baeder <tbaeder@redhat.com> - 3.0.9-60
|
||||
- Pass -pie separately to %%{make_build}
|
||||
- Pass --tag=CC to libtool invocations
|
||||
|
||||
* Mon Mar 16 2020 Tom Stellard <tstellar@redhat.com> - 3.0.9-59
|
||||
- Use make_build and make_install macros
|
||||
|
Loading…
Reference in New Issue
Block a user