tss2: rebase to v1.6.0 release
Tested with reg.sh -a against ibmtpm simulator version 1637. Signed-off-by: Jerry Snitselaar <jsnitsel@redhat.com>
This commit is contained in:
parent
fdad28706b
commit
e6b7d68bb6
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/ibmtss1027.tar.gz
|
||||
/makeman.sh
|
||||
/ibmtss1331.tar.gz
|
||||
/ibmtss1.6.0.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
diff -ur tss2-1234/utils/makefile-common tss2-1234-new/utils/makefile-common
|
||||
--- tss2-1234/utils/makefile-common 2018-05-29 12:00:46.000000000 -0700
|
||||
+++ tss2-1234-new/utils/makefile-common 2018-10-02 15:10:20.783078580 -0700
|
||||
@@ -44,7 +44,7 @@
|
||||
CCFLAGS += \
|
||||
-Wall -W -Wmissing-declarations -Wmissing-prototypes -Wnested-externs \
|
||||
-Wformat=2 -Wold-style-definition -Wno-self-assign \
|
||||
- -ggdb -O0 -c
|
||||
+ -ggdb -c
|
||||
|
||||
# to compile with optimizations on (warning will result)
|
||||
# -O3 -c
|
||||
diff -ur tss2-1234/utils/makefile.fedora tss2-1234-new/utils/makefile.fedora
|
||||
--- tss2-1234/utils/makefile.fedora 2018-05-15 10:07:20.000000000 -0700
|
||||
+++ tss2-1234-new/utils/makefile.fedora 2018-10-02 15:11:33.909083615 -0700
|
||||
@@ -71,7 +71,7 @@
|
||||
|
||||
# compile - common flags for TSS library and applications
|
||||
|
||||
-CCFLAGS += -DTPM_POSIX
|
||||
+CCFLAGS += -DTPM_POSIX -DTPM_INTERFACE_TYPE_DEFAULT="\"dev\"" -DTPM_DEVICE_DEFAULT="\"/dev/tpmrm0\""
|
||||
|
||||
# example of pointing to a locally built openssl 1.1
|
||||
# CCFLAGS += -I/home/kgold/openssl-1.1.0c/include
|
||||
@@ -119,7 +119,7 @@
|
||||
LNLFLAGS += -shared -Wl,-z,now
|
||||
|
||||
# This is an alternative to using the bfd linker on Ubuntu
|
||||
-# LNLLIBS += -lcrypto
|
||||
+LNLLIBS += -lcrypto
|
||||
|
||||
# link - for applications, TSS path, TSS and OpenSSl libraries
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -ur tss2-1234/utils/policymaker.c tss2-1234-new/utils/policymaker.c
|
||||
--- tss2-1234/utils/policymaker.c 2018-10-18 12:16:59.742439220 -0700
|
||||
+++ tss2-1234-new/utils/policymaker.c 2018-10-18 12:34:34.991755536 -0700
|
||||
@@ -208,10 +208,10 @@
|
||||
}
|
||||
/* hash extend */
|
||||
if ((rc == 0) && (prc != NULL)) {
|
||||
- TSS_Hash_Generate(&digest,
|
||||
- startSizeInBytes, (uint8_t *)&digest.digest, /* extend */
|
||||
- lineLength /2, lineBinary,
|
||||
- 0, NULL);
|
||||
+ rc = TSS_Hash_Generate(&digest,
|
||||
+ startSizeInBytes, (uint8_t *)&digest.digest, /* extend */
|
||||
+ lineLength /2, lineBinary,
|
||||
+ 0, NULL);
|
||||
}
|
||||
if ((rc == 0) && (prc != NULL)) {
|
||||
if (verbose) TSS_PrintAll("intermediate policy digest",
|
12
picfix.patch
12
picfix.patch
@ -1,12 +0,0 @@
|
||||
diff -Nrup a/utils/makefile.fedora b/utils/makefile.fedora
|
||||
--- a/utils/makefile.fedora 2019-12-19 16:26:06.695476012 -0700
|
||||
+++ b/utils/makefile.fedora 2019-12-19 16:25:58.153501665 -0700
|
||||
@@ -181,6 +181,8 @@ tsscryptoh.o: $(TSS_HEADERS) tsscryptoh
|
||||
$(CC) $(CCFLAGS) $(CCLFLAGS) tsscryptoh.c
|
||||
tsscrypto.o: $(TSS_HEADERS) tsscrypto.c
|
||||
$(CC) $(CCFLAGS) $(CCLFLAGS) tsscrypto.c
|
||||
+tssprintcmd.o: $(TSS_HEADERS) tssprintcmd.c
|
||||
+ $(CC) $(CCFLAGS) $(CCLFLAGS) tssprintcmd.c
|
||||
tssutils.o: $(TSS_HEADERS) tssutils.c
|
||||
$(CC) $(CCFLAGS) $(CCLFLAGS) tssutils.c
|
||||
tssfile.o: $(TSS_HEADERS) tssfile.c
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ibmtss1331.tar.gz) = b1d41e0779f2ada6a61e38b8686b64272df5bf0c73b6fd8baac2d4ea9ae23e56910d95e6412683b44fc8bb7da7bc4a349709b02bf9b137498100b4d7288aca11
|
||||
SHA512 (ibmtss1.6.0.tar.gz) = 0bbe5282df56790dc2b63f4916977e15818704f6acdc18ee815fdf233d5a5955edfe285131a1e64c1c49d6f0fdde8e8baf97b633866e595df902dccbd4c61d5f
|
||||
|
1534
tss2-1.6.0-manpage-cleanup.patch
Normal file
1534
tss2-1.6.0-manpage-cleanup.patch
Normal file
File diff suppressed because it is too large
Load Diff
60
tss2.spec
60
tss2.spec
@ -6,20 +6,20 @@
|
||||
%global incname ibmtss
|
||||
|
||||
Name: tss2
|
||||
Version: 1331
|
||||
Release: 7%{?dist}
|
||||
Version: 1.6.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
Summary: IBM's TCG Software Stack (TSS) for TPM 2.0 and related utilities
|
||||
|
||||
License: BSD
|
||||
URL: http://sourceforge.net/projects/ibmtpm20tss/
|
||||
Source0: https://sourceforge.net/projects/ibmtpm20tss/files/ibmtss%{version}.tar.gz
|
||||
Patch1: flags-fixup.patch
|
||||
Patch2: hash_generate.patch
|
||||
Patch3: picfix.patch
|
||||
Patch0: tss2-1.6.0-manpage-cleanup.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: libtool
|
||||
BuildRequires: gcc
|
||||
BuildRequires: help2man
|
||||
BuildRequires: openssl-devel
|
||||
Requires: openssl
|
||||
|
||||
@ -34,7 +34,7 @@ education and debugging.
|
||||
|
||||
%package devel
|
||||
Summary: Development libraries and headers for IBM's TSS 2.0
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Development libraries and headers for IBM's TSS 2.0. You will need this in
|
||||
@ -44,56 +44,36 @@ order to build TSS 2.0 applications.
|
||||
%autosetup -p1 -c %{name}-%{version}
|
||||
|
||||
%build
|
||||
# nonstandard variable names are used in place of CFLAGS and LDFLAGS
|
||||
pushd utils
|
||||
autoreconf -vi
|
||||
%configure --disable-static --disable-tpm-1.2 --program-prefix=tss
|
||||
CCFLAGS="%{optflags}" \
|
||||
LNFLAGS="%{__global_ldflags}" \
|
||||
%{make_build} -f makefile.fedora
|
||||
popd
|
||||
%{make_build}
|
||||
|
||||
%install
|
||||
# Prefix for namespacing
|
||||
BIN_PREFIX=tss
|
||||
mkdir -p %{buildroot}/%{_bindir}
|
||||
mkdir -p %{buildroot}/%{_libdir}
|
||||
mkdir -p %{buildroot}/%{_includedir}/%{incname}/
|
||||
mkdir -p %{buildroot}/%{_mandir}/man1
|
||||
pushd utils
|
||||
# Pick out executables and copy with namespacing
|
||||
for f in *; do
|
||||
if [[ -x $f && -f $f && ! $f =~ .*\..* ]]; then
|
||||
cp -p $f %{buildroot}/%{_bindir}/${BIN_PREFIX}$f
|
||||
fi;
|
||||
done
|
||||
cp -p *.so.1.1 %{buildroot}/%{_libdir}
|
||||
cp -p %{incname}/*.h %{buildroot}/%{_includedir}/%{incname}/
|
||||
cp -p man/man1/tss*.1 %{buildroot}/%{_mandir}/man1/
|
||||
popd
|
||||
|
||||
|
||||
# Make symbolic links to the shared lib
|
||||
pushd %{buildroot}/%{_libdir}
|
||||
rm -f libibmtss.so.1
|
||||
ln -sf libibmtss.so.1.1 libibmtss.so.1
|
||||
rm -f libibmtss.so
|
||||
ln -sf libibmtss.so.1 libibmtss.so
|
||||
popd
|
||||
%make_install
|
||||
find %{buildroot} -type f -name "*.la" -delete -print
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%{_bindir}/tss*
|
||||
%{_libdir}/libibmtss.so.1
|
||||
%{_libdir}/libibmtss.so.1.*
|
||||
%{_libdir}/libibmtss.so.*
|
||||
%{_libdir}/libibmtssutils.so.*
|
||||
%attr(0644, root, root) %{_mandir}/man1/tss*.1*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/%{incname}
|
||||
%{_libdir}/libibmtss.so
|
||||
%{_libdir}/libibmtssutils.so
|
||||
%doc ibmtss.doc
|
||||
|
||||
%changelog
|
||||
* Mon Feb 8 2021 Jerry Snitselaar <jsnitsel@redhat.com> - 1.6.0-1
|
||||
- Rebase to v1.6.0 release.
|
||||
- Manpage cleanup.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1331-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user