import tree-1.7.0-15.el8
This commit is contained in:
commit
39bac30058
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/tree-1.7.0.tgz
|
1
.tree.metadata
Normal file
1
.tree.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
35bd212606e6c5d60f4d5062f4a59bb7b7b25949 SOURCES/tree-1.7.0.tgz
|
12
SOURCES/tree-args.patch
Normal file
12
SOURCES/tree-args.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up tree-1.6.0/tree.c.args tree-1.6.0/tree.c
|
||||||
|
--- tree-1.6.0/tree.c.args 2013-04-11 11:53:47.676572649 +0100
|
||||||
|
+++ tree-1.6.0/tree.c 2013-04-11 11:56:10.962350448 +0100
|
||||||
|
@@ -536,6 +536,8 @@ void usage(int n)
|
||||||
|
" --filelimit # Do not descend dirs with more than # files in them.\n"
|
||||||
|
" --timefmt <f> Print and format time according to the format <f>.\n"
|
||||||
|
" -o filename Output to file instead of stdout.\n"
|
||||||
|
+ " --du Print directory sizes.\n"
|
||||||
|
+ " --prune Prune empty directories from the output.\n"
|
||||||
|
" -------- File options ---------\n"
|
||||||
|
" -q Print non-printable characters as '?'.\n"
|
||||||
|
" -N Print non-printable characters as is.\n"
|
12
SOURCES/tree-dircolors-ec.patch
Normal file
12
SOURCES/tree-dircolors-ec.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up tree-1.6.0/color.c.dircolors-ec tree-1.6.0/color.c
|
||||||
|
--- tree-1.6.0/color.c.dircolors-ec 2013-07-09 13:29:19.431819355 +0100
|
||||||
|
+++ tree-1.6.0/color.c 2013-07-09 13:29:48.820987889 +0100
|
||||||
|
@@ -190,7 +190,7 @@ void parse_dir_colors()
|
||||||
|
if (!norm_flgs) norm_flgs = scopy("00");
|
||||||
|
|
||||||
|
if (!endcode) {
|
||||||
|
- sprintf(buf,"%s%s%s",leftcode,norm_flgs,rightcode);
|
||||||
|
+ sprintf(buf,"%s0%s",leftcode,rightcode);
|
||||||
|
endcode = scopy(buf);
|
||||||
|
}
|
||||||
|
|
15
SOURCES/tree-preserve-timestamps.patch
Normal file
15
SOURCES/tree-preserve-timestamps.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up tree-1.6.0/Makefile.preserve-timestamps tree-1.6.0/Makefile
|
||||||
|
--- tree-1.6.0/Makefile.preserve-timestamps 2011-06-27 16:11:26.000000000 +0100
|
||||||
|
+++ tree-1.6.0/Makefile 2011-06-27 16:12:36.394443602 +0100
|
||||||
|
@@ -97,9 +97,9 @@ install: tree
|
||||||
|
install -d $(BINDIR)
|
||||||
|
install -d $(MANDIR)
|
||||||
|
if [ -e $(TREE_DEST) ]; then \
|
||||||
|
- install $(TREE_DEST) $(BINDIR)/$(TREE_DEST); \
|
||||||
|
+ install -p $(TREE_DEST) $(BINDIR)/$(TREE_DEST); \
|
||||||
|
fi
|
||||||
|
- install doc/$(MAN) $(MANDIR)/$(MAN)
|
||||||
|
+ install -p doc/$(MAN) $(MANDIR)/$(MAN)
|
||||||
|
|
||||||
|
distclean:
|
||||||
|
if [ -f tree.o ]; then rm *.o; fi
|
14
SOURCES/tree-size-field-len.patch
Normal file
14
SOURCES/tree-size-field-len.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up tree-1.7.0/tree.c.size-field-len tree-1.7.0/tree.c
|
||||||
|
--- tree-1.7.0/tree.c.size-field-len 2014-04-25 16:30:51.539046882 +0100
|
||||||
|
+++ tree-1.7.0/tree.c 2014-04-25 16:32:20.098483921 +0100
|
||||||
|
@@ -1247,8 +1247,8 @@ int psize(char *buf, off_t size)
|
||||||
|
|
||||||
|
if (hflag || siflag) {
|
||||||
|
for (idx=size<usize?0:1; size >= (usize*usize); idx++,size/=usize);
|
||||||
|
- if (!idx) return sprintf(buf, " %4d", (int)size);
|
||||||
|
- else return sprintf(buf, ((size/usize) >= 10)? " %3.0f%c" : " %3.1f%c" , (float)size/(float)usize,unit[idx]);
|
||||||
|
+ if (!idx) return sprintf(buf, " %5d", (int)size);
|
||||||
|
+ else return sprintf(buf, ((size/usize) >= 10)? " %4.0f%c" : " %4.1f%c" , (float)size/(float)usize,unit[idx]);
|
||||||
|
} else return sprintf(buf, sizeof(off_t) == sizeof(long long)? " %11lld" : " %9ld", (long long int)size);
|
||||||
|
}
|
||||||
|
|
214
SOURCES/tree-static-analysis.patch
Normal file
214
SOURCES/tree-static-analysis.patch
Normal file
@ -0,0 +1,214 @@
|
|||||||
|
From 48641275c0cd018441685f2d3145038017f1ea42 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
|
Date: Tue, 6 Nov 2018 16:31:32 +0100
|
||||||
|
Subject: [PATCH] tree: fix programming mistakes detected by static analysis
|
||||||
|
|
||||||
|
---
|
||||||
|
color.c | 6 +++---
|
||||||
|
html.c | 5 +++--
|
||||||
|
json.c | 11 +++++------
|
||||||
|
tree.c | 2 +-
|
||||||
|
unix.c | 5 +++--
|
||||||
|
xml.c | 11 +++++------
|
||||||
|
6 files changed, 20 insertions(+), 20 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/color.c b/color.c
|
||||||
|
index b4ef54e..04425dc 100644
|
||||||
|
--- a/color.c
|
||||||
|
+++ b/color.c
|
||||||
|
@@ -235,8 +235,8 @@ int cmd(char *s)
|
||||||
|
|
||||||
|
for(i=0;cmds[i].cmdnum;i++)
|
||||||
|
if (!strcmp(cmds[i].cmd,s)) return cmds[i].cmdnum;
|
||||||
|
- if (s[0] == '*') return DOT_EXTENSION;
|
||||||
|
- return ERROR;
|
||||||
|
+ if (s[0] == '*') return DOT_EXTENSION;
|
||||||
|
+ return ERROR;
|
||||||
|
}
|
||||||
|
|
||||||
|
int color(u_short mode, char *name, bool orphan, bool islink)
|
||||||
|
@@ -489,7 +489,7 @@ void initlinedraw(int flag)
|
||||||
|
for(linedraw=cstable;linedraw->name;++linedraw)
|
||||||
|
for(s=linedraw->name;*s;++s)
|
||||||
|
fprintf(stderr," %s\n",*s);
|
||||||
|
- return;
|
||||||
|
+ return;
|
||||||
|
}
|
||||||
|
if (charset) {
|
||||||
|
for(linedraw=cstable;linedraw->name;++linedraw)
|
||||||
|
diff --git a/html.c b/html.c
|
||||||
|
index 75e2ed1..35fb525 100644
|
||||||
|
--- a/html.c
|
||||||
|
+++ b/html.c
|
||||||
|
@@ -220,7 +220,7 @@ off_t html_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
if (*(*dir)->lnk == '/')
|
||||||
|
listdir((*dir)->lnk,dt,ft,lev+1,dev);
|
||||||
|
else {
|
||||||
|
- if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->name)+1024));
|
||||||
|
+ if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->lnk)+1024));
|
||||||
|
if (fflag && !strcmp(d,"/")) sprintf(path,"%s%s",d,(*dir)->lnk);
|
||||||
|
else sprintf(path,"%s/%s",d,(*dir)->lnk);
|
||||||
|
listdir(path,dt,ft,lev+1,dev);
|
||||||
|
@@ -253,7 +253,7 @@ off_t html_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
{
|
||||||
|
struct _info **dir;
|
||||||
|
off_t size = 0;
|
||||||
|
- char *err;
|
||||||
|
+ char *err = NULL;
|
||||||
|
|
||||||
|
dir = getfulltree(d, lev, dev, &size, &err);
|
||||||
|
|
||||||
|
@@ -261,6 +261,7 @@ off_t html_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
|
||||||
|
htmlr_listdir(dir, d, dt, ft, lev);
|
||||||
|
|
||||||
|
+ free(err);
|
||||||
|
return size;
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/json.c b/json.c
|
||||||
|
index 4b15e0d..8c71324 100644
|
||||||
|
--- a/json.c
|
||||||
|
+++ b/json.c
|
||||||
|
@@ -97,8 +97,7 @@ off_t json_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
while(*dir) {
|
||||||
|
if (!noindent) json_indent(lev);
|
||||||
|
|
||||||
|
- if ((*dir)->lnk) mt = (*dir)->mode & S_IFMT;
|
||||||
|
- else mt = (*dir)->mode & S_IFMT;
|
||||||
|
+ mt = (*dir)->mode & S_IFMT;
|
||||||
|
for(t=0;ifmt[t];t++)
|
||||||
|
if (ifmt[t] == mt) break;
|
||||||
|
fprintf(outfile,"{\"type\":\"%s\"", ftype[t]);
|
||||||
|
@@ -140,7 +139,7 @@ off_t json_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
if (*(*dir)->lnk == '/')
|
||||||
|
listdir((*dir)->lnk,dt,ft,lev+1,dev);
|
||||||
|
else {
|
||||||
|
- if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->name)+1024));
|
||||||
|
+ if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->lnk)+1024));
|
||||||
|
if (fflag && !strcmp(d,"/")) sprintf(path,"%s%s",d,(*dir)->lnk);
|
||||||
|
else sprintf(path,"%s/%s",d,(*dir)->lnk);
|
||||||
|
listdir(path,dt,ft,lev+1,dev);
|
||||||
|
@@ -180,7 +179,7 @@ off_t json_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
{
|
||||||
|
struct _info **dir;
|
||||||
|
off_t size = 0;
|
||||||
|
- char *err;
|
||||||
|
+ char *err = NULL;
|
||||||
|
|
||||||
|
dir = getfulltree(d, lev, dev, &size, &err);
|
||||||
|
|
||||||
|
@@ -188,6 +187,7 @@ off_t json_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
|
||||||
|
jsonr_listdir(dir, d, dt, ft, lev);
|
||||||
|
|
||||||
|
+ free(err);
|
||||||
|
return size;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -210,8 +210,7 @@ void jsonr_listdir(struct _info **dir, char *d, int *dt, int *ft, u_long lev)
|
||||||
|
while(*dir) {
|
||||||
|
if (!noindent) json_indent(lev);
|
||||||
|
|
||||||
|
- if ((*dir)->lnk) mt = (*dir)->mode & S_IFMT;
|
||||||
|
- else mt = (*dir)->mode & S_IFMT;
|
||||||
|
+ mt = (*dir)->mode & S_IFMT;
|
||||||
|
for(t=0;ifmt[t];t++)
|
||||||
|
if (ifmt[t] == mt) break;
|
||||||
|
fprintf(outfile,"{\"type\":\"%s\"", ftype[t]);
|
||||||
|
diff --git a/tree.c b/tree.c
|
||||||
|
index 03140fe..73dd101 100644
|
||||||
|
--- a/tree.c
|
||||||
|
+++ b/tree.c
|
||||||
|
@@ -851,7 +851,7 @@ struct _info **getfulltree(char *d, u_long lev, dev_t dev, off_t *size, char **e
|
||||||
|
if (*(*dir)->lnk == '/')
|
||||||
|
(*dir)->child = getfulltree((*dir)->lnk,lev+1,dev,&((*dir)->size),&((*dir)->err));
|
||||||
|
else {
|
||||||
|
- if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->name)+1024));
|
||||||
|
+ if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->lnk)+1024));
|
||||||
|
if (fflag && !strcmp(d,"/")) sprintf(path,"%s%s",d,(*dir)->lnk);
|
||||||
|
else sprintf(path,"%s/%s",d,(*dir)->lnk);
|
||||||
|
(*dir)->child = getfulltree(path,lev+1,dev,&((*dir)->size),&((*dir)->err));
|
||||||
|
diff --git a/unix.c b/unix.c
|
||||||
|
index ca5f76f..9476307 100644
|
||||||
|
--- a/unix.c
|
||||||
|
+++ b/unix.c
|
||||||
|
@@ -128,7 +128,7 @@ off_t unix_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
if (*(*dir)->lnk == '/')
|
||||||
|
listdir((*dir)->lnk,dt,ft,lev+1,dev);
|
||||||
|
else {
|
||||||
|
- if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->name)+1024));
|
||||||
|
+ if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->lnk)+1024));
|
||||||
|
if (fflag && !strcmp(d,"/")) sprintf(path,"%s%s",d,(*dir)->lnk);
|
||||||
|
else sprintf(path,"%s/%s",d,(*dir)->lnk);
|
||||||
|
listdir(path,dt,ft,lev+1,dev);
|
||||||
|
@@ -161,7 +161,7 @@ off_t unix_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
{
|
||||||
|
struct _info **dir;
|
||||||
|
off_t size = 0;
|
||||||
|
- char *err;
|
||||||
|
+ char *err = NULL;
|
||||||
|
|
||||||
|
dir = getfulltree(d, lev, dev, &size, &err);
|
||||||
|
|
||||||
|
@@ -169,6 +169,7 @@ off_t unix_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
|
||||||
|
r_listdir(dir, d, dt, ft, lev);
|
||||||
|
|
||||||
|
+ free(err);
|
||||||
|
return size;
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/xml.c b/xml.c
|
||||||
|
index 32f3c0c..512eed7 100644
|
||||||
|
--- a/xml.c
|
||||||
|
+++ b/xml.c
|
||||||
|
@@ -105,8 +105,7 @@ off_t xml_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
while(*dir) {
|
||||||
|
if (!noindent) xml_indent(lev);
|
||||||
|
|
||||||
|
- if ((*dir)->lnk) mt = (*dir)->mode & S_IFMT;
|
||||||
|
- else mt = (*dir)->mode & S_IFMT;
|
||||||
|
+ mt = (*dir)->mode & S_IFMT;
|
||||||
|
for(t=0;ifmt[t];t++)
|
||||||
|
if (ifmt[t] == mt) break;
|
||||||
|
fprintf(outfile,"<%s", ftype[t]);
|
||||||
|
@@ -144,7 +143,7 @@ off_t xml_listdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
if (*(*dir)->lnk == '/')
|
||||||
|
listdir((*dir)->lnk,dt,ft,lev+1,dev);
|
||||||
|
else {
|
||||||
|
- if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->name)+1024));
|
||||||
|
+ if (strlen(d)+strlen((*dir)->lnk)+2 > pathsize) path=xrealloc(path,pathsize=(strlen(d)+strlen((*dir)->lnk)+1024));
|
||||||
|
if (fflag && !strcmp(d,"/")) sprintf(path,"%s%s",d,(*dir)->lnk);
|
||||||
|
else sprintf(path,"%s/%s",d,(*dir)->lnk);
|
||||||
|
listdir(path,dt,ft,lev+1,dev);
|
||||||
|
@@ -180,7 +179,7 @@ off_t xml_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
{
|
||||||
|
struct _info **dir;
|
||||||
|
off_t size = 0;
|
||||||
|
- char *err;
|
||||||
|
+ char *err = NULL;
|
||||||
|
|
||||||
|
dir = getfulltree(d, lev, dev, &size, &err);
|
||||||
|
|
||||||
|
@@ -188,6 +187,7 @@ off_t xml_rlistdir(char *d, int *dt, int *ft, u_long lev, dev_t dev)
|
||||||
|
|
||||||
|
xmlr_listdir(dir, d, dt, ft, lev);
|
||||||
|
|
||||||
|
+ free(err);
|
||||||
|
return size;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -210,8 +210,7 @@ void xmlr_listdir(struct _info **dir, char *d, int *dt, int *ft, u_long lev)
|
||||||
|
while(*dir) {
|
||||||
|
if (!noindent) xml_indent(lev);
|
||||||
|
|
||||||
|
- if ((*dir)->lnk) mt = (*dir)->mode & S_IFMT;
|
||||||
|
- else mt = (*dir)->mode & S_IFMT;
|
||||||
|
+ mt = (*dir)->mode & S_IFMT;
|
||||||
|
for(t=0;ifmt[t];t++)
|
||||||
|
if (ifmt[t] == mt) break;
|
||||||
|
fprintf(outfile,"<%s", ftype[t]);
|
||||||
|
--
|
||||||
|
2.17.2
|
||||||
|
|
308
SPECS/tree.spec
Normal file
308
SPECS/tree.spec
Normal file
@ -0,0 +1,308 @@
|
|||||||
|
Summary: File system tree viewer
|
||||||
|
Name: tree
|
||||||
|
Version: 1.7.0
|
||||||
|
Release: 15%{?dist}
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://mama.indstate.edu/users/ice/tree/
|
||||||
|
Source: ftp://mama.indstate.edu/linux/tree/tree-%{version}.tgz
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
|
||||||
|
# Preserve timestamp on man page.
|
||||||
|
Patch2: tree-preserve-timestamps.patch
|
||||||
|
|
||||||
|
# Document --du and --prune options in help output (bug #948991).
|
||||||
|
Patch4: tree-args.patch
|
||||||
|
|
||||||
|
# Use correct default for dircolors "ec" field (bug #812934).
|
||||||
|
Patch6: tree-dircolors-ec.patch
|
||||||
|
|
||||||
|
# Keep file size field length constant regardless of whether SI units
|
||||||
|
# are used (bug #997937).
|
||||||
|
Patch7: tree-size-field-len.patch
|
||||||
|
|
||||||
|
# fix programming mistakes detected by static analysis (#1602718)
|
||||||
|
Patch8: tree-static-analysis.patch
|
||||||
|
|
||||||
|
%description
|
||||||
|
The tree utility recursively displays the contents of directories in a
|
||||||
|
tree-like format. Tree is basically a UNIX port of the DOS tree
|
||||||
|
utility.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
|
||||||
|
# do not escape UTF-8 chars in file names by default in UTF-8 locale (#1480778)
|
||||||
|
sed -e 's/LINUX/__linux__/' -i tree.c
|
||||||
|
|
||||||
|
%build
|
||||||
|
make CFLAGS="$RPM_OPT_FLAGS $(getconf LFS_CFLAGS)" \
|
||||||
|
LDFLAGS="$RPM_LD_FLAGS" %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||||
|
|
||||||
|
make BINDIR=$RPM_BUILD_ROOT%{_bindir} \
|
||||||
|
MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
|
||||||
|
install
|
||||||
|
|
||||||
|
chmod -x $RPM_BUILD_ROOT%{_mandir}/man1/tree.1
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_bindir}/tree
|
||||||
|
%{_mandir}/man1/tree.1*
|
||||||
|
%doc README LICENSE
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Nov 07 2018 Kamil Dudka <kdudka@redhat.com> - 1.7.0-15
|
||||||
|
- fix programming mistakes detected by static analysis (#1602718)
|
||||||
|
|
||||||
|
* Fri Feb 23 2018 Florian Weimer <fweimer@redhat.com> - 1.7.0-14
|
||||||
|
- Use LDFLAGS from redhat-rpm-config
|
||||||
|
|
||||||
|
* Mon Feb 19 2018 Kamil Dudka <kdudka@redhat.com> - 1.7.0-13
|
||||||
|
- add explicit BR for the gcc compiler
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 14 2017 Kamil Dudka <kdudka@redhat.com> - 1.7.0-11
|
||||||
|
- do not escape UTF-8 chars in file names by default in UTF-8 locale (#1480778)
|
||||||
|
- modernize spec file (Group, BuildRoot, autosetup, clean, defattr)
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Sep 01 2016 Kamil Dudka <kdudka@redhat.com> - 1.7.0-7
|
||||||
|
- drop a non-upstream patch that disabled color output by default (#1284657)
|
||||||
|
|
||||||
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.7.0-4
|
||||||
|
- Rebuilt for Fedora 23 Change
|
||||||
|
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||||
|
|
||||||
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Apr 25 2014 Tim Waugh <twaugh@redhat.com> - 1.7.0-1
|
||||||
|
- 1.7.0 (bug #1090962).
|
||||||
|
|
||||||
|
* Fri Aug 16 2013 Tim Waugh <twaugh@redhat.com> - 1.6.0-11
|
||||||
|
- Keep file size field length constant regardless of whether SI units
|
||||||
|
are used (bug #997937).
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 9 2013 Tim Waugh <twaugh@redhat.com> - 1.6.0-9
|
||||||
|
- Use correct default for dircolors "ec" field (bug #812934).
|
||||||
|
|
||||||
|
* Thu Jul 4 2013 Tim Waugh <twaugh@redhat.com> - 1.6.0-8
|
||||||
|
- Handle large UID/GID values (bug #980945).
|
||||||
|
|
||||||
|
* Thu Apr 11 2013 Tim Waugh <twaugh@redhat.com> - 1.6.0-7
|
||||||
|
- Document --du and --prune options in help output (bug #948991).
|
||||||
|
|
||||||
|
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 5 2011 Tim Waugh <twaugh@redhat.com> 1.6.0-3
|
||||||
|
- Put LFS_CFLAGS in CFLAGS not CPPFLAGS so they actually get used
|
||||||
|
(bug #769655).
|
||||||
|
|
||||||
|
* Mon Jul 4 2011 Tim Waugh <twaugh@redhat.com> 1.6.0-2
|
||||||
|
- Don't strip the binary too early (bug #718456).
|
||||||
|
|
||||||
|
* Mon Jun 27 2011 Tim Waugh <twaugh@redhat.com> 1.6.0-1
|
||||||
|
- 1.6.0 (bug #716879).
|
||||||
|
|
||||||
|
* Fri May 20 2011 Tim Waugh <twaugh@redhat.com> 1.5.3-4
|
||||||
|
- Fixed memory leak spotted by coverity (bug #704570).
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 3 2010 Tim Waugh <twaugh@redhat.com> 1.5.3-2
|
||||||
|
- Added comments to all patches.
|
||||||
|
|
||||||
|
* Fri Nov 27 2009 Tim Waugh <twaugh@redhat.com> 1.5.3-1
|
||||||
|
- 1.5.3 (bug #517342, bug #541255).
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2.2-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 10 2009 Tim Waugh <twaugh@redhat.com> 1.5.2.2-3
|
||||||
|
- Reinstate no-color-by-default patch (bug #504245).
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 27 2009 Tim Waugh <twaugh@redhat.com> 1.5.2.2-1
|
||||||
|
- 1.5.2.2.
|
||||||
|
|
||||||
|
* Mon Nov 24 2008 Tim Waugh <twaugh@redhat.com> 1.5.2.1-2
|
||||||
|
- Better summary.
|
||||||
|
|
||||||
|
* Tue Sep 2 2008 Tim Waugh <twaugh@redhat.com> 1.5.2.1-1
|
||||||
|
- Removed patch fuzz.
|
||||||
|
- 1.5.2.1.
|
||||||
|
|
||||||
|
* Mon Jun 16 2008 Tim Waugh <twaugh@redhat.com> 1.5.2-1
|
||||||
|
- 1.5.2.
|
||||||
|
- Dropped no-colour patch.
|
||||||
|
|
||||||
|
* Thu Jun 5 2008 Tim Waugh <twaugh@redhat.com> 1.5.1.2-1
|
||||||
|
- 1.5.1.2.
|
||||||
|
|
||||||
|
* Fri Apr 25 2008 Tim Waugh <twaugh@redhat.com> 1.5.1.1-1
|
||||||
|
- 1.5.1.1.
|
||||||
|
|
||||||
|
* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 1.5.0-9
|
||||||
|
- Rebuild for GCC 4.3.
|
||||||
|
|
||||||
|
* Wed Aug 29 2007 Tim Waugh <twaugh@redhat.com> 1.5.0-8
|
||||||
|
- More specific license tag.
|
||||||
|
|
||||||
|
* Wed Feb 7 2007 Tim Waugh <twaugh@redhat.com> 1.5.0-7
|
||||||
|
- Current version no longer ships binary, so don't try removing
|
||||||
|
it (bug #226503).
|
||||||
|
|
||||||
|
* Tue Feb 6 2007 Tim Waugh <twaugh@redhat.com> 1.5.0-6
|
||||||
|
- Preserve timestamps on install (bug #226503).
|
||||||
|
- Added SMP flags (bug #226503).
|
||||||
|
- Removed Prefix: tag (bug #226503).
|
||||||
|
- Removed bogus mkdir call (bug #226503).
|
||||||
|
- Ship the LICENSE file (bug #226503).
|
||||||
|
- Fixed summary (bug #226503).
|
||||||
|
|
||||||
|
* Fri Dec 15 2006 Tim Waugh <twaugh@redhat.com> 1.5.0-5
|
||||||
|
- Fixed '--charset' option (bug #188884).
|
||||||
|
|
||||||
|
* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.5.0-4
|
||||||
|
- rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5.0-3.2.1
|
||||||
|
- bump again for double-long bug on ppc(64)
|
||||||
|
|
||||||
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5.0-3.2
|
||||||
|
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||||
|
|
||||||
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 1.5.0-3
|
||||||
|
- Rebuild for new GCC.
|
||||||
|
|
||||||
|
* Sun Dec 05 2004 Florian La Roche <laroche@redhat.com>
|
||||||
|
- add quotes around CPPFLAGS
|
||||||
|
|
||||||
|
* Mon Sep 13 2004 Tim Waugh <twaugh@redhat.com> 1.5.0-1
|
||||||
|
- 1.5.0 (bug #131854).
|
||||||
|
- No longer need utf8 or gcc34 patches.
|
||||||
|
|
||||||
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Thu Feb 5 2004 Tim Waugh <twaugh@redhat.com> 1.4b3-2
|
||||||
|
- Fixed compilation with GCC 3.4.
|
||||||
|
|
||||||
|
* Wed Aug 13 2003 Tim Waugh <twaugh@redhat.com> 1.4b3-1
|
||||||
|
- Upgraded (bug #88525).
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Nov 8 2002 Tim Waugh <twaugh@redhat.com> 1.2-21
|
||||||
|
- Assume -N except if -q is given (bug #77517).
|
||||||
|
|
||||||
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Tue Apr 23 2002 Tim Waugh <twaugh@redhat.com> 1.2-18
|
||||||
|
- Don't explicitly strip binaries (bug #62569).
|
||||||
|
- Fix malloc/realloc problems (bug #56858).
|
||||||
|
|
||||||
|
* Fri Mar 22 2002 Tim Waugh <twaugh@redhat.com> 1.2-17
|
||||||
|
- Large file support (bug #61456).
|
||||||
|
|
||||||
|
* Wed Feb 27 2002 Tim Waugh <twaugh@redhat.com> 1.2-16
|
||||||
|
- Rebuild in new environment.
|
||||||
|
|
||||||
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Fri Oct 5 2001 Tim Waugh <twaugh@redhat.com> 1.2-14
|
||||||
|
- Fix size format (bug #54298).
|
||||||
|
- Don't use colours by default (bug #25389).
|
||||||
|
|
||||||
|
* Mon Jul 30 2001 Tim Waugh <twaugh@redhat.com> 1.2-13
|
||||||
|
- Change Copyright: to License:.
|
||||||
|
- Don't dump core if LS_COLORS is too big (bug #50016).
|
||||||
|
|
||||||
|
* Wed May 30 2001 Tim Waugh <twaugh@redhat.com> 1.2-12
|
||||||
|
- Sync description with specspo.
|
||||||
|
|
||||||
|
* Tue Oct 10 2000 Tim Waugh <twaugh@redhat.com> 1.2-11
|
||||||
|
- Don't blabber about carrots in the man page (bug #18823)
|
||||||
|
- Use RPM_OPT_FLAGS while building
|
||||||
|
|
||||||
|
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||||
|
- automatic rebuild
|
||||||
|
|
||||||
|
* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
|
||||||
|
- rebuild, FHS stuff
|
||||||
|
|
||||||
|
* Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
|
||||||
|
- remove executable bit from man page (Bug #9035)
|
||||||
|
- deal with rpm compressing man pages
|
||||||
|
|
||||||
|
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- auto rebuild in the new build environment (release 6)
|
||||||
|
|
||||||
|
* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
|
||||||
|
- built package for 6.0
|
||||||
|
|
||||||
|
* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- build root
|
||||||
|
|
||||||
|
* Tue May 05 1998 Prospector System <bugs@redhat.com>
|
||||||
|
- translations modified for de, fr, tr
|
||||||
|
|
||||||
|
* Wed Apr 29 1998 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- installing in /usr/bin
|
||||||
|
|
||||||
|
* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
|
||||||
|
- updated version
|
||||||
|
- fixed src url
|
||||||
|
|
||||||
|
* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
|
||||||
|
- built against glibc
|
Loading…
Reference in New Issue
Block a user