- new upstream release

- patch to generate comments compliant with DSC 3.0 (#558380)
This commit is contained in:
Kamil Dudka 2010-03-03 13:32:12 +00:00
parent 30e7c21e64
commit fbcba3cd00
7 changed files with 95 additions and 22 deletions

View File

@ -1,2 +1 @@
transfig.3.2.4.tar.gz transfig.3.2.5c.tar.gz
transfig.3.2.5.tar.gz

View File

@ -1 +1 @@
3b2cffdd25529ae5877e305f29aae6d1 transfig.3.2.5.tar.gz 0cc55ed6b4ae67a3e610e501acd694f9 transfig.3.2.5c.tar.gz

View File

@ -1,7 +1,8 @@
diff -Naur transfig.3.2.5-modularX/fig2dev/Imakefile transfig.3.2.5/fig2dev/Imakefile diff --git a/fig2dev/Imakefile b/fig2dev/Imakefile
--- transfig.3.2.5-modularX/fig2dev/Imakefile 2008-11-26 10:02:04.000000000 +0100 index 2f76e0b..7e07c39 100755
+++ transfig.3.2.5/fig2dev/Imakefile 2008-11-26 10:02:55.000000000 +0100 --- a/fig2dev/Imakefile
@@ -229,7 +229,7 @@ +++ b/fig2dev/Imakefile
@@ -229,7 +229,7 @@ install::
else (set -x; $(MKDIRHIER) $(DESTDIR)$(XFIGLIBDIR)/bitmaps ); fi ; \ else (set -x; $(MKDIRHIER) $(DESTDIR)$(XFIGLIBDIR)/bitmaps ); fi ; \
echo Copying bitmap files for tk to $(DESTDIR)$(XFIGLIBDIR)/bitmaps ; \ echo Copying bitmap files for tk to $(DESTDIR)$(XFIGLIBDIR)/bitmaps ; \
for f in * ; do \ for f in * ; do \

View File

@ -0,0 +1,57 @@
diff --git a/fig2dev/dev/genps.c b/fig2dev/dev/genps.c
index c7c9e62..00065f2 100644
--- a/fig2dev/dev/genps.c
+++ b/fig2dev/dev/genps.c
@@ -594,9 +594,9 @@ F_compound *objects;
}
if (epsflag)
- fprintf(tfp, "%%!PS-Adobe-2.0 EPSF-2.0\n"); /* Encapsulated PostScript */
+ fprintf(tfp, "%%!PS-Adobe-3.0 EPSF-3.0\n"); /* Encapsulated PostScript */
else
- fprintf(tfp, "%%!PS-Adobe-2.0\n"); /* PostScript magic strings */
+ fprintf(tfp, "%%!PS-Adobe-3.0\n"); /* PostScript magic strings */
if (gethostname(host, sizeof(host)) == -1)
(void)strcpy(host, "unknown-host!?!?");
@@ -674,6 +674,22 @@ F_compound *objects;
for (i=strlen(psize)-1; i>=0; i--)
psize[i] = tolower(psize[i]);
fprintf(tfp, "%%%%DocumentPaperSizes: %s\n",psize);
+ } else if (pdfflag) {
+ /* set the page size for PDF to the figure size */
+ fprintf(tfp, "<< /PageSize [%d %d] >> setpagedevice\n",
+ clipux-cliplx,clipuy-cliply);
+ }
+
+ /* put in the magnification for information purposes */
+ fprintf(tfp, "%%Magnification: %.4f\n",metric? mag*76.2/80.0 : mag);
+ fprintf(tfp, "%%%%EndComments\n");
+
+ /* This %%BeginSetup .. %%EndSetup has to occur after
+ * %%EndComments even though it includes comments, they are
+ * not header comments. The header comment block must be
+ * contiguous, with no non-comment lines in it.
+ */
+ if (!epsflag && !pdfflag) {
fprintf(tfp, "%%%%BeginSetup\n");
fprintf(tfp, "[{\n");
fprintf(tfp, "%%%%BeginFeature: *PageRegion %s\n", papersize);
@@ -684,17 +700,8 @@ F_compound *objects;
fprintf(tfp, "%%%%EndFeature\n");
fprintf(tfp, "} stopped cleartomark\n");
fprintf(tfp, "%%%%EndSetup\n");
- } else if (pdfflag) {
- /* set the page size for PDF to the figure size */
- fprintf(tfp, "<< /PageSize [%d %d] >> setpagedevice\n",
- clipux-cliplx,clipuy-cliply);
}
-
- /* put in the magnification for information purposes */
- fprintf(tfp, "%%Magnification: %.4f\n",metric? mag*76.2/80.0 : mag);
- fprintf(tfp, "%%%%EndComments\n");
-
/* if the user wants an ASCII preview, route the rest of the eps to a temp file */
if (asciipreview) {
saveofile = tfp;

View File

@ -1,6 +1,8 @@
--- transfig.3.2.5/fig2dev/Imakefile.modularx 2007-04-16 14:49:29.000000000 +0200 diff --git a/fig2dev/Imakefile b/fig2dev/Imakefile
+++ transfig.3.2.5/fig2dev/Imakefile 2007-04-16 14:51:15.000000000 +0200 index 90d67ca..2f76e0b 100755
@@ -34,7 +34,7 @@ --- a/fig2dev/Imakefile
+++ b/fig2dev/Imakefile
@@ -34,7 +34,7 @@ XCOMM ******
XCOMM You should point XFIGLIBDIR to the same directory you did when you compiled XCOMM You should point XFIGLIBDIR to the same directory you did when you compiled
XCOMM and installed xfig. XCOMM and installed xfig.
@ -9,7 +11,7 @@
XCOMM ****** XCOMM ******
XCOMM If your system doesn't have the strerror() function (has sys_errlist) then XCOMM If your system doesn't have the strerror() function (has sys_errlist) then
@@ -62,7 +62,7 @@ @@ -62,7 +62,7 @@ XCOMM Note that this changed slightly from the previous versions - you need
XCOMM the full name (rgb.txt) now. XCOMM the full name (rgb.txt) now.
XCOMM XCOMM
@ -18,7 +20,7 @@
XCOMM Comment out the following #define USEPNG if you don't want PNG support XCOMM Comment out the following #define USEPNG if you don't want PNG support
XCOMM Uncomment the #define for USEPNG if you want to be able to import XCOMM Uncomment the #define for USEPNG if you want to be able to import
@@ -141,7 +141,7 @@ @@ -141,7 +141,7 @@ XCOMM Comment out the next line if you have any problems with locale not being f
#ifdef I18N #ifdef I18N
I18N_DEFS = -DI18N I18N_DEFS = -DI18N

View File

@ -1,6 +1,7 @@
diff -up transfig.3.2.5/Imakefile~ transfig.3.2.5/Imakefile diff --git a/Imakefile b/Imakefile
--- transfig.3.2.5/Imakefile~ 2003-03-25 22:48:02.000000000 +0200 index 5e44c8a..2f7fc4d 100755
+++ transfig.3.2.5/Imakefile 2009-05-04 22:12:20.000000000 +0300 --- a/Imakefile
+++ b/Imakefile
@@ -22,7 +22,7 @@ XCOMM to make transfig and fig2dev: @@ -22,7 +22,7 @@ XCOMM to make transfig and fig2dev:
XCOMM type "xmkmf", "make Makefiles", "make" then "make install" XCOMM type "xmkmf", "make Makefiles", "make" then "make install"

View File

@ -1,7 +1,7 @@
Summary: Utility for converting FIG files (made by xfig) to other formats Summary: Utility for converting FIG files (made by xfig) to other formats
Name: transfig Name: transfig
Version: 3.2.5 Version: 3.2.5c
Release: 8%{?dist} Release: 1%{?dist}
Epoch: 1 Epoch: 1
License: MIT License: MIT
URL: http://www.xfig.org/ URL: http://www.xfig.org/
@ -9,8 +9,11 @@ Group: Applications/Multimedia
Source0: http://downloads.sourceforge.net/mcj/%{name}.%{version}.tar.gz Source0: http://downloads.sourceforge.net/mcj/%{name}.%{version}.tar.gz
Patch0: transfig-3.2.5-optflags.patch Patch0: transfig-3.2.5-optflags.patch
Patch5: transfig-3.2.5-modularX.patch Patch1: transfig-3.2.5-modularX.patch
Patch6: transfig-3.2.5-bitmap.patch Patch2: transfig-3.2.5-bitmap.patch
# bz #558380
Patch3: transfig-3.2.5-dsc3.0.patch
Requires: ghostscript Requires: ghostscript
Requires: bc Requires: bc
@ -35,12 +38,17 @@ figures into certain graphics languages.
%prep %prep
%setup -q -n %{name}.%{version} %setup -q -n %{name}.%{version}
%patch0 -p1 -b .optflags %patch0 -p1
%patch5 -p1 -b .modularX %patch1 -p1
%patch6 -p1 -b .bitmap %patch2 -p1
%patch3 -p1
# fix source permissions # fix source permissions
find -type f -exec chmod -x {} \; find -type f -exec chmod -x {} \;
# remove garbage
rm -f doc/manual/Makefile.orig doc/fig2dev.1.orig
%build %build
xmkmf xmkmf
make Makefiles make Makefiles
@ -71,6 +79,11 @@ rm -rf %{buildroot}
%{_datadir}/fig2dev %{_datadir}/fig2dev
%changelog %changelog
* Wed Mar 03 2010 Kamil Dudka <kdudka@redhat.com> - 1:3.2.5c-1
- new upstream release
- patch to generate comments compliant with DSC 3.0, thanks to Ian Dall
(#558380)
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.2.5-8 * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.2.5-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild