Use libmediaart-2.0
This commit is contained in:
parent
5510757064
commit
f230ccb974
118
tracker-1.3.2-libmediaart-2.0.patch
Normal file
118
tracker-1.3.2-libmediaart-2.0.patch
Normal file
@ -0,0 +1,118 @@
|
|||||||
|
From a87a0319b170276284edaeb6e61bd1c0fe41a834 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yanko Kaneti <yaneti@declera.com>
|
||||||
|
Date: Tue, 20 Jan 2015 17:35:12 +0200
|
||||||
|
Subject: Mechanically adjust for libmediaart-2.0
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=743250
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index ec8b150..017b4cf 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -231,7 +231,7 @@ NETWORK_MANAGER_REQUIRED=0.8
|
||||||
|
GSTREAMER_REQUIRED=0.10.31
|
||||||
|
GUPNP_DLNA_REQUIRED=0.9.4
|
||||||
|
LIBPNG_REQUIRED=0.89
|
||||||
|
-LIBMEDIAART_REQUIRED=0.5.0
|
||||||
|
+LIBMEDIAART_REQUIRED=1.9.0
|
||||||
|
|
||||||
|
# 3.6.11 for sqlite_backup API
|
||||||
|
# 3.6.16 to fix test failures
|
||||||
|
@@ -1107,7 +1107,7 @@ AC_ARG_ENABLE(libmediaart,
|
||||||
|
|
||||||
|
if test "x$enable_libmediaart" != "xno" ; then
|
||||||
|
PKG_CHECK_MODULES(LIBMEDIAART,
|
||||||
|
- [libmediaart-1.0 >= $LIBMEDIAART_REQUIRED],
|
||||||
|
+ [libmediaart-2.0 >= $LIBMEDIAART_REQUIRED],
|
||||||
|
[have_libmediaart=yes],
|
||||||
|
[have_libmediaart=no])
|
||||||
|
|
||||||
|
@@ -1124,7 +1124,7 @@ if test "x$enable_libmediaart" != "xno" ; then
|
||||||
|
TRACKER_MINER_FS_LIBS="$TRACKER_MINER_FS_LIBS $LIBMEDIAART_LIBS"
|
||||||
|
|
||||||
|
# Used for .pc file...
|
||||||
|
- LIBTRACKER_MINER_PC_REQUIRES="libmediaart-1.0"
|
||||||
|
+ LIBTRACKER_MINER_PC_REQUIRES="libmediaart-2.0"
|
||||||
|
AC_SUBST(LIBTRACKER_MINER_PC_REQUIRES)
|
||||||
|
|
||||||
|
if test "x$have_libmediaart" = "xyes"; then
|
||||||
|
diff --git a/src/libtracker-miner/tracker-media-art.c b/src/libtracker-miner/tracker-media-art.c
|
||||||
|
index c0559e9..cbba55d 100644
|
||||||
|
--- a/src/libtracker-miner/tracker-media-art.c
|
||||||
|
+++ b/src/libtracker-miner/tracker-media-art.c
|
||||||
|
@@ -96,16 +96,16 @@ on_query_finished (GObject *source_object,
|
||||||
|
/* The get_path API does stripping itself */
|
||||||
|
media_art_get_path (artist,
|
||||||
|
album,
|
||||||
|
- "album", NULL,
|
||||||
|
- &target, NULL);
|
||||||
|
+ "album",
|
||||||
|
+ &target);
|
||||||
|
|
||||||
|
g_hash_table_replace (table, target, target);
|
||||||
|
|
||||||
|
/* Also add the file to which the symlinks are made */
|
||||||
|
media_art_get_path (NULL,
|
||||||
|
album,
|
||||||
|
- "album", NULL,
|
||||||
|
- &album_path, NULL);
|
||||||
|
+ "album",
|
||||||
|
+ &album_path);
|
||||||
|
|
||||||
|
|
||||||
|
g_hash_table_replace (table, album_path, album_path);
|
||||||
|
diff --git a/src/tracker-extract/tracker-extract-gstreamer.c b/src/tracker-extract/tracker-extract-gstreamer.c
|
||||||
|
index 7d52e0b..ef56d88 100644
|
||||||
|
--- a/src/tracker-extract/tracker-extract-gstreamer.c
|
||||||
|
+++ b/src/tracker-extract/tracker-extract-gstreamer.c
|
||||||
|
@@ -1661,6 +1661,7 @@ tracker_extract_gstreamer (const gchar *uri,
|
||||||
|
extractor->media_art_buffer_mime,
|
||||||
|
extractor->media_art_artist,
|
||||||
|
extractor->media_art_title,
|
||||||
|
+ NULL,
|
||||||
|
&error);
|
||||||
|
} else {
|
||||||
|
success = media_art_process_file (media_art_process,
|
||||||
|
@@ -1669,6 +1670,7 @@ tracker_extract_gstreamer (const gchar *uri,
|
||||||
|
tracker_extract_info_get_file (info),
|
||||||
|
extractor->media_art_artist,
|
||||||
|
extractor->media_art_title,
|
||||||
|
+ NULL,
|
||||||
|
&error);
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/src/tracker-extract/tracker-extract-mp3.c b/src/tracker-extract/tracker-extract-mp3.c
|
||||||
|
index f2ef306..b93e4f4 100644
|
||||||
|
--- a/src/tracker-extract/tracker-extract-mp3.c
|
||||||
|
+++ b/src/tracker-extract/tracker-extract-mp3.c
|
||||||
|
@@ -2675,6 +2675,7 @@ tracker_extract_get_metadata (TrackerExtractInfo *info)
|
||||||
|
md.media_art_mime,
|
||||||
|
md.performer,
|
||||||
|
md.title,
|
||||||
|
+ NULL,
|
||||||
|
&error);
|
||||||
|
} else {
|
||||||
|
success = media_art_process_file (media_art_process,
|
||||||
|
@@ -2683,6 +2684,7 @@ tracker_extract_get_metadata (TrackerExtractInfo *info)
|
||||||
|
file,
|
||||||
|
md.performer,
|
||||||
|
md.title,
|
||||||
|
+ NULL,
|
||||||
|
&error);
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/src/tracker-extract/tracker-extract-vorbis.c b/src/tracker-extract/tracker-extract-vorbis.c
|
||||||
|
index e619650..91c383c 100644
|
||||||
|
--- a/src/tracker-extract/tracker-extract-vorbis.c
|
||||||
|
+++ b/src/tracker-extract/tracker-extract-vorbis.c
|
||||||
|
@@ -527,6 +527,7 @@ tracker_extract_get_metadata (TrackerExtractInfo *info)
|
||||||
|
file,
|
||||||
|
vd.album_artist ? vd.album_artist : vd.artist,
|
||||||
|
vd.album,
|
||||||
|
+ NULL,
|
||||||
|
&error);
|
||||||
|
|
||||||
|
if (!success || error) {
|
||||||
|
--
|
||||||
|
cgit v0.10.1
|
||||||
|
|
16
tracker.spec
16
tracker.spec
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 1.3.2
|
Version: 1.3.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Desktop-neutral search tool and indexer
|
Summary: Desktop-neutral search tool and indexer
|
||||||
|
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -34,6 +34,9 @@ Patch1: 0001-miners-Detect-locale-changes-only-when-the-miner-cou.patch
|
|||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=735406
|
# https://bugzilla.gnome.org/show_bug.cgi?id=735406
|
||||||
Patch2: 0001-libtracker-miner-Restrict-the-amount-of-data-that-is.patch
|
Patch2: 0001-libtracker-miner-Restrict-the-amount-of-data-that-is.patch
|
||||||
|
|
||||||
|
# https://bugzilla.gnome.org/show_bug.cgi?id=743250
|
||||||
|
Patch3: tracker-1.3.2-libmediaart-2.0.patch
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: firefox
|
BuildRequires: firefox
|
||||||
BuildRequires: giflib-devel
|
BuildRequires: giflib-devel
|
||||||
@ -73,7 +76,7 @@ BuildRequires: pkgconfig(libnm-glib)
|
|||||||
BuildRequires: pkgconfig(libosinfo-1.0)
|
BuildRequires: pkgconfig(libosinfo-1.0)
|
||||||
BuildRequires: pkgconfig(libpng)
|
BuildRequires: pkgconfig(libpng)
|
||||||
%if 0%{?with_libmediaart}
|
%if 0%{?with_libmediaart}
|
||||||
BuildRequires: pkgconfig(libmediaart-1.0)
|
BuildRequires: pkgconfig(libmediaart-2.0)
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: pkgconfig(libxml-2.0)
|
BuildRequires: pkgconfig(libxml-2.0)
|
||||||
BuildRequires: pkgconfig(poppler-glib)
|
BuildRequires: pkgconfig(poppler-glib)
|
||||||
@ -84,6 +87,9 @@ BuildRequires: pkgconfig(upower-glib)
|
|||||||
BuildRequires: pkgconfig(uuid)
|
BuildRequires: pkgconfig(uuid)
|
||||||
BuildRequires: pkgconfig(vorbisfile)
|
BuildRequires: pkgconfig(vorbisfile)
|
||||||
|
|
||||||
|
# Needed for autoreconf
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
|
||||||
Obsoletes: compat-tracker018 < 0.17.2-2
|
Obsoletes: compat-tracker018 < 0.17.2-2
|
||||||
Obsoletes: tracker-miner-flickr < 0.16.0
|
Obsoletes: tracker-miner-flickr < 0.16.0
|
||||||
Obsoletes: tracker-nautilus-plugin < 0.17.2-2
|
Obsoletes: tracker-nautilus-plugin < 0.17.2-2
|
||||||
@ -180,6 +186,9 @@ This package contains the documentation for tracker
|
|||||||
%patch0 -p1 -b .autostart-gnome
|
%patch0 -p1 -b .autostart-gnome
|
||||||
%patch1 -p1 -b .detect-locale-changes
|
%patch1 -p1 -b .detect-locale-changes
|
||||||
%patch2 -p1 -b .restrict-logs
|
%patch2 -p1 -b .restrict-logs
|
||||||
|
%patch3 -p1 -b .mediaart-2.0
|
||||||
|
|
||||||
|
autoreconf --force --install
|
||||||
|
|
||||||
## nuke unwanted rpaths, see also
|
## nuke unwanted rpaths, see also
|
||||||
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
||||||
@ -326,6 +335,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 26 2015 David King <amigadave@amigadave.com> - 1.3.2-4
|
||||||
|
- Use libmediaart-2.0
|
||||||
|
|
||||||
* Tue Jan 13 2015 Debarshi Ray <rishi@fedoraproject.org> - 1.3.2-3
|
* Tue Jan 13 2015 Debarshi Ray <rishi@fedoraproject.org> - 1.3.2-3
|
||||||
- Backport upstream patch to restrict the amount of data that is logged for
|
- Backport upstream patch to restrict the amount of data that is logged for
|
||||||
errors (GNOME #735406)
|
errors (GNOME #735406)
|
||||||
|
Loading…
Reference in New Issue
Block a user