- Update to 0.8.2 release
This commit is contained in:
parent
e0928a423e
commit
c085334638
@ -1 +1 @@
|
||||
tracker-0.8.0.tar.bz2
|
||||
tracker-0.8.2.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
38332acd7500eb7347f8cf4655d30441 tracker-0.8.0.tar.bz2
|
||||
3b516bb3d0936381fc268897f1e65183 tracker-0.8.2.tar.bz2
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- docs/tools/Makefile.am 2010-02-17 12:04:07.000000000 -0500
|
||||
+++ docs/tools/Makefile.am.new 2010-02-20 01:49:57.034603685 -0500
|
||||
--- docs/tools/Makefile.am 2010-04-01 11:24:01.000000000 -0400
|
||||
+++ docs/tools/Makefile.am.new 2010-04-19 09:53:22.782313357 -0400
|
||||
@@ -20,7 +20,9 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
@ -22,9 +22,9 @@
|
||||
|
||||
gen-doc.stamp: ttl2sgml
|
||||
$(top_srcdir)/docs/tools/gen-doc.sh
|
||||
--- docs/tools/Makefile.in 2010-02-19 12:28:04.000000000 -0500
|
||||
+++ docs/tools/Makefile.in.new 2010-02-20 01:49:17.190437481 -0500
|
||||
@@ -377,7 +377,9 @@
|
||||
--- docs/tools/Makefile.in 2010-04-15 11:51:12.000000000 -0400
|
||||
+++ docs/tools/Makefile.in.new 2010-04-19 09:54:41.868435722 -0400
|
||||
@@ -378,7 +378,9 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
@ -35,23 +35,22 @@
|
||||
|
||||
ttl2sgml_SOURCES = \
|
||||
ttl2sgml.c \
|
||||
@@ -395,8 +397,9 @@
|
||||
@@ -396,7 +398,9 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GLIB2_LIBS) \
|
||||
- $(GIO_LIBS)
|
||||
-
|
||||
+ $(GIO_LIBS) \
|
||||
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
|
||||
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
|
||||
|
||||
|
||||
#
|
||||
# The origianal diagram but with .png extension
|
||||
--- docs/reference/libtracker-client/Makefile.am 2010-02-19 12:52:38.000000000 -0500
|
||||
+++ docs/reference/libtracker-client/Makefile.am.new 2010-03-02 13:16:20.942711481 -0500
|
||||
@@ -46,7 +46,9 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-client/Makefile.am 2010-04-15 06:14:08.000000000 -0400
|
||||
+++ docs/reference/libtracker-client/Makefile.am.new 2010-04-19 09:56:26.248325370 -0400
|
||||
@@ -40,7 +40,9 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
||||
@ -60,11 +59,11 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-client/Makefile.in 2010-02-26 07:00:16.000000000 -0500
|
||||
+++ docs/reference/libtracker-client/Makefile.in.new 2010-03-02 13:20:25.225089828 -0500
|
||||
@@ -367,7 +367,9 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-client/Makefile.in 2010-04-15 11:51:12.000000000 -0400
|
||||
+++ docs/reference/libtracker-client/Makefile.in.new 2010-04-19 09:57:14.958188757 -0400
|
||||
@@ -364,7 +364,9 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
||||
@ -73,11 +72,11 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-common/Makefile.am 2010-02-19 12:52:38.000000000 -0500
|
||||
+++ docs/reference/libtracker-common/Makefile.am.new 2010-03-02 13:17:17.902711556 -0500
|
||||
@@ -43,7 +43,8 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-common/Makefile.am 2010-04-15 06:14:08.000000000 -0400
|
||||
+++ docs/reference/libtracker-common/Makefile.am.new 2010-04-19 09:59:04.634098797 -0400
|
||||
@@ -37,7 +37,8 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
||||
@ -85,11 +84,11 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-common/Makefile.in 2010-02-26 07:00:16.000000000 -0500
|
||||
+++ docs/reference/libtracker-common/Makefile.in.new 2010-03-02 13:21:05.764818185 -0500
|
||||
@@ -363,7 +363,8 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-common/Makefile.in 2010-04-15 11:51:12.000000000 -0400
|
||||
+++ docs/reference/libtracker-common/Makefile.in.new 2010-04-19 10:01:08.364095170 -0400
|
||||
@@ -360,7 +360,8 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
||||
@ -97,8 +96,8 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-extract/Makefile.am 2010-02-19 12:52:38.000000000 -0500
|
||||
+++ docs/reference/libtracker-extract/Makefile.am.new 2010-03-02 13:18:16.565064140 -0500
|
||||
--- docs/reference/libtracker-extract/Makefile.am 2010-03-29 10:54:50.000000000 -0400
|
||||
+++ docs/reference/libtracker-extract/Makefile.am.new 2010-04-19 10:02:46.533447803 -0400
|
||||
@@ -34,7 +34,9 @@
|
||||
GTKDOC_LIBS = \
|
||||
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
|
||||
@ -110,9 +109,9 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-extract/Makefile.in 2010-02-26 07:00:16.000000000 -0500
|
||||
+++ docs/reference/libtracker-extract/Makefile.in.new 2010-03-02 13:21:47.998712414 -0500
|
||||
@@ -354,7 +354,9 @@
|
||||
--- docs/reference/libtracker-extract/Makefile.in 2010-04-15 11:51:12.000000000 -0400
|
||||
+++ docs/reference/libtracker-extract/Makefile.in.new 2010-04-19 10:03:29.565082879 -0400
|
||||
@@ -357,7 +357,9 @@
|
||||
GTKDOC_LIBS = \
|
||||
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
@ -123,11 +122,11 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-miner/Makefile.am 2010-03-18 10:15:42.000000000 -0400
|
||||
+++ docs/reference/libtracker-miner/Makefile.am.new 2010-03-18 14:31:43.572676975 -0400
|
||||
@@ -52,7 +52,10 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-miner/Makefile.am 2010-04-15 06:14:08.000000000 -0400
|
||||
+++ docs/reference/libtracker-miner/Makefile.am.new 2010-04-19 10:04:20.494435581 -0400
|
||||
@@ -50,7 +50,10 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
||||
@ -137,11 +136,11 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- docs/reference/libtracker-miner/Makefile.in 2010-03-18 14:08:27.000000000 -0400
|
||||
+++ docs/reference/libtracker-miner/Makefile.in.new 2010-03-18 14:32:33.372731452 -0400
|
||||
@@ -377,7 +377,10 @@
|
||||
$(UNAC_LIBS) \
|
||||
$(PANGO_LIBS) \
|
||||
--- docs/reference/libtracker-miner/Makefile.in 2010-04-15 11:51:12.000000000 -0400
|
||||
+++ docs/reference/libtracker-miner/Makefile.in.new 2010-04-19 10:05:07.469082598 -0400
|
||||
@@ -374,7 +374,10 @@
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(DBUS_LIBS) \
|
||||
$(GIO_LIBS) \
|
||||
- $(GLIB2_LIBS)
|
||||
+ $(GLIB2_LIBS) \
|
11
tracker.spec
11
tracker.spec
@ -1,12 +1,12 @@
|
||||
Summary: An object database, tag/metadata database, search tool and indexer
|
||||
Name: tracker
|
||||
Version: 0.8.0
|
||||
Version: 0.8.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://projects.gnome.org/tracker/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/%{name}-%{version}.tar.bz2
|
||||
Patch0: tracker-0.7-doc-build.patch
|
||||
Patch0: tracker-0.8-doc-build.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: poppler-glib-devel evolution-devel libxml2-devel libgsf-devel
|
||||
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
||||
@ -71,7 +71,8 @@ This package contains the documentation for tracker
|
||||
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
||||
|
||||
%build
|
||||
%configure --disable-static --enable-gtk-doc --enable-tracker-search-bar
|
||||
%configure --disable-static --enable-tracker-search-bar \
|
||||
--enable-gtk-doc --disable-functional-tests
|
||||
|
||||
# Disable rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
@ -93,6 +94,7 @@ desktop-file-install --delete-original \
|
||||
%{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
|
||||
|
||||
find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
|
||||
rm -rf %{buildroot}%{_datadir}/tracker-tests
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
@ -163,6 +165,9 @@ fi
|
||||
%{_datadir}/gtk-doc/html/ontology/
|
||||
|
||||
%changelog
|
||||
* Mon Apr 19 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.2-1
|
||||
- Update to 0.8.2 release
|
||||
|
||||
* Thu Apr 01 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.0-1
|
||||
- Update to 0.8.0 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user