Update to 1.3.5

This commit is contained in:
David King 2015-03-06 16:50:04 +00:00
parent 4066a5691f
commit b9793aaf92
4 changed files with 6 additions and 101 deletions

View File

@ -1 +1 @@
0e76a642a4105b47f6f592db75e4d1ac tracker-1.3.4.tar.xz c7c6f2474392ecf5d89e4c2e04b9c93e tracker-1.3.5.tar.xz

View File

@ -1,30 +0,0 @@
From ed805f6992f3c5cfb78f139a5e49ab62909fb944 Mon Sep 17 00:00:00 2001
From: David King <amigadave@amigadave.com>
Date: Tue, 3 Mar 2015 20:53:43 +0000
Subject: [PATCH] configure: Fix giflib check
As libgif often links to libX11, and some linker flags require that
dependent libraries must be explicitly linked with, try adding -lX11 to
the linker commandline when trying to link with -lgif.
https://bugzilla.gnome.org/show_bug.cgi?id=745582
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 11c785e..fb4364d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2102,7 +2102,7 @@ AC_ARG_ENABLE(libgif,
if test "x$enable_libgif" != "xno" ; then
AC_CHECK_HEADER(gif_lib.h,
- AC_CHECK_LIB(gif, DGifOpen))
+ AC_CHECK_LIB(gif, DGifOpen, [], [], [-lX11]))
have_libgif=${ac_cv_lib_gif_DGifOpen:-no}
--
2.3.1

View File

@ -1,58 +0,0 @@
From 4b5ab1ebf21df6a190d1e3d775709a53262b5c51 Mon Sep 17 00:00:00 2001
From: David King <amigadave@amigadave.com>
Date: Tue, 3 Mar 2015 18:22:41 +0000
Subject: [PATCH 1/3] tracker-compat: put absolute path in shell script
https://bugzilla.gnome.org/show_bug.cgi?id=743738
---
src/tracker/Makefile.am | 5 ++++-
src/tracker/tracker-compat | 8 --------
src/tracker/tracker-compat.in | 8 ++++++++
3 files changed, 12 insertions(+), 9 deletions(-)
delete mode 100755 src/tracker/tracker-compat
create mode 100755 src/tracker/tracker-compat.in
diff --git a/src/tracker/Makefile.am b/src/tracker/Makefile.am
index cb777aa..7c16dff 100644
--- a/src/tracker/Makefile.am
+++ b/src/tracker/Makefile.am
@@ -79,4 +79,7 @@ uninstall-hook:
completiondir = $(sysconfdir)/bash_completion.d
completion_DATA = tracker-prompt.sh
-EXTRA_DIST = $(completion_DATA) tracker-compat
+tracker-compat: tracker-compat.in
+ $(AM_V_at)sed -e "s|@bindir[@]|${bindir}|" $< > $@
+
+EXTRA_DIST = $(completion_DATA) tracker-compat.in
diff --git a/src/tracker/tracker-compat b/src/tracker/tracker-compat
deleted file mode 100755
index 4667ad6..0000000
--- a/src/tracker/tracker-compat
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-#export TRACKER_OLD_CMD=`echo $0 | sed 's/^[./]*//'`
-export TRACKER_OLD_CMD=`basename $0`
-echo "WARNING: The '$TRACKER_OLD_CMD' command is no longer available." > /dev/stderr
-echo "WARNING: Use 'tracker <command> [<args>]' instead...\n" > /dev/stderr
-
-./tracker $@
diff --git a/src/tracker/tracker-compat.in b/src/tracker/tracker-compat.in
new file mode 100755
index 0000000..263d3d5
--- /dev/null
+++ b/src/tracker/tracker-compat.in
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+#export TRACKER_OLD_CMD=`echo $0 | sed 's/^[./]*//'`
+export TRACKER_OLD_CMD=`basename $0`
+echo "WARNING: The '$TRACKER_OLD_CMD' command is no longer available." > /dev/stderr
+echo "WARNING: Use 'tracker <command> [<args>]' instead...\n" > /dev/stderr
+
+@bindir@/tracker $@
--
2.3.1

View File

@ -15,8 +15,8 @@
%endif %endif
Name: tracker Name: tracker
Version: 1.3.4 Version: 1.3.5
Release: 2%{?dist} Release: 1%{?dist}
Summary: Desktop-neutral search tool and indexer Summary: Desktop-neutral search tool and indexer
Group: Applications/System Group: Applications/System
@ -27,14 +27,7 @@ Source0: https://download.gnome.org/sources/%{name}/1.3/%{name}-%{version
# only autostart in Gnome, see also # only autostart in Gnome, see also
# https://bugzilla.redhat.com/show_bug.cgi?id=771601 # https://bugzilla.redhat.com/show_bug.cgi?id=771601
Patch0: 0001-Only-autostart-in-GNOME-771601.patch Patch0: 0001-Only-autostart-in-GNOME-771601.patch
# Fix checking for gif support.
# https://bugzilla.gnome.org/show_bug.cgi?id=745582
Patch1: tracker-1.3.4-fix-giflib-check.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1198166
Patch2: tracker-1.3.4-fix-tracker-compat.patch
# Required for patch1 and patch2.
BuildRequires: autoconf automake libtool
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
BuildRequires: firefox BuildRequires: firefox
BuildRequires: giflib-devel BuildRequires: giflib-devel
@ -179,8 +172,6 @@ This package contains the documentation for tracker
%setup -q %setup -q
%patch0 -p1 -b .autostart-gnome %patch0 -p1 -b .autostart-gnome
%patch1 -p1 -b .giflib-check
%patch2 -p1 -b .tracker-compat
## nuke unwanted rpaths, see also ## nuke unwanted rpaths, see also
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath ## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
@ -188,7 +179,6 @@ sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
%build %build
autoreconf --force --install
# Workaround linking problems with AC_CHECK_LIB. # Workaround linking problems with AC_CHECK_LIB.
LDFLAGS_save="$LDFLAGS" LDFLAGS_save="$LDFLAGS"
LDFLAGS="$LDFLAGS -fPIC" LDFLAGS="$LDFLAGS -fPIC"
@ -333,6 +323,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog %changelog
* Fri Mar 06 2015 David King <amigadave@amigadave.com> - 1.3.5-1
- Update to 1.3.5
* Tue Mar 03 2015 David King <amigadave@amigadave.com> - 1.3.4-2 * Tue Mar 03 2015 David King <amigadave@amigadave.com> - 1.3.4-2
- Fix checking for giflib - Fix checking for giflib
- Fix tracker-compat script path (#1198166) - Fix tracker-compat script path (#1198166)