- Update to 0.8.11 release

- Adapt to EDS Camel API changes (patch not tested yet).
This commit is contained in:
Deji Akingunola 2010-06-16 22:55:29 +00:00
parent 1f093c84fd
commit b56d86e0e2
4 changed files with 103 additions and 15 deletions

View File

@ -1 +1 @@
c332fd7115b45f8001d5f73a5b51509f tracker-0.8.5.tar.bz2
ac328f4552f168ba989d345effe059f8 tracker-0.8.11.tar.bz2

View File

@ -1,6 +1,6 @@
--- docs/tools/Makefile.am 2010-04-01 11:24:01.000000000 -0400
+++ docs/tools/Makefile.am.new 2010-04-19 09:53:22.782313357 -0400
@@ -20,7 +20,9 @@
--- docs/tools/Makefile.am 2010-05-20 13:14:53.000000000 -0400
+++ docs/tools/Makefile.am.new 2010-05-27 13:47:46.082189121 -0400
@@ -23,7 +23,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
@ -11,7 +11,7 @@
ttl2sgml_SOURCES = \
ttl2sgml.c \
@@ -38,7 +40,9 @@
@@ -41,6 +43,8 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
@ -20,11 +20,10 @@
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
gen-doc.stamp: ttl2sgml
$(top_srcdir)/docs/tools/gen-doc.sh
--- docs/tools/Makefile.in 2010-04-15 11:51:12.000000000 -0400
+++ docs/tools/Makefile.in.new 2010-04-19 09:54:41.868435722 -0400
@@ -378,7 +378,9 @@
EXTRA_DIST = gen-doc.sh
--- docs/tools/Makefile.in 2010-05-27 09:48:15.000000000 -0400
+++ docs/tools/Makefile.in.new 2010-05-27 13:49:52.845946280 -0400
@@ -385,7 +385,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
@ -35,7 +34,7 @@
ttl2sgml_SOURCES = \
ttl2sgml.c \
@@ -396,7 +398,9 @@
@@ -403,7 +405,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
@ -44,8 +43,8 @@
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
#
EXTRA_DIST = gen-doc.sh
all: all-am
--- docs/reference/libtracker-client/Makefile.am 2010-04-15 06:14:08.000000000 -0400
+++ docs/reference/libtracker-client/Makefile.am.new 2010-04-19 09:56:26.248325370 -0400
@@ -40,7 +40,9 @@

View File

@ -1,5 +1,5 @@
--- src/plugins/evolution/tracker-evolution-plugin.c 2010-04-29 13:20:00.000000000 -0400
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-05-07 10:08:55.892873454 -0400
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-06-16 18:21:39.776821965 -0400
@@ -39,27 +39,7 @@
#include <sqlite3.h>
@ -29,3 +29,85 @@
#include <mail/mail-config.h>
#include <mail/mail-session.h>
@@ -303,8 +283,8 @@
static void
folder_registry_free (FolderRegistry *registry)
{
- camel_object_remove_event (registry->folder, registry->hook_info->hook_id);
- camel_object_unref (registry->folder);
+ g_signal_handler_disconnect (registry->folder, registry->hook_info->hook_id);
+ g_object_unref (registry->folder);
g_free (registry->hook_info->account_uri);
g_slice_free (OnSummaryChangedInfo, registry->hook_info);
g_slice_free (FolderRegistry, registry);
@@ -321,7 +301,7 @@
registry->hook_info->account_uri = g_strdup (account_uri);
registry->hook_info->self = self; /* weak */
registry->hook_info->hook_id = 0;
- camel_object_ref (folder);
+ g_object_ref (folder);
registry->folder = folder;
return registry;
@@ -1340,8 +1320,8 @@
goto not_ready;
}
- hook_id = camel_object_hook_event (folder, "folder_changed",
- CAMEL_CALLBACK (on_folder_summary_changed),
+ hook_id = g_signal_connect (folder, "folder_changed",
+ G_CALLBACK (on_folder_summary_changed),
registry->hook_info);
registry->hook_info->hook_id = hook_id;
@@ -1816,7 +1796,7 @@
static void
on_folder_renamed (CamelStore *store,
- CamelRenameInfo *info,
+ CamelFolderInfo *info,
StoreRegistry *registry)
{
unregister_account (registry->self, registry->account);
@@ -1842,7 +1822,7 @@
static void
store_registry_free (StoreRegistry *registry)
{
- camel_object_remove_event (registry->store, registry->hook_id);
+ g_signal_handler_disconnect (registry->store, registry->hook_id);
camel_object_unref (registry->store);
g_slice_free (StoreRegistry, registry);
}
@@ -1871,8 +1851,8 @@
/* Hook up catching folder changes in the store */
registry = store_registry_new (store, account, self);
- hook_id = camel_object_hook_event (store, "folder_created",
- CAMEL_CALLBACK (on_folder_created),
+ hook_id = g_signal_connect (store, "folder_created",
+ G_CALLBACK (on_folder_created),
registry);
registry->hook_id = hook_id;
g_hash_table_replace (priv->registered_stores,
@@ -1880,8 +1860,8 @@
registry);
registry = store_registry_new (store, account, self);
- hook_id = camel_object_hook_event (store, "folder_renamed",
- CAMEL_CALLBACK (on_folder_renamed),
+ hook_id = g_signal_connect (store, "folder_renamed",
+ G_CALLBACK (on_folder_renamed),
registry);
registry->hook_id = hook_id;
g_hash_table_replace (priv->registered_stores,
@@ -1889,8 +1869,8 @@
registry);
registry = store_registry_new (store, account, self);
- hook_id = camel_object_hook_event (store, "folder_deleted",
- CAMEL_CALLBACK (on_folder_deleted),
+ hook_id = g_signal_connect (store, "folder_deleted",
+ G_CALLBACK (on_folder_deleted),
registry);
registry->hook_id = hook_id;
g_hash_table_replace (priv->registered_stores,

View File

@ -1,6 +1,6 @@
Summary: An object database, tag/metadata database, search tool and indexer
Name: tracker
Version: 0.8.5
Version: 0.8.11
Release: 1%{?dist}
License: GPLv2+
Group: Applications/System
@ -181,6 +181,13 @@ fi
%{_datadir}/gtk-doc/html/ontology/
%changelog
* Tue Jun 15 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.11-1
- Update to 0.8.11 release
- Adapt to EDS Camel API changes (patch not tested yet).
* Thu May 27 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.9-1
- Update to 0.8.9 release
* Thu May 06 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.5-1
- Update to 0.8.5 release
- Provide an upgrade path for paperbox (make ~-search-tool obsolete it) on F-13.