rebuild for dependencies
This commit is contained in:
parent
7c666933f3
commit
a9d88617b9
65
tracker-gmime26.patch
Normal file
65
tracker-gmime26.patch
Normal file
@ -0,0 +1,65 @@
|
||||
diff -ru tracker-0.6.96.orig/configure tracker-0.6.96/configure
|
||||
--- tracker-0.6.96.orig/configure 2010-02-13 23:39:07.000000000 +0000
|
||||
+++ tracker-0.6.96/configure 2010-02-13 23:39:29.000000000 +0000
|
||||
@@ -12739,12 +12739,12 @@
|
||||
pkg_cv_GMIME_CFLAGS="$GMIME_CFLAGS"
|
||||
else
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4 >= \$GMIME_REQUIRED\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4 >= $GMIME_REQUIRED") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6 >= \$GMIME_REQUIRED\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6 >= $GMIME_REQUIRED") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.4 >= $GMIME_REQUIRED" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.6 >= $GMIME_REQUIRED" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -12757,12 +12757,12 @@
|
||||
pkg_cv_GMIME_LIBS="$GMIME_LIBS"
|
||||
else
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4 >= \$GMIME_REQUIRED\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4 >= $GMIME_REQUIRED") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6 >= \$GMIME_REQUIRED\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6 >= $GMIME_REQUIRED") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.4 >= $GMIME_REQUIRED" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.6 >= $GMIME_REQUIRED" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -12781,14 +12781,14 @@
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gmime-2.4 >= $GMIME_REQUIRED"`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gmime-2.6 >= $GMIME_REQUIRED"`
|
||||
else
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gmime-2.4 >= $GMIME_REQUIRED"`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gmime-2.6 >= $GMIME_REQUIRED"`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GMIME_PKG_ERRORS" >&5
|
||||
|
||||
- as_fn_error "Package requirements (gmime-2.4 >= $GMIME_REQUIRED) were not met:
|
||||
+ as_fn_error "Package requirements (gmime-2.6 >= $GMIME_REQUIRED) were not met:
|
||||
|
||||
$GMIME_PKG_ERRORS
|
||||
|
||||
diff -ru tracker-0.6.96.orig/configure.ac tracker-0.6.96/configure.ac
|
||||
--- tracker-0.6.96.orig/configure.ac 2010-02-13 23:39:07.000000000 +0000
|
||||
+++ tracker-0.6.96/configure.ac 2010-02-13 23:39:24.000000000 +0000
|
||||
@@ -182,7 +182,7 @@
|
||||
AC_SUBST(PANGO_LIBS)
|
||||
|
||||
# Check for GMime
|
||||
-PKG_CHECK_MODULES(GMIME, [gmime-2.4 >= $GMIME_REQUIRED])
|
||||
+PKG_CHECK_MODULES(GMIME, [gmime-2.6 >= $GMIME_REQUIRED])
|
||||
AC_SUBST(GMIME_CFLAGS)
|
||||
AC_SUBST(GMIME_LIBS)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: An object database, tag/metadata database, search tool and indexer
|
||||
Name: tracker
|
||||
Version: 0.6.96
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://projects.gnome.org/tracker/
|
||||
@ -9,6 +9,7 @@ Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.t
|
||||
# The wvText utility used in msword_filter is bad, use abiword instead
|
||||
Patch0: tracker-msword_filter.patch
|
||||
Patch1: tracker-ldfind.patch
|
||||
Patch2: tracker-gmime26.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
||||
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
||||
@ -63,6 +64,8 @@ GNOME libraries
|
||||
%setup -q
|
||||
%patch0 -p0 -b .wv
|
||||
%patch1 -p0 -b .ld
|
||||
%patch2 -p1 -b .gmime26
|
||||
touch -r aclocal.m4 configure.ac
|
||||
|
||||
%global deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
||||
%if "%deskbar_applet_ver" >= "2.19.4"
|
||||
@ -165,6 +168,9 @@ fi
|
||||
%{_mandir}/man1/tracker-search-tool.1.gz
|
||||
|
||||
%changelog
|
||||
* Sat Feb 13 2010 Caolán McNamara <caolanm@redhat.com> - 0.6.96-4
|
||||
- rebuild for dependencies
|
||||
|
||||
* Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-3
|
||||
- Add patch to explicitly list some missing libs for the linker
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user