- Patch to not use deprecated wvText utility as MSWord filter
- Remove libvorbis dependency, it is not necessary where gstreamer is present.
This commit is contained in:
parent
582aaa5a41
commit
a143d2ded0
20
tracker-msword_filter.patch
Normal file
20
tracker-msword_filter.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- filters/application/msword_filter 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ filters/application/msword_filter.new 2010-02-08 08:18:57.117202359 -0500
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
|
||||||
|
tmpdir=`mktemp -td tracker.msword_filter.XXXXXXXXXX` || exit 1
|
||||||
|
tmpfile="$tmpdir"/tmpfile
|
||||||
|
-tmptxtfile="$tmpdir"/tmptxtfile
|
||||||
|
+tmptxtfile="$tmpdir"/tmpfile.text
|
||||||
|
|
||||||
|
cp "$1" "$tmpfile"
|
||||||
|
|
||||||
|
@@ -12,7 +12,7 @@
|
||||||
|
|
||||||
|
cd "$tmpdir"
|
||||||
|
|
||||||
|
-nice -n19 wvText "$tmpfile" "$tmptxtfile" > /dev/null 2>&1
|
||||||
|
+nice -n19 abiword --to=text > /dev/null 2>&1
|
||||||
|
|
||||||
|
cat "$tmptxtfile"
|
||||||
|
|
20
tracker.spec
20
tracker.spec
@ -1,22 +1,24 @@
|
|||||||
Summary: An object database, tag/metadata database, search tool and indexer
|
Summary: An object database, tag/metadata database, search tool and indexer
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 0.6.96
|
Version: 0.6.96
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://projects.gnome.org/tracker/
|
URL: http://projects.gnome.org/tracker/
|
||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
||||||
|
# The wvText utility used in msword_filter is bad, use abiword instead
|
||||||
|
Patch0: tracker-msword_filter.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
||||||
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
||||||
BuildRequires: totem-pl-parser-devel, libgsf-devel, gstreamer-devel
|
BuildRequires: totem-pl-parser-devel, libgsf-devel, gstreamer-devel
|
||||||
BuildRequires: gstreamer-plugins-base-devel libvorbis-devel
|
BuildRequires: gstreamer-plugins-base-devel
|
||||||
BuildRequires: libjpeg-devel, libexif-devel, exempi-devel, raptor-devel
|
BuildRequires: libjpeg-devel, libexif-devel, exempi-devel, raptor-devel
|
||||||
BuildRequires: libiptcdata-devel
|
BuildRequires: libiptcdata-devel
|
||||||
BuildRequires: desktop-file-utils, intltool, gettext, deskbar-applet-devel
|
BuildRequires: desktop-file-utils, intltool, gettext, deskbar-applet-devel
|
||||||
BuildRequires: sqlite-devel, qdbm-devel, pygtk2-devel, libtiff-devel
|
BuildRequires: sqlite-devel, qdbm-devel, pygtk2-devel, libtiff-devel
|
||||||
|
|
||||||
Requires: w3m, wv, odt2txt
|
Requires: w3m, odt2txt
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tracker is a powerful desktop-neutral first class object database,
|
Tracker is a powerful desktop-neutral first class object database,
|
||||||
@ -31,7 +33,10 @@ It provides additional features for file based objects including context
|
|||||||
linking and audit trails for a file object.
|
linking and audit trails for a file object.
|
||||||
|
|
||||||
It has the ability to index, store, harvest metadata. retrieve and search
|
It has the ability to index, store, harvest metadata. retrieve and search
|
||||||
all types of files and other first class objects
|
all types of files and other first class objects.
|
||||||
|
|
||||||
|
NOTE: This package REQUIRES 'abiword' to be installed, in order to properly
|
||||||
|
index MS Word files.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Headers for developing programs that will use %{name}
|
Summary: Headers for developing programs that will use %{name}
|
||||||
@ -55,6 +60,7 @@ GNOME libraries
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p0 -b .wv
|
||||||
|
|
||||||
%define deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
%define deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
||||||
%if "%deskbar_applet_ver" >= "2.19.4"
|
%if "%deskbar_applet_ver" >= "2.19.4"
|
||||||
@ -69,7 +75,7 @@ GNOME libraries
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \
|
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \
|
||||||
--enable-external-qdbm --enable-libvorbis --disable-rpath
|
--enable-external-qdbm --disable-rpath
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -153,6 +159,10 @@ fi
|
|||||||
%{_mandir}/man1/tracker-search-tool.1.gz
|
%{_mandir}/man1/tracker-search-tool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 08 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-2
|
||||||
|
- Patch to not use deprecated wvText utility as MSWord filter
|
||||||
|
- Remove libvorbis dependency, it is not necessary where gstreamer is present.
|
||||||
|
|
||||||
* Thu Feb 04 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-1
|
* Thu Feb 04 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-1
|
||||||
- Update to 0.6.96 release (Hope it fix the many abrt bugs).
|
- Update to 0.6.96 release (Hope it fix the many abrt bugs).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user