- First update to 0.9.x series

- Re-word the package summary (conformant to upstream wording).
This commit is contained in:
Deji Akingunola 2010-10-08 10:27:12 -04:00
parent 25f87b2417
commit 9517702e1a
8 changed files with 187 additions and 95 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
tracker-0.8.13.tar.bz2 tracker-0.8.13.tar.bz2
/tracker-0.8.16.tar.bz2 /tracker-0.8.16.tar.bz2
/tracker-0.9.24.tar.bz2

View File

@ -1 +1 @@
503117377b228e4575105c6b4ce34eaa tracker-0.8.17.tar.bz2 97f419e9dbefc8d72017eb95e10b1fc6 tracker-0.9.24.tar.bz2

View File

@ -1,12 +0,0 @@
diff -up tracker-0.8.17/src/tracker-extract/tracker-extract-pdf.c.poppler15 tracker-0.8.17/src/tracker-extract/tracker-extract-pdf.c
--- tracker-0.8.17/src/tracker-extract/tracker-extract-pdf.c.poppler15 2010-10-06 16:23:04.353101001 -0400
+++ tracker-0.8.17/src/tracker-extract/tracker-extract-pdf.c 2010-10-06 16:23:36.238100975 -0400
@@ -243,7 +243,7 @@ extract_content (PopplerDocument *docume
rect.x1 = rect.y1 = 0;
poppler_page_get_size (page, &rect.x2, &rect.y2);
- text = poppler_page_get_text (page, POPPLER_SELECTION_WORD, &rect);
+ text = poppler_page_get_selected_text (page, POPPLER_SELECTION_WORD, &rect);
t = tracker_text_normalize (text, n_words - words, &normalized_words);
words += normalized_words;

View File

@ -1,7 +1,10 @@
--- docs/tools/Makefile.am 2010-05-20 13:14:53.000000000 -0400 --- docs/tools/Makefile.am 2010-09-09 06:37:06.000000000 -0400
+++ docs/tools/Makefile.am.new 2010-05-27 13:47:46.082189121 -0400 +++ docs/tools/Makefile.am.new 2010-09-09 10:44:10.022458044 -0400
@@ -23,7 +23,9 @@ @@ -23,9 +23,12 @@
ontology_graph_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \ $(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \ $(DBUS_LIBS) \
$(GIO_LIBS) \ $(GIO_LIBS) \
- $(GLIB2_LIBS) - $(GLIB2_LIBS)
@ -11,8 +14,11 @@
ttl2sgml_SOURCES = \ ttl2sgml_SOURCES = \
ttl2sgml.c \ ttl2sgml.c \
@@ -41,6 +43,8 @@ @@ -41,8 +44,11 @@
ttl2sgml_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \ $(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \ $(DBUS_LIBS) \
$(GLIB2_LIBS) \ $(GLIB2_LIBS) \
- $(GIO_LIBS) - $(GIO_LIBS)
@ -21,10 +27,13 @@
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs + -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
EXTRA_DIST = gen-doc.sh EXTRA_DIST = gen-doc.sh
--- docs/tools/Makefile.in 2010-05-27 09:48:15.000000000 -0400 --- docs/tools/Makefile.in 2010-09-09 10:19:42.000000000 -0400
+++ docs/tools/Makefile.in.new 2010-05-27 13:49:52.845946280 -0400 +++ docs/tools/Makefile.in.new 2010-09-09 10:44:10.023458812 -0400
@@ -385,7 +385,9 @@ @@ -394,9 +394,12 @@
ontology_graph_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \ $(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \ $(DBUS_LIBS) \
$(GIO_LIBS) \ $(GIO_LIBS) \
- $(GLIB2_LIBS) - $(GLIB2_LIBS)
@ -34,8 +43,11 @@
ttl2sgml_SOURCES = \ ttl2sgml_SOURCES = \
ttl2sgml.c \ ttl2sgml.c \
@@ -403,7 +405,9 @@ @@ -412,9 +415,12 @@
ttl2sgml_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \ $(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \ $(DBUS_LIBS) \
$(GLIB2_LIBS) \ $(GLIB2_LIBS) \
- $(GIO_LIBS) - $(GIO_LIBS)
@ -70,30 +82,6 @@
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs + -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-common/Makefile.am 2010-04-15 06:14:08.000000000 -0400
+++ docs/reference/libtracker-common/Makefile.am.new 2010-04-19 09:59:04.634098797 -0400
@@ -37,7 +37,8 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-common/Makefile.in 2010-04-15 11:51:12.000000000 -0400
+++ docs/reference/libtracker-common/Makefile.in.new 2010-04-19 10:01:08.364095170 -0400
@@ -360,7 +360,8 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb # Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-extract/Makefile.am 2010-03-29 10:54:50.000000000 -0400 --- docs/reference/libtracker-extract/Makefile.am 2010-03-29 10:54:50.000000000 -0400
+++ docs/reference/libtracker-extract/Makefile.am.new 2010-04-19 10:02:46.533447803 -0400 +++ docs/reference/libtracker-extract/Makefile.am.new 2010-04-19 10:02:46.533447803 -0400
@ -130,7 +118,7 @@
- $(GLIB2_LIBS) - $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \ + $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \ + -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \ + -Wl,-rpath,$(top_builddir)/src/libtracker-sparql/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs + -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
@ -144,7 +132,33 @@
- $(GLIB2_LIBS) - $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \ + $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \ + -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \ + -Wl,-rpath,$(top_builddir)/src/libtracker-sparql/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-sparql/Makefile.am 2010-09-09 06:37:06.000000000 -0400
+++ docs/reference/libtracker-sparql/Makefile.am.new 2010-09-09 11:55:36.723180352 -0400
@@ -38,7 +38,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-sparql/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-sparql/Makefile.in 2010-09-09 10:19:42.000000000 -0400
+++ docs/reference/libtracker-sparql/Makefile.in.new 2010-09-09 11:59:35.941180003 -0400
@@ -374,7 +374,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-sparql/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs + -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs

116
tracker-build-fix.patch Normal file
View File

@ -0,0 +1,116 @@
--- src/tracker-store/Makefile.am 2010-08-19 12:12:34.000000000 -0400
+++ src/tracker-store/Makefile.am.new 2010-08-27 10:50:06.330393972 -0400
@@ -67,6 +67,7 @@
$(plugin_libs) \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(SQLITE3_LIBS) \
$(DBUS_LIBS) \
$(GIO_LIBS) \
--- src/tracker-store/Makefile.in 2010-08-26 12:11:20.000000000 -0400
+++ src/tracker-store/Makefile.in.new 2010-08-27 10:49:58.636167543 -0400
@@ -432,6 +432,7 @@
$(plugin_libs) \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(SQLITE3_LIBS) \
$(DBUS_LIBS) \
$(GIO_LIBS) \
--- src/tracker-status-icon/Makefile.am 2010-08-19 12:12:34.000000000 -0400
+++ src/tracker-status-icon/Makefile.am.new 2010-08-27 11:49:55.511265601 -0400
@@ -18,6 +18,7 @@
# Note: the -lX11 is needed for XGetModifierMapping() and other X11 calls
tracker_status_icon_LDADD = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(TRACKER_APPS_LIBS) \
$(PANGO_LIBS) \
--- src/tracker-status-icon/Makefile.in 2010-08-26 12:11:20.000000000 -0400
+++ src/tracker-status-icon/Makefile.in.new 2010-08-27 11:50:22.409182561 -0400
@@ -411,6 +411,7 @@
# Note: the -lX11 is needed for XGetModifierMapping() and other X11 calls
tracker_status_icon_LDADD = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(TRACKER_APPS_LIBS) \
$(PANGO_LIBS) \
--- src/tracker-search-bar/Makefile.am 2010-08-18 11:24:42.000000000 -0400
+++ src/tracker-search-bar/Makefile.am.new 2010-08-27 12:37:22.262163283 -0400
@@ -26,6 +26,7 @@
tracker_search_bar_LDADD = \
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-common/libtracker-common.la \
$(TRACKER_APPS_LIBS) \
$(TRACKER_APPLETS_LIBS) \
$(GDKPIXBUF_LIBS) \
--- src/tracker-search-bar/Makefile.in 2010-08-26 12:11:20.000000000 -0400
+++ src/tracker-search-bar/Makefile.in.new 2010-08-27 12:39:13.383515566 -0400
@@ -423,6 +423,7 @@
tracker_search_bar_LDADD = \
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-common/libtracker-common.la \
$(TRACKER_APPS_LIBS) \
$(TRACKER_APPLETS_LIBS) \
$(GDKPIXBUF_LIBS) \
--- utils/services/Makefile.am 2010-09-09 06:37:07.000000000 -0400
+++ utils/services/Makefile.am.new 2010-09-09 13:04:54.568431854 -0400
@@ -22,6 +22,7 @@
ontology_validator_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
$(GLIB2_LIBS)
@@ -32,6 +33,7 @@
data_validator_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
$(GIO_LIBS)
--- utils/services/Makefile.in 2010-09-09 10:19:51.000000000 -0400
+++ utils/services/Makefile.in.new 2010-09-09 13:05:28.104243559 -0400
@@ -394,6 +394,7 @@
ontology_validator_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
$(GLIB2_LIBS)
@@ -404,6 +405,7 @@
data_validator_LDADD = \
$(top_builddir)/src/libtracker-data/libtracker-data.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
$(GIO_LIBS)
--- examples/libtracker-miner/Makefile.am 2010-08-18 11:24:42.000000000 -0400
+++ examples/libtracker-miner/Makefile.am.new 2010-09-09 13:48:33.440304951 -0400
@@ -23,6 +23,7 @@
tracker_miner_test_LDADD = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GMODULE_LIBS) \
--- examples/libtracker-miner/Makefile.in 2010-09-09 10:19:43.000000000 -0400
+++ examples/libtracker-miner/Makefile.in.new 2010-09-09 13:49:15.929180352 -0400
@@ -388,6 +388,7 @@
tracker_miner_test_LDADD = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GMODULE_LIBS) \

View File

@ -1,10 +0,0 @@
--- src/plugins/evolution/tracker-evolution-plugin.c 2010-08-19 11:59:05.000000000 -0400
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-08-20 10:56:53.792961353 -0400
@@ -41,7 +41,6 @@
#include <sqlite3.h>
#include <camel/camel.h>
-#include <camel/camel-db.h>
#include <mail/mail-config.h>
#include <mail/mail-session.h>

View File

@ -1,14 +0,0 @@
--- src/plugins/nautilus/tracker-tags-extension.c 2010-08-18 11:23:00.000000000 -0400
+++ src/plugins/nautilus/tracker-tags-extension.c.new 2010-09-28 23:14:09.054708298 -0400
@@ -125,7 +125,11 @@
window,
GTK_DIALOG_MODAL |
GTK_DIALOG_DESTROY_WITH_PARENT |
+#if GTK_CHECK_VERSION (2,90,7)
+ 0,
+#else
GTK_DIALOG_NO_SEPARATOR,
+#endif
GTK_STOCK_CLOSE,
GTK_RESPONSE_CLOSE,
NULL);

View File

@ -1,29 +1,26 @@
Summary: An object database, tag/metadata database, search tool and indexer Summary: Desktop-neutral search tool and indexer
Name: tracker Name: tracker
Version: 0.8.17 Version: 0.9.24
Release: 4%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: Applications/System Group: Applications/System
URL: http://projects.gnome.org/tracker/ URL: http://projects.gnome.org/tracker/
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/%{name}-%{version}.tar.bz2 Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.9/%{name}-%{version}.tar.bz2
Patch0: tracker-0.8-doc-build.patch Patch0: tracker-0.9-doc-build.patch
Patch1: tracker-eds-build-fix.patch Patch1: tracker-build-fix.patch
Patch2: tracker-gtk-2.90.patch
Patch3: tracker-0.8.17-poppler-0.15.0-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: poppler-glib-devel libxml2-devel libgsf-devel BuildRequires: poppler-devel evolution-devel libxml2-devel libgsf-devel
BuildRequires: libuuid-devel libnotify-devel dbus-devel BuildRequires: libuuid-devel libnotify-devel dbus-devel
BuildRequires: gnome-desktop-devel nautilus-devel gnome-panel-devel BuildRequires: gnome-desktop-devel nautilus-devel gnome-panel-devel
BuildRequires: libjpeg-devel libexif-devel exempi-devel raptor-devel BuildRequires: libjpeg-devel libexif-devel exempi-devel raptor-devel
BuildRequires: libiptcdata-devel libtiff-devel libpng-devel BuildRequires: libiptcdata-devel libtiff-devel libpng-devel giflib-devel
BuildRequires: sqlite-devel vala-devel libgee-devel pygtk2-devel BuildRequires: sqlite-devel vala-devel libgee-devel pygtk2-devel
BuildRequires: gstreamer-plugins-base-devel gstreamer-devel id3lib-devel BuildRequires: gstreamer-plugins-base-devel gstreamer-devel id3lib-devel
BuildRequires: totem-pl-parser-devel libvorbis-devel flac-devel enca-devel BuildRequires: totem-pl-parser-devel libvorbis-devel flac-devel enca-devel
BuildRequires: upower-devel gnome-keyring-devel evolution-devel BuildRequires: upower-devel gnome-keyring-devel NetworkManager-glib-devel
BuildRequires: libunistring-devel
BuildRequires: desktop-file-utils intltool gettext graphviz BuildRequires: desktop-file-utils intltool gettext graphviz
Requires: odt2txt
%description %description
Tracker is a powerful desktop-neutral first class object database, Tracker is a powerful desktop-neutral first class object database,
tag/metadata database, search tool and indexer. tag/metadata database, search tool and indexer.
@ -78,16 +75,15 @@ This package contains the documentation for tracker
%prep %prep
%setup -q %setup -q
%patch0 -p0 %patch0 -p0 -b .fix
%patch1 -p0 %patch1 -p0 -b .fix2
%patch2 -p0
%patch3 -p1 -b .poppler15
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir) %global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
%build %build
%configure --disable-static --enable-tracker-search-bar \ %configure --disable-static --enable-tracker-search-bar \
--enable-gtk-doc --disable-functional-tests --enable-gtk-doc --disable-functional-tests --disable-unit-tests
# Disable the unit tests for now, because of build issues.
# Disable rpath # Disable rpath
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@ -100,7 +96,7 @@ rm -rf %{buildroot}
make DESTDIR=%{buildroot} install make DESTDIR=%{buildroot} install
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
echo "%{_libdir}/tracker-0.8" \ echo "%{_libdir}/tracker-0.9" \
> %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
desktop-file-install --delete-original \ desktop-file-install --delete-original \
@ -140,7 +136,7 @@ fi
%{_datadir}/tracker/ %{_datadir}/tracker/
%{_datadir}/dbus-1/services/org.freedesktop.Tracker* %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
%{_libdir}/*.so.* %{_libdir}/*.so.*
%{_libdir}/tracker-0.8/ %{_libdir}/tracker-0.9/
%{_mandir}/*/tracker*.gz %{_mandir}/*/tracker*.gz
%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
%{_sysconfdir}/xdg/autostart/tracker*.desktop %{_sysconfdir}/xdg/autostart/tracker*.desktop
@ -153,7 +149,7 @@ fi
%files devel %files devel
%defattr(-, root, root, -) %defattr(-, root, root, -)
%{_includedir}/tracker-0.8/ %{_includedir}/tracker-0.9/
%{_libdir}/*.so %{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc %{_libdir}/pkgconfig/*.pc
%{_datadir}/vala/vapi/tracker*.* %{_datadir}/vala/vapi/tracker*.*
@ -179,15 +175,16 @@ fi
%files docs %files docs
%defattr(-, root, root, -) %defattr(-, root, root, -)
%doc docs/reference/COPYING %doc docs/reference/COPYING
%{_datadir}/gtk-doc/html/libtracker-common/
%{_datadir}/gtk-doc/html/libtracker-miner/ %{_datadir}/gtk-doc/html/libtracker-miner/
%{_datadir}/gtk-doc/html/libtracker-client/ %{_datadir}/gtk-doc/html/libtracker-client/
%{_datadir}/gtk-doc/html/libtracker-extract/ %{_datadir}/gtk-doc/html/libtracker-extract/
%{_datadir}/gtk-doc/html/libtracker-sparql/
%{_datadir}/gtk-doc/html/ontology/ %{_datadir}/gtk-doc/html/ontology/
%changelog %changelog
* Wed Oct 6 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 0.8.17-4 * Fri Oct 08 2010 Deji Akingunola <dakingun@gmail.com> - 0.9.24-1
- fix code for poppler-0.15 - First update to 0.9.x series
- Re-word the package summary (conformant to upstream wording).
* Thu Sep 28 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.17-3 * Thu Sep 28 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.17-3
- Rebuild for poppler-0.15. - Rebuild for poppler-0.15.