Update to 1.6.0
This commit is contained in:
parent
eea54779b5
commit
94da78f1a0
2
sources
2
sources
@ -1 +1 @@
|
|||||||
1f64091c12134babd8f9d6e5d8148b95 tracker-1.5.2.tar.xz
|
037847a890fa30e8d258e03e59047ea0 tracker-1.6.0.tar.xz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 9e2682ecd7ed17033e63e49f847a7d74a43f3f88 Mon Sep 17 00:00:00 2001
|
|
||||||
From: David King <amigadave@amigadave.com>
|
|
||||||
Date: Tue, 25 Aug 2015 10:28:34 +0100
|
|
||||||
Subject: [PATCH] tracker-miner-fs: avoid crash during init
|
|
||||||
|
|
||||||
Correctly handle the result of tracker_sparql_cursor_get_string(), which
|
|
||||||
can be NULL.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=754055
|
|
||||||
---
|
|
||||||
src/miners/fs/tracker-miner-files.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/miners/fs/tracker-miner-files.c b/src/miners/fs/tracker-miner-files.c
|
|
||||||
index fb7445f..527c6e5 100644
|
|
||||||
--- a/src/miners/fs/tracker-miner-files.c
|
|
||||||
+++ b/src/miners/fs/tracker-miner-files.c
|
|
||||||
@@ -929,6 +929,9 @@ init_mount_points (TrackerMinerFiles *miner_files)
|
|
||||||
|
|
||||||
urn = tracker_sparql_cursor_get_string (cursor, 0, NULL);
|
|
||||||
|
|
||||||
+ if (!urn)
|
|
||||||
+ continue;
|
|
||||||
+
|
|
||||||
if (strcmp (urn, TRACKER_DATASOURCE_URN_NON_REMOVABLE_MEDIA) == 0) {
|
|
||||||
/* Report non-removable media to be mounted by HAL as well */
|
|
||||||
state |= VOLUME_MOUNTED;
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
13
tracker.spec
13
tracker.spec
@ -15,22 +15,19 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 1.5.2
|
Version: 1.6.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Desktop-neutral search tool and indexer
|
Summary: Desktop-neutral search tool and indexer
|
||||||
|
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://wiki.gnome.org/Projects/Tracker
|
URL: https://wiki.gnome.org/Projects/Tracker
|
||||||
Source0: https://download.gnome.org/sources/%{name}/1.5/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/1.6/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# only autostart in Gnome, see also
|
# only autostart in Gnome, see also
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=771601
|
# https://bugzilla.redhat.com/show_bug.cgi?id=771601
|
||||||
Patch0: 0001-Only-autostart-in-GNOME-771601.patch
|
Patch0: 0001-Only-autostart-in-GNOME-771601.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1246896
|
|
||||||
Patch1: tracker-1.5.2-fix-fs-miner-crash.patch
|
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: firefox
|
BuildRequires: firefox
|
||||||
BuildRequires: giflib-devel
|
BuildRequires: giflib-devel
|
||||||
@ -177,7 +174,6 @@ This package contains the documentation for tracker
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1 -b .autostart-gnome
|
%patch0 -p1 -b .autostart-gnome
|
||||||
%patch1 -p1 -b .miner-crash
|
|
||||||
|
|
||||||
## nuke unwanted rpaths, see also
|
## nuke unwanted rpaths, see also
|
||||||
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
||||||
@ -332,6 +328,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 22 2015 Kalev Lember <klember@redhat.com> - 1.6.0-1
|
||||||
|
- Update to 1.6.0
|
||||||
|
|
||||||
* Thu Sep 03 2015 Jonathan Wakely <jwakely@redhat.com> - 1.5.2-3
|
* Thu Sep 03 2015 Jonathan Wakely <jwakely@redhat.com> - 1.5.2-3
|
||||||
- Rebuilt for Boost 1.59
|
- Rebuilt for Boost 1.59
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user