Update to 3.7.alpha
This commit is contained in:
parent
4a85d69ff0
commit
90c0964ad8
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/tracker-3.6.beta.tar.xz
|
/tracker-3.6.beta.tar.xz
|
||||||
/tracker-3.6.rc.tar.xz
|
/tracker-3.6.rc.tar.xz
|
||||||
/tracker-3.6.0.tar.xz
|
/tracker-3.6.0.tar.xz
|
||||||
|
/tracker-3.7.alpha.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (tracker-3.6.0.tar.xz) = d3b7d4c1fd1cdcccc0d78c05f43b85f5cdab584e378cb56a2b568293ff95c887650d41c3c7f65de8864a0b6f80ae26410f4a443f045a80e30bacdf7ef9499697
|
SHA512 (tracker-3.7.alpha.tar.xz) = 5fa9d029860ceb0442e475961df5767b27fd7c15363fe231721f23686fe6d83bd693bbd88b1c37619146cb426373b902842b8f44b6c53bd6ca405ad68e2f40b4
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 2529a2c6e06ef8c4..b5cfca155816c9bf 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -211,13 +211,13 @@ result = cc.run('''
|
|
||||||
int main (int argc, char *argv[]) {
|
|
||||||
char *modifiers[] = { "%Y", "%C%y", "%4Y", "%2C%y", NULL };
|
|
||||||
time_t timestamp = -58979923200; /* 0101-01-01T01:01:01Z */
|
|
||||||
- char *buf[100];
|
|
||||||
+ char buf[100];
|
|
||||||
struct tm tm;
|
|
||||||
int i;
|
|
||||||
gmtime_r (×tamp, &tm);
|
|
||||||
for (i = 0; modifiers[i]; i++) {
|
|
||||||
- strftime (&buf, sizeof buf, modifiers[i], &tm);
|
|
||||||
- if (strcmp (&buf, "0101") == 0) {
|
|
||||||
+ strftime (buf, sizeof buf, modifiers[i], &tm);
|
|
||||||
+ if (strcmp (buf, "0101") == 0) {
|
|
||||||
printf ("%s", modifiers[i]);
|
|
||||||
return 0;
|
|
||||||
}
|
|
11
tracker.spec
11
tracker.spec
@ -3,14 +3,13 @@
|
|||||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||||
|
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 3.6.0
|
Version: 3.7~alpha
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Desktop-neutral metadata database and search tool
|
Summary: Desktop-neutral metadata database and search tool
|
||||||
|
|
||||||
License: GPL-2.0-or-later
|
License: GPL-2.0-or-later
|
||||||
URL: https://gnome.pages.gitlab.gnome.org/tracker/
|
URL: https://gnome.pages.gitlab.gnome.org/tracker/
|
||||||
Source0: https://download.gnome.org/sources/tracker/3.6/tracker-%{tarball_version}.tar.xz
|
Source0: https://download.gnome.org/sources/tracker/3.7/tracker-%{tarball_version}.tar.xz
|
||||||
Patch0: tracker-meson-c99.patch
|
|
||||||
|
|
||||||
BuildRequires: asciidoc
|
BuildRequires: asciidoc
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -147,7 +146,6 @@ The %{name}-devel package contains the documentation for %{name}.
|
|||||||
%{_libdir}/girepository-1.0/Tracker-3.0.typelib
|
%{_libdir}/girepository-1.0/Tracker-3.0.typelib
|
||||||
%{_libdir}/libtracker-sparql-3.0.so.0*
|
%{_libdir}/libtracker-sparql-3.0.so.0*
|
||||||
%{_libdir}/tracker-3.0/
|
%{_libdir}/tracker-3.0/
|
||||||
%{_datadir}/tracker3/
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/tracker-3.0/
|
%{_includedir}/tracker-3.0/
|
||||||
@ -168,6 +166,9 @@ The %{name}-devel package contains the documentation for %{name}.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 19 2024 David King <amigadave@amigadave.com> - 3.7~alpha-1
|
||||||
|
- Update to 3.7.alpha
|
||||||
|
|
||||||
* Mon Jan 08 2024 Florian Weimer <fweimer@redhat.com> - 3.6.0-2
|
* Mon Jan 08 2024 Florian Weimer <fweimer@redhat.com> - 3.6.0-2
|
||||||
- Backport upstream patch to fix C compatibility issue in Meson probe
|
- Backport upstream patch to fix C compatibility issue in Meson probe
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user