- Add patch to explicitly list some missing libs for the linker
This commit is contained in:
parent
a143d2ded0
commit
7c666933f3
204
tracker-ldfind.patch
Normal file
204
tracker-ldfind.patch
Normal file
@ -0,0 +1,204 @@
|
|||||||
|
--- src/tracker-utils/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ src/tracker-utils/Makefile.am.new 2010-02-10 12:14:03.649870479 -0500
|
||||||
|
@@ -15,9 +15,11 @@
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GIO_LIBS) \
|
||||||
|
$(GCOV_LIBS) \
|
||||||
|
- $(GLIB2_LIBS)
|
||||||
|
+ $(GLIB2_LIBS) \
|
||||||
|
+ $(DBUS_LIBS)
|
||||||
|
|
||||||
|
bin_PROGRAMS = \
|
||||||
|
tracker-search \
|
||||||
|
--- src/tracker-utils/Makefile.in 2010-02-04 05:56:50.000000000 -0500
|
||||||
|
+++ src/tracker-utils/Makefile.in.new 2010-02-10 12:13:10.646869409 -0500
|
||||||
|
@@ -386,9 +386,11 @@
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GIO_LIBS) \
|
||||||
|
$(GCOV_LIBS) \
|
||||||
|
- $(GLIB2_LIBS)
|
||||||
|
+ $(GLIB2_LIBS) \
|
||||||
|
+ $(DBUS_LIBS)
|
||||||
|
|
||||||
|
tracker_search_SOURCES = tracker-search.c
|
||||||
|
tracker_search_LDADD = $(libs)
|
||||||
|
--- src/tracker-extract/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ src/tracker-extract/Makefile.am.new 2010-02-10 12:37:07.051869630 -0500
|
||||||
|
@@ -161,6 +161,7 @@
|
||||||
|
libextract_ps_la_LDFLAGS = $(module_flags)
|
||||||
|
libextract_ps_la_LIBADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS) \
|
||||||
|
$(GCOV_LIBS)
|
||||||
|
|
||||||
|
@@ -242,10 +243,13 @@
|
||||||
|
|
||||||
|
tracker_extract_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GMODULE_LIBS) \
|
||||||
|
$(GTHREAD_LIBS) \
|
||||||
|
$(GCOV_LIBS) \
|
||||||
|
- $(GLIB2_LIBS)
|
||||||
|
+ $(GLIB2_LIBS) \
|
||||||
|
+ $(GIO_LIBS) \
|
||||||
|
+ $(DBUS_LIBS)
|
||||||
|
|
||||||
|
dbus_sources = \
|
||||||
|
tracker-extract-glue.h
|
||||||
|
--- src/tracker-extract/Makefile.in 2010-02-04 05:56:50.000000000 -0500
|
||||||
|
+++ src/tracker-extract/Makefile.in.new 2010-02-10 12:36:39.011869844 -0500
|
||||||
|
@@ -662,6 +662,7 @@
|
||||||
|
libextract_ps_la_LDFLAGS = $(module_flags)
|
||||||
|
libextract_ps_la_LIBADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS) \
|
||||||
|
$(GCOV_LIBS)
|
||||||
|
|
||||||
|
@@ -736,10 +737,13 @@
|
||||||
|
|
||||||
|
tracker_extract_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GMODULE_LIBS) \
|
||||||
|
$(GTHREAD_LIBS) \
|
||||||
|
$(GCOV_LIBS) \
|
||||||
|
- $(GLIB2_LIBS)
|
||||||
|
+ $(GLIB2_LIBS) \
|
||||||
|
+ $(GIO_LIBS) \
|
||||||
|
+ $(DBUS_LIBS)
|
||||||
|
|
||||||
|
dbus_sources = \
|
||||||
|
tracker-extract-glue.h
|
||||||
|
--- src/tracker-applet/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ src/tracker-applet/Makefile.am.new 2010-02-10 12:50:09.586869530 -0500
|
||||||
|
@@ -16,9 +16,11 @@
|
||||||
|
tracker_applet_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(TRACKER_APPLET_LIBS) \
|
||||||
|
$(LIBGLADE_LIBS) \
|
||||||
|
- $(GCOV_LIBS)
|
||||||
|
+ $(GCOV_LIBS) \
|
||||||
|
+ -lX11
|
||||||
|
|
||||||
|
tracker-marshal.h: tracker-marshal.list
|
||||||
|
$(GLIB_GENMARSHAL) $< --prefix=tracker_marshal --header > $@
|
||||||
|
--- src/tracker-applet/Makefile.in 2010-02-04 05:56:49.000000000 -0500
|
||||||
|
+++ src/tracker-applet/Makefile.in.new 2010-02-10 12:49:30.943869990 -0500
|
||||||
|
@@ -364,9 +364,11 @@
|
||||||
|
tracker_applet_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(TRACKER_APPLET_LIBS) \
|
||||||
|
$(LIBGLADE_LIBS) \
|
||||||
|
- $(GCOV_LIBS)
|
||||||
|
+ $(GCOV_LIBS) \
|
||||||
|
+ -lX11
|
||||||
|
|
||||||
|
marshal_sources = \
|
||||||
|
tracker-marshal.h \
|
||||||
|
--- src/tracker-preferences/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ src/tracker-preferences/Makefile.am.new 2010-02-10 13:05:09.906902848 -0500
|
||||||
|
@@ -35,6 +35,7 @@
|
||||||
|
tracker_preferences_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(LIBGLADE_LIBS) \
|
||||||
|
$(GTK2_LIBS) \
|
||||||
|
$(DBUS_LIBS) \
|
||||||
|
--- src/tracker-preferences/Makefile.in 2010-02-04 05:56:50.000000000 -0500
|
||||||
|
+++ src/tracker-preferences/Makefile.in.new 2010-02-10 13:05:35.819870342 -0500
|
||||||
|
@@ -381,6 +381,7 @@
|
||||||
|
tracker_preferences_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker/libtrackerclient.la \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(LIBGLADE_LIBS) \
|
||||||
|
$(GTK2_LIBS) \
|
||||||
|
$(DBUS_LIBS) \
|
||||||
|
--- utils/albumart/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ utils/albumart/Makefile.am.new 2010-02-10 13:25:36.531882295 -0500
|
||||||
|
@@ -14,5 +14,6 @@
|
||||||
|
|
||||||
|
albumart_strip_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
--- utils/albumart/Makefile.in 2010-02-04 05:56:51.000000000 -0500
|
||||||
|
+++ utils/albumart/Makefile.in.new 2010-02-10 13:26:00.227870154 -0500
|
||||||
|
@@ -333,6 +333,7 @@
|
||||||
|
|
||||||
|
albumart_strip_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
all: all-am
|
||||||
|
--- utils/mp3-genre-leading-uppercase/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ utils/mp3-genre-leading-uppercase/Makefile.am.new 2010-02-10 13:26:34.142895903 -0500
|
||||||
|
@@ -14,5 +14,6 @@
|
||||||
|
|
||||||
|
mp3_genre_leading_uppercase_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
--- utils/mp3-genre-leading-uppercase/Makefile.in 2010-02-04 05:56:51.000000000 -0500
|
||||||
|
+++ utils/mp3-genre-leading-uppercase/Makefile.in.new 2010-02-10 13:26:57.028869670 -0500
|
||||||
|
@@ -335,6 +335,7 @@
|
||||||
|
|
||||||
|
mp3_genre_leading_uppercase_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
all: all-am
|
||||||
|
--- utils/qdbm/Makefile.am 2010-02-04 05:25:44.000000000 -0500
|
||||||
|
+++ utils/qdbm/Makefile.am.new 2010-02-10 13:27:54.475886500 -0500
|
||||||
|
@@ -15,6 +15,7 @@
|
||||||
|
print_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(QDBM_LIBS) \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
@@ -24,6 +25,7 @@
|
||||||
|
search_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(QDBM_LIBS) \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
--- utils/qdbm/Makefile.in 2010-02-04 05:56:52.000000000 -0500
|
||||||
|
+++ utils/qdbm/Makefile.in.new 2010-02-10 13:28:16.643927434 -0500
|
||||||
|
@@ -341,6 +341,7 @@
|
||||||
|
print_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(QDBM_LIBS) \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
||||||
|
@@ -350,6 +351,7 @@
|
||||||
|
search_LDADD = \
|
||||||
|
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||||
|
$(top_builddir)/src/libtracker-db/libtracker-db.la \
|
||||||
|
+ $(top_builddir)/src/libstemmer/libstemmer.la \
|
||||||
|
$(QDBM_LIBS) \
|
||||||
|
$(GLIB2_LIBS)
|
||||||
|
|
@ -1,20 +1,24 @@
|
|||||||
--- filters/application/msword_filter 2010-02-04 05:25:44.000000000 -0500
|
--- filters/application/msword_filter 2010-02-04 05:25:44.000000000 -0500
|
||||||
+++ filters/application/msword_filter.new 2010-02-08 08:18:57.117202359 -0500
|
+++ filters/application/msword_filter.new 2010-02-10 09:52:42.768895298 -0500
|
||||||
@@ -2,7 +2,7 @@
|
@@ -1,8 +1,7 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
tmpdir=`mktemp -td tracker.msword_filter.XXXXXXXXXX` || exit 1
|
tmpdir=`mktemp -td tracker.msword_filter.XXXXXXXXXX` || exit 1
|
||||||
tmpfile="$tmpdir"/tmpfile
|
-tmpfile="$tmpdir"/tmpfile
|
||||||
-tmptxtfile="$tmpdir"/tmptxtfile
|
-tmptxtfile="$tmpdir"/tmptxtfile
|
||||||
+tmptxtfile="$tmpdir"/tmpfile.text
|
+tmpfile="$tmpdir"/tmpfil
|
||||||
|
|
||||||
cp "$1" "$tmpfile"
|
cp "$1" "$tmpfile"
|
||||||
|
|
||||||
@@ -12,7 +12,7 @@
|
@@ -12,9 +11,9 @@
|
||||||
|
|
||||||
cd "$tmpdir"
|
cd "$tmpdir"
|
||||||
|
|
||||||
-nice -n19 wvText "$tmpfile" "$tmptxtfile" > /dev/null 2>&1
|
-nice -n19 wvText "$tmpfile" "$tmptxtfile" > /dev/null 2>&1
|
||||||
+nice -n19 abiword --to=text > /dev/null 2>&1
|
+nice -n19 abiword --to=text tmpfil > /dev/null 2>&1
|
||||||
|
|
||||||
cat "$tmptxtfile"
|
-cat "$tmptxtfile"
|
||||||
|
+cat tmpfil.text
|
||||||
|
|
||||||
|
rm -rf "$tmpdir"
|
||||||
|
|
||||||
|
25
tracker.spec
25
tracker.spec
@ -1,13 +1,14 @@
|
|||||||
Summary: An object database, tag/metadata database, search tool and indexer
|
Summary: An object database, tag/metadata database, search tool and indexer
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 0.6.96
|
Version: 0.6.96
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://projects.gnome.org/tracker/
|
URL: http://projects.gnome.org/tracker/
|
||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
||||||
# The wvText utility used in msword_filter is bad, use abiword instead
|
# The wvText utility used in msword_filter is bad, use abiword instead
|
||||||
Patch0: tracker-msword_filter.patch
|
Patch0: tracker-msword_filter.patch
|
||||||
|
Patch1: tracker-ldfind.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
||||||
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
||||||
@ -61,21 +62,26 @@ GNOME libraries
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0 -b .wv
|
%patch0 -p0 -b .wv
|
||||||
|
%patch1 -p0 -b .ld
|
||||||
|
|
||||||
%define deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
%global deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
||||||
%if "%deskbar_applet_ver" >= "2.19.4"
|
%if "%deskbar_applet_ver" >= "2.19.4"
|
||||||
%define deskbar_applet_dir %(pkg-config --variable modulesdir deskbar-applet)
|
%global deskbar_applet_dir %(pkg-config --variable modulesdir deskbar-applet)
|
||||||
%define deskbar_type module
|
%global deskbar_type module
|
||||||
%else
|
%else
|
||||||
%define deskbar_applet_dir %(pkg-config --variable handlersdir deskbar-applet)
|
%global deskbar_applet_dir %(pkg-config --variable handlersdir deskbar-applet)
|
||||||
%define deskbar_type handler
|
%global deskbar_type handler
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \
|
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \
|
||||||
--enable-external-qdbm --disable-rpath
|
--enable-external-qdbm
|
||||||
|
|
||||||
|
# Disable rpath
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -159,6 +165,9 @@ fi
|
|||||||
%{_mandir}/man1/tracker-search-tool.1.gz
|
%{_mandir}/man1/tracker-search-tool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-3
|
||||||
|
- Add patch to explicitly list some missing libs for the linker
|
||||||
|
|
||||||
* Mon Feb 08 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-2
|
* Mon Feb 08 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-2
|
||||||
- Patch to not use deprecated wvText utility as MSWord filter
|
- Patch to not use deprecated wvText utility as MSWord filter
|
||||||
- Remove libvorbis dependency, it is not necessary where gstreamer is present.
|
- Remove libvorbis dependency, it is not necessary where gstreamer is present.
|
||||||
|
Loading…
Reference in New Issue
Block a user