- Update to 0.7.23 release

This commit is contained in:
Deji Akingunola 2010-03-03 16:08:51 +00:00
parent a9d88617b9
commit 475770fe5f
7 changed files with 270 additions and 370 deletions

View File

@ -1 +1 @@
tracker-0.6.96.tar.bz2 tracker-0.7.23.tar.bz2

View File

@ -1 +1 @@
a64d304d52866aae854f4383fb50b8bc tracker-0.6.96.tar.bz2 41b00c0782be0e7f4f42a3a23d93025b tracker-0.7.23.tar.bz2

207
tracker-0.7-doc-build.patch Normal file
View File

@ -0,0 +1,207 @@
--- docs/tools/Makefile.am 2010-02-17 12:04:07.000000000 -0500
+++ docs/tools/Makefile.am.new 2010-02-20 01:49:57.034603685 -0500
@@ -20,7 +20,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
ttl2sgml_SOURCES = \
ttl2sgml.c \
@@ -38,7 +40,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
- $(GIO_LIBS)
+ $(GIO_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
gen-doc.stamp: ttl2sgml
$(top_srcdir)/docs/tools/gen-doc.sh
--- docs/tools/Makefile.in 2010-02-19 12:28:04.000000000 -0500
+++ docs/tools/Makefile.in.new 2010-02-20 01:49:17.190437481 -0500
@@ -377,7 +377,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
ttl2sgml_SOURCES = \
ttl2sgml.c \
@@ -395,8 +397,9 @@
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(DBUS_LIBS) \
$(GLIB2_LIBS) \
- $(GIO_LIBS)
-
+ $(GIO_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-data/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
#
# The origianal diagram but with .png extension
--- docs/reference/libtracker-client/Makefile.am 2010-02-19 12:52:38.000000000 -0500
+++ docs/reference/libtracker-client/Makefile.am.new 2010-03-02 13:16:20.942711481 -0500
@@ -46,7 +46,9 @@
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-client/Makefile.in 2010-02-26 07:00:16.000000000 -0500
+++ docs/reference/libtracker-client/Makefile.in.new 2010-03-02 13:20:25.225089828 -0500
@@ -367,7 +367,9 @@
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-common/Makefile.am 2010-02-19 12:52:38.000000000 -0500
+++ docs/reference/libtracker-common/Makefile.am.new 2010-03-02 13:17:17.902711556 -0500
@@ -43,7 +43,8 @@
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-common/Makefile.in 2010-02-26 07:00:16.000000000 -0500
+++ docs/reference/libtracker-common/Makefile.in.new 2010-03-02 13:21:05.764818185 -0500
@@ -363,7 +363,8 @@
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-extract/Makefile.am 2010-02-19 12:52:38.000000000 -0500
+++ docs/reference/libtracker-extract/Makefile.am.new 2010-03-02 13:18:16.565064140 -0500
@@ -34,7 +34,9 @@
GTKDOC_LIBS = \
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-extract/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-extract/Makefile.in 2010-02-26 07:00:16.000000000 -0500
+++ docs/reference/libtracker-extract/Makefile.in.new 2010-03-02 13:21:47.998712414 -0500
@@ -354,7 +354,9 @@
GTKDOC_LIBS = \
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-extract/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-miner/Makefile.am 2010-02-19 12:52:38.000000000 -0500
+++ docs/reference/libtracker-miner/Makefile.am.new 2010-03-02 13:18:56.862940487 -0500
@@ -44,13 +44,17 @@
GTKDOC_LIBS = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(HAL_LIBS) \
$(DBUS_LIBS) \
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- docs/reference/libtracker-miner/Makefile.in 2010-02-26 07:00:17.000000000 -0500
+++ docs/reference/libtracker-miner/Makefile.in.new 2010-03-02 13:22:28.044762303 -0500
@@ -365,13 +365,17 @@
GTKDOC_LIBS = \
$(top_builddir)/src/libtracker-miner/libtracker-miner-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(HAL_LIBS) \
$(DBUS_LIBS) \
$(UNAC_LIBS) \
$(PANGO_LIBS) \
$(GIO_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-miner/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-client/.libs \
+ -Wl,-rpath,$(top_builddir)/src/libtracker-common/.libs
# Extra options to supply to gtkdoc-mkdb
--- tests/libtracker-db/Makefile.am 2010-02-19 12:52:38.000000000 -0500
+++ tests/libtracker-db/Makefile.am.new 2010-03-02 14:32:02.211593109 -0500
@@ -45,6 +45,7 @@
tracker_db_journal_LDADD = \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-fts/libtracker-fts.la \
$(top_builddir)/tests/common/libtracker-testcommon.la \
$(SQLITE3_LIBS) \
$(GMODULE_LIBS) \
--- tests/libtracker-db/Makefile.in 2010-02-26 07:00:22.000000000 -0500
+++ tests/libtracker-db/Makefile.in.new 2010-03-02 14:36:08.100524661 -0500
@@ -390,6 +390,7 @@
tracker_db_journal_LDADD = \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libtracker-fts/libtracker-fts.la \
$(top_builddir)/tests/common/libtracker-testcommon.la \
$(SQLITE3_LIBS) \
$(GMODULE_LIBS) \
--- tests/libtracker-extract/Makefile.am 2010-02-25 12:12:19.000000000 -0500
+++ tests/libtracker-extract/Makefile.am.new 2010-03-02 14:28:55.669655650 -0500
@@ -25,6 +25,7 @@
$(top_builddir)/tests/common/libtracker-testcommon.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
$(GMODULE_LIBS) \
$(GTHREAD_LIBS) \
$(GOBJECT_LIBS) \
--- tests/libtracker-extract/Makefile.in 2010-02-26 07:00:22.000000000 -0500
+++ tests/libtracker-extract/Makefile.in.new 2010-03-02 14:35:29.764638966 -0500
@@ -372,6 +372,7 @@
$(top_builddir)/tests/common/libtracker-testcommon.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-extract/libtracker-extract-@TRACKER_API_VERSION@.la \
+ $(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
$(GMODULE_LIBS) \
$(GTHREAD_LIBS) \
$(GOBJECT_LIBS) \

View File

@ -1,65 +0,0 @@
diff -ru tracker-0.6.96.orig/configure tracker-0.6.96/configure
--- tracker-0.6.96.orig/configure 2010-02-13 23:39:07.000000000 +0000
+++ tracker-0.6.96/configure 2010-02-13 23:39:29.000000000 +0000
@@ -12739,12 +12739,12 @@
pkg_cv_GMIME_CFLAGS="$GMIME_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4 >= \$GMIME_REQUIRED\""; } >&5
- ($PKG_CONFIG --exists --print-errors "gmime-2.4 >= $GMIME_REQUIRED") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6 >= \$GMIME_REQUIRED\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6 >= $GMIME_REQUIRED") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.4 >= $GMIME_REQUIRED" 2>/dev/null`
+ pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.6 >= $GMIME_REQUIRED" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -12757,12 +12757,12 @@
pkg_cv_GMIME_LIBS="$GMIME_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4 >= \$GMIME_REQUIRED\""; } >&5
- ($PKG_CONFIG --exists --print-errors "gmime-2.4 >= $GMIME_REQUIRED") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6 >= \$GMIME_REQUIRED\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6 >= $GMIME_REQUIRED") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.4 >= $GMIME_REQUIRED" 2>/dev/null`
+ pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.6 >= $GMIME_REQUIRED" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -12781,14 +12781,14 @@
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gmime-2.4 >= $GMIME_REQUIRED"`
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gmime-2.6 >= $GMIME_REQUIRED"`
else
- GMIME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gmime-2.4 >= $GMIME_REQUIRED"`
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gmime-2.6 >= $GMIME_REQUIRED"`
fi
# Put the nasty error message in config.log where it belongs
echo "$GMIME_PKG_ERRORS" >&5
- as_fn_error "Package requirements (gmime-2.4 >= $GMIME_REQUIRED) were not met:
+ as_fn_error "Package requirements (gmime-2.6 >= $GMIME_REQUIRED) were not met:
$GMIME_PKG_ERRORS
diff -ru tracker-0.6.96.orig/configure.ac tracker-0.6.96/configure.ac
--- tracker-0.6.96.orig/configure.ac 2010-02-13 23:39:07.000000000 +0000
+++ tracker-0.6.96/configure.ac 2010-02-13 23:39:24.000000000 +0000
@@ -182,7 +182,7 @@
AC_SUBST(PANGO_LIBS)
# Check for GMime
-PKG_CHECK_MODULES(GMIME, [gmime-2.4 >= $GMIME_REQUIRED])
+PKG_CHECK_MODULES(GMIME, [gmime-2.6 >= $GMIME_REQUIRED])
AC_SUBST(GMIME_CFLAGS)
AC_SUBST(GMIME_LIBS)

View File

@ -1,204 +0,0 @@
--- src/tracker-utils/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ src/tracker-utils/Makefile.am.new 2010-02-10 12:14:03.649870479 -0500
@@ -15,9 +15,11 @@
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GIO_LIBS) \
$(GCOV_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ $(DBUS_LIBS)
bin_PROGRAMS = \
tracker-search \
--- src/tracker-utils/Makefile.in 2010-02-04 05:56:50.000000000 -0500
+++ src/tracker-utils/Makefile.in.new 2010-02-10 12:13:10.646869409 -0500
@@ -386,9 +386,11 @@
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GIO_LIBS) \
$(GCOV_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ $(DBUS_LIBS)
tracker_search_SOURCES = tracker-search.c
tracker_search_LDADD = $(libs)
--- src/tracker-extract/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ src/tracker-extract/Makefile.am.new 2010-02-10 12:37:07.051869630 -0500
@@ -161,6 +161,7 @@
libextract_ps_la_LDFLAGS = $(module_flags)
libextract_ps_la_LIBADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS) \
$(GCOV_LIBS)
@@ -242,10 +243,13 @@
tracker_extract_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GMODULE_LIBS) \
$(GTHREAD_LIBS) \
$(GCOV_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ $(GIO_LIBS) \
+ $(DBUS_LIBS)
dbus_sources = \
tracker-extract-glue.h
--- src/tracker-extract/Makefile.in 2010-02-04 05:56:50.000000000 -0500
+++ src/tracker-extract/Makefile.in.new 2010-02-10 12:36:39.011869844 -0500
@@ -662,6 +662,7 @@
libextract_ps_la_LDFLAGS = $(module_flags)
libextract_ps_la_LIBADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS) \
$(GCOV_LIBS)
@@ -736,10 +737,13 @@
tracker_extract_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GMODULE_LIBS) \
$(GTHREAD_LIBS) \
$(GCOV_LIBS) \
- $(GLIB2_LIBS)
+ $(GLIB2_LIBS) \
+ $(GIO_LIBS) \
+ $(DBUS_LIBS)
dbus_sources = \
tracker-extract-glue.h
--- src/tracker-applet/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ src/tracker-applet/Makefile.am.new 2010-02-10 12:50:09.586869530 -0500
@@ -16,9 +16,11 @@
tracker_applet_LDADD = \
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(TRACKER_APPLET_LIBS) \
$(LIBGLADE_LIBS) \
- $(GCOV_LIBS)
+ $(GCOV_LIBS) \
+ -lX11
tracker-marshal.h: tracker-marshal.list
$(GLIB_GENMARSHAL) $< --prefix=tracker_marshal --header > $@
--- src/tracker-applet/Makefile.in 2010-02-04 05:56:49.000000000 -0500
+++ src/tracker-applet/Makefile.in.new 2010-02-10 12:49:30.943869990 -0500
@@ -364,9 +364,11 @@
tracker_applet_LDADD = \
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(TRACKER_APPLET_LIBS) \
$(LIBGLADE_LIBS) \
- $(GCOV_LIBS)
+ $(GCOV_LIBS) \
+ -lX11
marshal_sources = \
tracker-marshal.h \
--- src/tracker-preferences/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ src/tracker-preferences/Makefile.am.new 2010-02-10 13:05:09.906902848 -0500
@@ -35,6 +35,7 @@
tracker_preferences_LDADD = \
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(LIBGLADE_LIBS) \
$(GTK2_LIBS) \
$(DBUS_LIBS) \
--- src/tracker-preferences/Makefile.in 2010-02-04 05:56:50.000000000 -0500
+++ src/tracker-preferences/Makefile.in.new 2010-02-10 13:05:35.819870342 -0500
@@ -381,6 +381,7 @@
tracker_preferences_LDADD = \
$(top_builddir)/src/libtracker/libtrackerclient.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(LIBGLADE_LIBS) \
$(GTK2_LIBS) \
$(DBUS_LIBS) \
--- utils/albumart/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ utils/albumart/Makefile.am.new 2010-02-10 13:25:36.531882295 -0500
@@ -14,5 +14,6 @@
albumart_strip_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS)
--- utils/albumart/Makefile.in 2010-02-04 05:56:51.000000000 -0500
+++ utils/albumart/Makefile.in.new 2010-02-10 13:26:00.227870154 -0500
@@ -333,6 +333,7 @@
albumart_strip_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS)
all: all-am
--- utils/mp3-genre-leading-uppercase/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ utils/mp3-genre-leading-uppercase/Makefile.am.new 2010-02-10 13:26:34.142895903 -0500
@@ -14,5 +14,6 @@
mp3_genre_leading_uppercase_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS)
--- utils/mp3-genre-leading-uppercase/Makefile.in 2010-02-04 05:56:51.000000000 -0500
+++ utils/mp3-genre-leading-uppercase/Makefile.in.new 2010-02-10 13:26:57.028869670 -0500
@@ -335,6 +335,7 @@
mp3_genre_leading_uppercase_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(GLIB2_LIBS)
all: all-am
--- utils/qdbm/Makefile.am 2010-02-04 05:25:44.000000000 -0500
+++ utils/qdbm/Makefile.am.new 2010-02-10 13:27:54.475886500 -0500
@@ -15,6 +15,7 @@
print_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(QDBM_LIBS) \
$(GLIB2_LIBS)
@@ -24,6 +25,7 @@
search_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(QDBM_LIBS) \
$(GLIB2_LIBS)
--- utils/qdbm/Makefile.in 2010-02-04 05:56:52.000000000 -0500
+++ utils/qdbm/Makefile.in.new 2010-02-10 13:28:16.643927434 -0500
@@ -341,6 +341,7 @@
print_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(QDBM_LIBS) \
$(GLIB2_LIBS)
@@ -350,6 +351,7 @@
search_LDADD = \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(top_builddir)/src/libtracker-db/libtracker-db.la \
+ $(top_builddir)/src/libstemmer/libstemmer.la \
$(QDBM_LIBS) \
$(GLIB2_LIBS)

View File

@ -1,24 +0,0 @@
--- filters/application/msword_filter 2010-02-04 05:25:44.000000000 -0500
+++ filters/application/msword_filter.new 2010-02-10 09:52:42.768895298 -0500
@@ -1,8 +1,7 @@
#!/bin/sh
tmpdir=`mktemp -td tracker.msword_filter.XXXXXXXXXX` || exit 1
-tmpfile="$tmpdir"/tmpfile
-tmptxtfile="$tmpdir"/tmptxtfile
+tmpfile="$tmpdir"/tmpfil
cp "$1" "$tmpfile"
@@ -12,9 +11,9 @@
cd "$tmpdir"
-nice -n19 wvText "$tmpfile" "$tmptxtfile" > /dev/null 2>&1
+nice -n19 abiword --to=text tmpfil > /dev/null 2>&1
-cat "$tmptxtfile"
+cat tmpfil.text
rm -rf "$tmpdir"

View File

@ -1,26 +1,24 @@
Summary: An object database, tag/metadata database, search tool and indexer Summary: An object database, tag/metadata database, search tool and indexer
Name: tracker Name: tracker
Version: 0.6.96 Version: 0.7.23
Release: 4%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: Applications/System Group: Applications/System
URL: http://projects.gnome.org/tracker/ URL: http://projects.gnome.org/tracker/
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2 Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.7/%{name}-%{version}.tar.bz2
# The wvText utility used in msword_filter is bad, use abiword instead Patch0: tracker-0.7-doc-build.patch
Patch0: tracker-msword_filter.patch
Patch1: tracker-ldfind.patch
Patch2: tracker-gmime26.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel BuildRequires: poppler-glib-devel evolution-devel libxml2-devel libgsf-devel
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel BuildRequires: libuuid-devel libnotify-devel dbus-devel
BuildRequires: totem-pl-parser-devel, libgsf-devel, gstreamer-devel BuildRequires: gnome-desktop-devel nautilus-devel gnome-panel-devel
BuildRequires: gstreamer-plugins-base-devel BuildRequires: libjpeg-devel libexif-devel exempi-devel raptor-devel
BuildRequires: libjpeg-devel, libexif-devel, exempi-devel, raptor-devel BuildRequires: libiptcdata-devel libtiff-devel libpng-devel
BuildRequires: libiptcdata-devel BuildRequires: sqlite-devel vala-devel libgee-devel pygtk2-devel
BuildRequires: desktop-file-utils, intltool, gettext, deskbar-applet-devel BuildRequires: gstreamer-plugins-base-devel gstreamer-devel id3lib-devel
BuildRequires: sqlite-devel, qdbm-devel, pygtk2-devel, libtiff-devel BuildRequires: totem-pl-parser-devel libvorbis-devel flac-devel enca-devel
BuildRequires: DeviceKit-power-devel
Requires: w3m, odt2txt BuildRequires: desktop-file-utils intltool gettext graphviz
#BuildRequires: deskbar-applet
%description %description
Tracker is a powerful desktop-neutral first class object database, Tracker is a powerful desktop-neutral first class object database,
@ -35,10 +33,7 @@ It provides additional features for file based objects including context
linking and audit trails for a file object. linking and audit trails for a file object.
It has the ability to index, store, harvest metadata. retrieve and search It has the ability to index, store, harvest metadata. retrieve and search
all types of files and other first class objects. all types of files and other first class objects
NOTE: This package REQUIRES 'abiword' to be installed, in order to properly
index MS Word files.
%package devel %package devel
Summary: Headers for developing programs that will use %{name} Summary: Headers for developing programs that will use %{name}
@ -60,40 +55,44 @@ Requires: %{name} = %{version}-%{release}
Graphical frontend to tracker search facilities. This has dependencies on Graphical frontend to tracker search facilities. This has dependencies on
GNOME libraries GNOME libraries
%package docs
Summary: Documentations for tracker
Group: Documentation
BuildArch: noarch
%description docs
This package contains the documentation for tracker
%prep %prep
%setup -q %setup -q
%patch0 -p0 -b .wv %patch0 -p0 -b .fix
%patch1 -p0 -b .ld
%patch2 -p1 -b .gmime26
touch -r aclocal.m4 configure.ac
%global deskbar_applet_ver %(pkg-config --modversion deskbar-applet) #%global deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
%if "%deskbar_applet_ver" >= "2.19.4" #%if "%deskbar_applet_ver" >= "2.19.4"
%global deskbar_applet_dir %(pkg-config --variable modulesdir deskbar-applet) # %global deskbar_applet_dir %(pkg-config --variable modulesdir deskbar-applet)
%global deskbar_type module # %global deskbar_type module
%else #%else
%global deskbar_applet_dir %(pkg-config --variable handlersdir deskbar-applet) # %global deskbar_applet_dir %(pkg-config --variable handlersdir deskbar-applet)
%global deskbar_type handler # %global deskbar_type handler
%endif #%endif
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir) %global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
%build %build
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \ %configure --disable-static --enable-gtk-doc --enable-tracker-search-bar
--enable-external-qdbm
# Disable rpath # Disable rpath
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags} make V=1 %{?_smp_mflags}
%install %install
rm -rf %{buildroot} rm -rf %{buildroot}
make DESTDIR=%{buildroot} install make DESTDIR=%{buildroot} install
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
echo "%{_libdir}/tracker" \ echo "%{_libdir}/tracker-0.7" \
> %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
desktop-file-install --delete-original \ desktop-file-install --delete-original \
@ -128,65 +127,52 @@ fi
%defattr(-, root, root, -) %defattr(-, root, root, -)
%doc AUTHORS ChangeLog COPYING NEWS README %doc AUTHORS ChangeLog COPYING NEWS README
%{_bindir}/tracker* %{_bindir}/tracker*
%exclude %{_bindir}/tracker-applet
%exclude %{_bindir}/tracker-preferences
%exclude %{_bindir}/tracker-search-tool
%{_libexecdir}/tracker* %{_libexecdir}/tracker*
%{_datadir}/tracker/ %{_datadir}/tracker/
%{_datadir}/dbus-1/services/org.freedesktop.Tracker.* %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
%{_libdir}/*.so.* %{_libdir}/*.so.*
%{_libdir}/tracker/ %{_libdir}/tracker-0.7/
#%{evo_plugins_dir}/liborg-freedesktop-Tracker-evolution-plugin.so %{_libdir}/nautilus/extensions-2.0/libnautilus-tracker-tags.so
#%{evo_plugins_dir}/org-freedesktop-Tracker-evolution-plugin.eplug %{evo_plugins_dir}/liborg-freedesktop-Tracker-evolution-plugin.so
%{evo_plugins_dir}/org-freedesktop-Tracker-evolution-plugin.eplug
%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
%{_mandir}/*/tracker*.gz %{_mandir}/*/tracker*.gz
%exclude %{_mandir}/man1/tracker-applet.1.gz %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
%{_sysconfdir}/xdg/autostart/tracker*.desktop
%exclude %{_bindir}/tracker-preferences
%exclude %{_bindir}/tracker-search-tool
%exclude %{_mandir}/man1/tracker-search-bar.1.gz
%exclude %{_mandir}/man1/tracker-preferences.1.gz %exclude %{_mandir}/man1/tracker-preferences.1.gz
%exclude %{_mandir}/man1/tracker-search-tool.1.gz %exclude %{_mandir}/man1/tracker-search-tool.1.gz
%{_sysconfdir}/xdg/autostart/trackerd.desktop
%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
%doc %{_datadir}/gtk-doc/html/libtracker-common/
%doc %{_datadir}/gtk-doc/html/libtracker-module/
%files devel %files devel
%defattr(-, root, root, -) %defattr(-, root, root, -)
%{_includedir}/tracker* %{_includedir}/tracker-0.7/
%{_includedir}/libtracker-gtk/
%{_libdir}/*.so %{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc %{_libdir}/pkgconfig/*.pc
%files search-tool %files search-tool
%defattr(-, root, root, -) %defattr(-, root, root, -)
%{_bindir}/tracker-applet
%{_bindir}/tracker-preferences %{_bindir}/tracker-preferences
%{_bindir}/tracker-search-tool %{_bindir}/tracker-search-tool
%{deskbar_applet_dir}/tracker*.py* #%{deskbar_applet_dir}/tracker*.py*
%{_datadir}/icons/*/*/apps/tracker.* %{_datadir}/icons/*/*/apps/tracker.*
%{_datadir}/applications/*.desktop %{_datadir}/applications/*.desktop
%{_sysconfdir}/xdg/autostart/tracker-applet.desktop %{_mandir}/man1/tracker-search-bar.1.gz
%{_mandir}/man1/tracker-applet.1.gz
%{_mandir}/man1/tracker-preferences.1.gz %{_mandir}/man1/tracker-preferences.1.gz
%{_mandir}/man1/tracker-search-tool.1.gz %{_mandir}/man1/tracker-search-tool.1.gz
%files docs
%defattr(-, root, root, -)
%{_datadir}/gtk-doc/html/libtracker-common/
%{_datadir}/gtk-doc/html/libtracker-miner/
%{_datadir}/gtk-doc/html/libtracker-client/
%{_datadir}/gtk-doc/html/libtracker-extract/
%{_datadir}/gtk-doc/html/ontology/
%changelog %changelog
* Sat Feb 13 2010 Caolán McNamara <caolanm@redhat.com> - 0.6.96-4 * Tue Mar 02 2010 Deji Akingunola <dakingun@gmail.com> - 0.7.23-1
- rebuild for dependencies - Update to 0.7.23 release
* Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-3
- Add patch to explicitly list some missing libs for the linker
* Mon Feb 08 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-2
- Patch to not use deprecated wvText utility as MSWord filter
- Remove libvorbis dependency, it is not necessary where gstreamer is present.
* Thu Feb 04 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.96-1
- Update to 0.6.96 release (Hope it fix the many abrt bugs).
* Thu Jan 28 2010 - Caolán McNamara <caolanm@redhat.com> - 0.6.95-6
- rebuild for dependencies
* Thu Jan 21 2010 Deji Akingunola <dakingun@gmail.com> - 0.6.95-5
- Rebuilt for libgnome-desktop soname change.
- BR deskbar-applet-devel
* Sat Aug 29 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.95-4 * Sat Aug 29 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.95-4
- Explicitly require apps needed in the text filters of common documents (Fedora bug #517930) - Explicitly require apps needed in the text filters of common documents (Fedora bug #517930)