- Update to 0.9.33
- Substitute gdk-pixbuf for qt4 as music album extractor - Split off nautilus-plugin into a sub-package
This commit is contained in:
parent
d3cf3651d5
commit
44bdecfe18
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ tracker-0.8.13.tar.bz2
|
||||
/tracker-0.9.24.tar.bz2
|
||||
/tracker-0.9.27.tar.bz2
|
||||
/tracker-0.9.30.tar.bz2
|
||||
/tracker-0.9.33.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
fd30e4d3006e55ee5ab1bddb65f605e5 tracker-0.9.30.tar.bz2
|
||||
7098335404e8ee22bf207aa26784a41c tracker-0.9.33.tar.bz2
|
||||
|
@ -132,103 +132,3 @@
|
||||
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb
|
||||
--- utils/services/Makefile.am 2010-10-28 07:27:34.000000000 -0400
|
||||
+++ utils/services/Makefile.am.new 2010-11-02 13:42:30.907233528 -0400
|
||||
@@ -12,6 +12,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_DATA_LIBS)
|
||||
|
||||
--- utils/services/Makefile.in 2010-10-28 10:35:24.000000000 -0400
|
||||
+++ utils/services/Makefile.in.new 2010-11-02 13:42:54.921982795 -0400
|
||||
@@ -404,6 +404,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_DATA_LIBS)
|
||||
|
||||
--- utils/tracker-sql/Makefile.am 2010-11-11 06:47:26.000000000 -0500
|
||||
+++ utils/tracker-sql/Makefile.am.new 2010-11-11 22:09:02.945110269 -0500
|
||||
@@ -11,6 +11,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(TRACKER_UTILS_LIBS)
|
||||
|
||||
tracker_sql_SOURCES = tracker-sql.c
|
||||
--- utils/tracker-sql/Makefile.in 2010-11-11 12:23:57.000000000 -0500
|
||||
+++ utils/tracker-sql/Makefile.in.new 2010-11-11 22:09:57.374734659 -0500
|
||||
@@ -399,6 +399,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(TRACKER_UTILS_LIBS)
|
||||
|
||||
tracker_sql_SOURCES = tracker-sql.c
|
||||
--- tests/libtracker-client/Makefile.am 2010-10-28 07:27:34.000000000 -0400
|
||||
+++ tests/libtracker-client/Makefile.am.new 2010-11-02 13:56:19.094236462 -0400
|
||||
@@ -13,6 +13,7 @@
|
||||
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
|
||||
+ $(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_CLIENT_LIBS)
|
||||
|
||||
--- tests/libtracker-client/Makefile.in 2010-10-28 10:35:21.000000000 -0400
|
||||
+++ tests/libtracker-client/Makefile.in.new 2010-11-02 13:56:43.708234437 -0400
|
||||
@@ -394,6 +394,7 @@
|
||||
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-client/libtracker-client-@TRACKER_API_VERSION@.la \
|
||||
+ $(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_CLIENT_LIBS)
|
||||
|
||||
--- tests/libtracker-data/Makefile.am 2010-10-28 07:27:34.000000000 -0400
|
||||
+++ tests/libtracker-data/Makefile.am.new 2010-11-02 13:59:25.166864064 -0400
|
||||
@@ -45,6 +45,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(top_builddir)/tests/common/libtracker-testcommon.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_DATA_LIBS)
|
||||
--- tests/libtracker-data/Makefile.in 2010-10-28 10:35:21.000000000 -0400
|
||||
+++ tests/libtracker-data/Makefile.in.new 2010-11-02 13:59:57.944983215 -0400
|
||||
@@ -522,6 +522,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(top_builddir)/tests/common/libtracker-testcommon.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_DATA_LIBS)
|
||||
--- tests/libtracker-fts/Makefile.am 2010-10-28 07:27:34.000000000 -0400
|
||||
+++ tests/libtracker-fts/Makefile.am.new 2010-11-02 14:02:54.721996904 -0400
|
||||
@@ -24,6 +24,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(top_builddir)/tests/common/libtracker-testcommon.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_FTS_LIBS)
|
||||
--- tests/libtracker-fts/Makefile.in 2010-10-28 10:35:23.000000000 -0400
|
||||
+++ tests/libtracker-fts/Makefile.in.new 2010-11-02 14:03:15.048983075 -0400
|
||||
@@ -461,6 +461,7 @@
|
||||
LDADD = \
|
||||
$(top_builddir)/src/libtracker-common/libtracker-common.la \
|
||||
$(top_builddir)/src/libtracker-data/libtracker-data.la \
|
||||
+ $(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
|
||||
$(top_builddir)/tests/common/libtracker-testcommon.la \
|
||||
$(BUILD_LIBS) \
|
||||
$(LIBTRACKER_FTS_LIBS)
|
||||
|
22
tracker-0.9-gtk3-build-fixes.patch
Normal file
22
tracker-0.9-gtk3-build-fixes.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- configure.ac 2010-12-16 08:24:58.000000000 -0500
|
||||
+++ configure.ac.new 2010-12-22 11:43:35.761316716 -0500
|
||||
@@ -470,7 +470,7 @@
|
||||
TRACKER_NAUTILUS_EXTENSION_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
|
||||
gio-unix-2.0 >= $GLIB_REQUIRED
|
||||
gthread-2.0 >= $GLIB_REQUIRED
|
||||
- gtk+-2.0 >= $GTK_REQUIRED
|
||||
+ gtk+-3.0 >= $GTK_REQUIRED
|
||||
dbus-1 >= $DBUS_REQUIRED
|
||||
dbus-glib-1 >= $DBUS_GLIB_REQUIRED
|
||||
libnautilus-extension"
|
||||
--- configure 2010-12-16 08:25:32.000000000 -0500
|
||||
+++ configure.new 2010-12-22 11:44:06.683304843 -0500
|
||||
@@ -18833,7 +18833,7 @@
|
||||
TRACKER_NAUTILUS_EXTENSION_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
|
||||
gio-unix-2.0 >= $GLIB_REQUIRED
|
||||
gthread-2.0 >= $GLIB_REQUIRED
|
||||
- gtk+-2.0 >= $GTK_REQUIRED
|
||||
+ gtk+-3.0 >= $GTK_REQUIRED
|
||||
dbus-1 >= $DBUS_REQUIRED
|
||||
dbus-glib-1 >= $DBUS_GLIB_REQUIRED
|
||||
libnautilus-extension"
|
51
tracker.spec
51
tracker.spec
@ -1,25 +1,28 @@
|
||||
Summary: Desktop-neutral search tool and indexer
|
||||
Name: tracker
|
||||
Version: 0.9.30
|
||||
Release: 3%{?dist}
|
||||
Version: 0.9.33
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://projects.gnome.org/tracker/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.9/%{name}-%{version}.tar.bz2
|
||||
Patch0: tracker-0.9-fedora-build-fixes.patch
|
||||
Patch1: tracker-evo-build-fix.patch
|
||||
Patch2: tracker-0.9-gtk3-build-fixes.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: poppler-devel evolution-devel libxml2-devel libgsf-devel
|
||||
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
||||
BuildRequires: gnome-desktop-devel nautilus-devel gnome-panel-devel
|
||||
BuildRequires: libjpeg-devel libexif-devel exempi-devel raptor-devel
|
||||
BuildRequires: libiptcdata-devel libtiff-devel libpng-devel giflib-devel
|
||||
BuildRequires: sqlite-devel vala-devel libgee-devel pygtk2-devel qt4-devel
|
||||
BuildRequires: sqlite-devel vala-devel libgee-devel pygtk2-devel
|
||||
BuildRequires: gstreamer-plugins-base-devel gstreamer-devel id3lib-devel
|
||||
BuildRequires: totem-pl-parser-devel libvorbis-devel flac-devel enca-devel
|
||||
BuildRequires: upower-devel gnome-keyring-devel NetworkManager-glib-devel
|
||||
BuildRequires: libunistring-devel gupnp-dlna-devel taglib-devel
|
||||
BuildRequires: desktop-file-utils intltool gettext graphviz
|
||||
BuildRequires: gdk-pixbuf-devel
|
||||
BuildRequires: desktop-file-utils intltool gettext graphviz dia
|
||||
BuildRequires: autoconf automake libtool
|
||||
|
||||
%description
|
||||
Tracker is a powerful desktop-neutral first class object database,
|
||||
@ -65,6 +68,15 @@ Requires: %{name} = %{version}-%{release}
|
||||
%description evolution-plugin
|
||||
Tracker's evolution plugin
|
||||
|
||||
%package nautilus-plugin
|
||||
Summary: Tracker's nautilus plugin
|
||||
Group: User Interface/Desktops
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description nautilus-plugin
|
||||
Tracker's nautilus plugin, provides 'tagging' functionality. Ability to perform
|
||||
search in nuautilus using tracker is built-in directly in the nautilus package.
|
||||
|
||||
%package docs
|
||||
Summary: Documentations for tracker
|
||||
Group: Documentation
|
||||
@ -75,8 +87,11 @@ This package contains the documentation for tracker
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0 -b .fix
|
||||
%patch1 -p0 -b .fix2
|
||||
%patch2 -p0 -b .fix3
|
||||
autopoint --force &&
|
||||
AUTOPOINT='intltoolize --automake --copy' autoreconf --verbose --force --install
|
||||
%patch0 -p0 -b .fix
|
||||
|
||||
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
||||
|
||||
@ -96,13 +111,13 @@ rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||
echo "%{_libdir}/tracker-0.9" \
|
||||
echo "%{_libdir}/tracker-0.10" \
|
||||
> %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
|
||||
|
||||
desktop-file-install --delete-original \
|
||||
--vendor="fedora" \
|
||||
--dir=%{buildroot}%{_datadir}/applications \
|
||||
%{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
|
||||
%{buildroot}%{_datadir}/applications/%{name}-needle.desktop
|
||||
|
||||
find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
|
||||
rm -rf %{buildroot}%{_datadir}/tracker-tests
|
||||
@ -136,20 +151,20 @@ fi
|
||||
%{_datadir}/tracker/
|
||||
%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/tracker-0.9/
|
||||
%{_libdir}/tracker-0.10/
|
||||
%{_mandir}/*/tracker*.gz
|
||||
%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
|
||||
%{_sysconfdir}/xdg/autostart/tracker*.desktop
|
||||
%exclude %{_bindir}/tracker-preferences
|
||||
%exclude %{_bindir}/tracker-search-tool
|
||||
%exclude %{_bindir}/tracker-needle
|
||||
%exclude %{_libexecdir}/tracker-search-bar
|
||||
%exclude %{_mandir}/man1/tracker-search-bar.1.gz
|
||||
%exclude %{_mandir}/man1/tracker-preferences.1.gz
|
||||
%exclude %{_mandir}/man1/tracker-search-tool.1.gz
|
||||
%exclude %{_mandir}/man1/tracker-needle.1.gz
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, -)
|
||||
%{_includedir}/tracker-0.9/
|
||||
%{_includedir}/tracker-0.10/
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_datadir}/vala/vapi/tracker*.*
|
||||
@ -157,21 +172,24 @@ fi
|
||||
%files search-tool
|
||||
%defattr(-, root, root, -)
|
||||
%{_bindir}/tracker-preferences
|
||||
%{_bindir}/tracker-search-tool
|
||||
%{_bindir}/tracker-needle
|
||||
%{_libexecdir}/tracker-search-bar
|
||||
%{_libdir}/nautilus/extensions-2.0/libnautilus-tracker-tags.so
|
||||
%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
|
||||
%{_datadir}/icons/*/*/apps/tracker.*
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_mandir}/man1/tracker-search-bar.1.gz
|
||||
%{_mandir}/man1/tracker-preferences.1.gz
|
||||
%{_mandir}/man1/tracker-search-tool.1.gz
|
||||
%{_mandir}/man1/tracker-needle.1.gz
|
||||
|
||||
%files evolution-plugin
|
||||
%defattr(-, root, root, -)
|
||||
%{evo_plugins_dir}/liborg-freedesktop-Tracker-evolution-plugin.so
|
||||
%{evo_plugins_dir}/org-freedesktop-Tracker-evolution-plugin.eplug
|
||||
|
||||
%files nautilus-plugin
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/nautilus/extensions-2.0/libnautilus-tracker-tags.so
|
||||
|
||||
%files docs
|
||||
%defattr(-, root, root, -)
|
||||
%doc docs/reference/COPYING
|
||||
@ -182,6 +200,11 @@ fi
|
||||
%{_datadir}/gtk-doc/html/ontology/
|
||||
|
||||
%changelog
|
||||
* Tue Jan 04 2011 Deji Akingunola <dakingun@gmail.com> - 0.9.33-1
|
||||
- Update to 0.9.33
|
||||
- Substitute gdk-pixbuf for qt4 as music album extractor
|
||||
- Split off nautilus-plugin into a sub-package
|
||||
|
||||
* Sat Jan 01 2011 Rex Dieter <rdieter@fedoraproject.org> - 0.9.30-3
|
||||
- rebuild (poppler)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user