Fix tracker-compat script path (#1198166)
This commit is contained in:
parent
497fc5510b
commit
4066a5691f
58
tracker-1.3.4-fix-tracker-compat.patch
Normal file
58
tracker-1.3.4-fix-tracker-compat.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From 4b5ab1ebf21df6a190d1e3d775709a53262b5c51 Mon Sep 17 00:00:00 2001
|
||||||
|
From: David King <amigadave@amigadave.com>
|
||||||
|
Date: Tue, 3 Mar 2015 18:22:41 +0000
|
||||||
|
Subject: [PATCH 1/3] tracker-compat: put absolute path in shell script
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=743738
|
||||||
|
---
|
||||||
|
src/tracker/Makefile.am | 5 ++++-
|
||||||
|
src/tracker/tracker-compat | 8 --------
|
||||||
|
src/tracker/tracker-compat.in | 8 ++++++++
|
||||||
|
3 files changed, 12 insertions(+), 9 deletions(-)
|
||||||
|
delete mode 100755 src/tracker/tracker-compat
|
||||||
|
create mode 100755 src/tracker/tracker-compat.in
|
||||||
|
|
||||||
|
diff --git a/src/tracker/Makefile.am b/src/tracker/Makefile.am
|
||||||
|
index cb777aa..7c16dff 100644
|
||||||
|
--- a/src/tracker/Makefile.am
|
||||||
|
+++ b/src/tracker/Makefile.am
|
||||||
|
@@ -79,4 +79,7 @@ uninstall-hook:
|
||||||
|
completiondir = $(sysconfdir)/bash_completion.d
|
||||||
|
completion_DATA = tracker-prompt.sh
|
||||||
|
|
||||||
|
-EXTRA_DIST = $(completion_DATA) tracker-compat
|
||||||
|
+tracker-compat: tracker-compat.in
|
||||||
|
+ $(AM_V_at)sed -e "s|@bindir[@]|${bindir}|" $< > $@
|
||||||
|
+
|
||||||
|
+EXTRA_DIST = $(completion_DATA) tracker-compat.in
|
||||||
|
diff --git a/src/tracker/tracker-compat b/src/tracker/tracker-compat
|
||||||
|
deleted file mode 100755
|
||||||
|
index 4667ad6..0000000
|
||||||
|
--- a/src/tracker/tracker-compat
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,8 +0,0 @@
|
||||||
|
-#!/bin/sh
|
||||||
|
-
|
||||||
|
-#export TRACKER_OLD_CMD=`echo $0 | sed 's/^[./]*//'`
|
||||||
|
-export TRACKER_OLD_CMD=`basename $0`
|
||||||
|
-echo "WARNING: The '$TRACKER_OLD_CMD' command is no longer available." > /dev/stderr
|
||||||
|
-echo "WARNING: Use 'tracker <command> [<args>]' instead...\n" > /dev/stderr
|
||||||
|
-
|
||||||
|
-./tracker $@
|
||||||
|
diff --git a/src/tracker/tracker-compat.in b/src/tracker/tracker-compat.in
|
||||||
|
new file mode 100755
|
||||||
|
index 0000000..263d3d5
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/src/tracker/tracker-compat.in
|
||||||
|
@@ -0,0 +1,8 @@
|
||||||
|
+#!/bin/sh
|
||||||
|
+
|
||||||
|
+#export TRACKER_OLD_CMD=`echo $0 | sed 's/^[./]*//'`
|
||||||
|
+export TRACKER_OLD_CMD=`basename $0`
|
||||||
|
+echo "WARNING: The '$TRACKER_OLD_CMD' command is no longer available." > /dev/stderr
|
||||||
|
+echo "WARNING: Use 'tracker <command> [<args>]' instead...\n" > /dev/stderr
|
||||||
|
+
|
||||||
|
+@bindir@/tracker $@
|
||||||
|
--
|
||||||
|
2.3.1
|
||||||
|
|
@ -30,8 +30,10 @@ Patch0: 0001-Only-autostart-in-GNOME-771601.patch
|
|||||||
# Fix checking for gif support.
|
# Fix checking for gif support.
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=745582
|
# https://bugzilla.gnome.org/show_bug.cgi?id=745582
|
||||||
Patch1: tracker-1.3.4-fix-giflib-check.patch
|
Patch1: tracker-1.3.4-fix-giflib-check.patch
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1198166
|
||||||
|
Patch2: tracker-1.3.4-fix-tracker-compat.patch
|
||||||
|
|
||||||
# Required for patch1.
|
# Required for patch1 and patch2.
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: firefox
|
BuildRequires: firefox
|
||||||
@ -178,6 +180,7 @@ This package contains the documentation for tracker
|
|||||||
|
|
||||||
%patch0 -p1 -b .autostart-gnome
|
%patch0 -p1 -b .autostart-gnome
|
||||||
%patch1 -p1 -b .giflib-check
|
%patch1 -p1 -b .giflib-check
|
||||||
|
%patch2 -p1 -b .tracker-compat
|
||||||
|
|
||||||
## nuke unwanted rpaths, see also
|
## nuke unwanted rpaths, see also
|
||||||
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
||||||
@ -332,6 +335,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%changelog
|
%changelog
|
||||||
* Tue Mar 03 2015 David King <amigadave@amigadave.com> - 1.3.4-2
|
* Tue Mar 03 2015 David King <amigadave@amigadave.com> - 1.3.4-2
|
||||||
- Fix checking for giflib
|
- Fix checking for giflib
|
||||||
|
- Fix tracker-compat script path (#1198166)
|
||||||
|
|
||||||
* Tue Mar 03 2015 Kalev Lember <kalevlember@gmail.com> - 1.3.4-1
|
* Tue Mar 03 2015 Kalev Lember <kalevlember@gmail.com> - 1.3.4-1
|
||||||
- Update to 1.3.4
|
- Update to 1.3.4
|
||||||
|
Loading…
Reference in New Issue
Block a user