- Update to 0.8.15 release
- Package the docs licensing file - Patch for EDS API changes (Migrate from CamelException to GError) - Backport a memory leak fix
This commit is contained in:
parent
3c43011d95
commit
3a7f81c013
2
sources
2
sources
@ -1 +1 @@
|
|||||||
d11408a60e90f4d2aa021fde850b7649 tracker-0.8.13.tar.bz2
|
bd4dc2608a6e8b5cb494f36e4be77f87 tracker-0.8.15.tar.bz2
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- src/plugins/evolution/tracker-evolution-plugin.c 2010-04-29 13:20:00.000000000 -0400
|
--- src/plugins/evolution/tracker-evolution-plugin.c 2010-07-02 03:49:03.000000000 -0400
|
||||||
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-06-16 18:21:39.776821965 -0400
|
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-07-16 12:44:44.335347946 -0400
|
||||||
@@ -39,27 +39,7 @@
|
@@ -39,27 +39,7 @@
|
||||||
|
|
||||||
#include <sqlite3.h>
|
#include <sqlite3.h>
|
||||||
@ -49,7 +49,42 @@
|
|||||||
registry->folder = folder;
|
registry->folder = folder;
|
||||||
|
|
||||||
return registry;
|
return registry;
|
||||||
@@ -1340,8 +1320,8 @@
|
@@ -1267,7 +1247,7 @@
|
||||||
|
EAccount *account = (EAccount *) e_iterator_get (it);
|
||||||
|
CamelProvider *provider;
|
||||||
|
CamelStore *store;
|
||||||
|
- CamelException ex;
|
||||||
|
+ GError *error = NULL;
|
||||||
|
char *uri;
|
||||||
|
CamelDB *cdb_r;
|
||||||
|
sqlite3_stmt *stmt = NULL;
|
||||||
|
@@ -1275,13 +1255,11 @@
|
||||||
|
guint ret = SQLITE_OK;
|
||||||
|
guint64 latest = smallest;
|
||||||
|
|
||||||
|
- camel_exception_init (&ex);
|
||||||
|
-
|
||||||
|
if (!account->enabled || !(uri = account->source->url))
|
||||||
|
continue;
|
||||||
|
|
||||||
|
if (!(provider = camel_provider_get(uri, NULL))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ g_error_free (error);
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1289,8 +1267,8 @@
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1345,8 +1323,8 @@
|
||||||
goto not_ready;
|
goto not_ready;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -60,7 +95,64 @@
|
|||||||
registry->hook_info);
|
registry->hook_info);
|
||||||
registry->hook_info->hook_id = hook_id;
|
registry->hook_info->hook_id = hook_id;
|
||||||
|
|
||||||
@@ -1816,7 +1796,7 @@
|
@@ -1524,7 +1502,7 @@
|
||||||
|
/* Ownership was transfered to us in try_again */
|
||||||
|
free_introduction_info (winfo->intro_info);
|
||||||
|
camel_db_close (winfo->cdb_r);
|
||||||
|
- camel_object_unref (winfo->store);
|
||||||
|
+ g_object_unref (winfo->store);
|
||||||
|
camel_folder_info_free (winfo->iter);
|
||||||
|
g_free (winfo);
|
||||||
|
}
|
||||||
|
@@ -1579,7 +1557,7 @@
|
||||||
|
|
||||||
|
/* Ownership of these is transfered in try_again */
|
||||||
|
|
||||||
|
- camel_object_ref (store);
|
||||||
|
+ g_object_ref (store);
|
||||||
|
info->store = store;
|
||||||
|
/* This apparently creates a thread */
|
||||||
|
info->cdb_r = camel_db_clone (store->cdb_r, NULL);
|
||||||
|
@@ -1622,24 +1600,23 @@
|
||||||
|
{
|
||||||
|
CamelProvider *provider;
|
||||||
|
CamelStore *store;
|
||||||
|
- CamelException ex;
|
||||||
|
+ GError *error = NULL;
|
||||||
|
char *uri, *account_uri, *ptr;
|
||||||
|
IntroductionInfo *intro_info;
|
||||||
|
|
||||||
|
if (!account->enabled || !(uri = account->source->url))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- camel_exception_init (&ex);
|
||||||
|
- if (!(provider = camel_provider_get(uri, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(provider = camel_provider_get(uri, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1660,7 +1637,7 @@
|
||||||
|
|
||||||
|
mail_get_folderinfo (store, NULL, on_got_folderinfo_introduce, intro_info);
|
||||||
|
|
||||||
|
- camel_object_unref (store);
|
||||||
|
+ g_object_unref (store);
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1821,7 +1798,7 @@
|
||||||
|
|
||||||
static void
|
static void
|
||||||
on_folder_renamed (CamelStore *store,
|
on_folder_renamed (CamelStore *store,
|
||||||
@ -69,16 +161,27 @@
|
|||||||
StoreRegistry *registry)
|
StoreRegistry *registry)
|
||||||
{
|
{
|
||||||
unregister_account (registry->self, registry->account);
|
unregister_account (registry->self, registry->account);
|
||||||
@@ -1842,7 +1822,7 @@
|
@@ -1839,7 +1816,7 @@
|
||||||
|
registry->store = co;
|
||||||
|
registry->account = account; /* weak */
|
||||||
|
registry->self = self; /* weak */
|
||||||
|
- camel_object_ref (co);
|
||||||
|
+ g_object_ref (co);
|
||||||
|
|
||||||
|
return registry;
|
||||||
|
}
|
||||||
|
@@ -1847,8 +1824,8 @@
|
||||||
static void
|
static void
|
||||||
store_registry_free (StoreRegistry *registry)
|
store_registry_free (StoreRegistry *registry)
|
||||||
{
|
{
|
||||||
- camel_object_remove_event (registry->store, registry->hook_id);
|
- camel_object_remove_event (registry->store, registry->hook_id);
|
||||||
|
- camel_object_unref (registry->store);
|
||||||
+ g_signal_handler_disconnect (registry->store, registry->hook_id);
|
+ g_signal_handler_disconnect (registry->store, registry->hook_id);
|
||||||
camel_object_unref (registry->store);
|
+ g_object_unref (registry->store);
|
||||||
g_slice_free (StoreRegistry, registry);
|
g_slice_free (StoreRegistry, registry);
|
||||||
}
|
}
|
||||||
@@ -1871,8 +1851,8 @@
|
|
||||||
|
@@ -1876,8 +1853,8 @@
|
||||||
|
|
||||||
/* Hook up catching folder changes in the store */
|
/* Hook up catching folder changes in the store */
|
||||||
registry = store_registry_new (store, account, self);
|
registry = store_registry_new (store, account, self);
|
||||||
@ -89,7 +192,7 @@
|
|||||||
registry);
|
registry);
|
||||||
registry->hook_id = hook_id;
|
registry->hook_id = hook_id;
|
||||||
g_hash_table_replace (priv->registered_stores,
|
g_hash_table_replace (priv->registered_stores,
|
||||||
@@ -1880,8 +1860,8 @@
|
@@ -1885,8 +1862,8 @@
|
||||||
registry);
|
registry);
|
||||||
|
|
||||||
registry = store_registry_new (store, account, self);
|
registry = store_registry_new (store, account, self);
|
||||||
@ -100,7 +203,7 @@
|
|||||||
registry);
|
registry);
|
||||||
registry->hook_id = hook_id;
|
registry->hook_id = hook_id;
|
||||||
g_hash_table_replace (priv->registered_stores,
|
g_hash_table_replace (priv->registered_stores,
|
||||||
@@ -1889,8 +1869,8 @@
|
@@ -1894,8 +1871,8 @@
|
||||||
registry);
|
registry);
|
||||||
|
|
||||||
registry = store_registry_new (store, account, self);
|
registry = store_registry_new (store, account, self);
|
||||||
@ -111,3 +214,79 @@
|
|||||||
registry);
|
registry);
|
||||||
registry->hook_id = hook_id;
|
registry->hook_id = hook_id;
|
||||||
g_hash_table_replace (priv->registered_stores,
|
g_hash_table_replace (priv->registered_stores,
|
||||||
|
@@ -1921,24 +1898,23 @@
|
||||||
|
{
|
||||||
|
CamelProvider *provider;
|
||||||
|
CamelStore *store;
|
||||||
|
- CamelException ex;
|
||||||
|
+ GError *error = NULL;
|
||||||
|
char *uri;
|
||||||
|
RegisterInfo *reg_info;
|
||||||
|
|
||||||
|
if (!account->enabled || !(uri = account->source->url))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- camel_exception_init (&ex);
|
||||||
|
- if (!(provider = camel_provider_get(uri, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(provider = camel_provider_get(uri, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1953,7 +1929,7 @@
|
||||||
|
/* Get the account's folder-info and register it asynchronously */
|
||||||
|
mail_get_folderinfo (store, NULL, on_got_folderinfo_register, reg_info);
|
||||||
|
|
||||||
|
- camel_object_unref (store);
|
||||||
|
+ g_object_unref (store);
|
||||||
|
}
|
||||||
|
|
||||||
|
static gboolean
|
||||||
|
@@ -1992,22 +1968,21 @@
|
||||||
|
{
|
||||||
|
CamelProvider *provider;
|
||||||
|
CamelStore *store;
|
||||||
|
- CamelException ex;
|
||||||
|
+ GError *error = NULL;
|
||||||
|
char *uri = account->source->url;
|
||||||
|
RegisterInfo *reg_info;
|
||||||
|
|
||||||
|
|
||||||
|
- camel_exception_init (&ex);
|
||||||
|
- if (!(provider = camel_provider_get(uri, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(provider = camel_provider_get(uri, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
||||||
|
return;
|
||||||
|
|
||||||
|
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &ex))) {
|
||||||
|
- camel_exception_clear (&ex);
|
||||||
|
+ if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, &error))) {
|
||||||
|
+ g_error_free (error);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -2020,7 +1995,7 @@
|
||||||
|
/* Get the account's folder-info and unregister asynchronously */
|
||||||
|
mail_get_folderinfo (store, NULL, on_got_folderinfo_unregister, reg_info);
|
||||||
|
|
||||||
|
- camel_object_unref (store);
|
||||||
|
+ g_object_unref (store);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
10
tracker-memleak-fix.patch
Normal file
10
tracker-memleak-fix.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- src/libtracker-miner/tracker-storage.c 2010-07-16 06:25:01.000000000 -0400
|
||||||
|
+++ src/libtracker-miner/tracker-storage.c.new 2010-07-16 13:05:03.948459694 -0400
|
||||||
|
@@ -441,6 +441,7 @@
|
||||||
|
|
||||||
|
g_free (device_path);
|
||||||
|
g_free (mount_path);
|
||||||
|
+ g_unix_mount_free (entry);
|
||||||
|
} else {
|
||||||
|
g_debug (" No GUnixMountEntry found, needed for detecting if optical media... :(");
|
||||||
|
g_free (mount_path);
|
15
tracker.spec
15
tracker.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: An object database, tag/metadata database, search tool and indexer
|
Summary: An object database, tag/metadata database, search tool and indexer
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 0.8.13
|
Version: 0.8.15
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -8,6 +8,7 @@ URL: http://projects.gnome.org/tracker/
|
|||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/%{name}-%{version}.tar.bz2
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/%{name}-%{version}.tar.bz2
|
||||||
Patch0: tracker-0.8-doc-build.patch
|
Patch0: tracker-0.8-doc-build.patch
|
||||||
Patch1: tracker-eds-build-fix.patch
|
Patch1: tracker-eds-build-fix.patch
|
||||||
|
Patch2: tracker-memleak-fix.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: poppler-glib-devel evolution-devel libxml2-devel libgsf-devel
|
BuildRequires: poppler-glib-devel evolution-devel libxml2-devel libgsf-devel
|
||||||
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
||||||
@ -78,6 +79,7 @@ This package contains the documentation for tracker
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0 -b .fix
|
%patch0 -p0 -b .fix
|
||||||
%patch1 -p0 -b .fix
|
%patch1 -p0 -b .fix
|
||||||
|
%patch2 -p0 -b .mem
|
||||||
|
|
||||||
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
%global evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
||||||
|
|
||||||
@ -174,6 +176,7 @@ fi
|
|||||||
|
|
||||||
%files docs
|
%files docs
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
|
%doc docs/reference/COPYING
|
||||||
%{_datadir}/gtk-doc/html/libtracker-common/
|
%{_datadir}/gtk-doc/html/libtracker-common/
|
||||||
%{_datadir}/gtk-doc/html/libtracker-miner/
|
%{_datadir}/gtk-doc/html/libtracker-miner/
|
||||||
%{_datadir}/gtk-doc/html/libtracker-client/
|
%{_datadir}/gtk-doc/html/libtracker-client/
|
||||||
@ -181,6 +184,12 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/ontology/
|
%{_datadir}/gtk-doc/html/ontology/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 16 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.15-1
|
||||||
|
- Update to 0.8.15 release
|
||||||
|
- Package the docs licensing file
|
||||||
|
- Patch for EDS API changes (Migrate from CamelException to GError)
|
||||||
|
- Backport a memory leak fix
|
||||||
|
|
||||||
* Mon Jun 28 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.13-1
|
* Mon Jun 28 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.13-1
|
||||||
- Update to 0.8.13 release
|
- Update to 0.8.13 release
|
||||||
|
|
||||||
@ -189,7 +198,7 @@ fi
|
|||||||
|
|
||||||
* Tue Jun 15 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.11-1
|
* Tue Jun 15 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.11-1
|
||||||
- Update to 0.8.11 release
|
- Update to 0.8.11 release
|
||||||
- Adapt to EDS Camel API changes (patch not tested yet).
|
- Adapt to EDS Camel API changes (Convert CamelObject events to GObject signals), patch not tested yet.
|
||||||
|
|
||||||
* Thu May 27 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.9-1
|
* Thu May 27 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.9-1
|
||||||
- Update to 0.8.9 release
|
- Update to 0.8.9 release
|
||||||
@ -197,7 +206,7 @@ fi
|
|||||||
* Thu May 06 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.5-1
|
* Thu May 06 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.5-1
|
||||||
- Update to 0.8.5 release
|
- Update to 0.8.5 release
|
||||||
- Provide an upgrade path for paperbox (make ~-search-tool obsolete it) on F-13.
|
- Provide an upgrade path for paperbox (make ~-search-tool obsolete it) on F-13.
|
||||||
- Patch to build with eds-2.31.1
|
- Patch to build with eds-2.31.1 (Camel headers locked down)
|
||||||
|
|
||||||
* Thu Apr 29 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.4-1
|
* Thu Apr 29 2010 Deji Akingunola <dakingun@gmail.com> - 0.8.4-1
|
||||||
- Update to 0.8.4 release
|
- Update to 0.8.4 release
|
||||||
|
Loading…
Reference in New Issue
Block a user