Update to 1.3.2
This commit is contained in:
parent
d7ba76d58d
commit
13893b2d80
@ -1,33 +0,0 @@
|
||||
From ae24f17b6b8251a6359dba9b638847cb0f1f16a1 Mon Sep 17 00:00:00 2001
|
||||
From: Martyn Russell <martyn@lanedo.com>
|
||||
Date: Wed, 10 Dec 2014 09:35:34 +0000
|
||||
Subject: [PATCH] tracker-extract: Don't crash if g_file_make_symbolic_link()
|
||||
fails with no GError
|
||||
|
||||
We assume error is set, but in some cases it is not. Check before using it.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=741141
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1133042
|
||||
---
|
||||
src/tracker-extract/tracker-extract-persistence.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/tracker-extract/tracker-extract-persistence.c b/src/tracker-extract/tracker-extract-persistence.c
|
||||
index 38bdd35..ee9ebf1 100644
|
||||
--- a/src/tracker-extract/tracker-extract-persistence.c
|
||||
+++ b/src/tracker-extract/tracker-extract-persistence.c
|
||||
@@ -144,8 +144,8 @@ persistence_store_file (TrackerExtractPersistence *persistence,
|
||||
|
||||
if (!success) {
|
||||
g_warning ("Could not save '%s' into failsafe persistence store: %s",
|
||||
- path, error->message);
|
||||
- g_error_free (error);
|
||||
+ path, error ? error->message : "no error given");
|
||||
+ g_clear_error (&error);
|
||||
}
|
||||
|
||||
g_object_unref (link_file);
|
||||
--
|
||||
2.1.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
25c26969235ea7bb1ce57ccbd6bc8d9f tracker-1.3.1.tar.xz
|
||||
2411b648158b01ea815de41a70c297d7 tracker-1.3.2.tar.xz
|
||||
|
10
tracker.spec
10
tracker.spec
@ -15,8 +15,8 @@
|
||||
%endif
|
||||
|
||||
Name: tracker
|
||||
Version: 1.3.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.3.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Desktop-neutral search tool and indexer
|
||||
|
||||
Group: Applications/System
|
||||
@ -27,8 +27,6 @@ Source0: https://download.gnome.org/sources/%{name}/1.3/%{name}-%{version
|
||||
# only autostart in Gnome, see also
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=771601
|
||||
Patch0: 0001-Only-autostart-in-GNOME-771601.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1133042
|
||||
Patch1: 0001-tracker-extract-Don-t-crash-if-g_file_make_symbolic_.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: firefox
|
||||
@ -174,7 +172,6 @@ This package contains the documentation for tracker
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .autostart-gnome
|
||||
%patch1 -p1 -b .crash
|
||||
|
||||
## nuke unwanted rpaths, see also
|
||||
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
||||
@ -320,6 +317,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 19 2014 Richard Hughes <rhughes@redhat.com> - 1.3.2-1
|
||||
- Update to 1.3.2
|
||||
|
||||
* Wed Dec 10 2014 Matthias Clasen <mclasen@redhat.com> - 1.3.1-2
|
||||
- Fix a crash (#1133042)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user