- Update to 0.10.0
- Re-enable tracker-search-bar
This commit is contained in:
parent
6ac57d70a3
commit
10cf608568
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ tracker-0.8.13.tar.bz2
|
|||||||
/tracker-0.9.33.tar.bz2
|
/tracker-0.9.33.tar.bz2
|
||||||
/tracker-0.9.35.tar.bz2
|
/tracker-0.9.35.tar.bz2
|
||||||
/tracker-0.9.36.tar.bz2
|
/tracker-0.9.36.tar.bz2
|
||||||
|
/tracker-0.10.0.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
965f6e44414a8623dc1580dc2afe531d tracker-0.9.37.tar.bz2
|
03084485bdc91af0924121950e3f20db tracker-0.10.0.tar.bz2
|
||||||
|
26
tracker-0.10-gtk3-build-fixes.patch
Normal file
26
tracker-0.10-gtk3-build-fixes.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- configure.ac 2011-02-17 11:39:02.000000000 -0500
|
||||||
|
+++ configure.ac.new 2011-02-17 22:05:40.788691036 -0500
|
||||||
|
@@ -186,10 +186,10 @@
|
||||||
|
LIBEXIF_REQUIRED=0.6
|
||||||
|
LIBGSF_REQUIRED=1.13
|
||||||
|
EXEMPI_REQUIRED=2.1.0
|
||||||
|
-EVO_REQUIRED=2.91.90
|
||||||
|
-EVO_SHELL_REQUIRED=2.91.90
|
||||||
|
-EDS_REQUIRED=2.91.90
|
||||||
|
-CAMEL_REQUIRED=2.91.90
|
||||||
|
+EVO_REQUIRED=2.91.6
|
||||||
|
+EVO_SHELL_REQUIRED=2.91.6
|
||||||
|
+EDS_REQUIRED=2.91.6
|
||||||
|
+CAMEL_REQUIRED=2.91.6
|
||||||
|
# Unlikely version for now, Nepomuk integration isn't finished in streamanalyzer atm
|
||||||
|
LIBSTREAMANALYZER_REQUIRED=0.7.0
|
||||||
|
GEE_REQUIRED=0.3
|
||||||
|
@@ -440,7 +440,7 @@
|
||||||
|
TRACKER_NAUTILUS_EXTENSION_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
|
||||||
|
gio-unix-2.0 >= $GLIB_REQUIRED
|
||||||
|
gthread-2.0 >= $GLIB_REQUIRED
|
||||||
|
- gtk+-2.0 >= $GTK_REQUIRED
|
||||||
|
+ gtk+-3.0 >= $GTK_REQUIRED
|
||||||
|
libnautilus-extension"
|
||||||
|
|
||||||
|
PKG_CHECK_MODULES(TRACKER_NAUTILUS_EXTENSION, [$TRACKER_NAUTILUS_EXTENSION_REQUIRED],
|
@ -1,20 +0,0 @@
|
|||||||
--- configure.ac 2011-02-03 12:24:07.000000000 -0500
|
|
||||||
+++ configure.ac.new 2011-02-04 10:03:16.702394673 -0500
|
|
||||||
@@ -421,7 +421,7 @@
|
|
||||||
gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED
|
|
||||||
pango >= $PANGO_REQUIRED
|
|
||||||
gee-1.0 >= $GEE_REQUIRED
|
|
||||||
- libpanelapplet-3.0"
|
|
||||||
+ libpanelapplet-4.0"
|
|
||||||
|
|
||||||
PKG_CHECK_MODULES(TRACKER_SEARCH_BAR, [$TRACKER_SEARCH_BAR_REQUIRED],
|
|
||||||
[have_tracker_search_bar=yes],
|
|
||||||
@@ -431,7 +431,7 @@
|
|
||||||
TRACKER_NAUTILUS_EXTENSION_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
|
|
||||||
gio-unix-2.0 >= $GLIB_REQUIRED
|
|
||||||
gthread-2.0 >= $GLIB_REQUIRED
|
|
||||||
- gtk+-2.0 >= $GTK_REQUIRED
|
|
||||||
+ gtk+-3.0 >= $GTK_REQUIRED
|
|
||||||
libnautilus-extension"
|
|
||||||
|
|
||||||
PKG_CHECK_MODULES(TRACKER_NAUTILUS_EXTENSION, [$TRACKER_NAUTILUS_EXTENSION_REQUIRED],
|
|
@ -1,124 +0,0 @@
|
|||||||
--- src/plugins/evolution/tracker-evolution-plugin.c 2010-11-10 11:40:07.000000000 -0500
|
|
||||||
+++ src/plugins/evolution/tracker-evolution-plugin.c.new 2010-11-11 22:04:35.046263861 -0500
|
|
||||||
@@ -46,7 +46,8 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <mail/mail-config.h>
|
|
||||||
-#include <mail/mail-session.h>
|
|
||||||
+#include <mail/e-mail-session.h>
|
|
||||||
+#include <mail/e-mail-backend.h>
|
|
||||||
#include <mail/em-utils.h>
|
|
||||||
#include <mail/mail-ops.h>
|
|
||||||
|
|
||||||
@@ -1241,6 +1242,7 @@
|
|
||||||
|
|
||||||
for (it = e_list_get_iterator (E_LIST (priv->accounts)); e_iterator_is_valid (it); e_iterator_next (it)) {
|
|
||||||
EAccount *account = (EAccount *) e_iterator_get (it);
|
|
||||||
+ EMailSession *session;
|
|
||||||
CamelProvider *provider;
|
|
||||||
CamelStore *store;
|
|
||||||
char *uri;
|
|
||||||
@@ -1261,7 +1263,7 @@
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
+ if (!(store = (CamelStore *) camel_session_get_service (CAMEL_SESSION (session), uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -1352,6 +1354,11 @@
|
|
||||||
CamelStore *store,
|
|
||||||
gchar *account_uri)
|
|
||||||
{
|
|
||||||
+ EMailBackend *backend;
|
|
||||||
+ EMailSession *session;
|
|
||||||
+
|
|
||||||
+ session = e_mail_backend_get_session (backend);
|
|
||||||
+
|
|
||||||
TrackerEvolutionPluginPrivate *priv = TRACKER_EVOLUTION_PLUGIN_GET_PRIVATE (self);
|
|
||||||
|
|
||||||
if (!priv->registered_folders) {
|
|
||||||
@@ -1378,7 +1385,8 @@
|
|
||||||
/* This is asynchronous and hooked to the mail/ API, so nicely
|
|
||||||
* integrated with the Evolution UI application */
|
|
||||||
|
|
||||||
- mail_get_folder (iter->uri, 0, register_on_get_folder, info,
|
|
||||||
+ mail_get_folder (session, iter->uri, 0,
|
|
||||||
+ register_on_get_folder, info,
|
|
||||||
mail_msg_unordered_push);
|
|
||||||
|
|
||||||
if (iter->child) {
|
|
||||||
@@ -1436,6 +1444,11 @@
|
|
||||||
CamelStore *store,
|
|
||||||
gchar *account_uri)
|
|
||||||
{
|
|
||||||
+ EMailBackend *backend;
|
|
||||||
+ EMailSession *session;
|
|
||||||
+
|
|
||||||
+ session = e_mail_backend_get_session (backend);
|
|
||||||
+
|
|
||||||
/* Recursively walks all the folders in store */
|
|
||||||
|
|
||||||
while (titer) {
|
|
||||||
@@ -1448,7 +1461,8 @@
|
|
||||||
/* This is asynchronous and hooked to the mail/ API, so nicely
|
|
||||||
* integrated with the Evolution UI application */
|
|
||||||
|
|
||||||
- mail_get_folder (titer->uri, 0, unregister_on_get_folder, info,
|
|
||||||
+ mail_get_folder (session, titer->uri, 0,
|
|
||||||
+ unregister_on_get_folder, info,
|
|
||||||
mail_msg_unordered_push);
|
|
||||||
|
|
||||||
if (titer->child) {
|
|
||||||
@@ -1602,6 +1616,7 @@
|
|
||||||
EAccount *account,
|
|
||||||
ClientRegistry *info)
|
|
||||||
{
|
|
||||||
+ EMailSession *session;
|
|
||||||
CamelProvider *provider;
|
|
||||||
CamelStore *store;
|
|
||||||
char *uri, *account_uri, *ptr;
|
|
||||||
@@ -1617,7 +1632,7 @@
|
|
||||||
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
|
||||||
return;
|
|
||||||
|
|
||||||
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
+ if (!(store = (CamelStore *) camel_session_get_service (CAMEL_SESSION (session), uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -1933,6 +1948,7 @@
|
|
||||||
register_account (TrackerEvolutionPlugin *self,
|
|
||||||
EAccount *account)
|
|
||||||
{
|
|
||||||
+ EMailSession *session;
|
|
||||||
CamelProvider *provider;
|
|
||||||
CamelStore *store;
|
|
||||||
char *uri;
|
|
||||||
@@ -1948,7 +1964,7 @@
|
|
||||||
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
|
||||||
return;
|
|
||||||
|
|
||||||
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
+ if (!(store = (CamelStore *) camel_session_get_service (CAMEL_SESSION (session), uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -2004,6 +2020,7 @@
|
|
||||||
unregister_account (TrackerEvolutionPlugin *self,
|
|
||||||
EAccount *account)
|
|
||||||
{
|
|
||||||
+ EMailSession *session;
|
|
||||||
CamelProvider *provider;
|
|
||||||
CamelStore *store;
|
|
||||||
char *uri = account->source->url;
|
|
||||||
@@ -2017,7 +2034,7 @@
|
|
||||||
if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
|
|
||||||
return;
|
|
||||||
|
|
||||||
- if (!(store = (CamelStore *) camel_session_get_service (session, uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
+ if (!(store = (CamelStore *) camel_session_get_service (CAMEL_SESSION (session), uri, CAMEL_PROVIDER_STORE, NULL))) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
23
tracker-search-bar.1
Normal file
23
tracker-search-bar.1
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
.TH tracker-search-bar 1 "September 2009" GNU "User Commands"
|
||||||
|
|
||||||
|
.SH NAME
|
||||||
|
tracker-search-bar \- Search applet for the GNOME panel
|
||||||
|
|
||||||
|
.SH SYNOPSIS
|
||||||
|
.B tracker-search-bar
|
||||||
|
|
||||||
|
.SH DESCRIPTION
|
||||||
|
.B tracker-search-bar
|
||||||
|
is a graphical front end applet for the GNOME panel which allows basic
|
||||||
|
searching of common categories using Full Text Searching (FTS). This
|
||||||
|
means, that searching for \fIcar\fR will find files like
|
||||||
|
\fIcarlos.png\fR, \fIcar-tax.pdf\fR, etc.
|
||||||
|
|
||||||
|
.B tracker-search-bar
|
||||||
|
currently extends to images, videos, music, folders and documents. The
|
||||||
|
applet is meant to quickly be able to access the top hits associated
|
||||||
|
with your search terms from the desktop at any time.
|
||||||
|
|
||||||
|
.SH SEE ALSO
|
||||||
|
.BR tracker-search-tool (1),
|
||||||
|
.BR tracker-status-icon (1).
|
18
tracker.spec
18
tracker.spec
@ -1,14 +1,14 @@
|
|||||||
Summary: Desktop-neutral search tool and indexer
|
Summary: Desktop-neutral search tool and indexer
|
||||||
Name: tracker
|
Name: tracker
|
||||||
Version: 0.9.37
|
Version: 0.10.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://projects.gnome.org/tracker/
|
URL: http://projects.gnome.org/tracker/
|
||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.9/%{name}-%{version}.tar.bz2
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.9/%{name}-%{version}.tar.bz2
|
||||||
|
Source1: tracker-search-bar.1
|
||||||
Patch0: tracker-0.9-fedora-build-fixes.patch
|
Patch0: tracker-0.9-fedora-build-fixes.patch
|
||||||
Patch1: tracker-evo-build-fix.patch
|
Patch1: tracker-0.10-gtk3-build-fixes.patch
|
||||||
Patch2: tracker-0.9-gtk3-build-fixes.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: poppler-devel evolution-devel libxml2-devel libgsf-devel
|
BuildRequires: poppler-devel evolution-devel libxml2-devel libgsf-devel
|
||||||
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
BuildRequires: libuuid-devel libnotify-devel dbus-devel
|
||||||
@ -87,16 +87,16 @@ search in nuautilus using tracker is built-in directly in the nautilus package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0 -b .fix2
|
%patch1 -p0 -b .gtk3
|
||||||
%patch2 -p0 -b .fix3
|
|
||||||
autopoint --force &&
|
autopoint --force &&
|
||||||
AUTOPOINT='intltoolize --automake --copy' autoreconf --verbose --force --install
|
AUTOPOINT='intltoolize --automake --copy' autoreconf --verbose --force --install
|
||||||
%patch0 -p0 -b .fix
|
%patch0 -p0 -b .fix
|
||||||
|
cp -pr %{SOURCE1} docs/manpages
|
||||||
|
|
||||||
%global evo_plugins_dir %(pkg-config evolution-plugin-3.0 --variable=plugindir)
|
%global evo_plugins_dir %(pkg-config evolution-plugin-3.0 --variable=plugindir)
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --disable-tracker-search-bar \
|
%configure --disable-static \
|
||||||
--enable-miner-evolution --disable-gtk-doc --disable-functional-tests
|
--enable-miner-evolution --disable-gtk-doc --disable-functional-tests
|
||||||
# Disable the functional tests for now, they make use of python bytecodes.
|
# Disable the functional tests for now, they make use of python bytecodes.
|
||||||
|
|
||||||
@ -199,6 +199,10 @@ fi
|
|||||||
#%{_datadir}/gtk-doc/html/ontology/
|
#%{_datadir}/gtk-doc/html/ontology/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 17 2011 Deji Akingunola <dakingun@gmail.com> - 0.10.0-1
|
||||||
|
- Update to 0.10.0
|
||||||
|
- Re-enable tracker-search-bar
|
||||||
|
|
||||||
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.9.37-3
|
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.9.37-3
|
||||||
- Rebuild against newer gtk
|
- Rebuild against newer gtk
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user