Update to 2.2.0
- Switch to the meson build system
This commit is contained in:
parent
39a9f966de
commit
03f1caed31
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tracker-2.1.7.tar.xz) = 75203af91ec43641caf2a3870100b8c5affb613e442e5a271edafe68ac7c6551256f288e435ce4fc8cb6f9ee0ea54871ebba90e085d0baeba4914815d3be15a0
|
||||
SHA512 (tracker-2.2.0.tar.xz) = dcd4242ecbb26aef48b2ef02d626b55af57c5f77e3b3a0af584b38875bb26178919115ebd65f487b23c7b84b3a742b8cd5d20d51a194006caf2b399f1fc6cdbd
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 51198297605ec5468f587730c6a49d3be30384a0 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garnacho <carlosg@gnome.org>
|
||||
Date: Sun, 11 Nov 2018 16:08:20 +0100
|
||||
Subject: [PATCH] libtracker-miner: Silence PREUNMOUNT/UNMOUNTED events
|
||||
|
||||
Those may happen in certain circumstances on monitored dirs, but are safe
|
||||
to simply ignore. This leaves the warning for EVENT_MOVED which can only
|
||||
be a bug in GLib since we use G_FILE_MONITOR_WATCH_MOVES.
|
||||
|
||||
Closes: https://gitlab.gnome.org/GNOME/tracker/issues/54
|
||||
---
|
||||
src/libtracker-miner/tracker-monitor.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/libtracker-miner/tracker-monitor.c b/src/libtracker-miner/tracker-monitor.c
|
||||
index 368467039..6bbe3b315 100644
|
||||
--- a/src/libtracker-miner/tracker-monitor.c
|
||||
+++ b/src/libtracker-miner/tracker-monitor.c
|
||||
@@ -768,11 +768,12 @@ monitor_event_cb (GFileMonitor *file_monitor,
|
||||
G_FILE_MONITOR_EVENT_MOVED,
|
||||
is_directory, file, other_file);
|
||||
break;
|
||||
- case G_FILE_MONITOR_EVENT_PRE_UNMOUNT:
|
||||
- case G_FILE_MONITOR_EVENT_UNMOUNTED:
|
||||
case G_FILE_MONITOR_EVENT_MOVED:
|
||||
g_warn_if_reached ();
|
||||
break;
|
||||
+ case G_FILE_MONITOR_EVENT_PRE_UNMOUNT:
|
||||
+ case G_FILE_MONITOR_EVENT_UNMOUNTED:
|
||||
+ break;
|
||||
}
|
||||
|
||||
g_free (file_uri);
|
||||
--
|
||||
2.18.1
|
||||
|
35
tracker.spec
35
tracker.spec
@ -3,22 +3,23 @@
|
||||
%global systemd_units tracker-store.service
|
||||
|
||||
Name: tracker
|
||||
Version: 2.1.7
|
||||
Version: 2.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Desktop-neutral metadata database and search tool
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://wiki.gnome.org/Projects/Tracker
|
||||
Source0: https://download.gnome.org/sources/%{name}/2.1/%{name}-%{version}.tar.xz
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1648902
|
||||
Patch0: tracker-2.1.5-silence-file-monitor-warnings.patch
|
||||
Source0: https://download.gnome.org/sources/%{name}/2.2/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: intltool
|
||||
BuildRequires: libappstream-glib
|
||||
BuildRequires: libstemmer-devel
|
||||
BuildRequires: meson
|
||||
BuildRequires: systemd
|
||||
BuildRequires: vala
|
||||
BuildRequires: pkgconfig(dbus-1)
|
||||
BuildRequires: pkgconfig(gobject-introspection-1.0)
|
||||
BuildRequires: pkgconfig(icu-i18n)
|
||||
BuildRequires: pkgconfig(icu-uc)
|
||||
@ -85,25 +86,19 @@ This package contains the documentation for tracker
|
||||
sed -i -e 's/ | SQLITE_DETERMINISTIC//' src/libtracker-data/tracker-db-interface-sqlite.c
|
||||
%endif
|
||||
|
||||
## nuke unwanted rpaths, see also
|
||||
## https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
|
||||
sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
|
||||
|
||||
|
||||
%build
|
||||
# Disable the functional tests for now, they use python bytecodes.
|
||||
%configure --disable-static \
|
||||
--enable-gtk-doc \
|
||||
--with-unicode-support=libicu \
|
||||
--disable-functional-tests \
|
||||
--disable-silent-rules
|
||||
%make_build
|
||||
%meson \
|
||||
-Ddocs=true \
|
||||
-Dfunctional_tests=false \
|
||||
-Dunicode_support=icu \
|
||||
-Dsystemd_user_services=%{_userunitdir}
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
find %{buildroot} -type f -name "*.la" -delete
|
||||
%meson_install
|
||||
|
||||
# Remove .so symlinks for private libraries -- no external users are supposed
|
||||
# to link with them.
|
||||
@ -166,6 +161,10 @@ rm -f %{buildroot}%{_libdir}/tracker-2.0/*.so
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
|
||||
- Update to 2.2.0
|
||||
- Switch to the meson build system
|
||||
|
||||
* Wed Feb 06 2019 Kalev Lember <klember@redhat.com> - 2.1.7-1
|
||||
- Update to 2.1.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user