Rebase to 2.6.2.

This commit is contained in:
Zamir SUN 2017-11-11 10:35:04 +08:00
parent 8ba13d16b2
commit cb074fe339
5 changed files with 48 additions and 29 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/trace-cmd-2.2.1.tar.gz
/trace-cmd-2.6.tar.gz
/trace-cmd-2.6.1.tar.gz
/trace-cmd-v2.6.2.tar.gz

View File

@ -0,0 +1,33 @@
From 7e8a6e3d03c0a6a7a5014ce488be1e16f99db006 Mon Sep 17 00:00:00 2001
From: Zamir SUN <sztsian@gmail.com>
Date: Sat, 11 Nov 2017 10:28:32 +0800
Subject: [PATCH] trace-cmd: Figure out the arch and install library to the
right place
Signed-off-by: Zamir SUN <sztsian@gmail.com>
---
Makefile | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 5c35143..d10e547 100644
--- a/Makefile
+++ b/Makefile
@@ -47,7 +47,13 @@ html_install = $(prefix)/share/kernelshark/html
html_install_SQ = '$(subst ','\'',$(html_install))'
img_install = $(prefix)/share/kernelshark/html/images
img_install_SQ = '$(subst ','\'',$(img_install))'
-libdir ?= $(prefix)/lib
+
+# figure out what arch we are on and install to the right place
+ARCH = $(shell getconf LONG_BIT)
+LIBDIR_32 = /lib
+LIBDIR_64 = /lib64
+
+libdir ?= $(prefix)/$(LIBDIR_$(ARCH))
libdir_SQ = '$(subst ','\'',$(libdir))'
includedir = $(prefix)/include/trace-cmd
includedir_SQ = '$(subst ','\'',$(includedir))'
--
2.13.4

View File

@ -1 +1 @@
SHA512 (trace-cmd-2.6.1.tar.gz) = 741281c8dc9355218932c6edc6b585de92ffc2b530744d13b4eb838ead8d2c6ec91fd25f39e590b50223c3425ae1cf2ec949f269335fc9d2b0cf1c4999751ec4
SHA512 (trace-cmd-v2.6.2.tar.gz) = 9e2f5ff570fb551a7effc5842701c05fad95c1fdfac1ec18d1715c5960f8685f5936e3af50bc13653abeb2dbcdedf47abf17bf4820a3c5c41fd0882bc07fc61a

View File

@ -1,17 +0,0 @@
diff -up ./Makefile.orig ./Makefile
--- ./Makefile.orig 2016-08-18 00:26:57.580940826 -0400
+++ ./Makefile 2016-08-18 00:29:51.594273746 -0400
@@ -31,6 +31,13 @@ $(call allow-override,AR,$(CROSS_COMPILE
EXT = -std=gnu99
INSTALL = install
+# figure out what arch we are on and install to the right place
+ARCH = $(shell getconf LONG_BIT)
+LIBDIR_32 = /usr/lib
+LIBDIR_64 = /usr/lib64
+libdir=$(LIBDIR_$(ARCH))
+
+
# Use DESTDIR for installing into a different root directory.
# This is useful for building a package. The program will be
# installed in this directory as if it was the root directory.

View File

@ -1,24 +1,23 @@
#%global checkout 20170330git013205a8
# git tag
#%global git_commit trace-cmd-v2.6
%global git_commit 021710e1073fe203341b427cd1a4bac577ec899c
#%%global git_commit trace-cmd-v2.6.2
#%%global git_commit 57371aaa2f469d0ba15fd85276deca7bfdd7ce36
Name: trace-cmd
Version: 2.6.1
Release: 3%{?dist}
Version: 2.6.2
Release: 1%{?dist}
License: GPLv2 and LGPLv2
Summary: A user interface to Ftrace
Group: Development/Tools
URL: http://git.kernel.org/?p=linux/kernel/git/rostedt/trace-cmd.git;a=summary
# Upstream does not provide tarballs.
# If upstream does not provide tarballs.
# To generate:
# git clone git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git
# cd trace-cmd
# git archive --prefix=trace-cmd-%%{version}/ -o trace-cmd-%%{version}.tar.gz %%{git_commit}
Source0: trace-cmd-%{version}.tar.gz
# git archive --prefix=trace-cmd-%%{version}/ -o trace-cmd-v%%{version}.tar.gz %%{git_commit}
Source0: https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/%{name}-v%{version}.tar.gz
Source1: kernelshark.desktop
Patch1: trace-cmd-2.6-libdir.patch
Patch1: 0001-trace-cmd-Figure-out-the-arch-and-install-library-to.patch
BuildRequires: xmlto
BuildRequires: asciidoc
BuildRequires: mlocate
@ -43,7 +42,7 @@ Kernelshark is the GUI frontend for analyzing data produced by
'trace-cmd extract'
%prep
%setup -q -n %{name}-%{version}
%setup -q -n %{name}-v%{version}
%patch1 -p1
%build
@ -53,7 +52,7 @@ make V=1 CFLAGS="%{optflags} -D_GNU_SOURCE" MANPAGE_DOCBOOK_XSL=$MANPAGE_DOCBOOK
%install
make V=1 DESTDIR=%{buildroot} prefix=%{_prefix} install install_doc install_gui
make V=1 DESTDIR=%{buildroot}/ prefix=%{_prefix} install install_doc install_gui
find %{buildroot}%{_mandir} -type f | xargs chmod u-x,g-x,o-x
find %{buildroot}%{_datadir} -type f | xargs chmod u-x,g-x,o-x
find %{buildroot}%{_libdir} -type f -iname "*.so" | xargs chmod 0755
@ -78,6 +77,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/kernelshark.desktop
%changelog
* Sat Nov 11 2017 Zamir SUN <zsun@fedoraproject.org> - 2.6.2-1
- Rebase to 2.6.2.
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild