Update to latest upstream release

This commit is contained in:
Jon Stanley 2013-02-13 17:57:14 -05:00
parent 66dcf63f62
commit 6e56e74a7c
5 changed files with 40 additions and 34 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/trace-cmd-1.2.20120606git8266dff.tar.gz
/trace-cmd-2.1.0.tar.gz

View File

@ -1 +1 @@
21612c27a2274094269ed37e95a8341c trace-cmd-1.2.20120606git8266dff.tar.gz
c839258271dbcd3e821f521fcf6674ed trace-cmd-2.1.0.tar.gz

View File

@ -1,24 +0,0 @@
diff -up trace-cmd-1.2.20120606git8266dff/Makefile.orig trace-cmd-1.2.20120606git8266dff/Makefile
--- trace-cmd-1.2.20120606git8266dff/Makefile.orig 2012-08-28 16:24:54.445210277 -0400
+++ trace-cmd-1.2.20120606git8266dff/Makefile 2012-08-28 16:37:52.705480585 -0400
@@ -13,6 +13,11 @@ FILE_VERSION = 6
MAKEFLAGS += --no-print-directory
+# figure out what arch we are on and install to the right place
+ARCH = $(shell getconf LONG_BIT)
+LIBDIR_32 = lib
+LIBDIR_64 = lib64
+LIBDIR=$(LIBDIR_$(ARCH))
# Makefiles suck: This macro sets a default value of $(2) for the
# variable named by $(1), unless the variable has been set by
# environment or command line. This is necessary for CC and AR
@@ -56,7 +61,7 @@ ifeq ($(prefix),$(HOME))
plugin_dir = $(HOME)/.trace-cmd/plugins
python_dir = $(HOME)/.trace-cmd/python
else
-plugin_dir = $(prefix)/share/trace-cmd/plugins
+plugin_dir = $(prefix)/$(LIBDIR)/trace-cmd
python_dir = $(prefix)/share/trace-cmd/python
PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"

View File

@ -0,0 +1,25 @@
diff -up trace-cmd-2.1.0/Makefile.orig trace-cmd-2.1.0/Makefile
--- trace-cmd-2.1.0/Makefile.orig 2013-02-13 10:50:10.355656277 -0500
+++ trace-cmd-2.1.0/Makefile 2013-02-13 10:51:37.409584197 -0500
@@ -31,6 +31,12 @@ $(call allow-override,AR,$(CROSS_COMPILE
EXT = -std=gnu99
INSTALL = install
+# figure out what arch we are on and install to the right place
+ARCH = $(shell getconf LONG_BIT)
+LIBDIR_32 = lib
+LIBDIR_64 = lib64
+LIBDIR=$(LIBDIR_$(ARCH))
+
# Use DESTDIR for installing into a different root directory.
# This is useful for building a package. The program will be
# installed in this directory as if it was the root directory.
@@ -56,7 +62,7 @@ ifeq ($(prefix),$(HOME))
plugin_dir = $(HOME)/.trace-cmd/plugins
python_dir = $(HOME)/.trace-cmd/python
else
-plugin_dir = $(prefix)/lib/trace-cmd/plugins
+plugin_dir = $(prefix)/$(LIBDIR)/trace-cmd
python_dir = $(prefix)/lib/trace-cmd/python
PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"

View File

@ -1,9 +1,10 @@
%global checkout 20120606git8266dff
%global git_commit 8266dff
#%global checkout 20120606git8266dff
# git tag
%global git_commit trace-cmd-v2.1.0
Name: trace-cmd
Version: 1.2
Release: 4.%{checkout}%{?dist}
Version: 2.1.0
Release: 1%{?dist}
License: GPLv2 and LGPLv2
Summary: A user interface to Ftrace
@ -13,10 +14,10 @@ URL: http://git.kernel.org/?p=linux/kernel/git/rostedt/trace-cmd.git;a=summary
# To generate:
# git clone git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git
# cd trace-cmd
# git archive --prefix=trace-cmd-%%{version}.%%{checkout}/ -o trace-cmd-%%{version}.%%{checkout}.tar.gz %%{git_commit}
Source0: trace-cmd-%{version}.%{checkout}.tar.gz
# git archive --prefix=trace-cmd-%%{version}/ -o trace-cmd-%%{version}.tar.gz %%{git_commit}
Source0: trace-cmd-%{version}.tar.gz
Source1: kernelshark.desktop
Patch1: trace-cmd-1.2-plugin-dir.patch
Patch1: trace-cmd-2.1.0-plugin-dir.patch
BuildRequires: xmlto
BuildRequires: asciidoc
@ -42,13 +43,13 @@ Kernelshark is the GUI frontend for analyzing data produced by
'trace-cmd extract'
%prep
%setup -q -n %{name}-%{version}.%{checkout}
%setup -q -n %{name}-%{version}
%patch1 -p1
%build
# MANPAGE_DOCBOOK_XSL define is hack to avoid using locate
MANPAGE_DOCBOOK_XSL=`rpm -ql docbook-style-xsl | grep manpages/docbook.xsl`
make V=1 CFLAGS="%{optflags}" MANPAGE_DOCBOOK_XSL=$MANPAGE_DOCBOOK_XSL prefix=%{_prefix} all doc gui
make V=1 CFLAGS="%{optflags} -D_GNU_SOURCE" MANPAGE_DOCBOOK_XSL=$MANPAGE_DOCBOOK_XSL prefix=%{_prefix} all doc gui
%install
@ -75,6 +76,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/kernelshark.desktop
%changelog
* Wed Feb 13 2013 Jon Stanley <jonstanley@gmail.com> - 2.1.0-1
- Update to latest upstream
* Thu Sep 13 2012 Jon Stanley <jonstanley@gmail.com> - 1.2-4.20120606git8266dff
- Remove %%defattr