Rebase to version 3.3.1
Resolves: RHEL-76155 Signed-off-by: Jerome Marchand <jmarchan@redhat.com>
This commit is contained in:
parent
5a09a9fdb8
commit
593753eb30
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/trace-cmd-v2.8.3.tar.gz
|
||||
/trace-cmd-v2.9.1.tar.gz
|
||||
/trace-cmd-v2.9.2.tar.gz
|
||||
/trace-cmd-v3.3.1.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (trace-cmd-v2.9.2.tar.gz) = ddb32446a5185ee6414f297de1d48fe39a7141c833a608fd3977dd0efd496bf18b59ea5d064316e7deb86c1cd82f33dcea4c0c145bb31b2473e85593f4d0d461
|
||||
SHA512 (trace-cmd-v3.3.1.tar.gz) = a643efc2868d08871a7359dd0a17389685fb229f26328ee96f27a3dd94b5f3eb62009b945c14725eda1f09fa15367ffe2e2c3611d89860dcc031bbd6403cdee0
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 7e12e8ba4001f51869f28770246f0ac3dbfb9999 Mon Sep 17 00:00:00 2001
|
||||
From: "Tzvetomir Stoyanov (VMware)" <tz.stoyanov@gmail.com>
|
||||
Date: Fri, 14 May 2021 10:52:41 +0300
|
||||
Subject: [PATCH] trace-cmd: Fix broken profile command
|
||||
|
||||
Recent changes in creating trace.dat files broke the streams, used
|
||||
internaly by the trace-cmd profile command.
|
||||
|
||||
Link: https://lore.kernel.org/linux-trace-devel/20210514075241.65418-1-tz.stoyanov@gmail.com
|
||||
|
||||
Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=213045
|
||||
Reported-by: Jerome Marchand <jmarchan@redhat.com>
|
||||
Fixes: 1762536da ("trace-cmd: Have tracecmd_read_headers() specify the state to read up to")
|
||||
Signed-off-by: Tzvetomir Stoyanov (VMware) <tz.stoyanov@gmail.com>
|
||||
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
|
||||
---
|
||||
tracecmd/trace-stream.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tracecmd/trace-stream.c b/tracecmd/trace-stream.c
|
||||
index f503bf7..b47b208 100644
|
||||
--- a/tracecmd/trace-stream.c
|
||||
+++ b/tracecmd/trace-stream.c
|
||||
@@ -59,7 +59,7 @@ trace_stream_init(struct buffer_instance *instance, int cpu, int fd, int cpus,
|
||||
goto fail;
|
||||
}
|
||||
|
||||
- if (tracecmd_read_headers(trace_input, 0) < 0)
|
||||
+ if (tracecmd_read_headers(trace_input, TRACECMD_FILE_PRINTK) < 0)
|
||||
goto fail_free_input;
|
||||
|
||||
if (handle_init)
|
||||
--
|
||||
2.31.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,28 +0,0 @@
|
||||
From 31385f8933f00ddecfd4a00a578d7936186f75da Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Thu, 11 Nov 2021 18:22:09 +0100
|
||||
Subject: [PATCH] utils.mk: don't ignore LDFLAGS when linking the shared libs
|
||||
|
||||
do_compile_shared_library should't ignore LDFLAGS. That makes it
|
||||
difficult for packager to follow their distribution packaging
|
||||
guidelines.
|
||||
---
|
||||
scripts/utils.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/utils.mk b/scripts/utils.mk
|
||||
index ae8c9e77..4a594a9c 100644
|
||||
--- a/scripts/utils.mk
|
||||
+++ b/scripts/utils.mk
|
||||
@@ -72,7 +72,7 @@ do_build_static_lib = \
|
||||
|
||||
do_compile_shared_library = \
|
||||
($(print_shared_lib_compile) \
|
||||
- $(CC) --shared $^ '-Wl,-soname,$(@F),-rpath=$$ORIGIN' -o $@ $(LIBS))
|
||||
+ $(CC) --shared $^ '-Wl,-soname,$(@F),-rpath=$$ORIGIN' -o $@ $(LDFLAGS) $(LIBS))
|
||||
|
||||
do_compile_plugin_obj = \
|
||||
($(print_plugin_obj_compile) \
|
||||
--
|
||||
2.31.1
|
||||
|
@ -2,11 +2,12 @@
|
||||
#%%global git_commit trace-cmd-v2.6.2
|
||||
#%%global git_commit 57371aaa2f469d0ba15fd85276deca7bfdd7ce36
|
||||
|
||||
%global srcversion 2.9.2
|
||||
%global srcversion 3.3.1
|
||||
%global libversion 1.5.2
|
||||
|
||||
Name: trace-cmd
|
||||
Version: %{srcversion}
|
||||
Release: 10%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2 and LGPLv2
|
||||
Summary: A user interface to Ftrace
|
||||
Requires: libtracecmd
|
||||
@ -22,9 +23,6 @@ Source0: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/t
|
||||
Source1: trace-cmd.conf
|
||||
Source2: trace-cmd.service
|
||||
Source3: 98-trace-cmd.rules
|
||||
Patch0: trace-cmd-Fix-broken-profile-command.patch
|
||||
Patch1: trace-cmd-utils.mk-don-t-ignore-LDFLAGS-when-linking-the-share.patch
|
||||
Patch2: trace-cmd-Remove-last-elements-of-local-libtracefs-a.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -60,14 +58,14 @@ Python plugin support for trace-cmd
|
||||
|
||||
%package -n libtracecmd
|
||||
Summary: Libraries of trace-cmd
|
||||
Version: 0
|
||||
Version: %{libversion}
|
||||
|
||||
%description -n libtracecmd
|
||||
The libtracecmd library
|
||||
|
||||
%package -n libtracecmd-devel
|
||||
Summary: Development files for libtracecmd
|
||||
Version: 0
|
||||
Version: %{libversion}
|
||||
Requires: libtracecmd%{_isa} = %{version}-%{release}
|
||||
|
||||
%description -n libtracecmd-devel
|
||||
@ -92,7 +90,7 @@ make V=1 MANPAGE_DOCBOOK_XSL=$MANPAGE_DOCBOOK_XSL \
|
||||
for i in python/*.py ; do
|
||||
sed -i 's/env python2/python3/g' $i
|
||||
done
|
||||
chrpath --delete tracecmd/trace-cmd lib/trace-cmd/libtracecmd.so.0.0.1
|
||||
chrpath --delete tracecmd/trace-cmd lib/trace-cmd/libtracecmd.so.%{libversion}
|
||||
|
||||
%install
|
||||
make V=1 libdir=%{_libdir} prefix=%{_prefix} DESTDIR=%{buildroot}/ \
|
||||
@ -115,6 +113,7 @@ install -p -m 644 98-trace-cmd.rules %{buildroot}/%{_udevrulesdir}/
|
||||
%{_bindir}/trace-cmd
|
||||
%{_mandir}/man1/%{name}*
|
||||
%{_mandir}/man5/%{name}*
|
||||
%{_docdir}/trace-cmd/trace-cmd*.html
|
||||
%{_sysconfdir}/bash_completion.d/trace-cmd.bash
|
||||
%{_sysconfdir}/sysconfig/trace-cmd.conf
|
||||
%{_unitdir}/trace-cmd.service
|
||||
@ -126,8 +125,7 @@ install -p -m 644 98-trace-cmd.rules %{buildroot}/%{_udevrulesdir}/
|
||||
|
||||
%files -n libtracecmd
|
||||
%doc COPYING COPYING.LIB README
|
||||
%{_libdir}/libtracecmd.so.0
|
||||
%{_libdir}/libtracecmd.so.0.0.1
|
||||
%{_libdir}/libtracecmd.so.*
|
||||
%{_docdir}/libtracecmd-doc
|
||||
%{_mandir}/man3/libtracecmd*
|
||||
%{_mandir}/man3/tracecmd*
|
||||
@ -138,6 +136,9 @@ install -p -m 644 98-trace-cmd.rules %{buildroot}/%{_udevrulesdir}/
|
||||
%{_includedir}/trace-cmd
|
||||
|
||||
%changelog
|
||||
* Tue Feb 25 2025 Jerome Marchand <jmarchan@redhat.com> - 3.3.1-1
|
||||
- Rebase to version 3.3.1 (RHEL-76155)
|
||||
|
||||
* Fri Jul 21 2023 Jerome Marchand <jmarchan@redhat.com> - 2.9.2-10
|
||||
- Remove remaining trace of libtracefs and libtraceevent
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user