update gmime-2.6 patch
This commit is contained in:
parent
fa2e143ae9
commit
9b92b86341
@ -1,39 +1,39 @@
|
||||
diff -ru totem-pl-parser-2.29.1.orig/configure totem-pl-parser-2.29.1/configure
|
||||
--- totem-pl-parser-2.29.1.orig/configure 2010-02-13 21:20:44.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.1/configure 2010-02-13 21:21:10.000000000 +0000
|
||||
@@ -18513,12 +18513,12 @@
|
||||
diff -upr totem-pl-parser-2.29.92/configure totem-pl-parser-2.29.92.new/configure
|
||||
--- totem-pl-parser-2.29.92/configure 2010-03-15 16:33:39.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.92.new/configure 2010-03-15 17:14:02.000000000 +0000
|
||||
@@ -16169,12 +16169,12 @@ if test -n "$GMIME_CFLAGS"; then
|
||||
pkg_cv_GMIME_CFLAGS="$GMIME_CFLAGS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\"") >&5
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\"") >&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -18529,12 +18529,12 @@
|
||||
@@ -16185,12 +16185,12 @@ if test -n "$GMIME_LIBS"; then
|
||||
pkg_cv_GMIME_LIBS="$GMIME_LIBS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\"") >&5
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\"") >&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -18552,9 +18552,9 @@
|
||||
@@ -16208,9 +16208,9 @@ else
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
@ -45,7 +45,7 @@ diff -ru totem-pl-parser-2.29.1.orig/configure totem-pl-parser-2.29.1/configure
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GMIME_PKG_ERRORS" >&5
|
||||
@@ -18573,7 +18573,7 @@
|
||||
@@ -16229,14 +16229,14 @@ $as_echo "yes" >&6; }
|
||||
fi
|
||||
|
||||
if test "x$have_gmime" = "xyes" ; then
|
||||
@ -54,19 +54,18 @@ diff -ru totem-pl-parser-2.29.1.orig/configure totem-pl-parser-2.29.1/configure
|
||||
|
||||
USEGMIME=yes
|
||||
|
||||
@@ -18582,7 +18582,7 @@
|
||||
#define HAVE_GMIME 1
|
||||
_ACEOF
|
||||
|
||||
$as_echo "#define HAVE_GMIME 1" >>confdefs.h
|
||||
|
||||
- pkg_modules="$pkg_modules gmime-2.4"
|
||||
+ pkg_modules="$pkg_modules gmime-2.6"
|
||||
else
|
||||
{ { $as_echo "$as_me:$LINENO: error: libgmime is required to compile totem-pl-parser." >&5
|
||||
$as_echo "$as_me: error: libgmime is required to compile totem-pl-parser." >&2;}
|
||||
diff -ru totem-pl-parser-2.29.1.orig/configure.in totem-pl-parser-2.29.1/configure.in
|
||||
--- totem-pl-parser-2.29.1.orig/configure.in 2010-02-13 21:20:44.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.1/configure.in 2010-02-13 21:21:06.000000000 +0000
|
||||
@@ -72,15 +72,15 @@
|
||||
as_fn_error "libgmime is required to compile totem-pl-parser." "$LINENO" 5
|
||||
fi
|
||||
diff -upr totem-pl-parser-2.29.92/configure.in totem-pl-parser-2.29.92.new/configure.in
|
||||
--- totem-pl-parser-2.29.92/configure.in 2010-03-15 16:33:19.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.92.new/configure.in 2010-03-15 17:14:04.000000000 +0000
|
||||
@@ -71,15 +71,15 @@ AC_ARG_ENABLE(gmime-i-know-what-im-doing
|
||||
|
||||
if test "x$enable_gmime" = "xyes" ; then
|
||||
PKG_CHECK_MODULES(GMIME,
|
||||
|
@ -38,7 +38,7 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gmime26
|
||||
#%patch0 -p1 -b .gmime26
|
||||
|
||||
%build
|
||||
%configure --enable-static=no
|
||||
|
Loading…
Reference in New Issue
Block a user