Rebuild for gmime26
This commit is contained in:
parent
3d8ec8e143
commit
0f5ed41575
87
totem-pl-parser-2.29.1-gmine26.patch
Normal file
87
totem-pl-parser-2.29.1-gmine26.patch
Normal file
@ -0,0 +1,87 @@
|
||||
diff -ru totem-pl-parser-2.29.1.orig/configure totem-pl-parser-2.29.1/configure
|
||||
--- totem-pl-parser-2.29.1.orig/configure 2010-02-13 21:20:44.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.1/configure 2010-02-13 21:21:10.000000000 +0000
|
||||
@@ -18513,12 +18513,12 @@
|
||||
pkg_cv_GMIME_CFLAGS="$GMIME_CFLAGS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\"") >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\"") >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
- pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -18529,12 +18529,12 @@
|
||||
pkg_cv_GMIME_LIBS="$GMIME_LIBS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\"") >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\"") >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
- pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -18552,9 +18552,9 @@
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gmime-2.4" 2>&1`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gmime-2.6" 2>&1`
|
||||
else
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --print-errors "gmime-2.4" 2>&1`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --print-errors "gmime-2.6" 2>&1`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GMIME_PKG_ERRORS" >&5
|
||||
@@ -18573,7 +18573,7 @@
|
||||
fi
|
||||
|
||||
if test "x$have_gmime" = "xyes" ; then
|
||||
- GMIME=gmime-2.4
|
||||
+ GMIME=gmime-2.6
|
||||
|
||||
USEGMIME=yes
|
||||
|
||||
@@ -18582,7 +18582,7 @@
|
||||
#define HAVE_GMIME 1
|
||||
_ACEOF
|
||||
|
||||
- pkg_modules="$pkg_modules gmime-2.4"
|
||||
+ pkg_modules="$pkg_modules gmime-2.6"
|
||||
else
|
||||
{ { $as_echo "$as_me:$LINENO: error: libgmime is required to compile totem-pl-parser." >&5
|
||||
$as_echo "$as_me: error: libgmime is required to compile totem-pl-parser." >&2;}
|
||||
diff -ru totem-pl-parser-2.29.1.orig/configure.in totem-pl-parser-2.29.1/configure.in
|
||||
--- totem-pl-parser-2.29.1.orig/configure.in 2010-02-13 21:20:44.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.1/configure.in 2010-02-13 21:21:06.000000000 +0000
|
||||
@@ -72,15 +72,15 @@
|
||||
|
||||
if test "x$enable_gmime" = "xyes" ; then
|
||||
PKG_CHECK_MODULES(GMIME,
|
||||
- gmime-2.4,
|
||||
+ gmime-2.6,
|
||||
[have_gmime=yes],
|
||||
[have_gmime=no])
|
||||
|
||||
if test "x$have_gmime" = "xyes" ; then
|
||||
- AC_SUBST(GMIME, gmime-2.4)
|
||||
+ AC_SUBST(GMIME, gmime-2.6)
|
||||
AC_SUBST(USEGMIME, yes)
|
||||
AC_DEFINE(HAVE_GMIME, 1, [GMime available in the system])
|
||||
- pkg_modules="$pkg_modules gmime-2.4"
|
||||
+ pkg_modules="$pkg_modules gmime-2.6"
|
||||
else
|
||||
AC_MSG_ERROR([libgmime is required to compile totem-pl-parser.])
|
||||
fi
|
@ -1,6 +1,6 @@
|
||||
Name: totem-pl-parser
|
||||
Version: 2.29.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Totem Playlist Parser library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -17,6 +17,8 @@ BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: perl(XML::Parser) intltool
|
||||
|
||||
Patch0: totem-pl-parser-2.29.1-gmine26.patch
|
||||
|
||||
%description
|
||||
A library to parse and save playlists, as used in music and movie players.
|
||||
|
||||
@ -36,6 +38,7 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gmime26
|
||||
|
||||
%build
|
||||
%configure --enable-static=no
|
||||
@ -70,6 +73,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gtk-doc/html/totem-pl-parser
|
||||
|
||||
%changelog
|
||||
* Sat Feb 13 2010 Caolán McNamara <caolanm@redhat.com> 2.29.1-2
|
||||
- Rebuild for gmime26
|
||||
|
||||
* Tue Jan 26 2010 Bastien Nocera <bnocera@redhat.com> 2.29.1-1
|
||||
- Update to 2.29.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user