- Update to 2.30.0
This commit is contained in:
parent
ab7b8d11a2
commit
00268e2518
@ -1 +1 @@
|
||||
totem-pl-parser-2.29.92.tar.bz2
|
||||
totem-pl-parser-2.30.0.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
a032b83e0622fbdd675301e3dcdfeef9 totem-pl-parser-2.29.92.tar.bz2
|
||||
81bf8e3043a9ec89bdd391c36ebd50d1 totem-pl-parser-2.30.0.tar.bz2
|
||||
|
@ -1,86 +0,0 @@
|
||||
diff -upr totem-pl-parser-2.29.92/configure totem-pl-parser-2.29.92.new/configure
|
||||
--- totem-pl-parser-2.29.92/configure 2010-03-15 16:33:39.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.92.new/configure 2010-03-15 17:14:02.000000000 +0000
|
||||
@@ -16169,12 +16169,12 @@ if test -n "$GMIME_CFLAGS"; then
|
||||
pkg_cv_GMIME_CFLAGS="$GMIME_CFLAGS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_CFLAGS=`$PKG_CONFIG --cflags "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -16185,12 +16185,12 @@ if test -n "$GMIME_LIBS"; then
|
||||
pkg_cv_GMIME_LIBS="$GMIME_LIBS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.4\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "gmime-2.4") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gmime-2.6\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "gmime-2.6") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.4" 2>/dev/null`
|
||||
+ pkg_cv_GMIME_LIBS=`$PKG_CONFIG --libs "gmime-2.6" 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -16208,9 +16208,9 @@ else
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gmime-2.4" 2>&1`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gmime-2.6" 2>&1`
|
||||
else
|
||||
- GMIME_PKG_ERRORS=`$PKG_CONFIG --print-errors "gmime-2.4" 2>&1`
|
||||
+ GMIME_PKG_ERRORS=`$PKG_CONFIG --print-errors "gmime-2.6" 2>&1`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GMIME_PKG_ERRORS" >&5
|
||||
@@ -16229,14 +16229,14 @@ $as_echo "yes" >&6; }
|
||||
fi
|
||||
|
||||
if test "x$have_gmime" = "xyes" ; then
|
||||
- GMIME=gmime-2.4
|
||||
+ GMIME=gmime-2.6
|
||||
|
||||
USEGMIME=yes
|
||||
|
||||
|
||||
$as_echo "#define HAVE_GMIME 1" >>confdefs.h
|
||||
|
||||
- pkg_modules="$pkg_modules gmime-2.4"
|
||||
+ pkg_modules="$pkg_modules gmime-2.6"
|
||||
else
|
||||
as_fn_error "libgmime is required to compile totem-pl-parser." "$LINENO" 5
|
||||
fi
|
||||
diff -upr totem-pl-parser-2.29.92/configure.in totem-pl-parser-2.29.92.new/configure.in
|
||||
--- totem-pl-parser-2.29.92/configure.in 2010-03-15 16:33:19.000000000 +0000
|
||||
+++ totem-pl-parser-2.29.92.new/configure.in 2010-03-15 17:14:04.000000000 +0000
|
||||
@@ -71,15 +71,15 @@ AC_ARG_ENABLE(gmime-i-know-what-im-doing
|
||||
|
||||
if test "x$enable_gmime" = "xyes" ; then
|
||||
PKG_CHECK_MODULES(GMIME,
|
||||
- gmime-2.4,
|
||||
+ gmime-2.6,
|
||||
[have_gmime=yes],
|
||||
[have_gmime=no])
|
||||
|
||||
if test "x$have_gmime" = "xyes" ; then
|
||||
- AC_SUBST(GMIME, gmime-2.4)
|
||||
+ AC_SUBST(GMIME, gmime-2.6)
|
||||
AC_SUBST(USEGMIME, yes)
|
||||
AC_DEFINE(HAVE_GMIME, 1, [GMime available in the system])
|
||||
- pkg_modules="$pkg_modules gmime-2.4"
|
||||
+ pkg_modules="$pkg_modules gmime-2.6"
|
||||
else
|
||||
AC_MSG_ERROR([libgmime is required to compile totem-pl-parser.])
|
||||
fi
|
@ -1,5 +1,5 @@
|
||||
Name: totem-pl-parser
|
||||
Version: 2.29.92
|
||||
Version: 2.30.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Totem Playlist Parser library
|
||||
|
||||
@ -17,8 +17,6 @@ BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: perl(XML::Parser) intltool
|
||||
|
||||
Patch0: totem-pl-parser-2.29.1-gmine26.patch
|
||||
|
||||
%description
|
||||
A library to parse and save playlists, as used in music and movie players.
|
||||
|
||||
@ -38,7 +36,6 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gmime26
|
||||
|
||||
%build
|
||||
%configure --enable-static=no
|
||||
@ -73,6 +70,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gtk-doc/html/totem-pl-parser
|
||||
|
||||
%changelog
|
||||
* Mon Mar 29 2010 Bastien Nocera <bnocera@redhat.com> 2.30.0-1
|
||||
- Update to 2.30.0
|
||||
|
||||
* Mon Mar 15 2010 Bastien Nocera <bnocera@redhat.com> 2.29.92-1
|
||||
- Update to 2.29.92
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user