Update to 0.0.94
Based on code written by Ondřej Míchal.
This commit is contained in:
parent
adbd3c3842
commit
f9e5eff5aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/toolbox-0.0.91.tar.xz
|
||||
/toolbox-0.0.92.tar.xz
|
||||
/toolbox-0.0.93.tar.xz
|
||||
/toolbox-0.0.94.tar.xz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (toolbox-0.0.93.tar.xz) = bab8668b04572ebd2f8aac95b06f8d826e50cce448f272ecb0644e139d5bc949736f3710041040e0c6a59f92123c4edc21f8a893d152778b76332ca5ee940a2c
|
||||
SHA512 (toolbox-0.0.94.tar.xz) = 1acff39a7308bd563f3ca232aa59d341d890bfab22e95f91bb57bddabcec6ab23d7c367fe1ac54c637f1de5acee160beacda1244d6de2f713e8d7c26031af96b
|
||||
|
@ -1,4 +1,4 @@
|
||||
From d83d1f87082cc1cfb3c71844c8266787a258faba Mon Sep 17 00:00:00 2001
|
||||
From d70e3b4bf7825e67f57373fcd6e8da5ed1d5b461 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match Fedora's %{gobuild} for
|
||||
@ -29,16 +29,16 @@ explicitly specify the name of the output binary.
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index 8f84277ed6d8..ec6b9f68bb05 100755
|
||||
index f061a1c5ccf6..8baaff53b329 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -27,5 +27,6 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-go build -trimpath -ldflags "-X github.com/containers/toolbox/pkg/version.currentVersion=$3" -o "$2"
|
||||
-go build -trimpath -ldflags "-extldflags '-Wl,--wrap,pthread_sigmask $4' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -o "$2"
|
||||
+unset LDFLAGS
|
||||
+go build -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld ' -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -a -v -x -o "$2/toolbox"
|
||||
+go build -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,--wrap,pthread_sigmask $4' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -a -v -x -o "$2/toolbox"
|
||||
exit "$?"
|
||||
--
|
||||
2.25.4
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 3d5733cc7fe1ad7f6675a948c6f40d1dcbe290ca Mon Sep 17 00:00:00 2001
|
||||
From b1d265c4529eb0b23d10633326c075d54e07772f Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match Fedora's %{gobuild}
|
||||
@ -28,16 +28,16 @@ explicitly specify the name of the output binary.
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index 8f84277ed6d8..a0caf628435a 100755
|
||||
index f061a1c5ccf6..013a35e52a1a 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -27,5 +27,6 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-go build -trimpath -ldflags "-X github.com/containers/toolbox/pkg/version.currentVersion=$3" -o "$2"
|
||||
-go build -trimpath -ldflags "-extldflags '-Wl,--wrap,pthread_sigmask $4' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -o "$2"
|
||||
+unset LDFLAGS
|
||||
+go build -buildmode pie -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld ' -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -a -v -x -o "$2/toolbox"
|
||||
+go build -buildmode pie -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,--wrap,pthread_sigmask $4' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" -a -v -x -o "$2/toolbox"
|
||||
exit "$?"
|
||||
--
|
||||
2.25.4
|
||||
|
24
toolbox.spec
24
toolbox.spec
@ -1,10 +1,10 @@
|
||||
Name: toolbox
|
||||
Version: 0.0.93
|
||||
Version: 0.0.94
|
||||
|
||||
%global goipath github.com/containers/%{name}
|
||||
%gometa
|
||||
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Unprivileged development environment
|
||||
|
||||
License: ASL 2.0
|
||||
@ -109,6 +109,16 @@ The %{name}-experience package should be typically installed from the
|
||||
Dockerfile if the image isn't based on the fedora-toolbox image.
|
||||
|
||||
|
||||
%package tests
|
||||
Summary: Tests for %{name}
|
||||
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: bats
|
||||
|
||||
%description tests
|
||||
The %{name}-tests package contains system tests for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch100 -p1
|
||||
@ -131,8 +141,8 @@ ln -s src/pkg pkg
|
||||
%meson_build
|
||||
|
||||
|
||||
# %%check
|
||||
# %%meson_test
|
||||
%check
|
||||
%meson_test
|
||||
|
||||
|
||||
%install
|
||||
@ -153,8 +163,14 @@ ln -s src/pkg pkg
|
||||
|
||||
%files experience
|
||||
|
||||
%files tests
|
||||
%{_datadir}/%{name}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 24 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.94-1
|
||||
- Update to 0.0.94
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.93-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user