Update to 0.1.1
Resolves: RHEL-61904
This commit is contained in:
parent
d997ba39ef
commit
f8fbcb3929
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@
|
||||
/toolbox-0.0.99.4-vendored.tar.xz
|
||||
/toolbox-0.0.99.5-vendored.tar.xz
|
||||
/toolbox-0.0.99.6-vendored.tar.xz
|
||||
/toolbox-0.1.1-vendored.tar.xz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (toolbox-0.0.99.6-vendored.tar.xz) = 9ecec200069e8e2536e5ece43d411f9025dba6f60573e7939a0fc26deef29f0297d405a44fd409e978879b0579ab0a79ace97228a199584854c638213fa219d7
|
||||
SHA512 (toolbox-0.1.1-vendored.tar.xz) = dc3aa19f504de49addfe85fa800a0e553c65292cf0d48bca60946251fb8d7ba8bc53c9411a7db5f83f1d256ec960b0f22d2d5798f022be5b704c2bf3531f4ba1
|
||||
|
@ -1,81 +0,0 @@
|
||||
From ed14cd483ae45c5f4cf5596b11c384f4b42bb53b Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Fri, 4 Oct 2024 22:09:03 +0200
|
||||
Subject: [PATCH] Revert "playbooks, test/system: Work around bug in pasta(1)
|
||||
networks"
|
||||
|
||||
The bug in pasta(1) that necessitated this workaround has since been
|
||||
fixed in passt 2024_05_10.7288448 [1]. Some host operating systems like
|
||||
CentOS Stream 10 no longer have slirp4netns(1), and it's generally
|
||||
better to test the defaults.
|
||||
|
||||
This reverts commit b58f9a51088afbfc22edb0b25776cfa2c4d8cc40.
|
||||
|
||||
[1] https://github.com/containers/podman/issues/22575
|
||||
https://archives.passt.top/passt-dev/20240508090338.2735208-1-sbrivio@redhat.com/
|
||||
https://archives.passt.top/passt-user/20240510225714.6aa8e6c0@elisabeth/
|
||||
|
||||
https://github.com/containers/toolbox/pull/1562
|
||||
---
|
||||
playbooks/dependencies-centos-9-stream.yaml | 3 +--
|
||||
playbooks/dependencies-fedora.yaml | 3 +--
|
||||
test/system/libs/helpers.bash | 1 -
|
||||
3 files changed, 2 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/playbooks/dependencies-centos-9-stream.yaml b/playbooks/dependencies-centos-9-stream.yaml
|
||||
index 5c1194c03583..d058d314b7b3 100644
|
||||
--- a/playbooks/dependencies-centos-9-stream.yaml
|
||||
+++ b/playbooks/dependencies-centos-9-stream.yaml
|
||||
@@ -13,7 +13,6 @@
|
||||
- podman
|
||||
- shadow-utils-subid-devel
|
||||
- skopeo
|
||||
- - slirp4netns
|
||||
- systemd
|
||||
- udisks2
|
||||
|
||||
@@ -55,7 +54,7 @@
|
||||
chdir: '{{ zuul.project.src_dir }}'
|
||||
|
||||
- name: Check versions of crucial packages
|
||||
- command: rpm -qa ShellCheck bats codespell *kernel* gcc *glibc* golang golang-github-cpuguy83-md2man shadow-utils-subid-devel podman conmon containernetworking-plugins containers-common container-selinux crun fuse-overlayfs flatpak-session-helper skopeo slirp4netns
|
||||
+ command: rpm -qa ShellCheck bats codespell *kernel* gcc *glibc* golang golang-github-cpuguy83-md2man shadow-utils-subid-devel podman conmon containernetworking-plugins containers-common container-selinux crun fuse-overlayfs flatpak-session-helper skopeo
|
||||
|
||||
- name: Show podman versions
|
||||
command: podman version
|
||||
diff --git a/playbooks/dependencies-fedora.yaml b/playbooks/dependencies-fedora.yaml
|
||||
index ea605135a4c2..8007ce958ddb 100644
|
||||
--- a/playbooks/dependencies-fedora.yaml
|
||||
+++ b/playbooks/dependencies-fedora.yaml
|
||||
@@ -35,7 +35,6 @@
|
||||
- podman
|
||||
- shadow-utils-subid-devel
|
||||
- skopeo
|
||||
- - slirp4netns
|
||||
- systemd
|
||||
- udisks2
|
||||
use: "{{ 'dnf' if zuul.attempts > 1 else 'auto' }}"
|
||||
@@ -56,7 +55,7 @@
|
||||
chdir: '{{ zuul.project.src_dir }}'
|
||||
|
||||
- name: Check versions of crucial packages
|
||||
- command: rpm -qa ShellCheck bash bats codespell *kernel* gcc *glibc* shadow-utils-subid-devel golang golang-github-cpuguy83-md2man podman conmon containernetworking-plugins containers-common container-selinux crun fuse-overlayfs flatpak-session-helper skopeo slirp4netns
|
||||
+ command: rpm -qa ShellCheck bash bats codespell *kernel* gcc *glibc* shadow-utils-subid-devel golang golang-github-cpuguy83-md2man podman conmon containernetworking-plugins containers-common container-selinux crun fuse-overlayfs flatpak-session-helper skopeo
|
||||
|
||||
- name: Show podman versions
|
||||
command: podman version
|
||||
diff --git a/test/system/libs/helpers.bash b/test/system/libs/helpers.bash
|
||||
index dfd6236c2943..2d05641f5d0a 100644
|
||||
--- a/test/system/libs/helpers.bash
|
||||
+++ b/test/system/libs/helpers.bash
|
||||
@@ -195,7 +195,6 @@ function _setup_docker_registry() {
|
||||
--env REGISTRY_HTTP_TLS_CERTIFICATE=/certs/domain.crt \
|
||||
--env REGISTRY_HTTP_TLS_KEY=/certs/domain.key \
|
||||
--name "${DOCKER_REG_NAME}" \
|
||||
- --network slirp4netns \
|
||||
--privileged \
|
||||
--publish 50000:5000 \
|
||||
--rm \
|
||||
--
|
||||
2.46.1
|
||||
|
@ -1,104 +0,0 @@
|
||||
From 1e90c721858b3119702b93445f535f9c23af88e6 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Wed, 2 Oct 2024 22:43:37 +0200
|
||||
Subject: [PATCH] test/system: Unbreak the downstream Fedora CI
|
||||
|
||||
The working directory from which bats(1) is invoked might not be part of
|
||||
the Toolbx container. eg., the downstream Fedora CI invokes the tests
|
||||
as:
|
||||
$ cd /path/to/toolbox/test/system
|
||||
$ bats .
|
||||
|
||||
... and it led to:
|
||||
not ok 8 help: Try unknown command (forwarded to host)
|
||||
# tags: commands-options
|
||||
# (from function `assert_line' in file
|
||||
./libs/bats-assert/src/assert.bash, line 488,
|
||||
# in test file ./002-help.bats, line 135)
|
||||
# `assert_line --index 0
|
||||
"Error: unknown command \"foo\" for \"toolbox\""' failed
|
||||
#
|
||||
# -- line differs --
|
||||
# index : 0
|
||||
# expected : Error: unknown command "foo" for "toolbox"
|
||||
# actual : Error: crun: chdir to `/usr/share/toolbox/test/system`:
|
||||
No such file or directory: OCI runtime attempted to invoke a
|
||||
command that was not found
|
||||
# --
|
||||
#
|
||||
|
||||
https://github.com/containers/toolbox/pull/1560
|
||||
---
|
||||
test/system/002-help.bats | 2 ++
|
||||
test/system/501-create.bats | 2 ++
|
||||
test/system/504-run.bats | 2 ++
|
||||
test/system/505-enter.bats | 2 ++
|
||||
4 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/test/system/002-help.bats b/test/system/002-help.bats
|
||||
index 57e918a04d22..a8bfbc2c79d2 100644
|
||||
--- a/test/system/002-help.bats
|
||||
+++ b/test/system/002-help.bats
|
||||
@@ -25,9 +25,11 @@ setup() {
|
||||
bats_require_minimum_version 1.10.0
|
||||
_setup_environment
|
||||
cleanup_all
|
||||
+ pushd "$HOME" || return 1
|
||||
}
|
||||
|
||||
teardown() {
|
||||
+ popd || return 1
|
||||
cleanup_all
|
||||
}
|
||||
|
||||
diff --git a/test/system/501-create.bats b/test/system/501-create.bats
|
||||
index 3f50f98e6bf3..cfb676b7001b 100644
|
||||
--- a/test/system/501-create.bats
|
||||
+++ b/test/system/501-create.bats
|
||||
@@ -25,9 +25,11 @@ setup() {
|
||||
bats_require_minimum_version 1.8.0
|
||||
_setup_environment
|
||||
cleanup_all
|
||||
+ pushd "$HOME" || return 1
|
||||
}
|
||||
|
||||
teardown() {
|
||||
+ popd || return 1
|
||||
cleanup_all
|
||||
}
|
||||
|
||||
diff --git a/test/system/504-run.bats b/test/system/504-run.bats
|
||||
index cc5f6fa8bb09..6ee3e86af1ff 100644
|
||||
--- a/test/system/504-run.bats
|
||||
+++ b/test/system/504-run.bats
|
||||
@@ -25,9 +25,11 @@ setup() {
|
||||
bats_require_minimum_version 1.8.0
|
||||
_setup_environment
|
||||
cleanup_all
|
||||
+ pushd "$HOME" || return 1
|
||||
}
|
||||
|
||||
teardown() {
|
||||
+ popd || return 1
|
||||
cleanup_all
|
||||
}
|
||||
|
||||
diff --git a/test/system/505-enter.bats b/test/system/505-enter.bats
|
||||
index 405d184f145e..57e58651623d 100644
|
||||
--- a/test/system/505-enter.bats
|
||||
+++ b/test/system/505-enter.bats
|
||||
@@ -25,9 +25,11 @@ setup() {
|
||||
bats_require_minimum_version 1.8.0
|
||||
_setup_environment
|
||||
cleanup_all
|
||||
+ pushd "$HOME" || return 1
|
||||
}
|
||||
|
||||
teardown() {
|
||||
+ popd || return 1
|
||||
cleanup_all
|
||||
}
|
||||
|
||||
--
|
||||
2.46.1
|
||||
|
@ -1,30 +0,0 @@
|
||||
From b524f4cebd8c65746089f898e14a99c7cfded306 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Thu, 3 Oct 2024 22:08:04 +0200
|
||||
Subject: [PATCH] pkg/utils: Update fallback release to 40 for non-fedora hosts
|
||||
|
||||
Fedora 38 reached End of Life on 21st May 2024:
|
||||
https://docs.fedoraproject.org/en-US/releases/eol/
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2316312
|
||||
https://github.com/containers/toolbox/pull/1561
|
||||
---
|
||||
src/pkg/utils/utils.go | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pkg/utils/utils.go b/src/pkg/utils/utils.go
|
||||
index eefcd1eeb2cc..37a49fedf772 100644
|
||||
--- a/src/pkg/utils/utils.go
|
||||
+++ b/src/pkg/utils/utils.go
|
||||
@@ -64,7 +64,7 @@ const (
|
||||
containerNamePrefixFallback = "fedora-toolbox"
|
||||
distroFallback = "fedora"
|
||||
idTruncLength = 12
|
||||
- releaseFallback = "38"
|
||||
+ releaseFallback = "40"
|
||||
)
|
||||
|
||||
const (
|
||||
--
|
||||
2.46.1
|
||||
|
20
toolbox.spec
20
toolbox.spec
@ -1,7 +1,7 @@
|
||||
%global __brp_check_rpaths %{nil}
|
||||
|
||||
Name: toolbox
|
||||
Version: 0.0.99.6
|
||||
Version: 0.1.1
|
||||
|
||||
%global goipath github.com/containers/%{name}
|
||||
|
||||
@ -33,7 +33,7 @@ Version: 0.0.99.6
|
||||
%endif
|
||||
%endif
|
||||
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for interactive command line environments on Linux
|
||||
|
||||
License: Apache-2.0
|
||||
@ -43,11 +43,6 @@ Source0: https://github.com/containers/%{name}/releases/download/%{version
|
||||
# RHEL specific
|
||||
Source1: %{name}.conf
|
||||
|
||||
# Upstream
|
||||
Patch0: toolbox-Unbreak-downstream-Fedora-CI.patch
|
||||
Patch1: toolbox-Update-fallback-release-to-40-for-non-fedo.patch
|
||||
Patch2: toolbox-Revert-Work-around-bug-in-past.patch
|
||||
|
||||
# Fedora specific
|
||||
Patch100: toolbox-Make-the-build-flags-match-Fedora.patch
|
||||
|
||||
@ -68,7 +63,7 @@ BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: golang(github.com/HarryMichal/go-version) >= 1.0.1
|
||||
BuildRequires: golang-ipath(github.com/NVIDIA/go-nvlib) >= 0.6.1
|
||||
BuildRequires: golang-ipath(github.com/NVIDIA/go-nvml) >= 0.12.4.0
|
||||
BuildRequires: golang-ipath(github.com/NVIDIA/nvidia-container-toolkit) >= 1.16.1
|
||||
BuildRequires: golang-ipath(github.com/NVIDIA/nvidia-container-toolkit) >= 1.16.2
|
||||
BuildRequires: golang(github.com/acobaugh/osrelease) >= 0.1.0
|
||||
BuildRequires: golang(github.com/briandowns/spinner) >= 1.18.0
|
||||
BuildRequires: golang(github.com/docker/go-units) >= 0.5.0
|
||||
@ -79,7 +74,7 @@ BuildRequires: golang(github.com/google/renameio/v2) >= 2.0.0
|
||||
BuildRequires: golang(github.com/sirupsen/logrus) >= 1.9.3
|
||||
BuildRequires: golang(github.com/spf13/cobra) >= 1.3.0
|
||||
BuildRequires: golang(github.com/spf13/viper) >= 1.10.1
|
||||
BuildRequires: golang-ipath(golang.org/x/sys) >= 0.22.0
|
||||
BuildRequires: golang-ipath(golang.org/x/sys) >= 0.24.0
|
||||
BuildRequires: golang(golang.org/x/text) >= 0.3.8
|
||||
BuildRequires: golang-ipath(gopkg.in/yaml.v3) >= 3.0.1
|
||||
BuildRequires: golang-ipath(tags.cncf.io/container-device-interface) >= 0.8.0
|
||||
@ -140,9 +135,6 @@ The %{name}-tests package contains system tests for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -P0 -p1
|
||||
%patch -P1 -p1
|
||||
%patch -P2 -p1
|
||||
|
||||
%if 0%{?fedora}
|
||||
%patch -P100 -p1
|
||||
@ -218,6 +210,10 @@ install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/containers/%{name}.conf
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 01 2024 Debarshi Ray <rishi@fedoraproject.org> - 0.1.1-1
|
||||
- Update to 0.1.1
|
||||
Resolves: RHEL-61904
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.0.99.6-2
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
Loading…
Reference in New Issue
Block a user