parent
3b440cd46a
commit
d4a6831d26
@ -0,0 +1,44 @@
|
|||||||
|
From 6b47ff61936d2b602d29b229b079bda00dadad7e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||||
|
Date: Thu, 2 Sep 2021 14:57:37 +0200
|
||||||
|
Subject: [PATCH] cmd/root: Suggest a way forward if coreos/toolbox was used
|
||||||
|
|
||||||
|
github.com/coreos/toolbox bind mounts the entire /run from the host
|
||||||
|
operating system into the toolbox container. Due to this, when run
|
||||||
|
rootful, the /run/.containerenv created by Podman inside the container
|
||||||
|
is also seen on the host. This confuses Toolbox into thinking that it's
|
||||||
|
running inside a container, even when it's running on the host.
|
||||||
|
|
||||||
|
This is an attempt to differentiate between a toolbox container and
|
||||||
|
the host by looking at the 'container' environment variable, so that
|
||||||
|
the user can be presented with a more helpful error message.
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1998191
|
||||||
|
---
|
||||||
|
src/cmd/root.go | 10 ++++++++++
|
||||||
|
1 file changed, 10 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/cmd/root.go b/src/cmd/root.go
|
||||||
|
index 5e6f5874a469..139609592218 100644
|
||||||
|
--- a/src/cmd/root.go
|
||||||
|
+++ b/src/cmd/root.go
|
||||||
|
@@ -130,6 +130,16 @@ func preRun(cmd *cobra.Command, args []string) error {
|
||||||
|
|
||||||
|
if toolboxPath == "" {
|
||||||
|
if utils.IsInsideContainer() {
|
||||||
|
+ if containerType := os.Getenv("container"); containerType == "" {
|
||||||
|
+ var builder strings.Builder
|
||||||
|
+ fmt.Fprintf(&builder, "/run/.containerenv found on what looks like the host\n")
|
||||||
|
+ fmt.Fprintf(&builder, "If this is the host, then remove /run/.containerenv and try again.\n")
|
||||||
|
+ fmt.Fprintf(&builder, "Otherwise, contact your system administrator or file a bug.")
|
||||||
|
+
|
||||||
|
+ errMsg := builder.String()
|
||||||
|
+ return errors.New(errMsg)
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
return errors.New("TOOLBOX_PATH not set")
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
10
toolbox.spec
10
toolbox.spec
@ -9,7 +9,7 @@ Version: 0.0.99.3
|
|||||||
%global goipath github.com/containers/%{name}
|
%global goipath github.com/containers/%{name}
|
||||||
%gometa
|
%gometa
|
||||||
|
|
||||||
Release: 0.13.git660b6970e998%{?dist}
|
Release: 0.14.git660b6970e998%{?dist}
|
||||||
Summary: Unprivileged development environment
|
Summary: Unprivileged development environment
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -26,7 +26,8 @@ Source1: %{name}.conf
|
|||||||
Patch100: toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
|
Patch100: toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
|
||||||
Patch101: toolbox-Make-the-build-flags-match-RHEL-s-gobuild-for-PPC64.patch
|
Patch101: toolbox-Make-the-build-flags-match-RHEL-s-gobuild-for-PPC64.patch
|
||||||
Patch102: toolbox-cmd-run-Make-sosreport-work-by-setting-the-HOST-envi.patch
|
Patch102: toolbox-cmd-run-Make-sosreport-work-by-setting-the-HOST-envi.patch
|
||||||
Patch103: toolbox-Test-fixes-for-gating.patch
|
Patch103: toolbox-cmd-root-Suggest-a-way-forward-if-coreos-toolbox-was.patch
|
||||||
|
Patch104: toolbox-Test-fixes-for-gating.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1905383
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1905383
|
||||||
ExcludeArch: %{ix86}
|
ExcludeArch: %{ix86}
|
||||||
@ -68,6 +69,7 @@ The %{name}-tests package contains system tests for %{name}.
|
|||||||
|
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
%patch103 -p1
|
%patch103 -p1
|
||||||
|
%patch104 -p1
|
||||||
|
|
||||||
# %%gomkdir is absent from RHEL 8.
|
# %%gomkdir is absent from RHEL 8.
|
||||||
GOBUILDDIR="$(pwd)/_build"
|
GOBUILDDIR="$(pwd)/_build"
|
||||||
@ -115,6 +117,10 @@ install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/containers/%{name}.conf
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 22 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.14.git660b6970e998
|
||||||
|
- Suggest a way forward if coreos/toolbox was used
|
||||||
|
Resolves: #2006802
|
||||||
|
|
||||||
* Wed Sep 22 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.13.git660b6970e998
|
* Wed Sep 22 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.13.git660b6970e998
|
||||||
- Switch to using the Toolbox-specific UBI image by default
|
- Switch to using the Toolbox-specific UBI image by default
|
||||||
Resolves: #2004563
|
Resolves: #2004563
|
||||||
|
Loading…
Reference in New Issue
Block a user