Pull in the rest of the RHEL specific patches to further unify the build
There's no need to do a build just for this.
This commit is contained in:
parent
006d4f5d81
commit
b18f520f26
@ -0,0 +1,55 @@
|
|||||||
|
From 973600219168f3c4efeb627c103085555327eaa5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||||
|
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||||
|
Subject: [PATCH] build: Make the build flags match RHEL's %{gobuildflags} for
|
||||||
|
PPC64
|
||||||
|
|
||||||
|
The Go toolchain also doesn't like the LDFLAGS environment variable as
|
||||||
|
exported by RHEL's %{meson} RPM macro, and RHEL's RPM toolchain doesn't
|
||||||
|
like the compressed DWARF data generated by the Go toolchain.
|
||||||
|
|
||||||
|
Note that these flags are only meant for the "ppc64" CPU architecture,
|
||||||
|
and should be kept updated to match RHEL's Go guidelines. Use
|
||||||
|
'rpm --eval "%{gobuildflags}"' to expand the %{gobuildflags} macro.
|
||||||
|
---
|
||||||
|
src/go-build-wrapper | 13 +++++++++----
|
||||||
|
1 file changed, 9 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||||
|
index c572d6dfb02b..86f174716608 100755
|
||||||
|
--- a/src/go-build-wrapper
|
||||||
|
+++ b/src/go-build-wrapper
|
||||||
|
@@ -33,9 +33,9 @@ if ! cd "$1"; then
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
-tags=""
|
||||||
|
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-},libtrust_openssl"
|
||||||
|
if $7; then
|
||||||
|
- tags="-tags migration_path_for_coreos_toolbox"
|
||||||
|
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||||
|
fi
|
||||||
|
|
||||||
|
if ! libc_dir=$("$5" --print-file-name=libc.so); then
|
||||||
|
@@ -70,11 +70,16 @@ fi
|
||||||
|
|
||||||
|
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||||
|
|
||||||
|
+unset LDFLAGS
|
||||||
|
+
|
||||||
|
# shellcheck disable=SC2086
|
||||||
|
go build \
|
||||||
|
+ -compiler gc \
|
||||||
|
$tags \
|
||||||
|
- -trimpath \
|
||||||
|
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||||
|
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||||
|
+ -a \
|
||||||
|
+ -v \
|
||||||
|
+ -x \
|
||||||
|
-o "$2/$3"
|
||||||
|
|
||||||
|
exit "$?"
|
||||||
|
--
|
||||||
|
2.39.2
|
||||||
|
|
55
toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
Normal file
55
toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
Normal file
@ -0,0 +1,55 @@
|
|||||||
|
From aeaa8cd30a8c5ad33ee1fe6b9e84ecbb28f7264c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||||
|
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||||
|
Subject: [PATCH] build: Make the build flags match RHEL's %{gobuildflags}
|
||||||
|
|
||||||
|
The Go toolchain doesn't like the LDFLAGS environment variable as
|
||||||
|
exported by RHEL's %{meson} RPM macro, and RHEL's RPM toolchain doesn't
|
||||||
|
like the compressed DWARF data generated by the Go toolchain.
|
||||||
|
|
||||||
|
Note that these flags are meant for every CPU architecture other than
|
||||||
|
PPC64, and should be kept updated to match RHEL's Go guidelines. Use
|
||||||
|
'rpm --eval "%{gobuildflags}"' to expand the %{gobuildflags} macro.
|
||||||
|
---
|
||||||
|
src/go-build-wrapper | 14 ++++++++++----
|
||||||
|
1 file changed, 10 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||||
|
index c572d6dfb02b..d39764fda0c1 100755
|
||||||
|
--- a/src/go-build-wrapper
|
||||||
|
+++ b/src/go-build-wrapper
|
||||||
|
@@ -33,9 +33,9 @@ if ! cd "$1"; then
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
-tags=""
|
||||||
|
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-},libtrust_openssl"
|
||||||
|
if $7; then
|
||||||
|
- tags="-tags migration_path_for_coreos_toolbox"
|
||||||
|
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||||
|
fi
|
||||||
|
|
||||||
|
if ! libc_dir=$("$5" --print-file-name=libc.so); then
|
||||||
|
@@ -70,11 +70,17 @@ fi
|
||||||
|
|
||||||
|
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||||
|
|
||||||
|
+unset LDFLAGS
|
||||||
|
+
|
||||||
|
# shellcheck disable=SC2086
|
||||||
|
go build \
|
||||||
|
+ -buildmode pie \
|
||||||
|
+ -compiler gc \
|
||||||
|
$tags \
|
||||||
|
- -trimpath \
|
||||||
|
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||||
|
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||||
|
+ -a \
|
||||||
|
+ -v \
|
||||||
|
+ -x \
|
||||||
|
-o "$2/$3"
|
||||||
|
|
||||||
|
exit "$?"
|
||||||
|
--
|
||||||
|
2.39.2
|
||||||
|
|
12
toolbox.spec
12
toolbox.spec
@ -28,7 +28,9 @@ Patch100: toolbox-Make-the-build-flags-match-Fedora-s-gobuild.patch
|
|||||||
Patch101: toolbox-Make-the-build-flags-match-Fedora-s-gobuild-for-PPC64.patch
|
Patch101: toolbox-Make-the-build-flags-match-Fedora-s-gobuild-for-PPC64.patch
|
||||||
|
|
||||||
# RHEL specific
|
# RHEL specific
|
||||||
Patch200: toolbox-Add-migration-paths-for-coreos-toolbox-users.patch
|
Patch200: toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
|
||||||
|
Patch201: toolbox-Make-the-build-flags-match-RHEL-s-gobuild-for-PPC64.patch
|
||||||
|
Patch202: toolbox-Add-migration-paths-for-coreos-toolbox-users.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: go-md2man
|
BuildRequires: go-md2man
|
||||||
@ -167,14 +169,22 @@ The %{name}-tests package contains system tests for %{name}.
|
|||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
|
%if 0%{?fedora}
|
||||||
%ifnarch ppc64
|
%ifnarch ppc64
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
%else
|
%else
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
|
%ifnarch ppc64
|
||||||
%patch200 -p1
|
%patch200 -p1
|
||||||
|
%else
|
||||||
|
%patch201 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%patch202 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%gomkdir -s %{_builddir}/%{extractdir}/src %{?rhel:-k}
|
%gomkdir -s %{_builddir}/%{extractdir}/src %{?rhel:-k}
|
||||||
|
Loading…
Reference in New Issue
Block a user