import toolbox-0.0.99.3-3.el9_0
This commit is contained in:
commit
303f5500af
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/toolbox-0.0.99.3-vendored.tar.xz
|
1
.toolbox.metadata
Normal file
1
.toolbox.metadata
Normal file
@ -0,0 +1 @@
|
||||
ae6e6ac18c0d350eeabe9392a37ddc70cd60b52f SOURCES/toolbox-0.0.99.3-vendored.tar.xz
|
@ -0,0 +1,101 @@
|
||||
From 565947a7df6f4d18cb2f2d3a172b79391880288a Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Wed, 18 Aug 2021 17:55:21 +0200
|
||||
Subject: [PATCH 1/2] cmd/run: Make sosreport work by setting the HOST
|
||||
environment variable
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1940037
|
||||
---
|
||||
src/cmd/run.go | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/cmd/run.go b/src/cmd/run.go
|
||||
index 5954eac55fad..ca363815d4c9 100644
|
||||
--- a/src/cmd/run.go
|
||||
+++ b/src/cmd/run.go
|
||||
@@ -441,6 +441,7 @@ func constructExecArgs(container string,
|
||||
execArgs = append(execArgs, detachKeys...)
|
||||
|
||||
execArgs = append(execArgs, []string{
|
||||
+ "--env", "HOST=/run/host",
|
||||
"--interactive",
|
||||
"--tty",
|
||||
"--user", currentUser.Username,
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
||||
From fecbda4c3ea823eb04ebe392a6e1422e8ce8dd41 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Fri, 10 Dec 2021 13:42:15 +0100
|
||||
Subject: [PATCH 2/2] test/system: Update to test the migration path for
|
||||
coreos/toolbox users
|
||||
|
||||
This reverts the changes to the tests made in commit
|
||||
411147988b730dabf8b9e761a5426e12d648f008 by restoring commit
|
||||
ca899c8a561f357ae32c6ba6813520fd8b682abb and the parts of commit
|
||||
3aeb7cf288319e35eb9c5e26ea18d97452462c1e that were removed.
|
||||
---
|
||||
test/system/002-help.bats | 11 -----------
|
||||
test/system/100-root.bats | 27 +++++++++++++++++++++++++++
|
||||
2 files changed, 27 insertions(+), 11 deletions(-)
|
||||
create mode 100644 test/system/100-root.bats
|
||||
|
||||
diff --git a/test/system/002-help.bats b/test/system/002-help.bats
|
||||
index 689f95e472a1..525d44431ee5 100644
|
||||
--- a/test/system/002-help.bats
|
||||
+++ b/test/system/002-help.bats
|
||||
@@ -8,17 +8,6 @@ setup() {
|
||||
_setup_environment
|
||||
}
|
||||
|
||||
-@test "help: Try to run toolbox with no command" {
|
||||
- run $TOOLBOX
|
||||
-
|
||||
- assert_failure
|
||||
- assert_line --index 0 "Error: missing command"
|
||||
- assert_line --index 1 "create Create a new toolbox container"
|
||||
- assert_line --index 2 "enter Enter an existing toolbox container"
|
||||
- assert_line --index 3 "list List all existing toolbox containers and images"
|
||||
- assert_line --index 4 "Run 'toolbox --help' for usage."
|
||||
-}
|
||||
-
|
||||
@test "help: Run command 'help'" {
|
||||
if ! command -v man 2>/dev/null; then
|
||||
skip "Test works only if man is in PATH"
|
||||
diff --git a/test/system/100-root.bats b/test/system/100-root.bats
|
||||
new file mode 100644
|
||||
index 000000000000..32d87904213e
|
||||
--- /dev/null
|
||||
+++ b/test/system/100-root.bats
|
||||
@@ -0,0 +1,27 @@
|
||||
+#!/usr/bin/env bats
|
||||
+
|
||||
+load 'libs/bats-support/load'
|
||||
+load 'libs/bats-assert/load'
|
||||
+load 'libs/helpers'
|
||||
+
|
||||
+setup() {
|
||||
+ _setup_environment
|
||||
+ cleanup_containers
|
||||
+}
|
||||
+
|
||||
+teardown() {
|
||||
+ cleanup_containers
|
||||
+}
|
||||
+
|
||||
+@test "root: Try to enter the default container with no containers created" {
|
||||
+ run $TOOLBOX <<< "n"
|
||||
+
|
||||
+ assert_success
|
||||
+ assert_line --index 0 "No toolbox containers found. Create now? [y/N] A container can be created later with the 'create' command."
|
||||
+ assert_line --index 1 "Run 'toolbox --help' for usage."
|
||||
+}
|
||||
+
|
||||
+# TODO: Write the test
|
||||
+@test "root: Enter the default container when 1 non-default container is present" {
|
||||
+ skip "Testing of entering toolboxes is not implemented"
|
||||
+}
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,63 @@
|
||||
From 024cf19e52544814cdee80693a6dc12b5a92943c Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match RHEL's %{gobuild} for PPC64
|
||||
|
||||
The Go toolchain doesn't play well with passing compiler and linker
|
||||
flags via environment variables. The linker flags require a second
|
||||
level of quoting, which leaves the build system without a quote level
|
||||
to assign the flags to an environment variable like GOFLAGS.
|
||||
|
||||
This is one reason why RHEL doesn't have a RPM macro with only the
|
||||
flags. The %{gobuild} RPM macro includes the entire 'go build ...'
|
||||
invocation.
|
||||
|
||||
The Go toolchain also doesn't like the LDFLAGS environment variable as
|
||||
exported by RHEL's %{meson} RPM macro, and RHEL's RPM toolchain doesn't
|
||||
like the compressed DWARF data generated by the Go toolchain.
|
||||
|
||||
Note that these flags are only meant for the "ppc64" CPU architecture,
|
||||
and should be kept updated to match RHEL's Go guidelines. Use
|
||||
'rpm --eval "%{gobuild}"' to expand the %{gobuild} macro.
|
||||
---
|
||||
src/go-build-wrapper | 13 +++++++++----
|
||||
1 file changed, 9 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index ef4aafc8b024..00d7e9fca0e0 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -32,9 +32,9 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-tags=""
|
||||
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-}"
|
||||
if $6; then
|
||||
- tags="-tags migration_path_for_coreos_toolbox"
|
||||
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||
fi
|
||||
|
||||
if ! libc_dir=$("$4" --print-file-name=libc.so); then
|
||||
@@ -69,11 +69,16 @@ fi
|
||||
|
||||
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||
|
||||
+unset LDFLAGS
|
||||
+
|
||||
# shellcheck disable=SC2086
|
||||
go build \
|
||||
+ -compiler gc \
|
||||
$tags \
|
||||
- -trimpath \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -ldflags "${LDFLAGS:-} -compressdwarf=false -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -a \
|
||||
+ -v \
|
||||
+ -x \
|
||||
-o "$2/toolbox"
|
||||
|
||||
exit "$?"
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,64 @@
|
||||
From 89129bd096c8bfac4ff84fc19726898cc901c1fc Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match RHEL's %{gobuild}
|
||||
|
||||
The Go toolchain doesn't play well with passing compiler and linker
|
||||
flags via environment variables. The linker flags require a second
|
||||
level of quoting, which leaves the build system without a quote level
|
||||
to assign the flags to an environment variable like GOFLAGS.
|
||||
|
||||
This is one reason why RHEL doesn't have a RPM macro with only the
|
||||
flags. The %{gobuild} RPM macro includes the entire 'go build ...'
|
||||
invocation.
|
||||
|
||||
The Go toolchain also doesn't like the LDFLAGS environment variable as
|
||||
exported by RHEL's %{meson} RPM macro, and RHEL's RPM toolchain doesn't
|
||||
like the compressed DWARF data generated by the Go toolchain.
|
||||
|
||||
Note that these flags are meant for every CPU architecture other than
|
||||
PPC64, and should be kept updated to match RHEL's Go guidelines. Use
|
||||
'rpm --eval "%{gobuild}"' to expand the %{gobuild} macro.
|
||||
---
|
||||
src/go-build-wrapper | 14 ++++++++++----
|
||||
1 file changed, 10 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index ef4aafc8b024..e82e42ca8151 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -32,9 +32,9 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-tags=""
|
||||
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-}"
|
||||
if $6; then
|
||||
- tags="-tags migration_path_for_coreos_toolbox"
|
||||
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||
fi
|
||||
|
||||
if ! libc_dir=$("$4" --print-file-name=libc.so); then
|
||||
@@ -69,11 +69,17 @@ fi
|
||||
|
||||
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||
|
||||
+unset LDFLAGS
|
||||
+
|
||||
# shellcheck disable=SC2086
|
||||
go build \
|
||||
+ -buildmode pie \
|
||||
+ -compiler gc \
|
||||
$tags \
|
||||
- -trimpath \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -ldflags "${LDFLAGS:-} -compressdwarf=false -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -a \
|
||||
+ -v \
|
||||
+ -x \
|
||||
-o "$2/toolbox"
|
||||
|
||||
exit "$?"
|
||||
--
|
||||
2.31.1
|
||||
|
17
SOURCES/toolbox.conf
Normal file
17
SOURCES/toolbox.conf
Normal file
@ -0,0 +1,17 @@
|
||||
[general]
|
||||
# Create a toolbox container for a different operating system distro than the
|
||||
# host. Cannot be used with 'image'.
|
||||
## distro = "fedora"
|
||||
|
||||
# Create a toolbox container for a different operating system release than the
|
||||
# host. Cannot be used with 'image'.
|
||||
## release = "33"
|
||||
|
||||
# Change the name of the image used to create the toolbox container. This is
|
||||
# useful for creating containers from custom-built images. Cannot be used with
|
||||
# 'distro' or 'release'.
|
||||
#
|
||||
# If the name does not contain a registry, the local image storage will be
|
||||
# consulted, and if it's not present there then it will be pulled from a
|
||||
# suitable remote registry.
|
||||
image = "registry.access.redhat.com/ubi9/toolbox:latest"
|
336
SPECS/toolbox.spec
Normal file
336
SPECS/toolbox.spec
Normal file
@ -0,0 +1,336 @@
|
||||
%global __brp_check_rpaths %{nil}
|
||||
|
||||
# RHEL's RPM toolchain doesn't like the compressed DWARF data generated by the
|
||||
# Go toolchain.
|
||||
%global _dwz_low_mem_die_limit 0
|
||||
%global _find_debuginfo_dwz_opts %{nil}
|
||||
|
||||
Name: toolbox
|
||||
Version: 0.0.99.3
|
||||
|
||||
%global goipath github.com/containers/%{name}
|
||||
%gometa
|
||||
|
||||
Release: 3%{?dist}
|
||||
Summary: Tool for containerized command line environments on Linux
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://containertoolbx.org/
|
||||
|
||||
# https://github.com/containers/%%{name}/releases/download/%%{version}/%%{name}-%%{version}.tar.xz
|
||||
# A vendored tarball was created from the upstream tarball:
|
||||
# $ cd src
|
||||
# $ go mod vendor
|
||||
Source0: %{name}-%{version}-vendored.tar.xz
|
||||
Source1: %{name}.conf
|
||||
|
||||
# RHEL specific
|
||||
Patch100: toolbox-Make-the-build-flags-match-RHEL-s-gobuild.patch
|
||||
Patch101: toolbox-Make-the-build-flags-match-RHEL-s-gobuild-for-PPC64.patch
|
||||
Patch102: toolbox-Add-migration-paths-for-coreos-toolbox-users.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1905383
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
BuildRequires: golang >= 1.17.7
|
||||
BuildRequires: go-md2man
|
||||
BuildRequires: meson >= 0.58.0
|
||||
BuildRequires: pkgconfig(bash-completion)
|
||||
BuildRequires: systemd-rpm-macros
|
||||
|
||||
Requires: containers-common
|
||||
Requires: podman >= 1.4.0
|
||||
|
||||
|
||||
%description
|
||||
Toolbox is a tool for Linux operating systems, which allows the use of
|
||||
containerized command line environments. It is built on top of Podman and
|
||||
other standard container technologies from OCI.
|
||||
|
||||
|
||||
%package tests
|
||||
Summary: Tests for %{name}
|
||||
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: coreutils
|
||||
Requires: gawk
|
||||
Requires: grep
|
||||
Requires: skopeo
|
||||
|
||||
%description tests
|
||||
The %{name}-tests package contains system tests for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%ifnarch ppc64
|
||||
%patch100 -p1
|
||||
%else
|
||||
%patch101 -p1
|
||||
%endif
|
||||
|
||||
%patch102 -p1
|
||||
|
||||
# %%gomkdir is absent from RHEL 8.
|
||||
GOBUILDDIR="$(pwd)/_build"
|
||||
GOSOURCEDIR="$(pwd)"
|
||||
if [[ ! -e "$GOBUILDDIR/bin" ]] ; then
|
||||
install -m 0755 -vd "$GOBUILDDIR/bin"
|
||||
fi
|
||||
if [[ ! -e "$GOBUILDDIR/src/%{goipath}" ]] ; then
|
||||
install -m 0755 -vd "$(dirname $GOBUILDDIR/src/%{goipath})"
|
||||
ln -fs "$GOSOURCEDIR" "$GOBUILDDIR/src/%{goipath}"
|
||||
fi
|
||||
cd "$GOBUILDDIR/src/%{goipath}"
|
||||
|
||||
|
||||
%build
|
||||
export GO111MODULE=off
|
||||
GOBUILDDIR="$(pwd)/_build"
|
||||
export GOPATH="$GOBUILDDIR:%{gopath}"
|
||||
export CGO_CFLAGS="%{optflags} -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
|
||||
ln -s src/cmd cmd
|
||||
ln -s src/pkg pkg
|
||||
ln -s src/vendor vendor
|
||||
|
||||
%meson \
|
||||
--buildtype=plain \
|
||||
-Dmigration_path_for_coreos_toolbox=true \
|
||||
-Dprofile_dir=%{_sysconfdir}/profile.d \
|
||||
-Dtmpfiles_dir=%{_tmpfilesdir}
|
||||
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/containers/%{name}.conf
|
||||
|
||||
|
||||
%files
|
||||
%doc CODE-OF-CONDUCT.md NEWS README.md SECURITY.md
|
||||
%license COPYING
|
||||
%{_bindir}/%{name}
|
||||
%{_datadir}/bash-completion
|
||||
%{_mandir}/man1/%{name}.1*
|
||||
%{_mandir}/man1/%{name}-*.1*
|
||||
%config(noreplace) %{_sysconfdir}/containers/%{name}.conf
|
||||
%{_sysconfdir}/profile.d/%{name}.sh
|
||||
%{_tmpfilesdir}/%{name}.conf
|
||||
|
||||
%files tests
|
||||
%{_datadir}/%{name}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Apr 08 2022 Jindrich Novy <jnovy@redhat.com> - 0.0.99.3-3
|
||||
- bump golang BR to 1.17.7 to fix memleak when FIPS enabled
|
||||
- Related: #1975396
|
||||
|
||||
* Wed Mar 23 2022 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-2
|
||||
- Rebuild for FIPS-mode memory leak in the Go toolchain
|
||||
Resolves: #1975396
|
||||
|
||||
* Fri Dec 10 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-1
|
||||
- Update to 0.0.99.3
|
||||
- BuildRequire only systemd-rpm-macros as recommended by the Fedora packaging
|
||||
guidelines
|
||||
- Update the Summary to match upstream
|
||||
- Update the URL to point to the website
|
||||
Resolves: #2000807
|
||||
|
||||
* Wed Sep 22 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.14.git660b6970e998
|
||||
- Suggest a way forward if coreos/toolbox was used
|
||||
Resolves: #2006802
|
||||
|
||||
* Wed Sep 22 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.13.git660b6970e998
|
||||
- Switch to using the Toolbox-specific UBI image by default
|
||||
Resolves: #2004563
|
||||
|
||||
* Thu Sep 16 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.12.git660b6970e998
|
||||
- Changed image for tests and tests parameters to fix gating
|
||||
Related: #2000051
|
||||
|
||||
* Thu Sep 16 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.11.git660b6970e998
|
||||
- Changed image for tests and added /etc/containers dir check
|
||||
Related: #2000051
|
||||
|
||||
* Tue Sep 14 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.10.git660b6970e998
|
||||
- Added ability to force test system id and version id
|
||||
Related: #2000051
|
||||
|
||||
* Tue Sep 14 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.9.git660b6970e998
|
||||
- Fixed test roles and changed default image path
|
||||
Related: #2000051
|
||||
|
||||
* Tue Sep 14 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.8.git660b6970e998
|
||||
- Added default container image configuration for tests
|
||||
Related: #2000051
|
||||
|
||||
* Fri Sep 03 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.7.git660b6970e998
|
||||
- Added missing gating tests files and patch for tests
|
||||
Related: #2000051
|
||||
|
||||
* Fri Sep 03 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.3-0.6.git660b6970e998
|
||||
- re-add gating tests
|
||||
- Related: #2000051
|
||||
|
||||
* Fri Sep 03 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.3-0.5.git660b6970e998
|
||||
- Make sosreport work by setting the HOST environment variable
|
||||
- Related: #2000051
|
||||
|
||||
* Mon Aug 30 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.4.git660b6970e998
|
||||
- Fixed gating tests bats version
|
||||
Related: rhbz#1977343
|
||||
|
||||
* Tue Aug 24 2021 Oliver Gutiérrez <ogutierrez@redhat.com> - 0.0.99.3-0.3.git660b6970e998
|
||||
- Rebuilt for gating checks
|
||||
Related: rhbz#1977343
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 0.0.99.3-0.2.git660b6970e998
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Mon Aug 02 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.3-0.1.git660b6970e998
|
||||
- Fix the build on CentOS Stream
|
||||
Related: #1970747
|
||||
|
||||
* Wed Jul 28 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.2^1.git660b6970e998-1
|
||||
- Add support for configuration files
|
||||
- Related: #1970747
|
||||
|
||||
* Sat Jul 10 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.2-3
|
||||
- Expose the host's entire / in the container at /run/host
|
||||
- Resolves: #1977343
|
||||
|
||||
* Mon Jul 05 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.2-2
|
||||
- Actually apply the patch to make 'toolbox' create or fall back to a
|
||||
container if possible
|
||||
- Support logging into a registry if necessary
|
||||
- Resolves: #1977343
|
||||
|
||||
* Fri Jul 02 2021 Jindrich Novy <jnovy@redhat.com> - 0.0.99.2-1
|
||||
- update to 0.99.2
|
||||
- Resolves: #1977343
|
||||
|
||||
* Tue Jun 22 2021 Mohan Boddu <mboddu@redhat.com> - 0.0.99.1-4
|
||||
- Rebuilt for RHEL 9 BETA for openssl 3.0
|
||||
Related: rhbz#1971065
|
||||
|
||||
* Thu Apr 29 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.1-3
|
||||
- Fix FTBFS
|
||||
Resolves: #1912983
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.0.99.1-2
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Feb 23 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.1-1
|
||||
- Update to 0.0.99.1
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.99-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jan 12 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99-1
|
||||
- Update to 0.0.99
|
||||
|
||||
* Mon Jan 11 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.98.1-2
|
||||
- Harden the binary by using the same CGO_CFLAGS as on RHEL 8
|
||||
|
||||
* Thu Jan 07 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.98.1-1
|
||||
- Update to 0.0.98.1
|
||||
|
||||
* Tue Jan 05 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.0.98-1
|
||||
- Update to 0.0.98
|
||||
|
||||
* Wed Nov 25 2020 Ondřej Míchal <harrymichal@seznam.cz> - 0.0.97-2
|
||||
- Move krb5-libs from -support to -experience, and update the list of packages
|
||||
in -experience
|
||||
|
||||
* Tue Nov 03 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.97-1
|
||||
- Update to 0.0.97
|
||||
|
||||
* Thu Oct 01 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.96-1
|
||||
- Update to 0.0.96
|
||||
|
||||
* Sun Aug 30 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.95-1
|
||||
- Update to 0.0.95
|
||||
|
||||
* Mon Aug 24 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.94-1
|
||||
- Update to 0.0.94
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.93-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jul 25 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.93-1
|
||||
- Update to 0.0.93
|
||||
|
||||
* Fri Jul 03 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.92-1
|
||||
- Update to 0.0.92
|
||||
|
||||
* Fri Jul 03 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.91-2
|
||||
- Fix the 'toolbox --version' output
|
||||
|
||||
* Tue Jun 30 2020 Harry Míchal <harrymichal@seznam.cz> - 0.0.91-1
|
||||
- Update to 0.0.91
|
||||
|
||||
* Sat Jun 27 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.18-5
|
||||
- Remove ExclusiveArch to match Podman
|
||||
|
||||
* Wed Jun 10 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.18-4
|
||||
- Sync the "experience" packages with the current Dockerfile
|
||||
- Make "experience" Require "support"
|
||||
|
||||
* Fri Apr 03 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.18-3
|
||||
- Drop compatibility Obsoletes and Provides for fedora-toolbox
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.18-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Jan 14 2020 Debarshi Ray <rishi@fedoraproject.org> - 0.0.18-1
|
||||
- Update to 0.0.18
|
||||
|
||||
* Wed Nov 20 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.17-1
|
||||
- Update to 0.0.17
|
||||
|
||||
* Tue Oct 29 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.16-1
|
||||
- Update to 0.0.16
|
||||
|
||||
* Mon Sep 30 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.15-1
|
||||
- Update to 0.0.15
|
||||
|
||||
* Wed Sep 18 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.14-1
|
||||
- Update to 0.0.14
|
||||
|
||||
* Thu Sep 05 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.13-1
|
||||
- Update to 0.0.13
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Jul 22 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.12-1
|
||||
- Update to 0.0.12
|
||||
|
||||
* Tue Jun 25 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.11-2
|
||||
- Require flatpak-session-helper
|
||||
|
||||
* Fri Jun 21 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.11-1
|
||||
- Update to 0.0.11
|
||||
|
||||
* Tue May 21 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.10-1
|
||||
- Update to 0.0.10
|
||||
|
||||
* Tue Apr 30 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.9-1
|
||||
- Update to 0.0.9
|
||||
|
||||
* Tue Apr 16 2019 Adam Williamson <awilliam@redhat.com> - 0.0.8-2
|
||||
- Rebuild with Meson fix for #1699099
|
||||
|
||||
* Fri Apr 12 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.8-1
|
||||
- Update to 0.0.8
|
||||
|
||||
* Thu Mar 14 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.7-1
|
||||
- Update to 0.0.7
|
||||
|
||||
* Fri Feb 22 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.0.6-1
|
||||
- Initial build after rename from fedora-toolbox
|
Loading…
Reference in New Issue
Block a user