Remove unnecessary patches and update version of ECJ required by tomcat
This commit is contained in:
parent
f905e7e822
commit
c3a377befc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
apache-tomcat-*-src.tar.gz
|
||||
results_tomcat
|
||||
tomcat*.src.rpm
|
||||
apache-tomcat-*-src/
|
||||
|
@ -1,47 +0,0 @@
|
||||
--- build.xml.orig 2018-03-15 13:49:03.366863009 -0400
|
||||
+++ build.xml 2018-03-15 13:49:29.690870139 -0400
|
||||
@@ -1777,7 +1777,7 @@ Apache Tomcat ${version} native binaries
|
||||
additionalparam="-breakiterator -notimestamp"
|
||||
maxmemory="512m"
|
||||
failonerror="true"
|
||||
- failonwarning="true">
|
||||
+ failonwarning="false">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
<path refid="tomcat.webservices.classpath"/>
|
||||
@@ -1798,7 +1798,7 @@ Apache Tomcat ${version} native binaries
|
||||
additionalparam="-breakiterator -notimestamp"
|
||||
maxmemory="512m"
|
||||
failonerror="true"
|
||||
- failonwarning="true">
|
||||
+ failonwarning="false">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
<path refid="tomcat.webservices.classpath"/>
|
||||
@@ -1819,7 +1819,7 @@ Apache Tomcat ${version} native binaries
|
||||
additionalparam="-breakiterator -notimestamp"
|
||||
maxmemory="512m"
|
||||
failonerror="true"
|
||||
- failonwarning="true">
|
||||
+ failonwarning="false">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
<path refid="tomcat.webservices.classpath"/>
|
||||
@@ -1840,7 +1840,7 @@ Apache Tomcat ${version} native binaries
|
||||
additionalparam="-breakiterator -notimestamp"
|
||||
maxmemory="512m"
|
||||
failonerror="true"
|
||||
- failonwarning="true">
|
||||
+ failonwarning="false">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
<path refid="tomcat.webservices.classpath"/>
|
||||
@@ -1860,7 +1860,7 @@ Apache Tomcat ${version} native binaries
|
||||
additionalparam="-breakiterator -notimestamp ${java9.add.modules}"
|
||||
maxmemory="512m"
|
||||
failonerror="true"
|
||||
- failonwarning="true">
|
||||
+ failonwarning="false">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
<path refid="tomcat.webservices.classpath"/>
|
@ -1,36 +0,0 @@
|
||||
--- java/org/apache/jasper/compiler/JDTCompiler.java.orig 2018-07-31 17:05:49.639378409 -0400
|
||||
+++ java/org/apache/jasper/compiler/JDTCompiler.java 2018-07-31 17:06:36.947209122 -0400
|
||||
@@ -313,14 +313,6 @@ public class JDTCompiler extends org.apa
|
||||
} else if(opt.equals("1.8")) {
|
||||
settings.put(CompilerOptions.OPTION_Source,
|
||||
CompilerOptions.VERSION_1_8);
|
||||
- // Version format changed from Java 9 onwards.
|
||||
- // Support old format that was used in EA implementation as well
|
||||
- } else if(opt.equals("9") || opt.equals("1.9")) {
|
||||
- settings.put(CompilerOptions.OPTION_Source,
|
||||
- CompilerOptions.VERSION_9);
|
||||
- } else if(opt.equals("10")) {
|
||||
- settings.put(CompilerOptions.OPTION_Source,
|
||||
- CompilerOptions.VERSION_10);
|
||||
} else {
|
||||
log.warn("Unknown source VM " + opt + " ignored.");
|
||||
settings.put(CompilerOptions.OPTION_Source,
|
||||
@@ -367,18 +359,6 @@ public class JDTCompiler extends org.apa
|
||||
CompilerOptions.VERSION_1_8);
|
||||
settings.put(CompilerOptions.OPTION_Compliance,
|
||||
CompilerOptions.VERSION_1_8);
|
||||
- // Version format changed from Java 9 onwards.
|
||||
- // Support old format that was used in EA implementation as well
|
||||
- } else if(opt.equals("9") || opt.equals("1.9")) {
|
||||
- settings.put(CompilerOptions.OPTION_TargetPlatform,
|
||||
- CompilerOptions.VERSION_9);
|
||||
- settings.put(CompilerOptions.OPTION_Compliance,
|
||||
- CompilerOptions.VERSION_9);
|
||||
- } else if(opt.equals("10")) {
|
||||
- settings.put(CompilerOptions.OPTION_TargetPlatform,
|
||||
- CompilerOptions.VERSION_10);
|
||||
- settings.put(CompilerOptions.OPTION_Compliance,
|
||||
- CompilerOptions.VERSION_10);
|
||||
} else {
|
||||
log.warn("Unknown target VM " + opt + " ignored.");
|
||||
settings.put(CompilerOptions.OPTION_TargetPlatform,
|
10
tomcat.spec
10
tomcat.spec
@ -80,14 +80,12 @@ Source32: tomcat-named.service
|
||||
|
||||
Patch0: %{name}-%{major_version}.%{minor_version}-bootstrap-MANIFEST.MF.patch
|
||||
Patch1: %{name}-%{major_version}.%{minor_version}-tomcat-users-webapp.patch
|
||||
Patch2: %{name}-9.0.10-RemoveCompilerOptions.patch
|
||||
Patch3: disableJavadocFailOnWarning.patch
|
||||
Patch4: %{name}-build.patch
|
||||
Patch2: %{name}-build.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: ant
|
||||
BuildRequires: ecj >= 1:4.6.1
|
||||
BuildRequires: ecj >= 1:4.10
|
||||
BuildRequires: findutils
|
||||
BuildRequires: apache-commons-daemon
|
||||
BuildRequires: tomcat-taglibs-standard
|
||||
@ -166,7 +164,7 @@ Summary: Libraries needed to run the Tomcat Web container
|
||||
Requires: %{name}-jsp-%{jspspec}-api = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-servlet-%{servletspec}-api = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-el-%{elspec}-api = %{epoch}:%{version}-%{release}
|
||||
Requires: ecj >= 1:4.6.1
|
||||
Requires: ecj >= 1:4.10
|
||||
Requires(preun): coreutils
|
||||
|
||||
%description lib
|
||||
@ -207,8 +205,6 @@ find . -type f \( -name "*.bat" -o -name "*.class" -o -name Thumbs.db -o -name "
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch3 -p0
|
||||
%patch4 -p0
|
||||
|
||||
%{__ln_s} $(build-classpath tomcat-taglibs-standard/taglibs-standard-impl) webapps/examples/WEB-INF/lib/jstl.jar
|
||||
%{__ln_s} $(build-classpath tomcat-taglibs-standard/taglibs-standard-compat) webapps/examples/WEB-INF/lib/standard.jar
|
||||
|
Loading…
Reference in New Issue
Block a user