Drop JSVC support as it's not very useful these days
This commit is contained in:
parent
972b590988
commit
c363ab5b50
@ -1,22 +0,0 @@
|
|||||||
# Systemd unit file for tomcat
|
|
||||||
#
|
|
||||||
# To create clones of this service:
|
|
||||||
# 1) By default SERVICE_NAME=tomcat. When cloned, the value must be defined
|
|
||||||
# before tomcat-sysd is called.
|
|
||||||
# 2) Create /etc/sysconfig/${SERVICE_NAME} from /etc/sysconfig/tomcat
|
|
||||||
# to override tomcat defaults
|
|
||||||
|
|
||||||
[Unit]
|
|
||||||
Description=Apache Tomcat Web Application Container JSVC wrapper
|
|
||||||
After=syslog.target network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Type=simple
|
|
||||||
EnvironmentFile=/etc/tomcat/tomcat.conf
|
|
||||||
Environment="NAME=" "USE_JSVC=true"
|
|
||||||
EnvironmentFile=-/etc/sysconfig/tomcat
|
|
||||||
ExecStart=/usr/libexec/tomcat/server start
|
|
||||||
ExecStop=/usr/libexec/tomcat/server stop
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
@ -1,8 +0,0 @@
|
|||||||
@@@TCLOG@@@/catalina.out {
|
|
||||||
copytruncate
|
|
||||||
weekly
|
|
||||||
rotate 52
|
|
||||||
compress
|
|
||||||
missingok
|
|
||||||
create 0644 tomcat tomcat
|
|
||||||
}
|
|
29
tomcat.spec
29
tomcat.spec
@ -65,11 +65,9 @@ Source0: http://www.apache.org/dist/tomcat/tomcat-%{major_version}/v%{vers
|
|||||||
Source1: %{name}-%{major_version}.%{minor_version}.conf
|
Source1: %{name}-%{major_version}.%{minor_version}.conf
|
||||||
Source3: %{name}-%{major_version}.%{minor_version}.sysconfig
|
Source3: %{name}-%{major_version}.%{minor_version}.sysconfig
|
||||||
Source4: %{name}-%{major_version}.%{minor_version}.wrapper
|
Source4: %{name}-%{major_version}.%{minor_version}.wrapper
|
||||||
Source5: %{name}-%{major_version}.%{minor_version}.logrotate
|
|
||||||
Source6: %{name}-%{major_version}.%{minor_version}-digest.script
|
Source6: %{name}-%{major_version}.%{minor_version}-digest.script
|
||||||
Source7: %{name}-%{major_version}.%{minor_version}-tool-wrapper.script
|
Source7: %{name}-%{major_version}.%{minor_version}-tool-wrapper.script
|
||||||
Source11: %{name}-%{major_version}.%{minor_version}.service
|
Source11: %{name}-%{major_version}.%{minor_version}.service
|
||||||
Source20: %{name}-%{major_version}.%{minor_version}-jsvc.service
|
|
||||||
Source21: tomcat-functions
|
Source21: tomcat-functions
|
||||||
Source30: tomcat-preamble
|
Source30: tomcat-preamble
|
||||||
Source31: tomcat-server
|
Source31: tomcat-server
|
||||||
@ -86,7 +84,6 @@ BuildArch: noarch
|
|||||||
BuildRequires: ant
|
BuildRequires: ant
|
||||||
BuildRequires: ecj >= 1:4.10
|
BuildRequires: ecj >= 1:4.10
|
||||||
BuildRequires: findutils
|
BuildRequires: findutils
|
||||||
BuildRequires: apache-commons-daemon
|
|
||||||
BuildRequires: java-devel >= 1:1.8.0
|
BuildRequires: java-devel >= 1:1.8.0
|
||||||
BuildRequires: javapackages-local
|
BuildRequires: javapackages-local
|
||||||
BuildRequires: geronimo-jaxrpc
|
BuildRequires: geronimo-jaxrpc
|
||||||
@ -96,7 +93,6 @@ BuildRequires: aqute-bndlib
|
|||||||
BuildRequires: wsdl4j
|
BuildRequires: wsdl4j
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
|
|
||||||
Requires: apache-commons-daemon
|
|
||||||
Requires: java-headless >= 1:1.8.0
|
Requires: java-headless >= 1:1.8.0
|
||||||
Requires: javapackages-tools
|
Requires: javapackages-tools
|
||||||
Requires: procps
|
Requires: procps
|
||||||
@ -136,16 +132,6 @@ Requires: %{name} = %{epoch}:%{version}-%{release}
|
|||||||
%description docs-webapp
|
%description docs-webapp
|
||||||
The docs web application for Apache Tomcat.
|
The docs web application for Apache Tomcat.
|
||||||
|
|
||||||
%package jsvc
|
|
||||||
Summary: Apache jsvc wrapper for Apache Tomcat as separate service
|
|
||||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
|
||||||
Requires: apache-commons-daemon-jsvc
|
|
||||||
|
|
||||||
%description jsvc
|
|
||||||
Systemd service to start tomcat with jsvc,
|
|
||||||
which allows tomcat to perform some privileged operations
|
|
||||||
(e.g. bind to a port < 1024) and then switch identity to a non-privileged user.
|
|
||||||
|
|
||||||
%package jsp-%{jspspec}-api
|
%package jsp-%{jspspec}-api
|
||||||
Summary: Apache Tomcat JavaServer Pages v%{jspspec} API Implementation Classes
|
Summary: Apache Tomcat JavaServer Pages v%{jspspec} API Implementation Classes
|
||||||
Provides: jsp = %{jspspec}
|
Provides: jsp = %{jspspec}
|
||||||
@ -215,7 +201,7 @@ export OPT_JAR_LIST="xalan-j2-serializer"
|
|||||||
# who needs a build.properties file anyway
|
# who needs a build.properties file anyway
|
||||||
%{ant} -Dbase.path="." \
|
%{ant} -Dbase.path="." \
|
||||||
-Dbuild.compiler="modern" \
|
-Dbuild.compiler="modern" \
|
||||||
-Dcommons-daemon.jar="$(build-classpath apache-commons-daemon)" \
|
-Dcommons-daemon.jar="HACK" \
|
||||||
-Dcommons-daemon.native.src.tgz="HACK" \
|
-Dcommons-daemon.native.src.tgz="HACK" \
|
||||||
-Djdt.jar="$(build-classpath ecj/ecj)" \
|
-Djdt.jar="$(build-classpath ecj/ecj)" \
|
||||||
-Dtomcat-native.tar.gz="HACK" \
|
-Dtomcat-native.tar.gz="HACK" \
|
||||||
@ -247,7 +233,6 @@ export OPT_JAR_LIST="xalan-j2-serializer"
|
|||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_bindir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_bindir}
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_sbindir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_sbindir}
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_systemddir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_systemddir}
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d
|
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{appdir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{appdir}
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{bindir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{bindir}
|
||||||
@ -257,7 +242,6 @@ export OPT_JAR_LIST="xalan-j2-serializer"
|
|||||||
/bin/echo "Place your custom *.conf files here. Shell expansion is supported." > ${RPM_BUILD_ROOT}%{confdir}/conf.d/README
|
/bin/echo "Place your custom *.conf files here. Shell expansion is supported." > ${RPM_BUILD_ROOT}%{confdir}/conf.d/README
|
||||||
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{libdir}
|
%{__install} -d -m 0755 ${RPM_BUILD_ROOT}%{libdir}
|
||||||
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{logdir}
|
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{logdir}
|
||||||
/bin/touch ${RPM_BUILD_ROOT}%{logdir}/catalina.out
|
|
||||||
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{_localstatedir}/lib/tomcats
|
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{_localstatedir}/lib/tomcats
|
||||||
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{homedir}
|
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{homedir}
|
||||||
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{tempdir}
|
%{__install} -d -m 0775 ${RPM_BUILD_ROOT}%{tempdir}
|
||||||
@ -286,10 +270,6 @@ popd
|
|||||||
${RPM_BUILD_ROOT}%{_sbindir}/%{name}
|
${RPM_BUILD_ROOT}%{_sbindir}/%{name}
|
||||||
%{__install} -m 0644 %{SOURCE11} \
|
%{__install} -m 0644 %{SOURCE11} \
|
||||||
${RPM_BUILD_ROOT}%{_unitdir}/%{name}.service
|
${RPM_BUILD_ROOT}%{_unitdir}/%{name}.service
|
||||||
%{__install} -m 0644 %{SOURCE20} \
|
|
||||||
${RPM_BUILD_ROOT}%{_unitdir}/%{name}-jsvc.service
|
|
||||||
%{__sed} -e "s|\@\@\@TCLOG\@\@\@|%{logdir}|g" %{SOURCE5} \
|
|
||||||
> ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/%{name}
|
|
||||||
%{__sed} -e "s|\@\@\@TCHOME\@\@\@|%{homedir}|g" \
|
%{__sed} -e "s|\@\@\@TCHOME\@\@\@|%{homedir}|g" \
|
||||||
-e "s|\@\@\@TCTEMP\@\@\@|%{tempdir}|g" \
|
-e "s|\@\@\@TCTEMP\@\@\@|%{tempdir}|g" \
|
||||||
-e "s|\@\@\@LIBDIR\@\@\@|%{_libdir}|g" %{SOURCE6} \
|
-e "s|\@\@\@LIBDIR\@\@\@|%{_libdir}|g" %{SOURCE6} \
|
||||||
@ -486,17 +466,12 @@ fi
|
|||||||
%defattr(0644,tomcat,tomcat,0755)
|
%defattr(0644,tomcat,tomcat,0755)
|
||||||
%{appdir}/ROOT
|
%{appdir}/ROOT
|
||||||
|
|
||||||
%files jsvc
|
|
||||||
%defattr(755,root,root,0755)
|
|
||||||
%attr(0644,root,root) %{_unitdir}/%{name}-jsvc.service
|
|
||||||
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
|
||||||
%attr(0660,tomcat,tomcat) %verify(not size md5 mtime) %{logdir}/catalina.out
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Jun 03 2021 Coty Sutherland <csutherl@redhat.com> 1:9.0.45-2
|
* Thu Jun 03 2021 Coty Sutherland <csutherl@redhat.com> 1:9.0.45-2
|
||||||
- Remove examples webapps from subpackage
|
- Remove examples webapps from subpackage
|
||||||
- Updates to javapackages-local removed %%add_maven_depmap which broke the build,
|
- Updates to javapackages-local removed %%add_maven_depmap which broke the build,
|
||||||
so I removed the maven artifacts as they aren't very useful anyway
|
so I removed the maven artifacts as they aren't very useful anyway
|
||||||
|
- Drop JSVC support as it's not very useful these days
|
||||||
|
|
||||||
* Thu Apr 22 2021 Hui Wang <huwang@redhat.com> - 1:9.0.45-1
|
* Thu Apr 22 2021 Hui Wang <huwang@redhat.com> - 1:9.0.45-1
|
||||||
- Update to 9.0.45
|
- Update to 9.0.45
|
||||||
|
Loading…
Reference in New Issue
Block a user