Update tomcat to 9.0.68
This commit is contained in:
parent
83e980a86f
commit
8e4906e924
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (apache-tomcat-9.0.65-src.tar.gz) = 3ff344370cc36f5bed389ed198054783a4f5bc86476a751cda280618457a06bae38c1e764b0c110c2f68efe2d34243a4e24596e8b90e8fbd171bf584a22fd3bc
|
SHA512 (apache-tomcat-9.0.68-src.tar.gz) = 63bb2c42f683c4c5e362b19bda046de172382714e80298106c61cc728feea9681b568450f04cb95d6cae08e5a71933c7755b9b81b706c46d63f4683c2a3a96be
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- conf/catalina.policy.orig 2021-07-07 10:25:53.461393329 +0800
|
--- conf/catalina.policy.orig 2022-11-04 16:17:41.227506990 +0800
|
||||||
+++ conf/catalina.policy 2021-07-07 10:27:47.688682404 +0800
|
+++ conf/catalina.policy 2022-11-04 16:21:51.393351415 +0800
|
||||||
@@ -56,6 +56,16 @@ grant codeBase "file:${java.home}/lib/ex
|
@@ -56,6 +56,15 @@ grant codeBase "file:${java.home}/lib/ex
|
||||||
// permission java.security.AllPermission;
|
// permission java.security.AllPermission;
|
||||||
//};
|
//};
|
||||||
|
|
||||||
@ -13,11 +13,10 @@
|
|||||||
+grant codeBase "file:/usr/share/java/ecj/ecj.jar" {
|
+grant codeBase "file:/usr/share/java/ecj/ecj.jar" {
|
||||||
+ permission java.security.AllPermission;
|
+ permission java.security.AllPermission;
|
||||||
+};
|
+};
|
||||||
+
|
|
||||||
|
|
||||||
// ========== CATALINA CODE PERMISSIONS =======================================
|
// ========== CATALINA CODE PERMISSIONS =======================================
|
||||||
|
|
||||||
@@ -261,4 +271,4 @@ grant codeBase "file:${catalina.home}/we
|
@@ -261,4 +270,4 @@ grant codeBase "file:${catalina.home}/we
|
||||||
//
|
//
|
||||||
// The permissions granted to a specific JAR
|
// The permissions granted to a specific JAR
|
||||||
// grant codeBase "war:file:${catalina.base}/webapps/examples.war*/WEB-INF/lib/foo.jar" {
|
// grant codeBase "war:file:${catalina.base}/webapps/examples.war*/WEB-INF/lib/foo.jar" {
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- build.properties.default.orig 2022-06-21 20:30:04.498997718 +0800
|
--- build.properties.default.orig 2022-06-21 20:30:04.498997718 +0800
|
||||||
+++ build.properties.default 2022-06-21 20:30:57.579522800 +0800
|
+++ build.properties.default 2022-06-21 20:30:57.579522800 +0800
|
||||||
@@ -308,6 +308,16 @@ bnd.home=${base.path}/bnd-${bnd.version}
|
@@ -309,6 +309,16 @@ bnd.home=${base.path}/bnd-${bnd.version}
|
||||||
bnd.jar=${bnd.home}/biz.aQute.bnd-${bnd.version}.jar
|
bnd.jar=${bnd.home}/biz.aQute.bnd-${bnd.version}.jar
|
||||||
bnd.loc=${base-maven.loc}/biz/aQute/bnd/biz.aQute.bnd/${bnd.version}/biz.aQute.bnd-${bnd.version}.jar
|
bnd.loc=${base-maven.loc}/biz/aQute/bnd/biz.aQute.bnd/${bnd.version}/biz.aQute.bnd-${bnd.version}.jar
|
||||||
|
|
||||||
@ -15,7 +15,7 @@
|
|||||||
+osgi-annotations.loc=${base-maven.loc}/org/osgi/org.osgi.annotation.bundle/${osgi-annotations.version}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
+osgi-annotations.loc=${base-maven.loc}/org/osgi/org.osgi.annotation.bundle/${osgi-annotations.version}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
||||||
+
|
+
|
||||||
# ----- JSign, version 4.1 or later -----
|
# ----- JSign, version 4.1 or later -----
|
||||||
jsign.version=4.1
|
jsign.version=4.2
|
||||||
|
|
||||||
--- build.xml.orig 2022-06-21 20:36:12.785560093 +0800
|
--- build.xml.orig 2022-06-21 20:36:12.785560093 +0800
|
||||||
+++ build.xml 2022-06-21 20:40:41.155154959 +0800
|
+++ build.xml 2022-06-21 20:40:41.155154959 +0800
|
||||||
|
17
tomcat.spec
17
tomcat.spec
@ -31,7 +31,7 @@
|
|||||||
%global jspspec 2.3
|
%global jspspec 2.3
|
||||||
%global major_version 9
|
%global major_version 9
|
||||||
%global minor_version 0
|
%global minor_version 0
|
||||||
%global micro_version 65
|
%global micro_version 68
|
||||||
%global packdname apache-tomcat-%{version}-src
|
%global packdname apache-tomcat-%{version}-src
|
||||||
%global servletspec 4.0
|
%global servletspec 4.0
|
||||||
%global elspec 3.0
|
%global elspec 3.0
|
||||||
@ -56,7 +56,7 @@
|
|||||||
Name: tomcat
|
Name: tomcat
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: %{major_version}.%{minor_version}.%{micro_version}
|
Version: %{major_version}.%{minor_version}.%{micro_version}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -92,6 +92,8 @@ BuildRequires: findutils
|
|||||||
BuildRequires: java-devel >= 1:1.8.0
|
BuildRequires: java-devel >= 1:1.8.0
|
||||||
BuildRequires: javapackages-local
|
BuildRequires: javapackages-local
|
||||||
BuildRequires: aqute-bnd
|
BuildRequires: aqute-bnd
|
||||||
|
BuildRequires: aqute-bndlib
|
||||||
|
BuildRequires: wsdl4j
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
|
|
||||||
Requires: java-headless >= 1:1.8.0
|
Requires: java-headless >= 1:1.8.0
|
||||||
@ -222,9 +224,14 @@ touch HACK
|
|||||||
-Dcommons-daemon.native.win.mgr.exe="HACK" \
|
-Dcommons-daemon.native.win.mgr.exe="HACK" \
|
||||||
-Dnsis.exe="HACK" \
|
-Dnsis.exe="HACK" \
|
||||||
-Djaxrpc-lib.jar="HACK" \
|
-Djaxrpc-lib.jar="HACK" \
|
||||||
-Dwsdl4j-lib.jar="HACK" \
|
-Dwsdl4j-lib.jar="$(build-classpath wsdl4j)" \
|
||||||
-Dbnd.jar="$(build-classpath aqute-bnd/biz.aQute.bnd)" \
|
-Dbnd.jar="$(build-classpath aqute-bnd/biz.aQute.bnd)" \
|
||||||
|
-Dbndlib.jar="$(build-classpath aqute-bnd/biz.aQute.bndlib)" \
|
||||||
|
-Dbndlibg.jar="$(build-classpath aqute-bnd/aQute.libg)" \
|
||||||
|
-Dbndannotation.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
||||||
-Dosgi-annotations.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
-Dosgi-annotations.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
||||||
|
-Dslf4j-api.jar="$(build-classpath slf4j/slf4j-api)" \
|
||||||
|
-Dosgi-cmpn.jar="$(build-classpath osgi-compendium/osgi.cmpn)" \
|
||||||
-Dversion="%{version}" \
|
-Dversion="%{version}" \
|
||||||
-Dversion.build="%{micro_version}" \
|
-Dversion.build="%{micro_version}" \
|
||||||
deploy
|
deploy
|
||||||
@ -496,8 +503,8 @@ fi
|
|||||||
%{appdir}/ROOT
|
%{appdir}/ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Sep 01 2022 Coty Sutherland <csutherl@redhat.com> - 1:9.0.65-2
|
* Thu Nov 03 2033 Hui Wang <huwang@redhat.com> - 1:9.0.68-1
|
||||||
- Cleaning up some unused deps and system properties
|
- Update to 9.0.68
|
||||||
|
|
||||||
* Thu Jul 21 2022 Hui Wang <huwang@redhat.com> - 1:9.0.65-1
|
* Thu Jul 21 2022 Hui Wang <huwang@redhat.com> - 1:9.0.65-1
|
||||||
- Update to 9.0.65
|
- Update to 9.0.65
|
||||||
|
Loading…
Reference in New Issue
Block a user