Update for 9.0.64
This commit is contained in:
parent
d3f20202a3
commit
57ef513427
@ -1,7 +1,7 @@
|
||||
diff -up ./build.xml.orig ./build.xml
|
||||
--- build.xml.orig 2021-07-07 10:53:55.493742841 +0800
|
||||
+++ build.xml 2021-07-07 11:09:43.107968515 +0800
|
||||
@@ -1030,7 +1030,7 @@
|
||||
@@ -1020,7 +1020,7 @@
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.annotations-api"
|
||||
manifest="${tomcat.manifests}/annotations-api.jar.manifest"
|
||||
@ -10,7 +10,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
|
||||
<!-- Servlet Implementation JAR File -->
|
||||
<jarIt jarfile="${servlet-api.jar}"
|
||||
@@ -1039,41 +1039,41 @@
|
||||
@@ -1029,41 +1029,41 @@
|
||||
manifest="${tomcat.manifests}/servlet-api.jar.manifest"
|
||||
notice="${tomcat.manifests}/servlet-api.jar.notice"
|
||||
license="${tomcat.manifests}/servlet-api.jar.license"
|
||||
@ -58,7 +58,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
|
||||
<!-- Bootstrap JAR File -->
|
||||
<jarIt jarfile="${bootstrap.jar}"
|
||||
@@ -1085,61 +1085,61 @@
|
||||
@@ -1075,61 +1075,61 @@
|
||||
<jarIt jarfile="${tomcat-util.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.tomcat-util"
|
||||
@ -130,7 +130,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
|
||||
<!-- Catalina Ant Tasks JAR File -->
|
||||
<jarIt jarfile="${catalina-ant.jar}"
|
||||
@@ -1150,27 +1150,27 @@
|
||||
@@ -1140,27 +1140,27 @@
|
||||
<jarIt jarfile="${catalina-storeconfig.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.catalina-storeconfig"
|
||||
@ -162,7 +162,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
|
||||
<!-- i18n JARs -->
|
||||
<jar jarfile="${tomcat.build}/lib/tomcat-i18n-cs.jar"
|
||||
@@ -1644,7 +1644,7 @@
|
||||
@@ -1620,7 +1620,7 @@
|
||||
filesId="files.tomcat-embed-core"
|
||||
notice="${tomcat.manifests}/servlet-api.jar.notice"
|
||||
license="${tomcat.manifests}/servlet-api.jar.license"
|
||||
@ -171,7 +171,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
addGraal="true"
|
||||
graalPrefix="org.apache.tomcat.embed/tomcat-embed-core"
|
||||
graalFiles="res/graal/tomcat-embed-core/native-image"
|
||||
@@ -1652,7 +1652,7 @@
|
||||
@@ -1628,7 +1628,7 @@
|
||||
<jarIt jarfile="${tomcat-embed-el.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.tomcat-embed-el"
|
||||
@ -180,7 +180,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
addGraal="true"
|
||||
graalPrefix="org.apache.tomcat.embed/tomcat-embed-el"
|
||||
graalFiles="res/graal/tomcat-embed-el/native-image"
|
||||
@@ -1661,7 +1661,7 @@
|
||||
@@ -1637,7 +1637,7 @@
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.tomcat-embed-jasper"
|
||||
meta-inf="${tomcat.manifests}/jasper.jar"
|
||||
@ -189,7 +189,7 @@ diff -up ./build.xml.orig ./build.xml
|
||||
addGraal="true"
|
||||
graalPrefix="org.apache.tomcat.embed/tomcat-embed-jasper"
|
||||
graalFiles="res/graal/tomcat-embed-jasper/native-image"
|
||||
@@ -1670,7 +1670,7 @@
|
||||
@@ -1646,7 +1646,7 @@
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.tomcat-embed-websocket"
|
||||
meta-inf="${tomcat.manifests}/tomcat-websocket.jar"
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apache-tomcat-9.0.59-src.tar.gz) = cea0125ca9b90b247ed114fa7b2e9c63da38b1ef97b3a373a43ed0d775764178534a4014b254219c8c5a26575eaf0ddc25ebc1e276b2ad5086ef3406627f1c80
|
||||
SHA512 (apache-tomcat-9.0.64-src.tar.gz) = 7e01a979d41f7d73204b7a7ae5a85b0094626bf64bcfa3a52f1fc46989369d504b6dd49718084ee0a10af775cab488aae1e18ce05eb2b527800e2a693c7b6386
|
||||
|
@ -17,7 +17,7 @@
|
||||
|
||||
// ========== CATALINA CODE PERMISSIONS =======================================
|
||||
|
||||
@@ -262,4 +272,4 @@ grant codeBase "file:${catalina.home}/we
|
||||
@@ -261,4 +271,4 @@ grant codeBase "file:${catalina.home}/we
|
||||
//
|
||||
// The permissions granted to a specific JAR
|
||||
// grant codeBase "war:file:${catalina.base}/webapps/examples.war*/WEB-INF/lib/foo.jar" {
|
||||
|
66
tomcat-9.0-osgi-annotations.patch
Normal file
66
tomcat-9.0-osgi-annotations.patch
Normal file
@ -0,0 +1,66 @@
|
||||
--- build.properties.default.orig 2022-06-21 20:30:04.498997718 +0800
|
||||
+++ build.properties.default 2022-06-21 20:30:57.579522800 +0800
|
||||
@@ -308,6 +308,16 @@ bnd.home=${base.path}/bnd-${bnd.version}
|
||||
bnd.jar=${bnd.home}/biz.aQute.bnd-${bnd.version}.jar
|
||||
bnd.loc=${base-maven.loc}/biz/aQute/bnd/biz.aQute.bnd/${bnd.version}/biz.aQute.bnd-${bnd.version}.jar
|
||||
|
||||
+# ----- OSGi annotations bundle, version 1.0.0 or later -----
|
||||
+# ----- required to avoid Javadoc error when using bnd annotations -----
|
||||
+osgi-annotations.version=1.1.1
|
||||
+osgi-annotations.checksum.enabled=true
|
||||
+osgi-annotations.checksum.algorithm=MD5|SHA-1
|
||||
+osgi-annotations.checksum.value=04e5db48a469cb53dd0e4e954deab2e0|a1644f3dbbb614f2a44671d27dd13c4d9142007d
|
||||
+osgi-annotations.home=${base.path}/osgi-annotations-${osgi-annotations.version}
|
||||
+osgi-annotations.jar=${osgi-annotations.home}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
||||
+osgi-annotations.loc=${base-maven.loc}/org/osgi/org.osgi.annotation.bundle/${osgi-annotations.version}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
||||
+
|
||||
# ----- JSign, version 4.1 or later -----
|
||||
jsign.version=4.1
|
||||
|
||||
--- build.xml.orig 2022-06-21 20:36:12.785560093 +0800
|
||||
+++ build.xml 2022-06-21 20:40:41.155154959 +0800
|
||||
@@ -213,6 +213,7 @@
|
||||
<!-- Classpaths -->
|
||||
<path id="compile.classpath">
|
||||
<pathelement location="${bnd.jar}"/>
|
||||
+ <pathelement location="${osgi-annotations.jar}"/>
|
||||
<pathelement location="${jdt.jar}"/>
|
||||
<pathelement location="${jaxrpc-lib.jar}"/>
|
||||
<pathelement location="${wsdl4j-lib.jar}"/>
|
||||
@@ -2270,7 +2271,8 @@ Apache Tomcat ${version} native binaries
|
||||
failonwarning="true">
|
||||
<classpath>
|
||||
<path refid="compile.classpath"/>
|
||||
- <path location="${ant.core.lib}"/>
|
||||
+ <path location="${ant.core.lib}"/>
|
||||
+ <path location="${osgi-annotations.jar}"/>
|
||||
</classpath>
|
||||
<link href="../annotationapi"/>
|
||||
<link href="../servletapi"/>
|
||||
@@ -3671,12 +3673,26 @@ Read the Building page on the Apache Tom
|
||||
<param name="checksum.algorithm" value="${bnd.checksum.algorithm}"/>
|
||||
<param name="checksum.value" value="${bnd.checksum.value}"/>
|
||||
</antcall>
|
||||
+ <!-- Download OSGi annotations -->
|
||||
+ <antcall target="downloadfile">
|
||||
+ <param name="sourcefile" value="${osgi-annotations.loc}"/>
|
||||
+ <param name="destfile" value="${osgi-annotations.jar}"/>
|
||||
+ <param name="destdir" value="${osgi-annotations.home}"/>
|
||||
+ <param name="checksum.enabled" value="${osgi-annotations.checksum.enabled}"/>
|
||||
+ <param name="checksum.algorithm" value="${osgi-annotations.checksum.algorithm}"/>
|
||||
+ <param name="checksum.value" value="${osgi-annotations.checksum.value}"/>
|
||||
+ </antcall>
|
||||
</target>
|
||||
|
||||
<target name="setup-bnd" depends="download-bnd">
|
||||
<!-- Add bnd tasks to project -->
|
||||
<path id="bnd.classpath">
|
||||
<fileset file="${bnd.jar}" />
|
||||
+ <fileset file="${bndlib.jar}" />
|
||||
+ <fileset file="${bndlibg.jar}" />
|
||||
+ <fileset file="${bndannotation.jar}" />
|
||||
+ <fileset file="${slf4j-api.jar}" />
|
||||
+ <fileset file="${osgi-cmpn.jar}" />
|
||||
</path>
|
||||
|
||||
<taskdef resource="aQute/bnd/ant/taskdef.properties" classpathref="bnd.classpath" />
|
@ -1,6 +1,6 @@
|
||||
--- conf/tomcat-users.xml~ 2008-01-28 17:41:06.000000000 -0500
|
||||
+++ conf/tomcat-users.xml 2008-03-07 19:40:07.000000000 -0500
|
||||
@@ -23,4 +23,14 @@
|
||||
@@ -53,4 +53,14 @@
|
||||
<user username="both" password="<must-be-changed>" roles="tomcat,role1"/>
|
||||
<user username="role1" password="<must-be-changed>" roles="role1"/>
|
||||
-->
|
||||
|
@ -1,18 +1,3 @@
|
||||
diff -up ./build.xml.orig ./build.xml
|
||||
--- ./build.xml.orig 2020-07-13 12:59:09.555368724 -0400
|
||||
+++ ./build.xml 2020-07-13 13:06:51.246135917 -0400
|
||||
@@ -3307,6 +3307,11 @@ Read the Building page on the Apache Tom
|
||||
<!-- Add bnd tasks to project -->
|
||||
<path id="bnd.classpath">
|
||||
<fileset file="${bnd.jar}" />
|
||||
+ <fileset file="${bndlib.jar}" />
|
||||
+ <fileset file="${bndlibg.jar}" />
|
||||
+ <fileset file="${bndannotation.jar}" />
|
||||
+ <fileset file="${slf4j-api.jar}" />
|
||||
+ <fileset file="${osgi-cmpn.jar}" />
|
||||
</path>
|
||||
|
||||
<taskdef resource="aQute/bnd/ant/taskdef.properties" classpathref="bnd.classpath" />
|
||||
diff -up ./res/bnd/build-defaults.bnd.orig ./res/bnd/build-defaults.bnd
|
||||
--- ./res/bnd/build-defaults.bnd.orig 2020-07-13 13:47:01.229077747 -0400
|
||||
+++ ./res/bnd/build-defaults.bnd 2020-07-13 13:47:12.923095618 -0400
|
||||
|
10
tomcat.spec
10
tomcat.spec
@ -31,7 +31,7 @@
|
||||
%global jspspec 2.3
|
||||
%global major_version 9
|
||||
%global minor_version 0
|
||||
%global micro_version 59
|
||||
%global micro_version 64
|
||||
%global packdname apache-tomcat-%{version}-src
|
||||
%global servletspec 4.0
|
||||
%global elspec 3.0
|
||||
@ -56,7 +56,7 @@
|
||||
Name: tomcat
|
||||
Epoch: 1
|
||||
Version: %{major_version}.%{minor_version}.%{micro_version}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
||||
|
||||
License: ASL 2.0
|
||||
@ -81,6 +81,7 @@ Patch2: %{name}-build.patch
|
||||
Patch3: %{name}-%{major_version}.%{minor_version}-catalina-policy.patch
|
||||
Patch4: rhbz-1857043.patch
|
||||
Patch5: %{name}-%{major_version}.%{minor_version}-JDTCompiler.patch
|
||||
Patch6: %{name}-%{major_version}.%{minor_version}-osgi-annotations.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -191,6 +192,7 @@ find . -type f \( -name "*.bat" -o -name "*.class" -o -name Thumbs.db -o -name "
|
||||
%patch3 -p0
|
||||
%patch4 -p0
|
||||
%patch5 -p0
|
||||
%patch6 -p0
|
||||
|
||||
# Remove webservices naming resources as it's generally unused
|
||||
%{__rm} -rf java/org/apache/naming/factory/webservices
|
||||
@ -500,6 +502,10 @@ fi
|
||||
%{appdir}/ROOT
|
||||
|
||||
%changelog
|
||||
* Tue Jun 21 2022 Hui Wang <huwang@redhat.com> - 1:9.0.64-1
|
||||
- Update to 9.0.64
|
||||
- Add osgi-annotations dependency back
|
||||
|
||||
* Thu Mar 10 2022 Coty Sutherland <csutherl@redhat.com> - 1:9.0.59-3
|
||||
- Related: rhbz#2061424 Adjust fix so that it uses the proper env var
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user