Related: rhbz#2160511 Add conflicts declaration to the appropriate subpackages
Also, temporarily fix a malformed DTD so that rpminspect will pass
This commit is contained in:
parent
b8a32f4b4b
commit
39f054938e
8
fix-malformed-dtd.patch
Normal file
8
fix-malformed-dtd.patch
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
diff -up ./java/org/apache/tomcat/util/modeler/mbeans-descriptors.dtd.orig ./java/org/apache/tomcat/util/modeler/mbeans-descriptors.dtd
|
||||||
|
--- ./java/org/apache/tomcat/util/modeler/mbeans-descriptors.dtd.orig 2023-02-07 14:11:25.294179017 -0500
|
||||||
|
+++ ./java/org/apache/tomcat/util/modeler/mbeans-descriptors.dtd 2023-02-07 14:11:28.629196705 -0500
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
<!--
|
||||||
|
Licensed to the Apache Software Foundation (ASF) under one or more
|
||||||
|
contributor license agreements. See the NOTICE file distributed with
|
15
tomcat.spec
15
tomcat.spec
@ -56,7 +56,7 @@
|
|||||||
Name: tomcat
|
Name: tomcat
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: %{major_version}.%{minor_version}.%{micro_version}
|
Version: %{major_version}.%{minor_version}.%{micro_version}
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -84,6 +84,7 @@ Patch5: %{name}-%{major_version}.%{minor_version}-JDTCompiler.patch
|
|||||||
Patch6: %{name}-%{major_version}.%{minor_version}-bnd-annotation.patch
|
Patch6: %{name}-%{major_version}.%{minor_version}-bnd-annotation.patch
|
||||||
# The fixes for memory leak which have been fixed in 9.0.64, remove this patch in the next tomcat update
|
# The fixes for memory leak which have been fixed in 9.0.64, remove this patch in the next tomcat update
|
||||||
Patch7: %{name}-%{major_version}.%{minor_version}-memory-leak.patch
|
Patch7: %{name}-%{major_version}.%{minor_version}-memory-leak.patch
|
||||||
|
Patch8: fix-malformed-dtd.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -107,8 +108,7 @@ Requires(post): systemd
|
|||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
|
|
||||||
# we will change it to an obsoletes whenever the pki team is able to make the switch
|
# We will change it to an obsoletes whenever the pki team is able to make the switch
|
||||||
Conflicts: pki-servlet-4.0-api <= 1:9.0.50
|
|
||||||
Conflicts: pki-servlet-engine <= 1:9.0.50
|
Conflicts: pki-servlet-engine <= 1:9.0.50
|
||||||
|
|
||||||
# added after log4j sub-package was removed
|
# added after log4j sub-package was removed
|
||||||
@ -144,6 +144,7 @@ Provides: jsp = %{jspspec}
|
|||||||
Obsoletes: %{name}-jsp-2.2-api
|
Obsoletes: %{name}-jsp-2.2-api
|
||||||
Requires: %{name}-servlet-%{servletspec}-api = %{epoch}:%{version}-%{release}
|
Requires: %{name}-servlet-%{servletspec}-api = %{epoch}:%{version}-%{release}
|
||||||
Requires: %{name}-el-%{elspec}-api = %{epoch}:%{version}-%{release}
|
Requires: %{name}-el-%{elspec}-api = %{epoch}:%{version}-%{release}
|
||||||
|
Conflicts: pki-servlet-engine <= 1:9.0.50
|
||||||
|
|
||||||
%description jsp-%{jspspec}-api
|
%description jsp-%{jspspec}-api
|
||||||
Apache Tomcat JSP API Implementation Classes.
|
Apache Tomcat JSP API Implementation Classes.
|
||||||
@ -155,6 +156,7 @@ Requires: %{name}-servlet-%{servletspec}-api = %{epoch}:%{version}-%{release}
|
|||||||
Requires: %{name}-el-%{elspec}-api = %{epoch}:%{version}-%{release}
|
Requires: %{name}-el-%{elspec}-api = %{epoch}:%{version}-%{release}
|
||||||
Requires: ecj >= 1:4.10
|
Requires: ecj >= 1:4.10
|
||||||
Requires(preun): coreutils
|
Requires(preun): coreutils
|
||||||
|
Conflicts: pki-servlet-engine <= 1:9.0.50
|
||||||
|
|
||||||
%description lib
|
%description lib
|
||||||
Libraries needed to run the Tomcat Web container.
|
Libraries needed to run the Tomcat Web container.
|
||||||
@ -165,6 +167,7 @@ Provides: servlet = %{servletspec}
|
|||||||
Provides: servlet6
|
Provides: servlet6
|
||||||
Provides: servlet3
|
Provides: servlet3
|
||||||
Obsoletes: %{name}-servlet-3.1-api
|
Obsoletes: %{name}-servlet-3.1-api
|
||||||
|
Conflicts: pki-servlet-4.0-api <= 1:9.0.50
|
||||||
|
|
||||||
%description servlet-%{servletspec}-api
|
%description servlet-%{servletspec}-api
|
||||||
Apache Tomcat Servlet API Implementation Classes.
|
Apache Tomcat Servlet API Implementation Classes.
|
||||||
@ -173,6 +176,7 @@ Apache Tomcat Servlet API Implementation Classes.
|
|||||||
Summary: Apache Tomcat Expression Language v%{elspec} API Implementation Classes
|
Summary: Apache Tomcat Expression Language v%{elspec} API Implementation Classes
|
||||||
Provides: el_api = %{elspec}
|
Provides: el_api = %{elspec}
|
||||||
Obsoletes: %{name}-el-2.2-api
|
Obsoletes: %{name}-el-2.2-api
|
||||||
|
Conflicts: pki-servlet-engine <= 1:9.0.50
|
||||||
|
|
||||||
%description el-%{elspec}-api
|
%description el-%{elspec}-api
|
||||||
Apache Tomcat EL API Implementation Classes.
|
Apache Tomcat EL API Implementation Classes.
|
||||||
@ -198,6 +202,7 @@ find . -type f \( -name "*.bat" -o -name "*.class" -o -name Thumbs.db -o -name "
|
|||||||
%patch5 -p0
|
%patch5 -p0
|
||||||
%patch6 -p0
|
%patch6 -p0
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
|
%patch8 -p1
|
||||||
|
|
||||||
# Remove webservices naming resources as it's generally unused
|
# Remove webservices naming resources as it's generally unused
|
||||||
%{__rm} -rf java/org/apache/naming/factory/webservices
|
%{__rm} -rf java/org/apache/naming/factory/webservices
|
||||||
@ -503,6 +508,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 07 2023 Coty Sutherland <csutherl@redhat.com> - 1:9.0.62-3
|
||||||
|
- Add conflicts declaration to the appropriate subpackages
|
||||||
|
- Fix malformed DTD file that caused problems with rpminspect
|
||||||
|
|
||||||
* Fri Feb 03 2023 Hui Wang <huwang@redhat.com> - 1:9.0.62-2
|
* Fri Feb 03 2023 Hui Wang <huwang@redhat.com> - 1:9.0.62-2
|
||||||
- Add conflicts with the pki-servlet-engine package
|
- Add conflicts with the pki-servlet-engine package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user