Update to 9.0.71
Remove osgi-annotations patch Add bnd annotation dependency which is in bndlib package
This commit is contained in:
parent
3d349e6aea
commit
06d3a31415
10
tomcat-9.0-bnd-annotation.patch
Normal file
10
tomcat-9.0-bnd-annotation.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- build.xml.orig 2023-01-29 17:38:29.477052402 +0800
|
||||||
|
+++ build.xml 2023-01-29 17:42:03.369583841 +0800
|
||||||
|
@@ -216,6 +216,7 @@
|
||||||
|
<!-- Classpaths -->
|
||||||
|
<path id="compile.classpath">
|
||||||
|
<pathelement location="${bnd.jar}"/>
|
||||||
|
+ <pathelement location="${bnd-annotation.jar}"/>
|
||||||
|
<pathelement location="${jdt.jar}"/>
|
||||||
|
<pathelement location="${jaxrpc-lib.jar}"/>
|
||||||
|
<pathelement location="${wsdl4j-lib.jar}"/>
|
@ -1,66 +0,0 @@
|
|||||||
--- build.properties.default.orig 2022-06-21 20:30:04.498997718 +0800
|
|
||||||
+++ build.properties.default 2022-06-21 20:30:57.579522800 +0800
|
|
||||||
@@ -309,6 +309,16 @@ bnd.home=${base.path}/bnd-${bnd.version}
|
|
||||||
bnd.jar=${bnd.home}/biz.aQute.bnd-${bnd.version}.jar
|
|
||||||
bnd.loc=${base-maven.loc}/biz/aQute/bnd/biz.aQute.bnd/${bnd.version}/biz.aQute.bnd-${bnd.version}.jar
|
|
||||||
|
|
||||||
+# ----- OSGi annotations bundle, version 1.0.0 or later -----
|
|
||||||
+# ----- required to avoid Javadoc error when using bnd annotations -----
|
|
||||||
+osgi-annotations.version=1.1.1
|
|
||||||
+osgi-annotations.checksum.enabled=true
|
|
||||||
+osgi-annotations.checksum.algorithm=MD5|SHA-1
|
|
||||||
+osgi-annotations.checksum.value=04e5db48a469cb53dd0e4e954deab2e0|a1644f3dbbb614f2a44671d27dd13c4d9142007d
|
|
||||||
+osgi-annotations.home=${base.path}/osgi-annotations-${osgi-annotations.version}
|
|
||||||
+osgi-annotations.jar=${osgi-annotations.home}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
|
||||||
+osgi-annotations.loc=${base-maven.loc}/org/osgi/org.osgi.annotation.bundle/${osgi-annotations.version}/org.osgi.annotation.bundle-${osgi-annotations.version}.jar
|
|
||||||
+
|
|
||||||
# ----- JSign, version 4.1 or later -----
|
|
||||||
jsign.version=4.2
|
|
||||||
|
|
||||||
--- build.xml.orig 2022-06-21 20:36:12.785560093 +0800
|
|
||||||
+++ build.xml 2022-06-21 20:40:41.155154959 +0800
|
|
||||||
@@ -213,6 +213,7 @@
|
|
||||||
<!-- Classpaths -->
|
|
||||||
<path id="compile.classpath">
|
|
||||||
<pathelement location="${bnd.jar}"/>
|
|
||||||
+ <pathelement location="${osgi-annotations.jar}"/>
|
|
||||||
<pathelement location="${jdt.jar}"/>
|
|
||||||
<pathelement location="${jaxrpc-lib.jar}"/>
|
|
||||||
<pathelement location="${wsdl4j-lib.jar}"/>
|
|
||||||
@@ -2270,7 +2271,8 @@ Apache Tomcat ${version} native binaries
|
|
||||||
failonwarning="true">
|
|
||||||
<classpath>
|
|
||||||
<path refid="compile.classpath"/>
|
|
||||||
- <path location="${ant.core.lib}"/>
|
|
||||||
+ <path location="${ant.core.lib}"/>
|
|
||||||
+ <path location="${osgi-annotations.jar}"/>
|
|
||||||
</classpath>
|
|
||||||
<link href="../annotationapi"/>
|
|
||||||
<link href="../servletapi"/>
|
|
||||||
@@ -3671,12 +3673,26 @@ Read the Building page on the Apache Tom
|
|
||||||
<param name="checksum.algorithm" value="${bnd.checksum.algorithm}"/>
|
|
||||||
<param name="checksum.value" value="${bnd.checksum.value}"/>
|
|
||||||
</antcall>
|
|
||||||
+ <!-- Download OSGi annotations -->
|
|
||||||
+ <antcall target="downloadfile">
|
|
||||||
+ <param name="sourcefile" value="${osgi-annotations.loc}"/>
|
|
||||||
+ <param name="destfile" value="${osgi-annotations.jar}"/>
|
|
||||||
+ <param name="destdir" value="${osgi-annotations.home}"/>
|
|
||||||
+ <param name="checksum.enabled" value="${osgi-annotations.checksum.enabled}"/>
|
|
||||||
+ <param name="checksum.algorithm" value="${osgi-annotations.checksum.algorithm}"/>
|
|
||||||
+ <param name="checksum.value" value="${osgi-annotations.checksum.value}"/>
|
|
||||||
+ </antcall>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<target name="setup-bnd" depends="download-bnd">
|
|
||||||
<!-- Add bnd tasks to project -->
|
|
||||||
<path id="bnd.classpath">
|
|
||||||
<fileset file="${bnd.jar}" />
|
|
||||||
+ <fileset file="${bndlib.jar}" />
|
|
||||||
+ <fileset file="${bndlibg.jar}" />
|
|
||||||
+ <fileset file="${bndannotation.jar}" />
|
|
||||||
+ <fileset file="${slf4j-api.jar}" />
|
|
||||||
+ <fileset file="${osgi-cmpn.jar}" />
|
|
||||||
</path>
|
|
||||||
|
|
||||||
<taskdef resource="aQute/bnd/ant/taskdef.properties" classpathref="bnd.classpath" />
|
|
22
tomcat.spec
22
tomcat.spec
@ -31,7 +31,7 @@
|
|||||||
%global jspspec 2.3
|
%global jspspec 2.3
|
||||||
%global major_version 9
|
%global major_version 9
|
||||||
%global minor_version 0
|
%global minor_version 0
|
||||||
%global micro_version 70
|
%global micro_version 71
|
||||||
%global packdname apache-tomcat-%{version}-src
|
%global packdname apache-tomcat-%{version}-src
|
||||||
%global servletspec 4.0
|
%global servletspec 4.0
|
||||||
%global elspec 3.0
|
%global elspec 3.0
|
||||||
@ -56,7 +56,7 @@
|
|||||||
Name: tomcat
|
Name: tomcat
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: %{major_version}.%{minor_version}.%{micro_version}
|
Version: %{major_version}.%{minor_version}.%{micro_version}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
Summary: Apache Servlet/JSP Engine, RI for Servlet %{servletspec}/JSP %{jspspec} API
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -81,7 +81,7 @@ Patch2: %{name}-build.patch
|
|||||||
Patch3: %{name}-%{major_version}.%{minor_version}-catalina-policy.patch
|
Patch3: %{name}-%{major_version}.%{minor_version}-catalina-policy.patch
|
||||||
Patch4: rhbz-1857043.patch
|
Patch4: rhbz-1857043.patch
|
||||||
Patch5: %{name}-%{major_version}.%{minor_version}-JDTCompiler.patch
|
Patch5: %{name}-%{major_version}.%{minor_version}-JDTCompiler.patch
|
||||||
Patch6: %{name}-%{major_version}.%{minor_version}-osgi-annotations.patch
|
Patch6: %{name}-%{major_version}.%{minor_version}-bnd-annotation.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
ExclusiveArch: %{java_arches} noarch
|
ExclusiveArch: %{java_arches} noarch
|
||||||
@ -93,12 +93,10 @@ BuildRequires: java-devel >= 1:1.8.0
|
|||||||
BuildRequires: javapackages-local
|
BuildRequires: javapackages-local
|
||||||
BuildRequires: aqute-bnd
|
BuildRequires: aqute-bnd
|
||||||
BuildRequires: aqute-bndlib
|
BuildRequires: aqute-bndlib
|
||||||
BuildRequires: wsdl4j
|
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
|
|
||||||
Requires: java-headless >= 1:1.8.0
|
Requires: java-headless >= 1:1.8.0
|
||||||
Requires: javapackages-tools
|
Requires: javapackages-tools
|
||||||
Requires: procps
|
|
||||||
Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
Recommends: tomcat-native >= %{native_version}
|
Recommends: tomcat-native >= %{native_version}
|
||||||
@ -224,14 +222,9 @@ touch HACK
|
|||||||
-Dcommons-daemon.native.win.mgr.exe="HACK" \
|
-Dcommons-daemon.native.win.mgr.exe="HACK" \
|
||||||
-Dnsis.exe="HACK" \
|
-Dnsis.exe="HACK" \
|
||||||
-Djaxrpc-lib.jar="HACK" \
|
-Djaxrpc-lib.jar="HACK" \
|
||||||
-Dwsdl4j-lib.jar="$(build-classpath wsdl4j)" \
|
-Dwsdl4j-lib.jar="HACK" \
|
||||||
-Dbnd.jar="$(build-classpath aqute-bnd/biz.aQute.bnd)" \
|
-Dbnd.jar="$(build-classpath aqute-bnd/biz.aQute.bnd)" \
|
||||||
-Dbndlib.jar="$(build-classpath aqute-bnd/biz.aQute.bndlib)" \
|
-Dbnd-annotation.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
||||||
-Dbndlibg.jar="$(build-classpath aqute-bnd/aQute.libg)" \
|
|
||||||
-Dbndannotation.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
|
||||||
-Dosgi-annotations.jar="$(build-classpath aqute-bnd/biz.aQute.bnd.annotation)" \
|
|
||||||
-Dslf4j-api.jar="$(build-classpath slf4j/slf4j-api)" \
|
|
||||||
-Dosgi-cmpn.jar="$(build-classpath osgi-compendium/osgi.cmpn)" \
|
|
||||||
-Dversion="%{version}" \
|
-Dversion="%{version}" \
|
||||||
-Dversion.build="%{micro_version}" \
|
-Dversion.build="%{micro_version}" \
|
||||||
deploy
|
deploy
|
||||||
@ -503,6 +496,11 @@ fi
|
|||||||
%{appdir}/ROOT
|
%{appdir}/ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 29 2023 Hui Wang <huwang@redhat.com> - 1:9.0.71-1
|
||||||
|
- Update to 9.0.71
|
||||||
|
- Remove osgi-annotations patch
|
||||||
|
- Add bnd-annotation dependency which is in bndlib package
|
||||||
|
|
||||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:9.0.70-2
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:9.0.70-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user