Initial import

This commit is contained in:
Deji Akingunola 2007-11-29 22:34:36 +00:00
parent b9bf1733fa
commit b0921106f7
4 changed files with 140 additions and 0 deletions

View File

@ -0,0 +1 @@
tokyocabinet-1.0.8.tar.gz

View File

@ -0,0 +1 @@
2cd12881e0858deb11a9748c142263d7 tokyocabinet-1.0.8.tar.gz

62
tokyocabinet-fedora.patch Normal file
View File

@ -0,0 +1,62 @@
--- configure.in 2007-11-26 22:05:32.000000000 -0500
+++ configure.in.new 2007-11-28 09:55:52.000000000 -0500
@@ -25,25 +25,13 @@
MYPCFILES="tokyocabinet.pc"
# Building flags
-MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2"
-MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -L$HOME/include -L/usr/local/include -DNDEBUG -D_GNU_SOURCE=1"
-MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
+MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char $CFLAGS"
+MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -DNDEBUG -D_GNU_SOURCE=1"
+MYLDFLAGS="-L. -L\$(LIBDIR)"
MYRUNPATH="\$(LIBDIR)"
MYLDLIBPATHENV="LD_LIBRARY_PATH"
MYPOSTCMD="true"
-# Building paths
-pathtmp="$PATH"
-PATH="$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
-PATH="$PATH:/usr/ccs/bin:/usr/ucb:/usr/xpg4/bin:/usr/xpg6/bin:$pathtmp"
-LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
-CPATH="$HOME/include:/usr/local/include:$CPATH"
-PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
-export PATH LIBRARY_PATH LD_LIBRARY_PATH CPATH PKG_CONFIG_PATH
-
-
-
#================================================================
# Options
#================================================================
@@ -96,7 +84,7 @@
AC_HELP_STRING([--enable-fastest], [build for fastest run]))
if test "$enable_fastest" = "yes"
then
- MYCFLAGS="-std=c99 -Wall -fPIC -pedantic -fsigned-char -O3"
+ MYCFLAGS="-std=c99 -Wall -fPIC -pedantic -fsigned-char $CFLAGS -O3"
MYCFLAGS="$MYCFLAGS -fomit-frame-pointer -fforce-addr -minline-all-stringops"
MYCPPFLAGS="$MYCPPFLAGS -D_MYFASTEST"
enables="$enables (fastest)"
--- Makefile.in 2007-11-26 06:36:37.000000000 -0500
+++ Makefile.in.new 2007-11-28 09:52:22.000000000 -0500
@@ -51,8 +51,8 @@
CFLAGS = @MYCFLAGS@
LDFLAGS = @MYLDFLAGS@
LIBS = @LIBS@
-LDENV = LD_RUN_PATH=/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
-RUNENV = @MYLDLIBPATHENV@=.:/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
+LDENV =
+RUNENV = @MYLDLIBPATHENV@=.:$(LIBDIR)
POSTCMD = @MYPOSTCMD@
--- tokyocabinet.pc.in 2007-11-04 20:05:50.000000000 -0500
+++ tokyocabinet.pc.in.new 2007-11-28 09:49:01.000000000 -0500
@@ -9,5 +9,5 @@
Name: Tokyo Cabinet
Description: a modern implementation of DBM
Version: @PACKAGE_VERSION@
-Libs: -L${libdir} -ltokyocabinet @LIBS@
+Libs: -L${libdir} -ltokyocabinet
Cflags: -I${includedir}

76
tokyocabinet.spec Normal file
View File

@ -0,0 +1,76 @@
Summary: A modern implementation of a DBM
Name: tokyocabinet
Version: 1.0.8
Release: 1%{?dist}
License: LGPLv2+
Group: Development/Libraries
URL: http://tokyocabinet.sourceforge.net/
Source: http://tokyocabinet.sourceforge.net/%{name}-%{version}.tar.gz
Patch0: tokyocabinet-fedora.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: pkgconfig zlib-devel autoconf
%description
Tokyo Cabinet is a library of routines for managing a database. It is the
successor of QDBM. Tokyo Cabinet runs very fast. For example, the time required
to store 1 million records is 1.5 seconds for a hash database and 2.2 seconds
for a B+ tree database. Moreover, the database size is very small and can be up
to 8EB. Furthermore, the scalability of Tokyo Cabinet is great.
%package devel
Summary: Headers for developing programs that will use %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
%description devel
This package contains the libraries and header files needed for
developing with %{name}.
%prep
%setup -q
%patch0 -p0 -b .fedora
%build
autoconf
%configure CFLAGS="$CFLAGS"
make %{?_smp_mflags}
%install
rm -rf %{buildroot}
make DESTDIR=%{buildroot} install
rm -rf %{buildroot}%{_datadir}/%{name}
rm -rf %{buildroot}%{_libdir}/lib%{name}.a
%check
make check
%clean
rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-, root, root, -)
%doc ChangeLog COPYING README
%{_bindir}/tc*
%{_libdir}/libtokyocabinet.so.*
%{_mandir}/man1/tc*.gz
%files devel
%defattr(-, root, root, -)
%{_includedir}/tc*.h
%{_libdir}/*.so
%{_libdir}/pkgconfig/%{name}.pc
%{_mandir}/man3/t*.gz
%doc doc/*
%changelog
* Sat Nov 24 2007 Deji Akingunola <dakingun@gmail.com> - 1.0.8-1
- Update to 1.0.8
* Sat Nov 24 2007 Deji Akingunola <dakingun@gmail.com> - 1.0.6-1
- Initial package