135 lines
3.8 KiB
Diff
135 lines
3.8 KiB
Diff
--- pegasus/src/Pegasus/Compiler/cmdline/cimmof/Makefile.PIE 2006-01-30 11:17:34.000000000 -0500
|
|
+++ pegasus/src/Pegasus/Compiler/cmdline/cimmof/Makefile 2006-04-06 16:17:54.000000000 -0400
|
|
@@ -32,6 +32,8 @@
|
|
DIR = Pegasus/Compiler/cmdline/cimmof
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LOCAL_DEFINES = -DPEGASUS_CMDLINE_INTERNAL -DPEGASUS_INTERNALONLY
|
|
|
|
LIBRARIES = \
|
|
--- pegasus/src/Pegasus/Compiler/cmdline/cimmofl/Makefile.PIE 2006-01-30 11:17:34.000000000 -0500
|
|
+++ pegasus/src/Pegasus/Compiler/cmdline/cimmofl/Makefile 2006-04-06 16:17:43.000000000 -0400
|
|
@@ -32,6 +32,8 @@
|
|
DIR = Pegasus/Compiler/cmdline/cimmofl
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LOCAL_DEFINES = -DPEGASUS_INTERNALONLY
|
|
|
|
PROGRAM = cimmofl
|
|
--- pegasus/src/Pegasus/ProviderManager2/ProviderAgent/Makefile.PIE 2006-01-30 11:18:16.000000000 -0500
|
|
+++ pegasus/src/Pegasus/ProviderManager2/ProviderAgent/Makefile 2006-04-05 21:05:58.000000000 -0400
|
|
@@ -29,11 +29,12 @@
|
|
#//
|
|
#//==============================================================================
|
|
ROOT = ../../../..
|
|
-
|
|
DIR = Pegasus/ProviderManager2/ProviderAgent
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegprovidermanager \
|
|
pegprovider \
|
|
@@ -56,4 +57,3 @@
|
|
tests:
|
|
|
|
poststarttests:
|
|
-
|
|
--- pegasus/src/Server/Makefile.PIE 2006-01-30 11:19:33.000000000 -0500
|
|
+++ pegasus/src/Server/Makefile 2006-04-05 21:05:58.000000000 -0400
|
|
@@ -30,8 +30,11 @@
|
|
#//==============================================================================
|
|
ROOT = ../..
|
|
DIR = Server
|
|
+
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegclient \
|
|
pegserver \
|
|
--- pegasus/src/Clients/cimprovider/Makefile.PIE 2006-01-30 11:16:33.000000000 -0500
|
|
+++ pegasus/src/Clients/cimprovider/Makefile 2006-04-06 16:17:31.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegcliutils \
|
|
pegclient \
|
|
--- pegasus/src/Clients/osinfo/Makefile.PIE 2006-01-30 11:16:35.000000000 -0500
|
|
+++ pegasus/src/Clients/osinfo/Makefile 2006-04-06 16:17:14.000000000 -0400
|
|
@@ -35,6 +35,8 @@
|
|
DIR = Clients/osinfo
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegcliutils \
|
|
peggetoopt \
|
|
--- pegasus/src/Clients/cimuser/Makefile.PIE 2006-01-30 11:16:33.000000000 -0500
|
|
+++ pegasus/src/Clients/cimuser/Makefile 2006-04-06 16:17:01.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegcliutils \
|
|
pegclient \
|
|
--- pegasus/src/Clients/repupgrade/Makefile.PIE 2006-01-30 11:16:36.000000000 -0500
|
|
+++ pegasus/src/Clients/repupgrade/Makefile 2006-04-06 16:16:37.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LOCAL_DEFINES = -DPEGASUS_INTERNALONLY
|
|
|
|
LIBRARIES = \
|
|
--- pegasus/src/Clients/cimauth/Makefile.PIE 2006-01-30 11:16:32.000000000 -0500
|
|
+++ pegasus/src/Clients/cimauth/Makefile 2006-04-06 16:16:17.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegcliutils \
|
|
pegclient \
|
|
--- pegasus/src/Clients/cimconfig/Makefile.PIE 2006-01-30 11:16:32.000000000 -0500
|
|
+++ pegasus/src/Clients/cimconfig/Makefile 2006-04-06 16:15:59.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
LIBRARIES = \
|
|
pegcliutils \
|
|
pegclient \
|
|
--- pegasus/src/Clients/wbemexec/Makefile.PIE 2006-01-30 11:16:37.000000000 -0500
|
|
+++ pegasus/src/Clients/wbemexec/Makefile 2006-04-06 16:15:23.000000000 -0400
|
|
@@ -36,6 +36,8 @@
|
|
|
|
include $(ROOT)/mak/config.mak
|
|
|
|
+FLAGS := $(FLAGS:-fPIC=-fPIE)
|
|
+
|
|
ifdef PEGASUS_HAS_SSL
|
|
FLAGS += -DPEGASUS_HAS_SSL -DPEGASUS_SSL_RANDOMFILE
|
|
SYS_INCLUDES += -I$(OPENSSL_HOME)/include
|