Fix setupSDK in -devel, Use Experimental DMTF CIM schema version 2.38.0
This commit is contained in:
parent
1e74bb3433
commit
f00a90f47b
67
pegasus-2.14.1-fix-setup-sdk.patch
Normal file
67
pegasus-2.14.1-fix-setup-sdk.patch
Normal file
@ -0,0 +1,67 @@
|
||||
diff -up pegasus/src/SDK/samples/Providers/Load/Makefile.orig pegasus/src/SDK/samples/Providers/Load/Makefile
|
||||
--- pegasus/src/SDK/samples/Providers/Load/Makefile.orig 2012-05-14 11:12:20.000000000 +0200
|
||||
+++ pegasus/src/SDK/samples/Providers/Load/Makefile 2015-05-26 13:47:11.475608966 +0200
|
||||
@@ -37,7 +37,7 @@ else
|
||||
ifeq ($(PEGASUS_INTEROP_NAMESPACE),interop)
|
||||
INTEROPNS=interop
|
||||
else
|
||||
-INTEROPNS=root/PG_InterOp
|
||||
+INTEROPNS=root/interop
|
||||
endif
|
||||
endif
|
||||
|
||||
@@ -48,20 +48,20 @@ createCXXrepository:
|
||||
@$(ECHO) "+++++ Creating $(SAMPLECXXPROVIDERNS) namespace ..."
|
||||
@$(ECHO) "+++++ Loading SDK_CIM_Schema.mof into" \
|
||||
"$(SAMPLECXXPROVIDERNS) namespace ..."
|
||||
- @$(PEGASUS_BIN_DIR)/cimmof -I$(PEGASUS_CIM_SCHEMA_DIR) \
|
||||
+ @$(PEGASUS_BIN_DIR)/cimmof "-aE" -I$(PEGASUS_CIM_SCHEMA_DIR) \
|
||||
-n$(SAMPLECXXPROVIDERNS) SDK_CIM_Schema.mof
|
||||
@ $(ECHO) "+++++ Loading class definitions into " \
|
||||
"$(SAMPLECXXPROVIDERNS) namespace ..."
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(SAMPLECXXPROVIDERNS) \
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(SAMPLECXXPROVIDERNS) \
|
||||
SampleProviderSchema.mof
|
||||
|
||||
createCMPIrepository:
|
||||
@$(ECHO) "+++++ Creating $(SAMPLECMPIPROVIDERNS) namespace ..."
|
||||
@$(ECHO) "+++++ Loading SDK_CIM_Schema.mof into" \
|
||||
"$(SAMPLECMPIPROVIDERNS) namespace ..."
|
||||
- @$(PEGASUS_BIN_DIR)/cimmof -I$(PEGASUS_CIM_SCHEMA_DIR) \
|
||||
+ @$(PEGASUS_BIN_DIR)/cimmof "-aE" -I$(PEGASUS_CIM_SCHEMA_DIR) \
|
||||
-n$(SAMPLECMPIPROVIDERNS) SDK_CIM_Schema.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(SAMPLECMPIPROVIDERNS) CWS_FilesAndDir.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(SAMPLECMPIPROVIDERNS) CWS_FilesAndDir.mof
|
||||
|
||||
createrepository: createCXXrepository createCMPIrepository
|
||||
@$(ECHO) "+++++ Repository created."
|
||||
@@ -69,12 +69,12 @@ createrepository: createCXXrepository cr
|
||||
registerproviders:
|
||||
@ $(ECHO) "+++++ Registering providers for" \
|
||||
"$(SAMPLECXXPROVIDERNS) namespace ..."
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) InstanceProviderR.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) MethodProviderR.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) IndicationProviderR.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) SimpleDisplayConsumerR.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) CWS_FilesAndDirR.mof
|
||||
- @ $(PEGASUS_BIN_DIR)/cimmof -n$(INTEROPNS) AssociationProviderR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) InstanceProviderR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) MethodProviderR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) IndicationProviderR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) SimpleDisplayConsumerR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) CWS_FilesAndDirR.mof
|
||||
+ @ $(PEGASUS_BIN_DIR)/cimmof "-aE" -n$(INTEROPNS) AssociationProviderR.mof
|
||||
|
||||
deregisterproviders:
|
||||
@ $(ECHO) "+++++ Deregistering SDKInstanceProviderModule ..."
|
||||
diff -up pegasus/src/SDK/samples/Providers/Load/SDK_CIM_Schema.mof.orig pegasus/src/SDK/samples/Providers/Load/SDK_CIM_Schema.mof
|
||||
--- pegasus/src/SDK/samples/Providers/Load/SDK_CIM_Schema.mof.orig 2008-12-16 19:58:05.000000000 +0100
|
||||
+++ pegasus/src/SDK/samples/Providers/Load/SDK_CIM_Schema.mof 2015-05-26 13:47:48.406767875 +0200
|
||||
@@ -45,6 +45,7 @@
|
||||
#pragma include ("DMTF/Core/CIM_ManagedElement.mof")
|
||||
#pragma include ("DMTF/Core/CIM_ManagedSystemElement.mof")
|
||||
#pragma include ("DMTF/Core/CIM_LogicalElement.mof")
|
||||
+#pragma include ("DMTF/Core/CIM_AbstractComponent.mof")
|
||||
#pragma include ("DMTF/Core/CIM_Component.mof")
|
||||
#pragma include ("DMTF/Event/CIM_Indication.mof")
|
||||
#pragma include ("DMTF/System/CIM_LogicalFile.mof")
|
@ -1,6 +1,6 @@
|
||||
diff -up pegasus/env_var_Linux.status.orig pegasus/env_var_Linux.status
|
||||
--- pegasus/env_var_Linux.status.orig 2015-03-31 14:43:37.774479768 +0200
|
||||
+++ pegasus/env_var_Linux.status 2015-03-31 14:45:21.003914888 +0200
|
||||
diff -up pegasus/env_var_Linux.status.redhat-config pegasus/env_var_Linux.status
|
||||
--- pegasus/env_var_Linux.status.redhat-config 2015-04-01 00:41:07.000000000 +0200
|
||||
+++ pegasus/env_var_Linux.status 2015-05-26 13:05:21.021110656 +0200
|
||||
@@ -25,18 +25,21 @@ PEGASUS_HAS_SSL=yes
|
||||
PEGASUS_USE_SSL_RANDOMFILE=false
|
||||
PEGASUS_NOASSERTS=yes
|
||||
@ -9,7 +9,8 @@ diff -up pegasus/env_var_Linux.status.orig pegasus/env_var_Linux.status
|
||||
PEGASUS_USE_RELEASE_CONFIG_OPTIONS=true
|
||||
PEGASUS_USE_RELEASE_DIRS=true
|
||||
PEGASUS_USE_SYSLOGS=true
|
||||
PEGASUS_CIM_SCHEMA=CIM241
|
||||
-PEGASUS_CIM_SCHEMA=CIM241
|
||||
+PEGASUS_CIM_SCHEMA=CIM238
|
||||
PEGASUS_USE_NET_SNMP=true
|
||||
-PEGASUS_ENABLE_PRIVILEGE_SEPARATION=true
|
||||
+PEGASUS_ENABLE_PRIVILEGE_SEPARATION=false
|
||||
|
@ -8,7 +8,7 @@
|
||||
|
||||
Name: tog-pegasus
|
||||
Version: %{major_ver}.1
|
||||
Release: 25%{?dist}
|
||||
Release: 26%{?dist}
|
||||
Epoch: 2
|
||||
Summary: OpenPegasus WBEM Services for Linux
|
||||
|
||||
@ -86,6 +86,8 @@ Patch34: pegasus-2.14.1-build-fixes.patch
|
||||
Patch35: pegasus-2.14.1-ssl-include.patch
|
||||
# 36: fixes sending of SNMPv3 traps in cimserver
|
||||
Patch36: pegasus-2.14.1-snmpv3-trap.patch
|
||||
# 37: fixes setupSDK in -devel
|
||||
Patch37: pegasus-2.14.1-fix-setup-sdk.patch
|
||||
|
||||
BuildRequires: procps, libstdc++, pam-devel
|
||||
BuildRequires: openssl, openssl-devel
|
||||
@ -232,6 +234,7 @@ yes | mak/CreateDmtfSchema 238 %{SOURCE9} cim_schema_2.38.0
|
||||
%patch34 -p1 -b .build-fixes
|
||||
%patch35 -p1 -b .ssl-include
|
||||
%patch36 -p1 -b .snmpv3-trap
|
||||
%patch37 -p1 -b .fix-setup-sdk
|
||||
|
||||
|
||||
%build
|
||||
@ -322,6 +325,9 @@ install -m 644 src/Pegasus/Listener/CIMListener.h $RPM_BUILD_ROOT/%{_includedir}
|
||||
install -p %{SOURCE11} $RPM_BUILD_ROOT/usr/share/Pegasus/test/snmptrapd.conf
|
||||
%endif
|
||||
|
||||
# Install missing mof file for makeSDK
|
||||
install -p Schemas/CIM238/DMTF/Core/CIM_AbstractComponent.mof $RPM_BUILD_ROOT/usr/share/Pegasus/samples/Providers/Load/CIM238/DMTF/Core/
|
||||
|
||||
%check
|
||||
# run unit tests
|
||||
export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/usr/%{_lib}
|
||||
@ -510,6 +516,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 28 2015 Vitezslav Crhonek <vcrhonek@redhat.com> - 2:2.14.1-26
|
||||
- Fix setupSDK in -devel
|
||||
- Use Experimental DMTF CIM schema version 2.38.0
|
||||
|
||||
* Tue May 26 2015 Vitezslav Crhonek <vcrhonek@redhat.com> - 2:2.14.1-25
|
||||
- Fix sending of SNMPv3 traps
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user