changed %build section

This commit is contained in:
vcrhonek 2007-03-21 10:13:24 +00:00
parent 9e51e66e51
commit c3ef736aca
2 changed files with 118 additions and 17 deletions

View File

@ -0,0 +1,10 @@
--- pegasus.mark/Makefile.Release 2007-03-15 16:49:16.000000000 -0500
+++ pegasus/Makefile.Release 2007-03-15 16:50:52.000000000 -0500
@@ -156,6 +156,7 @@
PEGASUS_ADMIN_CMDS = \
cimauth \
+ cimuser \
cimconfig \
cimserver \
cimprovagt \

View File

@ -41,7 +41,7 @@
%endif
Version: 2.6.0
Release: 1%{?dist}
Release: 2%{?dist}
Epoch: 2
#
Summary: OpenPegasus WBEM Services for Linux
@ -54,10 +54,10 @@ License: Open Group Pegasus Open Source
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%{_target_cpu}-%(%{__id} -u -n)
#
Source: http://www.openpegasus.org/uploads/40/10123/%{srcname}-%{version}.tar.gz
Source1: RedHat.OpenPegasus.Makefile
Source2: README.RedHat.Security
Source3: genOpenPegasusSSLCerts
Source4: pegasus_arch_alternatives
Source1: README.RedHat.Security
Source2: genOpenPegasusSSLCerts
Source3: pegasus_arch_alternatives
Source4: RedHat.OpenPegasus.Makefile
#
# patches 2-4, 9-10, 12-38 now upstream
#
@ -76,6 +76,8 @@ Patch8: pegasus-2.5.1-pam-wbem.patch
# 11: http://cvs.rdg.opengroup.org/bugzilla/show_bug.cgi?id=5006
Patch11: pegasus-2.5.1-fix_tests.patch
#
Patch39: pegasus-2.6.0-cimuser.patch
#
Conflicts: openwbem
Provides: tog-pegasus-cimserver
#
@ -135,35 +137,123 @@ The OpenPegasus WBEM tests for the OpenPegasus %{version} Linux rpm.
%patch7 -p1 -b .local-or-remote-auth
%patch8 -p1 -b .pam-wbem
%patch11 -p1 -b .fix-tests
%patch39 -p1 -b .cimuser
find . -name 'CVS' -exec /bin/rm -rf '{}' ';' >/dev/null 2>&1 ||:;
%build
rm -rf ${RPM_BUILD_ROOT} || :;
cp -fp %SOURCE1 .;
cp -fp %SOURCE2 doc
cp -fp %SOURCE3 rpm
cp -fp %SOURCE1 doc
cp -fp %SOURCE2 rpm
cp -fp %SOURCE4 .;
export RPM_ARCH_LIB=%{_lib}
export RPM_ARCH=%{_target_cpu}
#make %{?_smp_mflags} -f RedHat.OpenPegasus.Makefile;
make -f RedHat.OpenPegasus.Makefile;
export RPM_BUILD_DIR=`pwd`
export RPM_ARCH=`uname -i`
export RPM_OPT_FLAGS=`rpm -q rpm --qf '%{OPTFLAGS}'`
%ifarch ia64
export PEGASUS_PLATFORM=LINUX_IA64_GNU
%else
%ifarch x86_64
export PEGASUS_PLATFORM=LINUX_X86_64_GNU
%else
%ifarch ppc
export PEGASUS_PLATFORM=LINUX_PPC_GNU
%else
%ifarch ppc64
export PEGASUS_PLATFORM=LINUX_PPC64_GNU
%else
%ifarch s390
export PEGASUS_PLATFORM=LINUX_ZSERIES_GNU
%else
%ifarch s390x
export PEGASUS_PLATFORM=LINUX_ZSERIES64_GNU
%else
export PEGASUS_PLATFORM=LINUX_IX86_GNU
%endif
%endif
%endif
%endif
%endif
%endif
export PEGASUS_ROOT=${RPM_BUILD_DIR}
export PEGASUS_HOME=${PEGASUS_ROOT}/build
export PEGASUS_ARCH_LIB=${RPM_ARCH_LIB}
export PEGASUS_ENVVAR_FILE=${PEGASUS_ROOT}/env_var_Linux.status
export PEGASUS_EXTRA_C_FLAGS="${RPM_OPT_FLAGS} -Wno-unused"
export PEGASUS_EXTRA_CXX_FLAGS=${PEGASUS_EXTRA_C_FLAGS}
export PEGASUS_EXTRA_PROGRAM_LINK_FLAGS="-pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
export OPENSSL_HOME=/usr
export OPENSSL_BIN=/usr/bin
export SYS_INCLUDES=-I/usr/kerberos/include
export LD_LIBRARY_PATH=${PEGASUS_HOME}/lib
export PATH=${PEGASUS_HOME}/bin:${PATH}
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_ProductVersionFile
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_CommonProductDirectoriesInclude
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_ConfigProductDirectoriesInclude
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release depend
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release all
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release repository
%if %{PEGASUS_BUILD_TEST_RPM}
#make %{?_smp_mflags} -f RedHat.OpenPegasus.Makefile tests;
make -f RedHat.OpenPegasus.Makefile tests;
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.ReleaseTest -s create_repository
%endif
%install
export RPM_ARCH_LIB=%{_lib}
export RPM_ARCH=%{_target_cpu}
export BSX=%{bsx}
export RPM_BUILD_DIR=`pwd`
export RPM_ARCH=`uname -i`
export RPM_OPT_FLAGS=`rpm -q rpm --qf '%{OPTFLAGS}'`
%ifarch ia64
export PEGASUS_PLATFORM=LINUX_IA64_GNU
%else
%ifarch x86_64
export PEGASUS_PLATFORM=LINUX_X86_64_GNU
%else
%ifarch ppc
export PEGASUS_PLATFORM=LINUX_PPC_GNU
%else
%ifarch ppc64
export PEGASUS_PLATFORM=LINUX_PPC64_GNU
%else
%ifarch s390
export PEGASUS_PLATFORM=LINUX_ZSERIES_GNU
%else
%ifarch s390x
export PEGASUS_PLATFORM=LINUX_ZSERIES64_GNU
%else
export PEGASUS_PLATFORM=LINUX_IX86_GNU
%endif
%endif
%endif
%endif
%endif
%endif
export PEGASUS_ROOT=${RPM_BUILD_DIR}
export PEGASUS_HOME=${PEGASUS_ROOT}/build
export PEGASUS_ARCH_LIB=${RPM_ARCH_LIB}
export PEGASUS_ENVVAR_FILE=${PEGASUS_ROOT}/env_var_Linux.status
export PEGASUS_EXTRA_C_FLAGS="${RPM_OPT_FLAGS} -Wno-unused"
export PEGASUS_EXTRA_CXX_FLAGS=${PEGASUS_EXTRA_C_FLAGS}
export PEGASUS_EXTRA_PROGRAM_LINK_FLAGS="-pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
export OPENSSL_HOME=/usr
export OPENSSL_BIN=/usr/bin
export SYS_INCLUDES=-I/usr/kerberos/include
export LD_LIBRARY_PATH=${PEGASUS_HOME}/lib
export PATH=${PEGASUS_HOME}/bin:${PATH}
make -f RedHat.OpenPegasus.Makefile install prefix=$RPM_BUILD_ROOT libdir=%{_libdir} root_user=%(%{__id} -u -n) pegasus_user=%(%{__id} -u -n)
%if %{PEGASUS_BUILD_TEST_RPM}
make -f RedHat.OpenPegasus.Makefile install_tests prefix=$RPM_BUILD_ROOT root_user=%(%{__id} -u -n) pegasus_user=%(%{__id} -u -n)
make -f %{SOURCE4} install_tests prefix=${RPM_BUILD_ROOT} root_user=%(%{__id} -u -n) pegasus_user=%(%{__id} -u -n)
%endif
%if %{multilib}
%{SOURCE4} --list '%ghost' | grep 'bin/' > ghost_arch_binaries;
%{SOURCE4} --list '%ghost' | grep 'mak/' > ghost_arch_devel;
%{SOURCE4} --list '%ghost' | grep 'test/'> ghost_arch_test;
cp -fp %{SOURCE4} $RPM_BUILD_ROOT/%{_datadir}/Pegasus/scripts;
%{SOURCE3} --list '%ghost' | grep 'bin/' > ghost_arch_binaries;
%{SOURCE3} --list '%ghost' | grep 'mak/' > ghost_arch_devel;
%{SOURCE3} --list '%ghost' | grep 'test/'> ghost_arch_test;
cp -fp %{SOURCE3} $RPM_BUILD_ROOT/%{_datadir}/Pegasus/scripts;
%else
touch ghost_arch_binaries;
touch ghost_arch_devel;
@ -173,6 +263,7 @@ make -f RedHat.OpenPegasus.Makefile install prefix=$RPM_BUILD_ROOT libdir=%{_lib
/usr/lib/rpm/brp-compress;
exit 0;
%endif
:;