Fix FTBFS, use make macros
This commit is contained in:
parent
e623c5c9e6
commit
6e55619347
10
pegasus-2.14.1-add-pegwsmserver-to-ldd-libs.patch
Normal file
10
pegasus-2.14.1-add-pegwsmserver-to-ldd-libs.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff -up pegasus/src/Pegasus/ExportClient/tests/libraries.mak.orig pegasus/src/Pegasus/ExportClient/tests/libraries.mak
|
||||
--- pegasus/src/Pegasus/ExportClient/tests/libraries.mak.orig 2020-11-26 10:20:13.938292092 +0100
|
||||
+++ pegasus/src/Pegasus/ExportClient/tests/libraries.mak 2020-11-26 10:25:30.248432039 +0100
|
||||
@@ -35,4 +35,5 @@ LIBRARIES= \
|
||||
pegrepository \
|
||||
pegconfig \
|
||||
pegclient \
|
||||
- pegcommon
|
||||
+ pegcommon \
|
||||
+ pegwsmserver
|
@ -8,7 +8,7 @@
|
||||
|
||||
Name: tog-pegasus
|
||||
Version: %{major_ver}.1
|
||||
Release: 56%{?dist}
|
||||
Release: 57%{?dist}
|
||||
Epoch: 2
|
||||
Summary: OpenPegasus WBEM Services for Linux
|
||||
|
||||
@ -102,6 +102,8 @@ Patch43: pegasus-2.14.1-fix-Wreserved-user-defined-literal.patch
|
||||
# 44: comply with Fedora crypto policy
|
||||
# (use 'PROFILE=SYSTEM' instead of 'DEFAULT' in SSL_CTX_set_cipher_list calls)
|
||||
Patch44: pegasus-2.14.1-crypto-policy-compliance.patch
|
||||
# 45: add required lib to fix FTBS
|
||||
Patch45: pegasus-2.14.1-add-pegwsmserver-to-ldd-libs.patch
|
||||
|
||||
BuildRequires: procps, libstdc++, pam-devel
|
||||
BuildRequires: openssl, openssl-devel
|
||||
@ -254,6 +256,7 @@ yes | mak/CreateDmtfSchema 238 %{SOURCE9} cim_schema_2.38.0
|
||||
%patch42 -p1 -b .openssl-1.1-fix
|
||||
%patch43 -p1 -b .Wreserved-user-defined-literal-fix
|
||||
%patch44 -p1 -b .crypto-policy-compliance
|
||||
%patch45 -p1 -b .add-pegwsmserver-to-ldd-libs
|
||||
|
||||
|
||||
%build
|
||||
@ -279,11 +282,11 @@ export PEGASUS_EXTRA_LINK_FLAGS="$RPM_OPT_FLAGS"
|
||||
export PEGASUS_EXTRA_PROGRAM_LINK_FLAGS="-g -pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
|
||||
export SYS_INCLUDES=-I/usr/kerberos/include
|
||||
|
||||
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_ProductVersionFile
|
||||
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_CommonProductDirectoriesInclude
|
||||
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release create_ConfigProductDirectoriesInclude
|
||||
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release all
|
||||
make %{?_smp_mflags} -f ${PEGASUS_ROOT}/Makefile.Release repository
|
||||
%make_build -f ${PEGASUS_ROOT}/Makefile.Release create_ProductVersionFile
|
||||
%make_build -f ${PEGASUS_ROOT}/Makefile.Release create_CommonProductDirectoriesInclude
|
||||
%make_build -f ${PEGASUS_ROOT}/Makefile.Release create_ConfigProductDirectoriesInclude
|
||||
%make_build -f ${PEGASUS_ROOT}/Makefile.Release all
|
||||
%make_build -f ${PEGASUS_ROOT}/Makefile.Release repository
|
||||
|
||||
|
||||
%install
|
||||
@ -555,6 +558,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Nov 26 2020 Vitezslav Crhonek <vcrhonek@redhat.com> - 2:2.14.1-57
|
||||
- Fix FTBFS
|
||||
- Use make macros, patch by Tom Stellard <tstellar@redhat.com>
|
||||
|
||||
* Thu Aug 27 2020 Josef Řídký <jridky@redhat.com> - 2:2.14.1-56
|
||||
- Rebuilt for new net-snmp release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user